On 22 Aug 2014, at 08:10, Matteo Beccati wrote:
> On 21/08/2014 19:42, Andrea Faulds wrote:
>> * IS_LONG/long - 32-bit or 64-bit integer (machine-dependant)
>> * IS_BIGINT/bigint - arbitrary-size integer
>> * IS_BIGINT_OR_LONG/integer - either a long or a bigint (pseudo-type)
>>
>> Replacing IS
Moin,
On Thu, August 21, 2014 19:23, Dmitry Stogov wrote:
> Hi,
>
>
> Thanks to Anatol and Pierre the 64-bit patch is ready
> https://github.com/weltling/php-src
>
>
> I made quick code review and don't see any technical problems now.
>
>
> The performance and memory consumption difference is negl
On 21/08/14 19:10, Andrea Faulds wrote:
>> I would instead to ask you to try to migrate a not so trivial extension :)
> No, seriously. Why can’t a sed script be used to change a constant name? Can
> you tell me why that wouldn’t work?
Compatibility across all builds?
Many of the times 'blanket' c
On 21/08/2014 19:42, Andrea Faulds wrote:
> * IS_LONG/long - 32-bit or 64-bit integer (machine-dependant)
> * IS_BIGINT/bigint - arbitrary-size integer
> * IS_BIGINT_OR_LONG/integer - either a long or a bigint (pseudo-type)
>
> Replacing IS_LONG with IS_INT kinda ruins my naming scheme. The intent
On Fri, Aug 22, 2014 at 8:45 AM, Dmitry Stogov wrote:
> zend_long/zend_ulong without renaming everything else would be a perfect
> solution from my point of view.
Again, no. long is the worst type ever, be as type or in names (ppl
then use this type to match the macro names).
If there is a need
zend_long/zend_ulong without renaming everything else would be a perfect
solution from my point of view.
Thanks. Dmitry.
On Fri, Aug 22, 2014 at 12:49 AM, Nikita Popov wrote:
> On Thu, Aug 21, 2014 at 7:23 PM, Dmitry Stogov wrote:
>
>> Hi,
>>
>> Thanks to Anatol and Pierre the 64-bit patch is
On Aug 21, 2014 10:49 PM, "Nikita Popov" wrote:
>
> I am against merging this with the long->int rename everywhere. This
seems like change for the sake of change.
It is accepted and ready to be merged.
> I am also concerned that we now have zend_uint_t (a 64-bit integer type)
and zend_uint (a 3
On 21 Aug 2014, at 21:49, Nikita Popov wrote:
> I am also concerned that we now have zend_uint_t (a 64-bit integer type)
> and zend_uint (a 32-bit integer type). Notice the difference? Yes, it's the
> missing _t.
>
> I would appreciate it if we could consider the following naming convention:
>
On Thu, Aug 21, 2014 at 7:23 PM, Dmitry Stogov wrote:
> Hi,
>
> Thanks to Anatol and Pierre the 64-bit patch is ready
> https://github.com/weltling/php-src
>
> I made quick code review and don't see any technical problems now.
>
> The performance and memory consumption difference is negligible. s
In worst case, we will always able to make a new RFC and rename them back,
but I really don't like to delay this patch just because few people
(including me) are not agree with names. RFC was already delayed for
months, and actually, it was voted with section about new names.
Thanks. Dmitry.
On
I completely agree.
Dmitry.
On Thu, Aug 21, 2014 at 10:21 PM, Pierre Joye wrote:
>
> On Aug 21, 2014 8:14 PM, "Dmitry Stogov" wrote:
> >
> > Pierre, wait a day, and if we won't have many developers, who against
> the new names - commit it as is.
> >
> > Thanks. Dmitry.
> We have waited months
On 21 Aug 2014, at 19:21, Pierre Joye wrote:
> Why should we follow different rules than other RFCs? Bigint is a work in
> progress, there is no vote, there is not even a discussion on this list about
> it. Asking us to hang on again for yet another rfc is really not something I
> can live wi
On Aug 21, 2014 8:14 PM, "Dmitry Stogov" wrote:
>
> Pierre, wait a day, and if we won't have many developers, who against the
new names - commit it as is.
>
> Thanks. Dmitry.
We have waited months due to phpng. We have waited months due to objection
after the rfc was accepted already (2nd attempt)
On 21 Aug 2014, at 19:14, Dmitry Stogov wrote:
> Pierre, wait a day, and if we won't have many developers, who against the new
> names - commit it as is.
Perhaps none will be against it now, however, how will they feel when they have
to change IS_INT in their extensions *again* to a new name
Pierre, wait a day, and if we won't have many developers, who against the
new names - commit it as is.
Thanks. Dmitry.
On Thu, Aug 21, 2014 at 10:03 PM, Pierre Joye wrote:
>
> On Aug 21, 2014 7:58 PM, "Andrea Faulds" wrote:
> >
> >
> > On 21 Aug 2014, at 18:56, Pierre Joye wrote:
> >
> > > T
On 21 Aug 2014, at 19:08, Pierre Joye wrote:
> Then please do a rfc, but we are not going to rewamp the patch for the 6th
> time. It has been accepted and we have been more than cooperative.
Do we really need to delay this by three weeks?
Forgive me if I’m wrong, but wouldn’t changing the
On Aug 21, 2014 8:05 PM, "Andrea Faulds" wrote:
>
>
> On 21 Aug 2014, at 19:03, Pierre Joye wrote:
>
> > Now to be honest I would merge it right away. I do not see why we need
to discuss that again. When I see how phpng got accepted without a word,
time to stop arguing about such things. Merge an
On 21 Aug 2014, at 18:56, Pierre Joye wrote:
> The original patch used the right naming based on the type used behind it.
So IS_LONGLONG, then?
> In any case, the patch represents what the rfc and the discussions around
> it say. I rather merge it asal and begin on the (long) list of todos for
On 21 Aug 2014, at 19:03, Pierre Joye wrote:
> Now to be honest I would merge it right away. I do not see why we need to
> discuss that again. When I see how phpng got accepted without a word, time to
> stop arguing about such things. Merge and move back to code. If one thinks
> that one thin
On Aug 21, 2014 7:58 PM, "Andrea Faulds" wrote:
>
>
> On 21 Aug 2014, at 18:56, Pierre Joye wrote:
>
> > The original patch used the right naming based on the type used behind
it.
>
> So IS_LONGLONG, then?
The original patch, the one from last year. We have made compromises to
fulfill other devs
On Aug 21, 2014 7:42 PM, "Andrea Faulds" wrote:
>
>
> On 21 Aug 2014, at 18:23, Dmitry Stogov wrote:
>
> > The only thing that I don't like is a massive renaming described here
> >
https://wiki.php.net/rfc/size_t_and_int64_next#semantical_macro_renamings
> >
> > IS_LONG -> IS_INT
> > Z_LVAL -> L_
On 8/21/14, 10:23 AM, Dmitry Stogov wrote:
Hi,
Thanks to Anatol and Pierre the 64-bit patch is ready
https://github.com/weltling/php-src
I made quick code review and don't see any technical problems now.
The performance and memory consumption difference is negligible. see
https://docs.google
On 21 Aug 2014, at 18:23, Dmitry Stogov wrote:
> The only thing that I don't like is a massive renaming described here
> https://wiki.php.net/rfc/size_t_and_int64_next#semantical_macro_renamings
>
> IS_LONG -> IS_INT
> Z_LVAL -> L_IVAL
> etc
>
> On one hand using INT may be more consistent, on
23 matches
Mail list logo