2012/8/15 Giedrius Dubinskas
> On Wed, Aug 15, 2012 at 4:54 PM, Sebastian Krebs
> wrote:
> > 2012/8/15 Giedrius Dubinskas
> >
> >> On Wed, Aug 15, 2012 at 2:19 PM, Yahav Gindi Bar
> >> wrote:
> >> > On Wed, Aug 15, 2012 at 2:09 PM, Paul Dragoonis
> >> wrote:
> >> >>
> >> >> Comments inline.
>
Giedrius Dubinskas wrote:
On Wed, Aug 15, 2012 at 6:54 PM, Lester Caine wrote:
Giedrius Dubinskas wrote:
My main aim with this suggestion is readability. I'd like to remove
unnecessary noise in code where it doesn't add any value to the
reader. Code is easy to type (especially with good autoc
On Wed, Aug 15, 2012 at 6:54 PM, Lester Caine wrote:
> Giedrius Dubinskas wrote:
>>
>> My main aim with this suggestion is readability. I'd like to remove
>> unnecessary noise in code where it doesn't add any value to the
>> reader. Code is easy to type (especially with good autocompletion) but
>>
Giedrius Dubinskas wrote:
My main aim with this suggestion is readability. I'd like to remove
unnecessary noise in code where it doesn't add any value to the
reader. Code is easy to type (especially with good autocompletion) but
it is read more often then typed and I think that is important. Or i
On Wed, Aug 15, 2012 at 4:54 PM, Sebastian Krebs wrote:
> 2012/8/15 Giedrius Dubinskas
>
>> On Wed, Aug 15, 2012 at 2:19 PM, Yahav Gindi Bar
>> wrote:
>> > On Wed, Aug 15, 2012 at 2:09 PM, Paul Dragoonis
>> wrote:
>> >>
>> >> Comments inline.
>> >>
>> >> On Wed, Aug 15, 2012 at 11:59 AM, Giedri
Hi,
This additional "function" seems little bit ... misplaced. :X Why not just
use MyFoo\Bar;
Bar\baz(); // <-- Would be cool, if this trigger an autloader if required
Except, that there is no autoloading everything already works this way.
Regards,
Sebastian
2012/8/15 Giedrius Dubinskas
>
2012/8/15 Giedrius Dubinskas
> On Wed, Aug 15, 2012 at 2:19 PM, Yahav Gindi Bar
> wrote:
> > On Wed, Aug 15, 2012 at 2:09 PM, Paul Dragoonis
> wrote:
> >>
> >> Comments inline.
> >>
> >> On Wed, Aug 15, 2012 at 11:59 AM, Giedrius Dubinskas
> >> wrote:
> >> > Hello Internals!
> >> >
> >> > I'm
Yes that is a very common use case and autoloading functions would
solve that one but my main aim here is readability. And that said I
would also suggest:
use function Namespaced\foo;
foo(); // calls Namespaced\foo();
;-)
--
Giedrius Dubinskas
On Wed, Aug 15, 2012 at 2:26 PM, Sebastian Kre
On Wed, Aug 15, 2012 at 2:19 PM, Yahav Gindi Bar wrote:
> On Wed, Aug 15, 2012 at 2:09 PM, Paul Dragoonis wrote:
>>
>> Comments inline.
>>
>> On Wed, Aug 15, 2012 at 11:59 AM, Giedrius Dubinskas
>> wrote:
>> > Hello Internals!
>> >
>> > I'm just on and off luker here but thought I'll throw in an
Hi,
because it fits into the context (even if it's slightly offtopic): Can I
throw in, that I would like to see autoloading for functions? :)
Regards,
Sebastian
2012/8/15 Nikita Popov
> On Wed, Aug 15, 2012 at 12:59 PM, Giedrius Dubinskas
> wrote:
> > Hello Internals!
> >
> > I'm just on and
On Wed, Aug 15, 2012 at 2:09 PM, Paul Dragoonis wrote:
> Comments inline.
>
> On Wed, Aug 15, 2012 at 11:59 AM, Giedrius Dubinskas
> wrote:
> > Hello Internals!
> >
> > I'm just on and off luker here but thought I'll throw in an idea for a
> > feature I'd love to see in PHP: aliasing static meth
On Wed, Aug 15, 2012 at 12:59 PM, Giedrius Dubinskas
wrote:
> Hello Internals!
>
> I'm just on and off luker here but thought I'll throw in an idea for a
> feature I'd love to see in PHP: aliasing static methods.
>
> Syntax would look something like this:
>
> use Namespaced\SomeClass::staticMeth
Comments inline.
On Wed, Aug 15, 2012 at 11:59 AM, Giedrius Dubinskas
wrote:
> Hello Internals!
>
> I'm just on and off luker here but thought I'll throw in an idea for a
> feature I'd love to see in PHP: aliasing static methods.
>
> Syntax would look something like this:
>
> use Namespaced\Som
Hello Internals!
I'm just on and off luker here but thought I'll throw in an idea for a
feature I'd love to see in PHP: aliasing static methods.
Syntax would look something like this:
use Namespaced\SomeClass::staticMethod;
use Some\Foo::bar as fooBar;
staticMethod(); // would call Namesp
14 matches
Mail list logo