> -Original Message-
> From: Robert Cummings [mailto:[EMAIL PROTECTED]
> Sent: 06 February 2007 16:09
>
> I know how much you want to feel special, but here's the
> definition of "read". Your description of how you interpret
> what you see falls into this definition:
Oh, no fair! You'v
On Tue, 2007-02-06 at 15:41 +, Ford, Mike wrote:
> On 06 February 2007 14:42, Robert Cummings wrote:
>
> > On Tue, 2007-02-06 at 14:08 +, Ford, Mike wrote:
> > > On 05 February 2007 17:29, Brian Moon wrote:
> > > > That is why you have coding standards. Our doucment states that
> > > > th
On 06 February 2007 14:42, Robert Cummings wrote:
> On Tue, 2007-02-06 at 14:08 +, Ford, Mike wrote:
> > On 05 February 2007 17:29, Brian Moon wrote:
> > > That is why you have coding standards. Our doucment states that
> > > this should be written as:
> > >
> > > $a = array(
> > > 1 => a
On Tue, Feb 06, 2007 at 04:16:28PM +0100, Christian Schneider wrote:
> Alain Williams wrote:
> > Anyway: it makes php look like perl -- and that would never do :-)
>
> Can we please stop that FUD? (even if it is meant as a joke)
No: it was NOT a serious point. What is wrong with the occasional gr
Alain Williams wrote:
> Anyway: it makes php look like perl -- and that would never do :-)
Can we please stop that FUD? (even if it is meant as a joke)
... if at all then you might say it looks like Javascript, Python or
Ruby. Perl uses an ugly mix of () and [] to emulate multi-dimensional
arrays
On Tue, Feb 06, 2007 at 09:41:34AM -0500, Robert Cummings wrote:
> On Tue, 2007-02-06 at 14:08 +, Ford, Mike wrote:
> > On 05 February 2007 17:29, Brian Moon wrote:
> > > That is why you have coding standards. Our doucment states that this
> > > should be written as:
> > >
> > > $a = array(
On Tue, 2007-02-06 at 14:08 +, Ford, Mike wrote:
> On 05 February 2007 17:29, Brian Moon wrote:
> > That is why you have coding standards. Our doucment states that this
> > should be written as:
> >
> > $a = array(
> > 1 => array('pears', 'apples'),
> > 2 => array('juice', 'oranges')
On 05 February 2007 17:29, Brian Moon wrote:
> Ford, Mike wrote:
> > > I don't find:
> > >
> > > $a = [1 => ['pears', 'apples'], 2 => ['juice', 'oranges']];
> > >
> > > any less readable than:
> > >
> > > $a = array(1 => array('pears', 'apples'), 2 => array('juice',
> > > 'oranges'));
> > >
>
Ford, Mike wrote:
I don't find:
$a = [1 => ['pears', 'apples'], 2 => ['juice', 'oranges']];
any less readable than:
$a = array(1 => array('pears', 'apples'), 2 => array('juice',
'oranges'));
Quite the opposite actually :)
Me too - I go beyond Edin on this one, as I find the array() versio
On 04 February 2007 18:38, Edin Kadribasic wrote:
> Lukas Kahwe Smith wrote:
> > Yes, you will come across it if its added.
> > I find the Javascript syntax confusing to read as well. However more
> > importantly I do not see the point in adding this sugar to save 5
> > chars.
>
> Nested arrays
On Sun, February 4, 2007 2:46 pm, Stefan Walk wrote:
> Steph wrote:
>> Hi Stas,
>>
>>> By pure coincidence, I was doing a bunch of javascript work lately
>>> too, and I find [] syntax OK. From readability POV it's not much
>>> difference, but much less clutter if you have really massive data
>>> ar
On Sun, 2007-02-04 at 19:38 +0100, Edin Kadribasic wrote:
> Lukas Kahwe Smith wrote:
> > Yes, you will come across it if its added.
> > I find the Javascript syntax confusing to read as well. However more
> > importantly I do not see the point in adding this sugar to save 5 chars.
>
> Nested array
Fine, but in javascript there is only one option. That's the difference.
- Steph
a = Array(1,2,3)
a = [1,2,3]
I stand corrected. Apologies for the noise.
- Steph
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Steph wrote:
> Hi Stas,
>
>> By pure coincidence, I was doing a bunch of javascript work lately
>> too, and I find [] syntax OK. From readability POV it's not much
>> difference, but much less clutter if you have really massive data
>> array - no array() things which take half of the space.
>
> F
Hi Stas,
By pure coincidence, I was doing a bunch of javascript work lately too,
and I find [] syntax OK. From readability POV it's not much difference,
but much less clutter if you have really massive data array - no array()
things which take half of the space.
Fine, but in javascript there
On Sun, 4 Feb 2007, Edin Kadribasic wrote:
> I don't find:
>
> $a = [1 => ['pears', 'apples'], 2 => ['juice', 'oranges']];
>
> any less readable than:
>
> $a = array(1 => array('pears', 'apples'), 2 => array('juice', 'oranges'));
>
> Quite the opposite actually :)
That's a personal thing, and
Lukas Kahwe Smith wrote:
> Yes, you will come across it if its added.
> I find the Javascript syntax confusing to read as well. However more
> importantly I do not see the point in adding this sugar to save 5 chars.
Nested arrays become very unreadable with the current PHP syntax. I
think killing
Steph wrote:
On 2/4/07, Ilia Alshanetsky <[EMAIL PROTECTED]> wrote:
I personally find array extremely clear, in recent weeks I had to do
A LOT of JavaScript work where the array syntax works in a manner you
suggest for PHP and its a massive pain. It does not make for a very
clear code. I think t
On 2/4/07, Ilia Alshanetsky <[EMAIL PROTECTED]> wrote:
I personally find array extremely clear, in recent weeks I had to do
A LOT of JavaScript work where the array syntax works in a manner you
suggest for PHP and its a massive pain. It does not make for a very
clear code. I think the syntax you
I personally find array extremely clear, in recent weeks I had to do A LOT
of JavaScript work where the array syntax works in a manner you suggest
for PHP and its a massive pain. It does not make for a very clear code. I
think the syntax you propose is extremely confusing and we should stick
20 matches
Mail list logo