Ford, Mike wrote:
I don't find:

$a = [1 => ['pears', 'apples'], 2 => ['juice', 'oranges']];

any less readable than:

$a = array(1 => array('pears', 'apples'), 2 => array('juice',
'oranges'));
Quite the opposite actually :)

Me too - I go beyond Edin on this one, as I find the array() version actually 
quite UNreadable and I have difficulty picking out what the individual arrays 
are; conversely, the [] version I take in at a glance.

That is why you have coding standards. Our doucment states that this should be written as:

$a = array(
        1 => array('pears', 'apples'),
        2 => array('juice', 'oranges')
);

I believe in either syntax, proper formatting of complex data can solve the readablity problems.

--

Brian Moon
-------------
http://dealnews.com/
It's good to be cheap =)

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to