Re: [Intel-gfx] [PATCH 11/13] drm/i915: Cut out the infamous ILK w/a from AGP layer

2013-01-16 Thread Ben Widawsky
On Wed, 16 Jan 2013 21:09:32 -0200 Rodrigo Vivi wrote: > On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > > And, move it to where the rest of the logic is. > > > > Cc: Dave Airlie > > Signed-off-by: Ben Widawsky > > --- > > drivers/char/agp/intel-gtt.c| 27 --

[Intel-gfx] Sandybridge Integrity Port issue

2013-01-16 Thread Matt Knowles
Hi, I am currently working with a team that is porting the Intel Linux open source stack to Integrity OS (a real-time OS by Green Hills) for embedded systems. The current architecture we're using is the Sandybridge architecture (device ID: 0x0116). After a good amount of work, we have finally m

Re: [Intel-gfx] [PATCH 12/13] drm/i915: Remove scratch page from shared

2013-01-16 Thread Rodrigo Vivi
Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > We already had a mapping in both (minus the phys_addr in AGP). > > Signed-off-by: Ben Widawsky > --- > drivers/char/agp/intel-gtt.c| 9 + > drivers/gpu/drm/i915/i915_drv.h | 2 ++ > drivers/g

Re: [Intel-gfx] [PATCH 11/13] drm/i915: Cut out the infamous ILK w/a from AGP layer

2013-01-16 Thread Rodrigo Vivi
On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > And, move it to where the rest of the logic is. > > Cc: Dave Airlie > Signed-off-by: Ben Widawsky > --- > drivers/char/agp/intel-gtt.c| 27 --- > drivers/gpu/drm/i915/i915_drv.h | 1 + > drivers/gpu/drm/

Re: [Intel-gfx] [PATCH 09/13] agp/intel: decouple more of the agp-i915 sharing

2013-01-16 Thread Rodrigo Vivi
Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > Signed-off-by: Ben Widawsky > --- > drivers/char/agp/intel-gtt.c | 35 +-- > include/drm/intel-gtt.h | 11 +-- > 2 files changed, 22 insertions(+), 24 deletions(-) > >

Re: [Intel-gfx] [PATCH 08/13] drm/i915: Move stolen_size to the new struct

2013-01-16 Thread Rodrigo Vivi
Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > Signed-off-by: Ben Widawsky > --- > drivers/gpu/drm/i915/i915_drv.h| 2 ++ > drivers/gpu/drm/i915/i915_gem_gtt.c| 7 --- > drivers/gpu/drm/i915/i915_gem_stolen.c | 8 > 3 files changed, 10

Re: [Intel-gfx] [PATCH 04/13] drm/i915: Create a gtt structure

2013-01-16 Thread Rodrigo Vivi
why not put gtt_mtrr to new gtt struct? anyways, feel free to use Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > The purpose of the gtt structure is to help isolate our gtt specific > properties from the rest of the code (in doing so it help us finish the > iso

Re: [Intel-gfx] [PATCH 03/13] drm/i915: Remove gtt_mappable_total

2013-01-16 Thread Rodrigo Vivi
for the patch itself feel free to use Reviewed-by: Rodrigo Vivi but at this point I just got a bit confused why not having an standard like always using total or always using end-start... On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > With the assertion from the previous patch in plac

Re: [Intel-gfx] [PATCH 02/13] drm/i915: Mappable_end can't ever be > end

2013-01-16 Thread Rodrigo Vivi
Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > Both DRI1 and DRI2 can never specify a mappable size which goes past the > GTT size. Don't pretend otherwise. > > Signed-off-by: Ben Widawsky > --- > drivers/gpu/drm/i915/i915_gem_gtt.c | 4 +++- > 1 file changed

Re: [Intel-gfx] [PATCH 01/13] drm/i915: Kill gtt_end

2013-01-16 Thread Rodrigo Vivi
Reviewed-by: Rodrigo Vivi On Tue, Jan 15, 2013 at 7:26 PM, Ben Widawsky wrote: > It's duplicated in the more useful gtt_total. > > Signed-off-by: Ben Widawsky > --- > drivers/gpu/drm/i915/i915_drv.h | 1 - > drivers/gpu/drm/i915/i915_gem_gtt.c | 3 +-- > 2 files changed, 1 insertion(+), 3

Re: [Intel-gfx] [PATCH] drm/i915: Fix SPRITE0_FLIP_DONE_INT_EN_VLV and SPRITE0_FLIPDONE_INT_STATUS_VLV

2013-01-16 Thread Daniel Vetter
On Wed, Jan 16, 2013 at 10:11:30AM -0800, Jesse Barnes wrote: > On Wed, 16 Jan 2013 19:59:03 +0200 > ville.syrj...@linux.intel.com wrote: > > > From: Ville Syrjälä > > > > Fix up some copypaste errors in the PIPESTAT register for VLV. > > > > SPRITE0_FLIP_DONE_INT_EN_VLV is bit 22, not bit 26.

[Intel-gfx] [PATCH 13/13 v2] drm/i915: Finally kill off struct intel_gtt

2013-01-16 Thread Ben Widawsky
Nothing is shared anymore between AGP and drm/i915 driver. Pre-GEN6 still uses AGP, but all necessary info is encapsulated per driver. v2: Conflict resolution from earlier rebase Signed-off-by: Ben Widawsky --- drivers/char/agp/intel-gtt.c| 7 --- drivers/gpu/drm/i915/i915_gem_gtt.

[Intel-gfx] [PATCH 10/13 v2] drm/i915: Needs_dmar, not

2013-01-16 Thread Ben Widawsky
The reasoning behind our code taking two paths depending upon whether or not we may have been configured for IOMMU isn't clear to me. It should always be safe to use the pci mapping functions as they are designed to abstract the decision we were handling in i915. Aside from simpler code, removing

[Intel-gfx] [PATCH 07/13 v2] drm/i915: Stop using gtt_total_entries

2013-01-16 Thread Ben Widawsky
Similar to gtt_mappable_entries we don't usually want the entries, it's easy enough to calculate it when you need. v2: Move relevant fields above pre-gen6 init Signed-off-by: Ben Widawsky --- drivers/gpu/drm/i915/i915_drv.h | 3 +++ drivers/gpu/drm/i915/i915_gem_gtt.c | 33

[Intel-gfx] [PATCH 06/13 v2] drm/i915: Remove use of gtt_mappable_entries

2013-01-16 Thread Ben Widawsky
Mappable_end, ie. size is almost always what you want as opposed to the number of entries. Since we already have that information, we can scrap the number of entries and only calculate it when needed. If gtt_start is !0, this will have slightly different behavior. This difference can only occur in

[Intel-gfx] [PATCH 05/13 v2] drm/i915: Remove use on gma_bus_addr on gen6+

2013-01-16 Thread Ben Widawsky
We have enough info to not use the intel_gtt bridge stuff. v2: Move setup of mappable_base above the legacy init stuff because we still need that on older platforms. (Daniel) Signed-off-by: Ben Widawsky --- drivers/gpu/drm/i915/i915_dma.c | 3 +-- drivers/gpu/drm/i915/i915_gem_gtt.c

Re: [Intel-gfx] [PATCH] drm/i915: Fix SPRITE0_FLIP_DONE_INT_EN_VLV and SPRITE0_FLIPDONE_INT_STATUS_VLV

2013-01-16 Thread Jesse Barnes
On Wed, 16 Jan 2013 19:59:03 +0200 ville.syrj...@linux.intel.com wrote: > From: Ville Syrjälä > > Fix up some copypaste errors in the PIPESTAT register for VLV. > > SPRITE0_FLIP_DONE_INT_EN_VLV is bit 22, not bit 26. > > SPRITE0_FLIPDONE_INT_STATUS_VLV is bit 14, not bit 15. > > Signed-off-by

[Intel-gfx] [PATCH] drm/i915: Fix SPRITE0_FLIP_DONE_INT_EN_VLV and SPRITE0_FLIPDONE_INT_STATUS_VLV

2013-01-16 Thread ville . syrjala
From: Ville Syrjälä Fix up some copypaste errors in the PIPESTAT register for VLV. SPRITE0_FLIP_DONE_INT_EN_VLV is bit 22, not bit 26. SPRITE0_FLIPDONE_INT_STATUS_VLV is bit 14, not bit 15. Signed-off-by: Ville Syrjälä --- drivers/gpu/drm/i915/i915_reg.h |4 ++-- 1 files changed, 2 inser

[Intel-gfx] [PATCH 2/4] drm/i915: Add "Automatic" mode for the "Broadcast RGB" property

2013-01-16 Thread ville . syrjala
From: Ville Syrjälä Add a new "Automatic" mode to the "Broadcast RGB" range property. When selected the driver automagically selects between full range and limited range output. Based on CEA-861 guidelines, limited range output is selected if the mode is a CEA mode, except 640x480. Otherwise ful

[Intel-gfx] drm/i915: RGB quantization range stuff v2

2013-01-16 Thread ville . syrjala
Second attempt at handling the RGB quantization range for HDMI and DP. The only change to the first set is that I dropped the has_hdmi_monitor bool. has_hdmi_sink is used instead. ___ Intel-gfx mailing list Intel-gfx@lists.freedesktop.org http://lists.fr

[Intel-gfx] [PATCH 4/4] drm/i915: Provide the quantization range in the AVI infoframe

2013-01-16 Thread ville . syrjala
From: Ville Syrjälä The AVI infoframe is able to inform the display whether the source is sending full or limited range RGB data. As per CEA-861 we must first check whether the display reports the quantization range as selectable, and if so we can set the approriate bits in the AVI inforframe.

[Intel-gfx] [PATCH 3/4] drm/edid: Add drm_rgb_quant_range_selectable()

2013-01-16 Thread ville . syrjala
From: Ville Syrjälä drm_rgb_quant_range_selectable() will report whether the monitor claims to support for RGB quantization range selection. The information can be found in the CEA Video capability block. Signed-off-by: Ville Syrjälä --- drivers/gpu/drm/drm_edid.c | 33 +

[Intel-gfx] [PATCH 1/4] drm/i915: Fix RGB color range property for PCH platforms

2013-01-16 Thread ville . syrjala
From: Ville Syrjälä The RGB color range select bit on the DP/SDVO/HDMI registers disappeared when PCH was introduced, and instead a new PIPECONF bit was added that performs the same function. Add a new INTEL_MODE_LIMITED_COLOR_RANGE private mode flag, and set it in the encoder mode_fixup if limi

Re: [Intel-gfx] [PATCH 11/11] drm/i915: Allow userspace to request an object at a specific offset

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:19AM +, Chris Wilson wrote: > Certain workarounds and workloads require objects at specific or at > least known offsets. Privileged users could pin an object into the GTT, > but that has obvious limitations for the general case. Instead, the user > can construct a

Re: [Intel-gfx] [PATCH 10/11] drm/i915: Skip holding a reference to the execbuffer objects

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:18AM +, Chris Wilson wrote: > As we only maintain the list underneath the struct_mutex, we can hold a > 'borrowed' reference to the objects safe in the knowledge that they will > not disappear. > > Signed-off-by: Chris Wilson Ok, after our irc discussion I've ch

Re: [Intel-gfx] [PATCH 09/11] drm/i915: Use the reloc.handle as an index into the execbuffer array

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:17AM +, Chris Wilson wrote: > Using copywinwin10 as an example that is dependent upon emitting a lot > of relocations (2 per operation), we see improvements of: > > c2d/gm45: 618000.0/sec to 623000.0/sec. > i3-330m: 748000.0/sec to 789000.0/sec. > > (measured rel

Re: [Intel-gfx] [PATCH 06/11] drm/i915: Take the handle idr spinlock once for looking up the exec objects

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:14AM +, Chris Wilson wrote: > Signed-off-by: Chris Wilson > --- Tiny bikeshed to sneak into follow-up patches, maybe ;-) > drivers/gpu/drm/i915/i915_gem_execbuffer.c | 86 > +++- > 1 file changed, 46 insertions(+), 40 deletions(-) >

Re: [Intel-gfx] [PATCH 05/11] drm/i915: Mark a temporary allocation for copy-from-user as such

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:13AM +, Chris Wilson wrote: > The difference is that the kernel will then know that this memory will > be reclaimable in the near future. > > Signed-off-by: Chris Wilson Queued for -next, thanks for the patch. -Daniel -- Daniel Vetter Software Engineer, Intel Co

Re: [Intel-gfx] [PATCH 03/11] drm: Optionally create mm blocks from top-to-bottom

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:11AM +, Chris Wilson wrote: > Clients like i915 needs to segregate cache domains within the GTT which > can lead to small amounts of fragmentation. By allocating the uncached > buffers from the bottom and the cacheable buffers from the top, we can > reduce the amou

Re: [Intel-gfx] [PATCH 01/11] drm/i915: Bail if we attempt to allocate pages for a purged object

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:09AM +, Chris Wilson wrote: > Move the existing checking inside bind_to_gtt() to the more appropriate > layer in order to prevent recreation of the pages after they have been > explicitly truncated. > > Signed-off-by: Chris Wilson Queued for -next, thanks for the

Re: [Intel-gfx] [PATCH 02/11] drm/i915: Avoid forcing relocations through the mappable GTT or CPU

2013-01-16 Thread Daniel Vetter
On Tue, Jan 08, 2013 at 10:53:10AM +, Chris Wilson wrote: > If the object lies outside of the mappable GTT aperture, do not force it > through the CPU domain for relocations, but simply flush the writes as > we perform them and then queue a chipset flush. > > Signed-off-by: Chris Wilson A fe

Re: [Intel-gfx] [PATCH 1/2] tests: Exercise new API for using a LUT with the execbuffer

2013-01-16 Thread Daniel Vetter
On Wed, Jan 16, 2013 at 04:42:35PM +0100, Daniel Vetter wrote: > On Wed, Dec 05, 2012 at 02:02:21PM +, Chris Wilson wrote: > > Signed-off-by: Chris Wilson > > --- > > tests/Makefile.am |1 + > > tests/gem_lut_handle.c | 109 > > > >

Re: [Intel-gfx] [PATCH 1/2] tests: Exercise new API for using a LUT with the execbuffer

2013-01-16 Thread Daniel Vetter
On Wed, Dec 05, 2012 at 02:02:21PM +, Chris Wilson wrote: > Signed-off-by: Chris Wilson > --- > tests/Makefile.am |1 + > tests/gem_lut_handle.c | 109 > > 2 files changed, 110 insertions(+) > create mode 100644 tests/gem_lut_handle

[Intel-gfx] [ANNOUNCE] xf86-video-intel 2.20.18

2013-01-16 Thread Chris Wilson
A bunch of miscellaneous fixes for assertion failures and various performance regressions when mixing new methods for offloads, along with a couple of improvements for rendering with gen4. * Remove use of packed unnormalized texture coordinates on gen4/5 as these GPUs do not support unnormaliz

Re: [Intel-gfx] [PATCH 11/11] drm/i915: Allow userspace to request an object at a specific offset

2013-01-16 Thread Imre Deak
On Tue, 2013-01-08 at 10:53 +, Chris Wilson wrote: > Certain workarounds and workloads require objects at specific or at > least known offsets. Privileged users could pin an object into the GTT, > but that has obvious limitations for the general case. Instead, the user > can construct a batch a

Re: [Intel-gfx] [PATCH] drm/i915: Add a debug interface to forcibly evict and shrink our object caches

2013-01-16 Thread Daniel Vetter
On Tue, Jan 15, 2013 at 12:39:35PM +, Chris Wilson wrote: > As a means to investigate some bad system behaviour related to the > purging of the active, inactive and unbound lists, it is useful to be > able to manually control when those lists should be cleared. > > v2: use _safe list iterators

Re: [Intel-gfx] [PATCH] drm/i915: Invalidate the relocation presumed_offsets along the slow path

2013-01-16 Thread Daniel Vetter
On Tue, Jan 15, 2013 at 04:17:54PM +, Chris Wilson wrote: > In the slow path, we are forced to copy the relocations prior to > acquiring the struct mutex in order to handle pagefaults. We forgo > copying the new offsets back into the relocation entries in order to > prevent a recursive locking

Re: [Intel-gfx] [PATCH] drm/i915/eDP: do not write power sequence registers for ghost eDP

2013-01-16 Thread Daniel Vetter
On Wed, Jan 16, 2013 at 10:53:40AM +0200, Jani Nikula wrote: > Some machines detect an eDP port even if it's not really there, and eDP > initialization has a fail path for this. Typically such machines have an > LVDS display instead. A regression introduced in > > commit 82ed61fa1a4e08d5f9e86fb1b7

[Intel-gfx] [PATCH] drm/i915/eDP: do not write power sequence registers for ghost eDP

2013-01-16 Thread Jani Nikula
Some machines detect an eDP port even if it's not really there, and eDP initialization has a fail path for this. Typically such machines have an LVDS display instead. A regression introduced in commit 82ed61fa1a4e08d5f9e86fb1b715b50ed678b6ac Author: Daniel Vetter Date: Sat Oct 20 20:57:41 2012