On Thu, 5 May 2022 16:13:59 GMT, Naoto Sato wrote:
> Trivial fix to 3rd party copyright notices.
Marked as reviewed by darcy (Reviewer).
-
PR: https://git.openjdk.java.net/jdk/pull/8558
On Fri, 15 Apr 2022 19:34:33 GMT, Pavel Rappo wrote:
> People rarely include JDK elements with package access in a javadoc run. That
> is why bugs in those elements' doc comments tend to remain unnoticed.
>
> There are many more bugs in the doc comments of the JDK elements with the
> package a
On Fri, 28 Jan 2022 14:39:31 GMT, Matteo Baccan wrote:
> Hi
>
> I have reviewed the code for removing double semicolons at the end of lines
>
> all the best
> matteo
Marked as reviewed by darcy (Reviewer).
-
PR: https://git.openjdk.java.net/jdk/pull/7268
On Sat, 22 Jan 2022 21:09:03 GMT, Joe Darcy wrote:
> Use presumed syntax that will be introduced by JDK-8280488.
This pull request has now been integrated.
Changeset: 8e82d002
Author: Joe Darcy
URL:
https://git.openjdk.java.net/jdk/commit/8e82d0021c119b7793870811fad37d7659c11
> Use presumed syntax that will be introduced by JDK-8280488.
Joe Darcy has updated the pull request with a new target base due to a merge or
a rebase. The incremental webrev excludes the unrelated changes brought in by
the merge/rebase. The pull request contains three additional commits si
On Mon, 24 Jan 2022 11:33:18 GMT, Pavel Rappo wrote:
> > Use presumed syntax that will be introduced by JDK-8280488.
>
> Is that a wrong bug? If you are talking about module-prefix syntax for links,
> then it was introduced in JDK 15; JDK-8164408: Add module support for @see,
> @link and @link
On Sat, 22 Jan 2022 21:09:03 GMT, Joe Darcy wrote:
> Use presumed syntax that will be introduced by JDK-8280488.
This should be the (near) final step to fully enable all doclint checks during
the javac portion of the build. The "reference" doclint check is currently
disabled
Use presumed syntax that will be introduced by JDK-8280488.
-
Commit messages:
- JDK-8280492: Address remaining doclint issues in JDK build
Changes: https://git.openjdk.java.net/jdk/pull/7189/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=7189&range=00
Issue: https:/
On Fri, 3 Dec 2021 01:18:20 GMT, Joe Darcy wrote:
> In JDK 18, JDK-8189591 added the ability to suppress doclint warnings.
> Therefore, it is now possible to enable the full doclint checks for the
> java.desktop module if the instances of warnings are suppressed. This patch
> d
On Fri, 3 Dec 2021 01:18:20 GMT, Joe Darcy wrote:
> In JDK 18, JDK-8189591 added the ability to suppress doclint warnings.
> Therefore, it is now possible to enable the full doclint checks for the
> java.desktop module if the instances of warnings are suppressed. This patch
> d
In JDK 18, JDK-8189591 added the ability to suppress doclint warnings.
Therefore, it is now possible to enable the full doclint checks for the
java.desktop module if the instances of warnings are suppressed. This patch
does this; it would be preferable to address the doc warnings directly, but
On Thu, 18 Nov 2021 21:51:30 GMT, Brent Christian wrote:
> Here are the code changes for the "Deprecate finalizers in the standard Java
> API" portion of JEP 421 ("Deprecate Finalization for Removal") for code
> review.
>
> This change makes the indicated deprecations, and updates the API spec
On Wed, 3 Nov 2021 12:17:09 GMT, Claes Redestad wrote:
>> src/java.base/share/classes/java/time/format/DateTimeFormatterBuilder.java
>> line 3544:
>>
>>> 3542: BigDecimal valueBD =
>>> BigDecimal.valueOf(value).subtract(minBD);
>>> 3543: BigDecimal fraction = valueBD.di
On Tue, 2 Nov 2021 16:30:56 GMT, Pavel Rappo wrote:
> This PR follows up one of the recent PRs, where I used a non-canonical
> modifier order. Since the problem was noticed [^1], why not to address it at
> mass?
>
> As far as I remember, the first mass-canonicalization of modifiers took place
On Thu, 9 Sep 2021 20:12:47 GMT, Andrey Turbanov
wrote:
> Redundant castings make code harder to read.
> Found them by IntelliJ IDEA.
> I tried to select only casts which are definitely safe to remove. Also didn't
> touch primitive types casts.
Curious. The JDK build is done with javac -Xlint:
On Mon, 27 Sep 2021 20:21:43 GMT, Joe Darcy wrote:
> Follow-up changes to JDK-8231334. , augmentations to javac's Xlint:serial
> checking are out for review (#5709) and various client libraries would need
> some changes to pass under the expanded checks.
>
> The cha
On Mon, 27 Sep 2021 21:40:13 GMT, Sergey Bylokhov wrote:
>
>
> Can we add comments to SuppressWarnings on why it was added? Previously we
> use this text
>
> > // Not statically typed as Serializable
Added in revision; used a different comment wording.
-
PR: https://git.openjdk
s in
> serializable types are not declared with a type statically known to be
> serializable. That isn't necessarily a correctness issues, but it does merit
> further scrutiny.
>
> I'll run a script to update the copyright year before pushing.
Joe Darcy has updated the p
Follow-up changes to JDK-8231334. , augmentations to javac's Xlint:serial
checking are out for review (#5709) and various client libraries would need
some changes to pass under the expanded checks.
The changes are to suppress warnings where non-transient fields in serializable
types are not dec
This is an initial PR for expanded lint warnings done under two bugs:
8202056: Expand serial warning to check for bad overloads of serial-related
methods and ineffectual fields
8160675: Issue lint warning for non-serializable non-transient instance fields
in serializable type
to get feedback on
On Fri, 10 Sep 2021 12:21:41 GMT, Naoto Sato wrote:
>> Simple spec clarification. A CSR has also been drafted
>> (https://bugs.openjdk.java.net/browse/JDK-8273296).
>
> Naoto Sato has updated the pull request with a new target base due to a merge
> or a rebase. The incremental webrev excludes t
On 8/18/2021 6:20 AM, Roger Riggs wrote:
On Wed, 18 Aug 2021 10:07:35 GMT, Claes Redestad wrote:
C-style array declarations generate noisy warnings in IDEs, et.c. This patch
cleans up all java.* packages.
(Copyrights intentionally not updated due the triviality of most changes)
34 Minutes
On Wed, 2 Jun 2021 15:25:16 GMT, Patrick Concannon
wrote:
> Hi,
>
> Could someone please review my code for updating the code in the `java.lang`
> packages to make use of the switch expressions?
>
> Kind regards,
> Patrick
Changes to Math and Long look fine.
-
Marked as reviewe
On Tue, 25 May 2021 14:57:22 GMT, Patrick Concannon
wrote:
>> Hi,
>>
>> Could someone please review my code for updating the code in the `java.io`,
>> `java.math`, and `java.text` packages to make use of the switch expressions?
>>
>> Kind regards,
>> Patrick
>
> Patrick Concannon has updated
On Mon, 17 May 2021 18:23:41 GMT, Weijun Wang wrote:
> Please review this implementation of [JEP
> 411](https://openjdk.java.net/jeps/411).
>
> The code change is divided into 3 commits. Please review them one by one.
>
> 1.
> https://github.com/openjdk/jdk/commit/576161d15423f58281e384174d28
On Tue, 6 Apr 2021 20:34:52 GMT, Ian Graves wrote:
> This fixes a bug where the formatting code for `%g` flags incorrectly tries
> to round `BigDecimal` after determining whether it should be a decimal
> numeric format or a scientific numeric format. The solution rounds before
> determining th
On Wed, 24 Mar 2021 23:17:46 GMT, Joe Darcy wrote:
> 8264148: Update spec for exceptions retrofitted for exception chaining
This pull request has now been integrated.
Changeset: 815248ab
Author: Joe Darcy
URL: https://git.openjdk.java.net/jdk/commit/815248ab
Stats: 84 lines in
On 3/30/2021 6:29 AM, Roger Riggs wrote:
On Wed, 24 Mar 2021 23:17:46 GMT, Joe Darcy wrote:
8264148: Update spec for exceptions retrofitted for exception chaining
I agree that the public field in WriteAbortedException could be remediated.
But it is also mostly harmless.
src
On 3/30/2021 6:43 AM, jmehrens wrote:
On Wed, 24 Mar 2021 23:17:46 GMT, Joe Darcy wrote:
8264148: Update spec for exceptions retrofitted for exception chaining
src/java.base/share/classes/java/io/WriteAbortedException.java line 86:
84: @Override
85: public Throwable getCause
On Thu, 25 Mar 2021 18:52:54 GMT, Stuart Marks wrote:
>> 8264148: Update spec for exceptions retrofitted for exception chaining
>
> The removal of the obsolescent "As of release 1.4, this exception has been
> retrofitted..." is good. Changing the calls from the other exception-getting
> methods
8264148: Update spec for exceptions retrofitted for exception chaining
-
Commit messages:
- Respond to review feedback.
- Respond to review feedback.
- Merge branch 'master' into 8264148
- Merge branch 'master' into 8264148
- 8264148: Update spec for exceptions retrofitted for ex
On Mon, 8 Mar 2021 18:48:30 GMT, Patrick Concannon
wrote:
> Hi,
>
> Could someone please review my code for updating the code in the `java.io`,
> `java.math`, and `java.text` packages to make use of the `instanceof` pattern
> variable?
>
> Kind regards,
> Patrick
Marked as reviewed by darcy
On Wed, 17 Feb 2021 17:39:00 GMT, Naoto Sato wrote:
>> Please review this doc fix to j.l.Character, which now includes the table of
>> the history of supported Unicode versions. A corresponding CSR will be filed
>> accordingly.
>
> Naoto Sato has updated the pull request incrementally with one
On Fri, 12 Feb 2021 17:03:57 GMT, Naoto Sato wrote:
>> src/java.base/share/classes/java/lang/Character.java line 86:
>>
>>> 84: * Unicode 10.0
>>> 85: * Java SE 9
>>> 86: * Unicode 8.0
>>
>> Do we really need the history in the API docs? Will will update this table
>> if there is a
On Thu, 22 Oct 2020 17:16:23 GMT, Jonathan Gibbons wrote:
> The change is (just) to remove legacy usages of a JDK-private custom tag.
Marked as reviewed by darcy (Reviewer).
-
PR: https://git.openjdk.java.net/jdk/pull/814
Hi Naoto,
I'd like to see a bit some discussion up front about the expected
evolution of this class.
For example, "once an era is defined, subsequent versions of the API
will add a constant for it. etc. Eras are expected to have consecutive
integers associated with them, etc. "
Once a form
Hello,
Should these changes have CSR requests?
Cheers,
-Joe
On 8/28/2018 10:09 AM, Naoto Sato wrote:
Hi Leo,
Looks good to me. Also, please work with sustaining wrt backports.
Naoto
On 8/28/18 7:56 AM, li.ji...@oracle.com wrote:
Hi,
Please review the changes for ISO 4217 Amendment #168
In general, if you've pushed to JDK 10, you don't need to do anything
else since there will be 10 -> 11 sync which will propagate the fix into 11.
HTH,
-Joe
On 1/17/2018 7:56 PM, Hamlin Li wrote:
Hi Naoto,
I have pushed the code change to http://hg.openjdk.java.net/jdk/jdk10,
I think I nee
to go with existing statement as this method always
returns 13 elements where the 13th element may be empty string or may
contain Calendar.UNDECIMBER, depending upon whether its supported by
the Calendar instance.
kindly suggest whether this looks fine!
Thanks,
Rachna
On 19/12/17 2:55 PM, joe d
Hi Rachna,
On 12/19/2017 1:13 AM, Rachna Goel wrote:
Hello Joe,
Thanks for the review.
Reason I added @implNote is that it's the case for the default
implementation. Not added as a part of spec, as some implementation
can just return 12 element array for same methods through the
"java.text
Hello Rachna,
On 12/18/2017 10:35 PM, Rachna Goel wrote:
Hi,
Kindly review API Doc fix for java.text.DateFormatSymbols.
JBS Issue : https://bugs.openjdk.java.net/browse/JDK-8146656
Webrev: http://cr.openjdk.java.net/~rgoel/8146656/webrev/
CSR: https://bugs.openjdk.java.net/browse/JDK-819141
Looks fine; thanks Amy,
-Joe
On 3/28/2016 7:33 PM, Amy Lu wrote:
java/util/Locale/LocaleProviders.sh starts failing after JDK-8150432,
there's simple issue in JDK-8150432.
Please review this quick fix.
bug: https://bugs.openjdk.java.net/browse/JDK-8152873
webrev: http://cr.openjdk.java.net/~a
Hello,
The changes for JDK-8087104 introduced some test failures which have not
yet been addressed (JDK-8151310). In order to get a clean snapshot for
the next integration, if the fix for JDK-8151310 doesn't arrive in time,
the changes for JDK-8087104 should be reverted until they can be
othe
Hi Yuka,
Your patch looks good; approved to be back.
Thanks,
-Joe
On 07/25/2013 07:42 AM, Yuka Kamiya wrote:
> Hello,
>
> Please review the fix for
> 8021108: Clean up doclint warnings and errors in java.text package
> for JDK 8.
>
> http://cr.openjdk.java.net/~peytoia/8021108/webrev.00/
>
>
>
Looks fine; approved.
Thanks,
-Joe
On 9/12/2012 10:19 AM, Olivier Lagneau wrote:
Please review The implementation of a fast-path algorithm for
optimizing the DecimalFormat.format(double, ...) call stack.
The webrev is here :
http://cr.openjdk.java.net/~olagneau/7050528/webrev.02/
As describ
Hello Olivier.
Olivier Lagneau wrote:
Please review The implementation of a fast-path algorithm for
optimizing the
DecimalFormat(double, ...) call stack.
The webrev is here :
http://cr.openjdk.java.net/~alanb/7050528/webrev.01
As described in the CR evaluation and suggested fix,
the speed-up
On 08/10/09 02:10 PM, Martin Buchholz wrote:
I should really be doing something else, but
I reworked my "surrogate readability patch"
http://cr.openjdk.java.net/~martin/webrevs/openjdk7/isSurrogate2/
to take into account Joe's suggestions.
I checked that the new comments matched the code; ev
47 matches
Mail list logo