> While I'm obviously not so excited about the exclusions idea, maybe
> I'm overseeing a very useful case; is there a compelling reason to
> want that, enough to justify the added complexity? I'm not so much
> concerned about our code complexity (which might be an issue too) but
> more about the th
I think the original proposal was great, but also that we're now
pushing it to accomplish too much.
This feature as the potential to be *brilliant* but it must be
striking simple to both understand and use.
So what I like of the original concept, is that people using it will
focus on what they nee
I'm trying to setup clustering of entities and Lucene indexes for our app
with Hibernate 3.6.5, Hibernate Search 3.4.0, Infinispan 5.0. I'm using
FileCacheStore for the Infinispan cache loader
(InfinispanDirectoryProvider).
MassIndexerImpl.startAndWait() never returns with this configuration. A
On Aug 25, 2011, at 9:31 AM, Hardy Ferentschik wrote:
> It still conflicts with the actual default value of depth and that there is
> no explicit way to say that it is ignored. I don't think "it seems clear"
> is a good enough reason.
That's reasonable. If everything is left in IndexEmbedded yo
On Thu, 25 Aug 2011 17:47:30 +0200, Zach Kurey
wrote:
>
> On Aug 25, 2011, at 2:28 AM, Hardy Ferentschik wrote:
>
>> Or just 'include' and 'exclude'.
>> I feel we are becoming overly verbose in the API design (which is
>> besides
>> this
>> particular issue)
>
> That doesn't seem clear to me.
> As Emmanuel mentioned, can we think of use cases where we would like to
> have access to Lucene Directories (/IndexManagers), which is currently
> mentioned in the docs:
> http://docs.jboss.org/hibernate/search/4.0/reference/en-US/html_single/#d0e6658
> ?
>
> Elmer
Yes that's an important questi
On Aug 25, 2011, at 2:28 AM, Hardy Ferentschik wrote:
> Or just 'include' and 'exclude'.
> I feel we are becoming overly verbose in the API design (which is besides
> this
> particular issue)
That doesn't seem clear to me. If its just include/exclude, what exactly is
being included/excluded?
quote Steve's reply here :)
{
subject: useful features for opening liras
time : Sep 3, 2010
}
##
Its *very* basic. Its just a simple term search. For example,
consider:
https://jira.
On Thu, 25 Aug 2011 17:06:01 +0200, Strong Liu wrote:
> I asked it before
and what happened?
___
hibernate-dev mailing list
hibernate-dev@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/hibernate-dev
I asked it before
---
Strong Liu
http://hibernate.org
http://github.com/stliu
On Aug 25, 2011, at 10:22 PM, Hardy Ferentschik wrote:
> hi,
>
> I have a vague feeling that we had this question before, but could we have
> SuggestiMate (see the JBoss issue tracker) on our Jira instance
hi,
I have a vague feeling that we had this question before, but could we have
SuggestiMate (see the JBoss issue tracker) on our Jira instance as well?
--Hardy
___
hibernate-dev mailing list
hibernate-dev@lists.jboss.org
https://lists.jboss.org/mailma
> Current signature is not accepting the FullTextFilterImplementor, but
> accepts multiple classes:
> SearchFactory.openIndexReader(Class... entities);
>
> Since we can't use two varargs on the same method, this won't work
> unless you're suggesting that we should support a single type only.
No, t
> C - SearchFactory.openIndexReader(String... indexName);
>
> This is simple
I quite like it. And even though you are not going through the
> but it is in no way delegating to the ShardingStrategy
> to make the index names choice which I think would be way more usable.
but you can still impleme
On Thu, 2011-08-25 at 13:26 +0200, Emmanuel Bernard wrote:
> On 25 août 2011, at 12:09, Elmer van Chastelet wrote:
>
> > As is also mentioned in [1], there is currently no direct access to the
> > index managers, so getting a FSDirectory is currently not possible in
> > 4.0alpha1. I think HS shoul
2011/8/25 Elmer van Chastelet :
> Hi all,
>
> Yesterday I had a discussion with Sanne on irc [3] about the new api to
> access index readers in HS4.0. We couldn't complete our discussion
> yesterday, so let's continue here.
> As explained in the forum [1], there is currently no good solution for
>
On Thu, 25 Aug 2011 12:09:50 +0200, Elmer van Chastelet
wrote:
> Currently two basic ideas came to mind:
> A - Have a SearchFactory.openIndexReader(Class c,
> FullTextFilterImplementor...): This is similar to how the IndexManager's
> are gathered at query time, and is probably therefore easy to
On 25 août 2011, at 12:09, Elmer van Chastelet wrote:
> As is also mentioned in [1], there is currently no direct access to the
> index managers, so getting a FSDirectory is currently not possible in
> 4.0alpha1. I think HS should support this to offer the flexibility to
> work on the Lucene inde
On 25 août 2011, at 11:28, Hardy Ferentschik wrote:
> My experience that is is not a good idea to change implicitly
> ignore default values. In this case I would rather see an additional
> enum parameter which allows the user to explicitly select the embedding
> mode (BY_DEPTH, BY_PATH) or maybe
Hi all,
Yesterday I had a discussion with Sanne on irc [3] about the new api to
access index readers in HS4.0. We couldn't complete our discussion
yesterday, so let's continue here.
As explained in the forum [1], there is currently no good solution for
getting a reader with a subset of the indexe
Comments inline:
>> This complicates things. First of all it means that the "subPaths"
>> property should now be named "includeSubPaths" instead, as opposing to
>> "excludeSubPaths".
>
> Yes, if 'excludeSubPaths' is provided, then 'subPaths' should be renamed
> to 'includeSubPaths', for cleanlin
>>
>> Maybe you're right but I don't have the same rightness feeling.
>>
>> Anyways, we can't rewrite history and we can differentiate not set
>> from set to a value in Java's annotations. Besides, I suspect (has to
>> be verified) that normal forms don't like null values even for foreign
>> key
21 matches
Mail list logo