In the case of NIS etc, it is unclear whether it is possible to distinguish
local from
non-local as the system API makes this seamless/transparent. Well, we just have
to study
this when we find the time to consider this feature. Times are busy at the
moment.
M
Justin Lloyd wrote:
> One distin
Probably just need to upgrade. The computation of when something has already
been done
needed some tuning in the past, but I think it's ok now.
Jean-Noël Rivasseau wrote:
> Hi,
>
> This is actually one of the first thing I tried to do with cf-engine,
> never managed to do "correctly". Now I ha
1. You pass a list to the method
2. the $(d) becomes an iterator for both vars and commands
3. the last value wins in the vars assisgnment because it happens last, and is
thereafter
constant
4. the iteration over echo has constant x and 3 x variable d,
Nicolas Charles wrote:
> This is strange in
You can use {} or () for variables.
Nicolas Charles wrote:
> Hi Neil,
>
> Shouldn't it be $(mod) rather than ${mod} ? I guess the () are for
> function parameters, whereas {} are for variables and classes, isn't it ?
>
> Regards,
> Nicolas
>
> 2009/12/2 mailto:nwat...@symcor.com>>
>
> Any
Variables are not getting expanded / not defined. Hard to say more.
nwat...@symcor.com wrote:
> Anyone?
>
> Sincerely,
> --
> Neil Watson
> 416-673-3465
>
> help-cfengine-boun...@cfengine.org wrote on 2009-12-01 21:07:40:
>
>> I've put together a test bundle for this. Nova gives out these err
Hi,
This is actually one of the first thing I tried to do with cf-engine, never
managed to do "correctly". Now I have much more cf-engine experience,
understands better how the software is supposed to work, but I am still
stuck on this one.
Basically this code explains what I want to do:
bundle
It would be nice if the parser allowed us to express this
"$(trg[$(files_list)])"
Like this
"$(trg [ $(files_list) ] )"
for better readability.
--
Neil Watson
Linux/UNIX Consultant
http://watson-wilson.ca
___
Help-cfengine mailing list
Help-cfengine@cf
On Wed, Dec 02, 2009 at 04:17:29PM -0800, Mike Hoskins wrote:
> Which has always been true, but for my own edification... Some bloggers
> used to say the old 2.x parser was more easily confused by one form than
> the other. I presume that is all fixed in 3.x, and does it even/still
> hold f
On Wed, Dec 02, 2009 at 04:17:29PM -0800, Mike Hoskins wrote:
> Which has always been true, but for my own edification... Some bloggers
> used to say the old 2.x parser was more easily confused by one form than
> the other. I presume that is all fixed in 3.x, and does it even/still
> hold f
Neil Watson wrote:
> On Wed, Dec 02, 2009 at 11:04:49PM +0100, Nicolas Charles wrote:
>> Shouldn't it be $(mod) rather than ${mod} ? I guess the () are for
>> function parameters, whereas {} are for variables and classes, isn't it
>
> {} and () can both be used to identify variables.
Which ha
On Wed, Dec 02, 2009 at 11:04:49PM +0100, Nicolas Charles wrote:
>
> Shouldn't it be $(mod) rather than ${mod} ? I guess the () are for
> function parameters, whereas {} are for variables and classes, isn't it
{} and () can both be used to identify variables.
--
Neil Watson
Linux/UNIX Consul
This is strange indeed, I played with your example to understand what was
happening, and I tried this
body common control {
bundlesequence => { "foo" };
}
bundle agent foo {
vars:
"d" slist => { "1.one","1.two","1.three" };
methods:
"any" usebun
Is there a way to define an empty list ?
I tried with the following code, and "ltwo" isn't expanded
body common control {
bundlesequence => { "test" };
}
bundle common g {
classes:
"all" expression => "any";
}
bundle agent test {
vars:
sunos_5_10::
"lone" slist =>
Hi Neil,
Shouldn't it be $(mod) rather than ${mod} ? I guess the () are for function
parameters, whereas {} are for variables and classes, isn't it ?
Regards,
Nicolas
2009/12/2
> Anyone?
>
> Sincerely,
> --
> Neil Watson
> 416-673-3465
>
> help-cfengine-boun...@cfengine.org wrote on 2009-12-01
Anyone?
Sincerely,
--
Neil Watson
416-673-3465
help-cfengine-boun...@cfengine.org wrote on 2009-12-01 21:07:40:
> I've put together a test bundle for this. Nova gives out these errors:
> cf-promises -f ./foo.cf
> Invalid mode string (${mod})
> Problem validating a mode string
> Promise (version
help-cfengine-boun...@cfengine.org wrote on 2009-12-02 16:13:56:
> Hi,
>
> Why don't you use only ${d} in methods?
>
> methods:
> "any" usebundle => subfoo("${d}");
>
> I think you would get expected results.
It does but as Mark pointed out it is a little more efficient to pass the
list one
Hi,
Why don't you use only ${d} in methods?
methods:
"any" usebundle => subfoo("${d}");
I think you would get expected results.
Cheers,
--Nakarin
On Dec 2, 2009, at 9:28 PM, nwat...@symcor.com wrote:
> Thanks for the tip Mark. Using this method again for something different
> get's me som
Thanks for the tip Mark. Using this method again for something different
get's me some unexpected results:
body common control {
bundlesequence => { "foo" };
}
bundle common g {
vars:
sunos_5_10::
"svc_cmd" string => "/usr/sbin/svcadm",
Yes. Use regcmp to parse the output of svcadmin -l for a string like
'online' or 'maintenance'
On Dec 3, 2009 4:02 AM, wrote:
Has anyone done any work gathering the status of services via the Solaris
SMF tool kit? There are some interesting caveats.
1. svcs returns zero whether the service is
One distinction I'd make regarding Paul's feedback would be for systems
with mixed accounts. If a system primarily uses LDAP, for example, but
perhaps I only want to look for expired local accounts (since most
likely expired LDAP accounts would be handled differently), then I'd
want to be able to s
I have also seen weird memory stuff in these places, but I have no idea where
it is coming
from. And it has not caused me trouble.
M
Matt Richards wrote:
> I should have looked at my traceback more carefully:
>
>> ssleay_rand_bytes(buf = " \271`", num = 22), line 485 in "md_rand.c"
>> RAND_b
I should have looked at my traceback more carefully:
> ssleay_rand_bytes(buf = " \271`", num = 22), line 485 in "md_rand.c"
> RAND_bytes(buf = " \271`", num = 32), line 227 in "rand_lib.c"
num=32 and num=22? That shouldn't happen. Looking at the code it should be the
same as it is not modifie
Has anyone done any work gathering the status of services via the Solaris
SMF tool kit? There are some interesting caveats.
1. svcs returns zero whether the service is running or not.
2. Service names have unusual characters (:/) that can update Cf if
trying to make them into classes.
Sincere
It should work, it is just inefficient :-)
Nakarin Phooripoom wrote:
> Why does it work fine for me? ^^"
>
> macbook:bin $ sudo cat /tmp/foo
> Hello world!!!
> macbook:bin $ sudo ./cf-agent -f /tmp/bar.cf -K
> macbook:bin $ sudo cat /tmp/foo
> Hello world!!!
> one
> two
> three
>
> Cheers,
> --
Why does it work fine for me? ^^"
macbook:bin $ sudo cat /tmp/foo
Hello world!!!
macbook:bin $ sudo ./cf-agent -f /tmp/bar.cf -K
macbook:bin $ sudo cat /tmp/foo
Hello world!!!
one
two
three
Cheers,
--Nakarin
On Dec 2, 2009, at 5:15 PM, Mark Burgess wrote:
>
> First you need to pass the list to
First you need to pass the list to the edit bundle with @(list)
rather than iterating too high up -- otherwise you will edit the file once for
each line,
instead of editing the file once with all lines.
see tests/units/unit_edit_insert_lines_silly.cf
(attached)
nwat...@symcor.com wrote:
> G
Hello everyone,
Mark will be in France next week, and will be giving a presentation for all
people that want to chat with him and know more about CFEngine 3. The
meeting will be on Tuesday 8th December, at about 19:30, in the south of
Paris (see below).
Please sign up if you intend to assist, so
Greetings,
I need some help with a editing promise that uses list iteration.
body common control {
bundlesequence => { "test" };
}
bundle common g {
classes:
"all" expression => "any";
}
bundle agent test {
vars:
any::
"x" slist => { "one", "two", "thr
I have tried 0.9.8j/k/l and 1.0 beta 4. All seem to do it, but only on the
policy host, not the clients. There is a mixture of 64bit and 32bit machines,
but from the SSL code, it doesn't appear like that would make a difference,
especially since I bind it to a 32bit only compile.
On Dec 2, 200
Someone told me that the new version 1 is unstable. You could try downgrading?
Matt Richards wrote:
> I didn't think cf-monitord was required, I am just taking stabs in the dark
> on this one. cf-serverd has been crashing a few times a day now and it is
> driving me crazy trying to figure it
I didn't think cf-monitord was required, I am just taking stabs in the dark on
this one. cf-serverd has been crashing a few times a day now and it is driving
me crazy trying to figure it out. It has nothing to do with cfengine (as far as
I can tell), but with the low level SSL functions. Maybe
Not required, but cfengien uses data for seeding encryption algorithms. SSL is
not used by
cfengine, only the low level encryption algorithms
Matt Richards wrote:
> Greetings,
>
> I am trying to track down what I think is an SSL bug and I am wondering if
> cf-monitord is required to be running
Oh, I see. You are thinking too procedurally. Your statement is not convergent,
so it is
rejected by cfengine. There is no convergent solution for "x" in your statement.
nwat...@symcor.com wrote:
> Mark Burgess wrote on 2009-12-02 00:21:41:
>
>> Exactly as you did. It works for me.
>
> What I
I do not believe cf-monitor is required in order for cf-agent and
cf-serverd to work properly.
Sincerely,
--
Neil Watson
416-673-3465
CONFIDENTIALITY WARNING
This communication, including any attachments, is for the exclusive use of
addressee and may contain proprietary and/or confidential in
Greetings,
I am trying to track down what I think is an SSL bug and I am wondering if
cf-monitord is required to be running. I am not currently running it.
___
Help-cfengine mailing list
Help-cfengine@cfengine.org
https://cfengine.org/mailman/listinfo/h
Mark Burgess wrote on 2009-12-02 00:21:41:
>
> Exactly as you did. It works for me.
What I did I would consider concatenating lists. I was hoping to append
as in:
vars:
any::
"x" slist => { "one", "two", "three" };
redhat::
"x" slist => { "@{x}",
36 matches
Mail list logo