Thanks Xavi.
I wonder though: How to solve so that we don't copy all
complete items to achieve similar results? I prefer not
to keep Harbour items in C structures if possible.
Brgds,
Viktor
On 2010 Feb 13, at 05:22, Xavi wrote:
> Hi Viktor,
>
>> Should be fixed now. (Though for me only one o
Done
here is updated incremental guide for hbide
http://harbourlanguage.blogspot.com/
asap i remove hbmk2 from my hbide ready to use distribution
Please made any comment is welcome
2010/2/12 Pritpal Bedi :
>
>
> Massimo Belgrano wrote:
>>
>>> Also bottom output panel must not be shown all the t
> Thanks Xavi.
>
> I wonder though: How to solve so that we don't copy all
> complete items to achieve similar results? I prefer not
> to keep Harbour items in C structures if possible.
To be precise: How to solve it ideally. Without doing
all the manual memcpy() and hb_cdp*() calls, but using
Revision: 13855
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13855&view=rev
Author: vszakats
Date: 2010-02-13 10:30:15 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 11:29 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Revision: 13856
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13856&view=rev
Author: vszakats
Date: 2010-02-13 10:42:35 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 11:42 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/wapi_winbas
can i create project file indipendent from location project directory?
i have project created for c:\harbour\contrib\hbide and not run in
c:\harbour\hbide
2010/2/13 Massimo Belgrano :
> Done
> here is updated incremental guide for hbide
> http://harbourlanguage.blogspot.com/
> asap i remove hbmk2
On Sat, 13 Feb 2010, Szak�ts Viktor wrote:
Hi,
> >> HB_SIZE nLen;
> >> const char * s = hb_itemGetStr( pParam, hb_setGetOSCP(), &hString, &nLen );
> >> p = hb_strunshare( &hString, s, nLen );
> > Exactly and now 'p' is writable string with 'nLen' characters which
> > you can change.
> It doesn't
Revision: 13857
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13857&view=rev
Author: druzus
Date: 2010-02-13 11:36:11 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 12:36 UTC+0100 Przemyslaw Czerpak (druzus/at/priv.onet.pl)
* harbour/src/vm/strapi
Revision: 13858
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13858&view=rev
Author: vouchcac
Date: 2010-02-13 11:44:30 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 03:07 UTC-0800 Pritpal Bedi (prit...@vouchcac.com)
* contrib/hbqt/hbqt_hbqplaint
Hi!
> * harbour/contrib/hbwin/win_dlg.c
> + added WIN_GETOPENFILENAME( [...@]], [], ;
> [], [], ;
> [], [...@]], ;
> [] )
> -> | + e"\0" + [ + e"\0" + ] | ""
> + added WIN_GETSAFEFILENAM
On Sat, 13 Feb 2010, Vailton Renato wrote:
Hi!
> > * harbour/contrib/hbwin/win_dlg.c
> > + added WIN_GETOPENFILENAME( [...@]], [], ;
> > [], [], ;
> > [], [...@]], ;
> > [] )
> > -> | + e"\0
Revision: 13859
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13859&view=rev
Author: vszakats
Date: 2010-02-13 12:12:35 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 13:10 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Hi Przemek,
[...]
> { [, ] }
> 3. array of arrays with names and wildcards:
> { { , } [, { , } ] }
> The default OFN flags are:
> OFN_EXPLORER | OFN_ALLOWMULTISELECT | OFN_HIDEREADONLY
>
> I'll probably add support also for other standard dialogs.
>
> BTW. Viktor I would like to add HW
Revision: 13860
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13860&view=rev
Author: vszakats
Date: 2010-02-13 12:37:19 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 13:36 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Revision: 13861
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13861&view=rev
Author: vszakats
Date: 2010-02-13 12:53:24 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 13:51 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Thanks Viktor,
IMHO before we need to know how to set the minimum version of Windows.
Usually this is done by defining in the final project _WIN32_WINNT.
So the code would look something like this .-
...
#if ( _WIN32_WINNT >= 0x0500 ) && ! defined( HB_OS_WIN_CE )
# define HBDI_L_FGPN( p1, p2,
Hi Xavi,
Another method, and this is what we use consistently
in Harbour, is to #define _WIN32_WINNT to 0x0500.
Though probably we should rather use GetProcAddress()
for GetLongPathName() to not break apps running on
older Windows versions.
Brgds,
Viktor
On 2010 Feb 13, at 14:15, Xavi wrote:
Hello Jaroslaw,
Jarosław Kądzioła wrote:
>
> Local cPort := "\\.\COM28"
> Local phone_number := '123456789'
> Local sms_text := 'This is SMS'
>
> sms_Send( cPort, phone_number , sms_text , .T. )
>
When trying to use the ports COM1 or COM3 is returned -3, to use COM2 me is
returned .F.
What
Hi Viktor,
I have a question about using HB_OS_WIN_CE macro in HBWIN library.
As I can see many functions are disabled and sometimes even such
basic ones like GetProcAddress() which for sure exists in WinCE.
So my question is why this macro was used?
If you only had not time to update some code f
Hi Przemek,
> I have a question about using HB_OS_WIN_CE macro in HBWIN library.
> As I can see many functions are disabled and sometimes even such
> basic ones like GetProcAddress() which for sure exists in WinCE.
> So my question is why this macro was used?
I didn't verify this specific case in
Revision: 13862
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13862&view=rev
Author: druzus
Date: 2010-02-13 14:57:10 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 15:57 UTC+0100 Przemyslaw Czerpak (druzus/at/priv.onet.pl)
* harbour/ChangeLog
Hi Viktor,
Another method, and this is what we use consistently
in Harbour, is to #define _WIN32_WINNT to 0x0500.
IMHO this is not good because we may incorporate, now or in the future,
functionality of XP, W7 ...
Though probably we should rather use GetProcAddress()
for GetLongPathName() t
Witam,
W liście datowanym 13 lutego 2010 (15:22:33) można przeczytać:
> Hello Jaroslaw,
> Jarosław Kądzioła wrote:
>>
>> Local cPort := "\\.\COM28"
>> Local phone_number := '123456789'
>> Local sms_text := 'This is SMS'
>>
>> sms_Send( cPort, phone_number , sms_text , .T. )
>>
> When tryin
>> Another method, and this is what we use consistently
>> in Harbour, is to #define _WIN32_WINNT to 0x0500.
>
> IMHO this is not good because we may incorporate, now or in the future,
> functionality of XP, W7 ...
I also don't understand why do we do it.
I've once raised this issue, but I got
On Sat, 13 Feb 2010, Szak�ts Viktor wrote:
Hi Viktor,
> > If you only had not time to update some code for WinCE builds
> > then please at least leave a not about it or add iTODO warning.
> > Now seems that we have to verify all
> > #if [!] defined( HB_OS_WIN_CE )
> > conditional compilation ma
Hi,
>>> If you only had not time to update some code for WinCE builds
>>> then please at least leave a not about it or add iTODO warning.
>>> Now seems that we have to verify all
>>> #if [!] defined( HB_OS_WIN_CE )
>>> conditional compilation macros and mark the ones which cannot be
>>> implement
Revision: 13863
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13863&view=rev
Author: vszakats
Date: 2010-02-13 17:32:18 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 18:28 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/hbwin.h
*
Revision: 13864
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13864&view=rev
Author: vszakats
Date: 2010-02-13 19:08:16 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 20:06 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Revision: 13865
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13865&view=rev
Author: vszakats
Date: 2010-02-13 19:22:06 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 20:20 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/win_dll.c
Revision: 13866
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13866&view=rev
Author: vszakats
Date: 2010-02-13 19:51:13 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 20:20 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/Makefile
Revision: 13867
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13867&view=rev
Author: vszakats
Date: 2010-02-13 19:53:02 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 20:52 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/hbdyn.h
*
Hi Viktor,
I would suggest that if type of string param not is RAW, not use hb_stor*len
use hb_stor*
This would avoid the possible inclusion of terminating null character.
I also recommend the use of a new our macro in exclusive HB_TEXT for UNICODE
literals.
Or at least change the current defi
Hi,
> I would suggest that if type of string param not is RAW, not use hb_stor*len
> use hb_stor*
> This would avoid the possible inclusion of terminating null character.
Okay, let's gather these and apply them when we
see the bigger picture. Some function may want to
return internal zeroes, s
On Sat, 13 Feb 2010, Szak�ts Viktor wrote:
Hi,
> Above macro should rather be named WINTEXT() or U16TEXT().
This macro is used for native OS texts. In WINCE it's U16.
In desktop windows it's 8bit ASCII text. It doesn't matter
if UNICODE macro is set or not so U16TEXT() is highly confusing
name.
On Sat, 13 Feb 2010, Xavi wrote:
> I also recommend the use of a new our macro in exclusive HB_TEXT for UNICODE
> literals.
> Or at least change the current definition of HBTEXT to avoid problems.
> ...
>#if defined( UNICODE ) || defined( HB_OS_WIN_CE )
> #define HBTEXT( x ) TEXT( x )
>
Hi,
On 2010 Feb 13, at 22:18, Przemysław Czerpak wrote:
> On Sat, 13 Feb 2010, Szak�ts Viktor wrote:
>
> Hi,
>
>> Above macro should rather be named WINTEXT() or U16TEXT().
>
> This macro is used for native OS texts. In WINCE it's U16.
> In desktop windows it's 8bit ASCII text. It doesn't matt
> I would suggest that if type of string param not is RAW, not use hb_stor*len
> use hb_stor*
> This would avoid the possible inclusion of terminating null character.
There is GPF when trying it without length.
(replace hb_parclen() with -1 in hb_u32ret() calls)
Any idea why?
Brgds,
Viktor
___
Revision: 13868
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13868&view=rev
Author: vszakats
Date: 2010-02-13 21:42:06 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 22:41 UTC+0100 Viktor Szakats (harbour.01 syenar.hu)
* contrib/hbwin/hbdyn.c
On Sat, 13 Feb 2010, Szak�ts Viktor wrote:
Hi,
> I don't know about other OSes, but on Windows there
> is no distinction between char and string when using
> TEXT() macro (it works for both), so IMO it's not
> absolutely necessary to match it with type name, since
> it will be confusing in pl
Revision: 13869
http://harbour-project.svn.sourceforge.net/harbour-project/?rev=13869&view=rev
Author: druzus
Date: 2010-02-13 22:16:03 + (Sat, 13 Feb 2010)
Log Message:
---
2010-02-13 23:15 UTC+0100 Przemyslaw Czerpak (druzus/at/priv.onet.pl)
* harbour/contrib/hbwin
>> I don't know about other OSes, but on Windows there
>> is no distinction between char and string when using
>> TEXT() macro (it works for both), so IMO it's not
>> absolutely necessary to match it with type name, since
>> it will be confusing in places anyway.
>
> Sorry I do not know what y
Hbide not starts in linux guve this error
http://www.postimage.org/image.php?v=gxsSMCr
Bruno
___
Harbour mailing list (attachment size limit: 40KB)
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour
Bruno Luciani wrote:
>
> Hbide not starts in linux guve this error
>
>
> http://www.postimage.org/image.php?v=gxsSMCr
>
1. Check if folder where hbIDE.exe resides contains "resources"
sub folder or not. It must be there...
2. If it is there, then check for .ui and matching .uic files and
2010/2/13 Pritpal Bedi >
> 1. Check if folder where hbIDE.exe resides contains "resources"
> sub folder or not. It must be there...
>
It is ok
> 2. If it is there, then check for .ui and matching .uic files and see if
> all
> are in lower case.
>
Ok too
> 3. If still the error exists, repo
Hi Przemek,
You're right if HBTEXT is only for use inside of GetProcAddress.
It has to give 8bit ASCII text in all desktop windows.
IMHO for this reason if the code is for all desktop windows and for WinCE is
better to use GetProcAddressA.
[ Remember the A final for ASCII ]
...
#if defin
45 matches
Mail list logo