[PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays

2008-08-31 Thread Colin D Bennett
This is the first of many patches that I will be posting of my Google Summer of Code 2008 work on GRUB. This patch adds support to the 'grub-mkrescue' command on the i386-pc platform for specifying multiple '--overlay' options. Each --overlay option will result in the later overlays potentially o

[PATCH] GSoC #02 Minor tweak: Comment fix.

2008-08-31 Thread Colin D Bennett
One-liner: Fix an incorrect comment in include/grub/normal.h for GRUB_COMMAND_FLAG_NO_ARG_PARSE. The incorrect comment appears to have been a copy-and-paste error. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> * include/grub/normal.h: Fixed incorrect comment for

[PATCH] GSoC #03 Menu viewer interface

2008-08-31 Thread Colin D Bennett
This patch introduces a "menu viewer" handler interface. This will allow the graphical menu to be used interchangeably with the terminal based menu that normal.mod provides. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> Introduced menu_viewer interface. * includ

[PATCH] GSoC #04 Multiple fallback entries

2008-08-31 Thread Colin D Bennett
This patch adds support for multiple fallback entries. The entry numbers in the 'fallback' environment variable should be space-separated. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> Allow multiple fallback entries. * include/grub/normal.h (grub_menu_execute_c

[PATCH] GSoC #05 Menu entry class attribute

2008-08-31 Thread Colin D Bennett
This patch adds support for a 'class' attribute on menu entries. It is somewhat of a kludge, however since currently you just append "|class=this,that" to the menu entry title to specify the classes. Classes are used to provide a simple and flexible way for the best available icon to be used in a

[PATCH] GSoC #06 VBE optimization for BGR/BGRA color modes

2008-08-31 Thread Colin D Bennett
This patch adds optimized routines for video modes using BGR/BGRA color format. Most PC video cards use BGR (24-bit) or BGRA (32-bit) color modes, so this is an extremely important change and provides a massive performance benefit. I also renamed the R8G8B8A8 and R8B8B8 modes to RGBA and RGB8

[PATCH] GSoC #07 VBE double buffering

2008-08-31 Thread Colin D Bennett
This patch adds double buffering support to the VBE video driver. It uses page flipping if possible, and falls back on using an offscreen buffer which is blitted to video memory if page flipping is not possible. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> VBE smart dou

[PATCH] GSoC #08 vbeinfo enhancements

2008-08-31 Thread Colin D Bennett
This patch adds more information to the vbeinfo output, including the video adapter VBE version, total video memory, and the color layout of each video mode. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> * commands/i386/pc/vbeinfo.c (grub_cmd_vbeinfo): Show VBE version an

[PATCH] GSoC #09 Bitmap scaling

2008-08-31 Thread Colin D Bennett
This patch adds image scaling support. Nearest neighbor and bilinear interpolation algorithms are supported. The gfxterm background_image command scales the background image to fit the screen. This can be controlled with the new --mode/-m option. Regards, Colin === modified file 'conf/i386-pc.r

Re: [PATCH] GSoC #08 vbeinfo enhancements

2008-08-31 Thread Vesa Jääskeläinen
Colin D Bennett wrote: > This patch adds more information to the vbeinfo output, including the > video adapter VBE version, total video memory, and the color layout of > each video mode. Thanks for the patch. In it went with a slight modification. I think we need to get rid of those magic values

Re: [PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays

2008-08-31 Thread Vesa Jääskeläinen
Colin D Bennett wrote: > This is the first of many patches that I will be posting of my Google > Summer of Code 2008 work on GRUB. Hi Colin, Thanks for your patches so far. I don't think we can handle them all before you go to your holiday but we will try to be a bit more flexible this time, so i

Re: Idea: Move kernel to upper memory

2008-08-31 Thread Robert Millan
On Sat, Aug 30, 2008 at 11:15:35PM +0800, Bean wrote: > > Speaking of library, I think we can provide a dynamic library for core > grub2 function. Apps written properly can be executed in both native > os and grub2. For example: > > int main() > { > grub_printf ("Hello world\n"); > return 0;

Re: Idea: Move kernel to upper memory

2008-08-31 Thread Robert Millan
On Sat, Aug 30, 2008 at 11:15:35PM +0800, Bean wrote: > > gcc hello.c -o hello -lgrub2 Ah, what I meant about linking was to make it easy to link external code into GRUB modules. Standalone executables sound more overkill to me. -- Robert Millan The DRM opt-in fallacy: "Your data belongs to

Re: [PATCH] fix disk->id abuse

2008-08-31 Thread Robert Millan
On Sat, Aug 30, 2008 at 11:41:18AM -0400, Pavel Roskin wrote: > Quoting Robert Millan <[EMAIL PROTECTED]>: > > >So this patch means to solve both issues; makes single-disk drivers use a > >constant directly (since a pointer to string is meaningless and confusing), > >and disk/scsi.c use LUNs whic

Re: [PATCH] GSoC #08 vbeinfo enhancements

2008-08-31 Thread Colin D Bennett
On Sun, 31 Aug 2008 12:30:24 +0300 Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > Colin D Bennett wrote: > > This patch adds more information to the vbeinfo output, including > > the video adapter VBE version, total video memory, and the color > > layout of each video mode. > > Thanks for the pat

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Robert Millan
On Sat, Aug 30, 2008 at 10:15:36PM +0200, Felix Zielcke wrote: > Here's a patch which implements UUID support for the iso9660 filesystem, > by using the creation date in the `superblock'. Nice work :-) > The specs say that it's allowed to contain only zeros but I think this > shouldn't be a big p

Re: [PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays

2008-08-31 Thread Colin D Bennett
On Sun, 31 Aug 2008 12:32:59 +0300 Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > Colin D Bennett wrote: > > This is the first of many patches that I will be posting of my > > Google Summer of Code 2008 work on GRUB. > > Hi Colin, > > Thanks for your patches so far. I don't think we can handle t

Re: [PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays

2008-08-31 Thread Robert Millan
On Sat, Aug 30, 2008 at 11:43:41PM -0700, Colin D Bennett wrote: > === modified file 'util/i386/pc/grub-mkrescue.in' > --- util/i386/pc/grub-mkrescue.in 2008-07-12 14:40:50 + > +++ util/i386/pc/grub-mkrescue.in 2008-08-30 18:33:46 + > @@ -71,7 +71,7 @@ > --modules=*) > mo

Re: Idea: Move kernel to upper memory

2008-08-31 Thread Bean
On Sun, Aug 31, 2008 at 9:30 PM, Robert Millan <[EMAIL PROTECTED]> wrote: > On Sat, Aug 30, 2008 at 11:15:35PM +0800, Bean wrote: >> >> gcc hello.c -o hello -lgrub2 > > Ah, what I meant about linking was to make it easy to link external code into > GRUB modules. Standalone executables sound more o

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Felix Zielcke
Hello list, Am Sonntag, den 31.08.2008, 15:47 +0200 schrieb Robert Millan: > Nice work :-) By the way the TAB key on emacs is really nice you even don't need to care about moving the cursor to the beginning of the line :) > > The specs say that it's allowed to contain only zeros but I think thi

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Javier Martín
El dom, 31-08-2008 a las 16:27 +0200, Felix Zielcke escribió: > > > The specs say that it's allowed to contain only zeros but I think this > > > shouldn't be a big problem. > > > > I think this could indeed be a problem if it leads to collisions. If "all > > zeroes" is detected, one could rise an

Re: [patch] background_image: image centering and scaling

2008-08-31 Thread Colin D Bennett
On Fri, 29 Aug 2008 22:11:02 -0700 Olaf Mandel <[EMAIL PROTECTED]> wrote: > Vesa Jääskeläinen schrieb: > -Snipp- > > I will however look at if there are some ideas that you have > > provided what is still missing from new graphical menu > > implementation that should be there. > -Snipp- > > Hello

Re: [RFC] USB Support

2008-08-31 Thread Colin D Bennett
On Thu, 28 Aug 2008 12:16:59 +0200 Felix Zielcke <[EMAIL PROTECTED]> wrote: > + grub_usb_iterate (usb_iterate); > +} > + > + > > Weird ` ' character which seems not to make sense. Actually that is a form feed character, which the GNU coding standard recommends to be used to break up source cod

Re: [PATCH] GSoC #08 vbeinfo enhancements

2008-08-31 Thread Vesa Jääskeläinen
Colin D Bennett wrote: > On Sun, 31 Aug 2008 12:30:24 +0300 > Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > >> Colin D Bennett wrote: >>> This patch adds more information to the vbeinfo output, including >>> the video adapter VBE version, total video memory, and the color >>> layout of each video

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Felix Zielcke
Am Sonntag, den 31.08.2008, 17:06 +0200 schrieb Javier Martín: Hello Javier, > El dom, 31-08-2008 a las 16:27 +0200, Felix Zielcke escribió: > > > > But maybe it would be better to make a new type for this, though I don't > > have yet an idea how to call it. > > Suggestions please :) > What abou

[PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays (v2)

2008-08-31 Thread Colin D Bennett
On Sun, 31 Aug 2008 15:49:45 +0200 Robert Millan <[EMAIL PROTECTED]> wrote: > Hi, > > I'd suggest mentioning in --help that --overlay can be specified > multiple times. It is so. New patch attached. Regards, Colin 2008-08-30 Colin D Bennett <[EMAIL PROTECTED]> * util/i386/pc/grub-mkr

Re: [RFC] USB Support

2008-08-31 Thread Felix Zielcke
Am Sonntag, den 31.08.2008, 08:59 -0700 schrieb Colin D Bennett: Hello Colin, > > > > Weird ` ' character which seems not to make sense. > > Actually that is a form feed character, which the GNU coding standard > recommends to be used to break up source code at logical places: Yep Marco alread

Re: [PATCH] GSoC #09 Bitmap scaling

2008-08-31 Thread Vesa Jääskeläinen
Colin D Bennett wrote: > This patch adds image scaling support. Nearest neighbor and bilinear > interpolation algorithms are supported. > > The gfxterm background_image command scales the background image to fit > the screen. This can be controlled with the new --mode/-m option. Copyrights year

Re: [PATCH] GSoC #09 Bitmap scaling

2008-08-31 Thread Vesa Jääskeläinen
Vesa Jääskeläinen wrote: > Colin D Bennett wrote: >> This patch adds image scaling support. Nearest neighbor and bilinear >> interpolation algorithms are supported. >> >> The gfxterm background_image command scales the background image to fit >> the screen. This can be controlled with the new --m

Re: [RFC] USB Support

2008-08-31 Thread Colin D Bennett
On Sun, 31 Aug 2008 18:13:56 +0200 Felix Zielcke <[EMAIL PROTECTED]> wrote: > Thanks for the copy&paste and even the link to it. > I still find it weird and I even wasn't able yet to produce them in > Emacs. > Control-L is the wrong key combination for it ;) Try C-q C-L. Cheers, Colin

Re: [PATCH] GSoC #01 grub-mkrescue i386-pc multiple overlays (v2)

2008-08-31 Thread Robert Millan
On Sun, Aug 31, 2008 at 09:07:40AM -0700, Colin D Bennett wrote: > On Sun, 31 Aug 2008 15:49:45 +0200 > Robert Millan <[EMAIL PROTECTED]> wrote: > > > Hi, > > > > I'd suggest mentioning in --help that --overlay can be specified > > multiple times. > > It is so. New patch attached. Thanks! I c

[PATCH] GSoC #08 [v2] vbeinfo enhancements

2008-08-31 Thread Colin D Bennett
On Sun, 31 Aug 2008 18:59:53 +0300 Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > Colin D Bennett wrote: > > On Sun, 31 Aug 2008 12:30:24 +0300 > > Vesa Jääskeläinen <[EMAIL PROTECTED]> wrote: > > > >> Colin D Bennett wrote: > >>> This patch adds more information to the vbeinfo output, including

renaming util/biosdisk.c

2008-08-31 Thread Robert Millan
Hi, I think we discussed before about util/biosdisk.c being a confusing name, but I can't find that thread. Did we agree on renaming it to something else? If so, what to? -- Robert Millan The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and how) you may access your

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Robert Millan
Some more things I overlooked.. On Sun, Aug 31, 2008 at 04:27:04PM +0200, Felix Zielcke wrote: > +struct grub_iso9660_date > +{ > + grub_uint8_t year[4]; > + grub_uint8_t month[2]; > + grub_uint8_t day[2]; > + grub_uint8_t hour[2]; > + grub_uint8_t minute[2]; > + grub_uint8_t second[2]; > +

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Felix Zielcke
Am Sonntag, den 31.08.2008, 18:56 +0200 schrieb Robert Millan: > Some more things I overlooked.. > > +}__attribute__ ((packed)); > ^ > > Please add a space here Right. > > @@ -812,8 +826,59 @@ grub_iso9660_label (grub_device_t device > >return grub_errno; > > } > > > > - > > Please

Re: renaming util/biosdisk.c

2008-08-31 Thread Pavel Roskin
On Sun, 2008-08-31 at 18:49 +0200, Robert Millan wrote: > Hi, > > I think we discussed before about util/biosdisk.c being a confusing name, > but I can't find that thread. Did we agree on renaming it to something > else? If so, what to? My preference: util/hostdisk.c Runners-up: util/osdisk.c

Re: renaming util/biosdisk.c

2008-08-31 Thread Robert Millan
On Sun, Aug 31, 2008 at 02:07:08PM -0400, Pavel Roskin wrote: > On Sun, 2008-08-31 at 18:49 +0200, Robert Millan wrote: > > Hi, > > > > I think we discussed before about util/biosdisk.c being a confusing name, > > but I can't find that thread. Did we agree on renaming it to something > > else? I

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Robert Millan
On Sun, Aug 31, 2008 at 07:23:41PM +0200, Felix Zielcke wrote: > + *uuid = grub_malloc (sizeof ("-MM-DD-HH-mm-ss-hh") Lovely :-) > + sizeof ('\0')); Is this really needed? sizeof("foo") implicitly includes the trailing \0. -- Robert Millan The DRM opt-in fallacy: "Your data belon

Re: [PATCH] iso9660 UUID support by using the creation date/time

2008-08-31 Thread Felix Zielcke
Am Sonntag, den 31.08.2008, 20:40 +0200 schrieb Robert Millan: > On Sun, Aug 31, 2008 at 07:23:41PM +0200, Felix Zielcke wrote: > > + *uuid = grub_malloc (sizeof ("-MM-DD-HH-mm-ss-hh") > > Lovely :-) > > > + sizeof ('\0')); > > Is this really needed? sizeof("foo") implicitly includes th

Re: renaming util/biosdisk.c

2008-08-31 Thread Vesa Jääskeläinen
Robert Millan wrote: > On Sun, Aug 31, 2008 at 02:07:08PM -0400, Pavel Roskin wrote: >> On Sun, 2008-08-31 at 18:49 +0200, Robert Millan wrote: >>> Hi, >>> >>> I think we discussed before about util/biosdisk.c being a confusing name, >>> but I can't find that thread. Did we agree on renaming it to

Hiddenmenu for grub2

2008-08-31 Thread Niko Cavallini Araya
Hi, this week I made a clean debian sid install and decided to install grub2 (grub-pc) instead of -legacy. It is working nicely, great job there! Thank you! I wanted to add the "hiddenmenu" functionality found in grub-legacy, to this end I came across the previous version of http://grub.enbug.org/

man pages' NAME section wrong

2008-08-31 Thread jidanni
See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496706 and say if this is an upstream bug or not. ___ Grub-devel mailing list Grub-devel@gnu.org http://lists.gnu.org/mailman/listinfo/grub-devel

allow making no timeout

2008-08-31 Thread jidanni
>From http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497085 I assume this is an upstream problem. ___ Grub-devel mailing list Grub-devel@gnu.org http://lists.gnu.org/mailman/listinfo/grub-devel

Re: [PATCH] GSoC #08 [v3] vbeinfo enhancements

2008-08-31 Thread Colin D Bennett
This refinement is against current SVN head. It introduces the VBE mode info field constant values into vbe.h and these are used instead of the magic numbers in vbeinfo.c. Regards, Colin 2008-08-31 Colin D Bennett <[EMAIL PROTECTED]> * commands/i386/pc/vbeinfo.c (grub_cmd_vbeinfo): Show