On Sun, Sep 25, 2016, at 11:04 AM, Jakub Narębski wrote:
>
> For what it is worth it:
>
> Acked-by: Jakub Narębski
>
> (but unfortunately *not* tested by).
Thank you for all your help.
--
Ian Kelling
On Wed, Sep 28, 2016 at 07:01:38AM +0200, Michael Haggerty wrote:
> > - a global for chaining to error, like:
> >
> >struct error_context print_errors = {
> > error, /* actually a wrapper to handle va_list and NULL data */
> > NULL
> >};
>
> There could also
Let's see if I can get the first commit graduated before it turns two
years old. Six months to go! This series is about some oddities of
intent-to-add entries (aka "git add -N"):
1) An ita entry in git-status shows that it's added in the index
(compared to worktree) as a file change, not new fi
The original commit d95d728aba06a34394d15466045cbdabdada58a2 was
reverted in commit 78cc1a540ba127b13f2f3fd531777b57f3a9cd46 because we
were (and still are) not ready for a new world order. A lot more
investigation must be done to see what is impacted. See the 78cc1a5 for
details.
This patch takes
This function is basically "git diff --cached HEAD", It has three
callers:
- One in builtin/commit.c, which uses it to determine if the index is
different from HEAD and go ahead making a new commit.
- Two in sequencer.c, which use it to see if the index is dirty.
In the first case, if ita e
ita entries are dropped at tree creation phase. If the entire index
consists of just ita entries, the result would be a a commit with no
entries, which should be caught unless --allow-empty is specified.
Signed-off-by: Nguyễn Thái Ngọc Duy
---
builtin/commit.c | 11 ---
t/t2203-add-
On Wed, Sep 28, 2016 at 6:43 PM, Nguyễn Thái Ngọc Duy wrote:
> 1) and 2) are fixed by changing the position of ita entries in diff
> code. ita entries should be seen as a new file when compared between
> worktree and HEAD
Big typo. "between worktree and index".
--
Duy
A Dom, 25-09-2016 às 15:52 -0700, Junio C Hamano escreveu:
> > @@ -252,7 +253,7 @@ sub list_untracked {
> > }
> >
> > my $status_fmt = '%12s %12s %s';
> > -my $status_head = sprintf($status_fmt, 'staged', 'unstaged', 'path');
> > +my $status_head = sprintf($status_fmt, __('staged'), __('unstage
According to gpg2's doc/DETAILS:
"For each signature only one of the codes GOODSIG, BADSIG, EXPSIG,
EXPKEYSIG, REVKEYSIG or ERRSIG will be emitted."
gpg1 ("classic") behaves the same (although doc/DETAILS
differs).
Currently, we parse gpg's status output for GOODSIG, BADSIG and trust
information
On Wed, Sep 28, 2016 at 7:43 PM, Vasco Almeida wrote:
> A Dom, 25-09-2016 às 15:52 -0700, Junio C Hamano escreveu:
>> > @@ -252,7 +253,7 @@ sub list_untracked {
>> > }
>> >
>> > my $status_fmt = '%12s %12s %s';
>> > -my $status_head = sprintf($status_fmt, 'staged', 'unstaged', 'path');
>> > +my
On 28/09/16 15:24, Michael J Gruber wrote:
> According to gpg2's doc/DETAILS:
> "For each signature only one of the codes GOODSIG, BADSIG, EXPSIG,
> EXPKEYSIG, REVKEYSIG or ERRSIG will be emitted."
>
> gpg1 ("classic") behaves the same (although doc/DETAILS
> differs).
>
> Currently, we parse g
Delegation of credentials is disabled by default in libcurl since
version 7.21.7 due to security vulnerability CVE-2011-2192. Which
makes troubles with GSS/kerberos authentication where delegation
of credentials is required. This can be changed with option
CURLOPT_GSSAPI_DELEGATION in libcurl with
Vasco Almeida writes:
> As far as I understand, %12s means that the argument printed will have
> a minimum length of 12 columns. So if the translation of 'stage' is
> longer than 12 it will be printed fully no matter what. Though in that
> case, the header will not be align correctly anymore:
Ex
Resending
> -Original Message-
> From: git-ow...@vger.kernel.org [mailto:git-ow...@vger.kernel.org] On
> Behalf Of Philip Oakley
> Sent: Saturday, September 24, 2016 3:31 PM
> To: Junio C Hamano
> Cc: Ben Peart ; pclo...@gmail.com;
> git@vger.kernel.org
> Subject: Re: [PATCH v3] checkout:
On 28.9.2016 18:05, Petr Stodulka wrote:
> Delegation of credentials is disabled by default in libcurl since
> version 7.21.7 due to security vulnerability CVE-2011-2192. Which
> makes troubles with GSS/kerberos authentication where delegation
> of credentials is required. This can be changed wit
On Wed, Sep 28, 2016 at 06:05:52PM +0200, Petr Stodulka wrote:
> Delegation of credentials is disabled by default in libcurl since
> version 7.21.7 due to security vulnerability CVE-2011-2192. Which
> makes troubles with GSS/kerberos authentication where delegation
> of credentials is required. Th
On 09/27, Junio C Hamano wrote:
> Junio C Hamano writes:
>
> > In nul_to_q and q_to_nul implementations (t/test-lib-functions.sh)
> > we seem to avoid using "tr", even though q_to_cr and others do use
> > it. I wonder if we had some portability issues with passing NUL
> > through tr or something
Junio C Hamano writes:
>>> git clone --resume
>>
>> I think calling "git fetch" should resume, actually.
>> It would reduce the learning curve and seems natural to me:
>> "fetch" is jabout grabbing whatever else appeared since the
>> last clone/fetch happened.
>
> I hate say this but it sounds t
"Ben Peart" writes:
> The fact that "git checkout -b NEW" updates the index and as a
> result reflects any changes in the sparse-checkout and the issue
> Junio pointed out earlier about not calling show_local_changes
> at the end of merge_working_tree are the only difference in behavior
> I am
Kevin Wern writes:
> On Fri, Sep 16, 2016 at 04:07:00PM -0700, Junio C Hamano wrote:
>> Kevin Wern writes:
>>
>> > Add option RUN_COMMAND_NO_STDOUT, which sets no_stdout on a child
>> > process.
>> >
>> > This will be used by git clone when calling index-pack on a downloaded
>> > packfile.
>>
"Eric S. Raymond" writes:
> Jeff King :
>> I am not qualified to write on the current state of
>> the art in CVS importing.
>
> I *am* qualified; cvs-fast-export has had a lot of work put into it by
> myself and others over the last five years. Nobody else is really
> working this
Delegation of credentials is disabled by default in libcurl since
version 7.21.7 due to security vulnerability CVE-2011-2192. Which
makes troubles with GSS/kerberos authentication when delegation
of credentials is required. This can be changed with option
CURLOPT_GSSAPI_DELEGATION in libcurl with s
Jeff King writes:
> if (!dont_change_ref) {
> struct ref_transaction *transaction;
> - struct strbuf err = STRBUF_INIT;
> -
> - transaction = ref_transaction_begin(&err);
> - if (!transaction ||
> - ref_transaction_update(tra
On Wed, Sep 28, 2016 at 10:54:52AM -0700, Junio C Hamano wrote:
>
> I just got an impression that you were apologetic for having to add
> this option that is otherwise useless and tried to suggest a simpler
> solution that does not involve such an addition.
Sorry, to be clear, I meant I was ok wi
Junio C Hamano writes:
> Junio C Hamano writes:
>
> What "git clone" should have been was:
>
> * Parse command line arguments;
>
> * Create a new repository and go into it; this step would
> require us to have parsed the command line for --template,
> , --separate-git-dir, et
Nguyễn Thái Ngọc Duy writes:
> This function is basically "git diff --cached HEAD", It has three
> callers:
>
> - One in builtin/commit.c, which uses it to determine if the index is
>different from HEAD and go ahead making a new commit.
>
> - Two in sequencer.c, which use it to see if the
Brandon Williams writes:
>> I actually think it would make more sense to add
>>
>> lf_to_nul () {
>> perl -pe 'y/\012/\000/'
>> }
>>
>> to t/test-lib-functions.sh somewhere near q_to_nul if we were to go
>> this route.
>
> Turns out this function already exists in test-lib-f
On 28.9.2016 19:16, Jeff King wrote:
> On Wed, Sep 28, 2016 at 06:05:52PM +0200, Petr Stodulka wrote:
>
>> Delegation of credentials is disabled by default in libcurl since
>> version 7.21.7 due to security vulnerability CVE-2011-2192. Which
>> makes troubles with GSS/kerberos authentication whe
Nguyễn Thái Ngọc Duy writes:
> The original commit d95d728aba06a34394d15466045cbdabdada58a2 was
> reverted in commit 78cc1a540ba127b13f2f3fd531777b57f3a9cd46 because we
> were (and still are) not ready for a new world order. A lot more
> investigation must be done to see what is impacted. See th
Changes since v3:
- t5100-mailinfo: Reverted back to capital $DATA
- t5100-mailinfo: Moved quotes to around the entire string, instead of the
variable, as per Junio's suggestion
Kevin Daudt (2):
t5100-mailinfo: replace common path prefix with variable
mailinfo: unescape quoted-pair in heade
rfc2822 has provisions for quoted strings in structured header fields,
but also allows for escaping these with so-called quoted-pairs.
The only thing git currently does is removing exterior quotes, but
quotes within are left alone.
Remove exterior quotes and remove escape characters so that they
Many tests need to store data in a file, and repeat the same pattern to
refer to that path:
"$TEST_DIRECTORY"/t5100/
Create a variable that contains this path, and use that instead.
While we're making this change, make sure the quotes are not just around
the variable, but around the entire s
Michael J Gruber writes:
> - Use GNUPGHOME="$HOME/gnupg-home-not-used" just like in other tests (lib).
If you are not using /dev/null, I expected you to do
. ./test-lib.sh
GNUPGHOME_saved=$GNPGHOME
. "$TEST_DIRECTORY/lib-gpg.sh"
and then use
GNUPGHOME="$GNUPGHO
Kevin Daudt writes:
> Many tests need to store data in a file, and repeat the same pattern to
> refer to that path:
>
> "$TEST_DIRECTORY"/t5100/
>
> Create a variable that contains this path, and use that instead.
>
> While we're making this change, make sure the quotes are not just around
>
On Wed, Sep 28, 2016 at 01:21:13PM -0700, Junio C Hamano wrote:
> Kevin Daudt writes:
>
> > Many tests need to store data in a file, and repeat the same pattern to
> > refer to that path:
> >
> > "$TEST_DIRECTORY"/t5100/
> >
> > Create a variable that contains this path, and use that instead.
Junio C Hamano writes:
> As I already said, --shift-ita is not quite descriptive and I think
> it should be renamed to something else, but I kept that in the
> following attempt to rewrite:
> ...
Please do not use that verbatim; it was full of typo and grammo.
> After reading the three patches
Junio C Hamano wrote:
> Eric Wong writes:
>
> >> [primeclone]
> >>url = http://location/pack-$NAME.pack
> >>filetype = pack
> >
> > If unconfigured, I wonder if a primeclone pack can be inferred by
> > the existence of a pack bitmap (or merely being the biggest+oldest
> > pack for dumb H
On 28/09/16 20:59, Junio C Hamano wrote:
> Michael J Gruber writes:
>> + "X" for a good expired signature, or good signature made by an expired
>> key,
>
> As an attempt to clarify that we cover both EXPSIG and EXPKEYSIG
> cases, I think this is good enough. I may have phrased the former
>
Petr Stodulka writes:
> However, I discuss it with libcurl maintainer and he confirm that this
> option can be required in some cases and this is what I need to do.
> this already. I tested just setting of parameter in libcurl according
> to description and nothing else seems broken. So anyone el
Macro CURLAUTH_GSSNEGOTIATE is deprecated since cURL v7.38.0 and
should be used CURLAUTH_NEGOTIATE instead. For compatibility
with older versions of cURL is CURLAUTH_NEGOTIATE set as alias
to CURLAUTH_GSSNEGOTIATE
Signed-off-by: Petr Stodulka
---
http.c| 4 ++--
http.h| 7 +++
I suspect that you are preparing a reroll already, but the one that
is sitting in 'pu' seems to be flaky in t/t0021 and I seem to see
occasional failures from it.
I didn't trace where the test goes wrong, but one easy mistake you
could make (I am not saying that is the reason of the failure) is to
Add a super-prefix environment variable 'GIT_INTERNAL_SUPER_PREFIX'
which can be used to specify a path from above a repository down to its
root. The immediate use of this option is by commands which have a
--recurse-submodule option in order to give context to submodules about
how they were invok
Pass through some known-safe options when recursing into submodules.
(--cached, --stage, -v, -t, -z, --debug, --eol)
Other options are compiled into an argv_array but if an unsafe option is
given the caller will be errored out.
Signed-off-by: Brandon Williams
---
builtin/ls-files.c
Allow ls-files to recognize submodules in order to retrieve a list of
files from a repository's submodules. This is done by forking off a
process to recursively call ls-files on all submodules. Use top-level
--super-prefix option to pass a path to the submodule which it can
use to prepend to outpu
The big change in this version is the introduction of a --super-prefix option
to the top level git. After much discussion this seemed to be a better naming
scheme than 'submodule-prefix' as it could be an option other cmds could use
independent of submodules.
In 3/4 I changed the compile_submodul
Pathspecs can be a bit tricky when trying to apply them to submodules.
The main challenge is that the pathspecs will be with respect to the
superproject and not with respect to paths in the submodule. The
approach this patch takes is to pass in the identical pathspec from the
superproject to the s
This does not make any practical difference in today's code, but
everybody else accesses the default abbreviation length via the
DEFAULT_ABBREV macro. Make sure this oddball codepath does not
stray from the convention.
Signed-off-by: Junio C Hamano
---
builtin/blame.c | 2 +-
1 file changed, 1
On Wed, Sep 28, 2016 at 2:50 PM, Brandon Williams wrote:
>
> DESCRIPTION
> @@ -601,6 +602,11 @@ foo.bar= ...`) sets `foo.bar` to the empty string.
> details. Equivalent to setting the `GIT_NAMESPACE` environment
> variable.
>
> +--super-prefix=::
> + Set a prefix which giv
On Wed, Sep 28, 2016 at 2:50 PM, Brandon Williams wrote:
> Allow ls-files to recognize submodules in order to retrieve a list of
> files from a repository's submodules. This is done by forking off a
> process to recursively call ls-files on all submodules. Use top-level
> --super-prefix option to
Brandon Williams writes:
> Add a super-prefix environment variable 'GIT_INTERNAL_SUPER_PREFIX'
> which can be used to specify a path from above a repository down to its
> root. The immediate use of this option is by commands which have a
> --recurse-submodule option in order to give context to s
Brandon Williams writes:
> +--recurse-submodules::
> + Recursively calls ls-files on each submodule in the repository.
> + Currently there is only support for the --cached mode.
Good to describe it, but at this step, there is only support for the
"--cached" mode and it does not take a pa
Part third (and last) of the review of v8 11/11.
W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com napisał:
[...]
> diff --git a/contrib/long-running-filter/example.pl
> b/contrib/long-running-filter/example.pl
> new file mode 100755
> index 000..c13a631
> --- /dev/null
> +++ b/contrib/long
W dniu 26.09.2016 o 20:49, Lars Schneider pisze:
> On 24 Sep 2016, at 23:14, Jakub Narębski wrote:
>> W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze:
>>
>>> From: Lars Schneider
>>>
>>> packet_write() should be called packet_write_fmt() as the string
>>> parameter can be formatted.
>>
As Peff said, responding in a thread started by Linus's suggestion
to raise the default abbreviation to 12 hexdigits:
I actually think "12" might be sane for a long time. That's 48 bits of
sha1, so we'd expect a 50% change of a _single_ collision at 2^24, or 16
million. The biggest re
The command accesses default_abbrev (defined in environment.c and is
updated via core.abbrev configuration), but never makes any call to
git_config(). The output from "worktree list" ignores the abbrev
setting for this reason.
Make a call to git_config() to read the default set of configuration
v
Most parts of these two tests want to read from the local
configuration file they prepare and make sure expected names and
values appear with "git config --list".
Once we add custom configuration items that we want to affect the
tests with globally to t/gitconfig-for-test file, these will start
se
Per request/suggestion by Linus.
This took far more effort to keep the existing tests working than
the actual change.
Junio C Hamano (4):
config: allow customizing /etc/gitconfig location
t13xx: do not assume system config is empty
worktree: honor configuration variables
core.abbrev: rai
With a new environment variable GIT_ETC_GITCONFIG, the users can
specify a file that is used instead of /etc/gitconfig to read (and
write) the system-wide configuration.
Earlier, we introduced GIT_CONFIG_NOSYSTEM environment variable
ab88c363 ("allow suppressing of global and system config",
2008-
> As Peff said, responding in a thread started by Linus's suggestion
> to raise the default abbreviation to 12 hexdigits:
>
> I actually think "12" might be sane for a long time. That's 48 bits of
> sha1, so we'd expect a 50% change of a _single_ collision at 2^24, or 16
s/change/chance/
On Thu, 29 Sep 2016 at 04:44:00, SZEDER Gábor wrote:
> I for one raise my hand in protest...
>
> "few extra bytes" is not the only downside, and it's not at all about
> how many characters are copy-and-pasted. In my opinion it's much more
> important that this change wastes 5 columns worth of val
Simple example output from the Git repository:
git log-times --graph --date-order --decorate --no-merges -n 5 v2.5.3
=== 2015-09-17 ===
* ee6ad5f4 12:16 jch (tag: v2.5.3) Git 2.5.3
=== 2015-09-09 ===
* b9d66899 14:22 js am --skip/--abort: merge HEAD/ORIG_HEAD tree into index
| ==
Am 29.09.2016 um 01:30 schrieb Junio C Hamano:
As Peff said, responding in a thread started by Linus's suggestion
to raise the default abbreviation to 12 hexdigits:
This is waayy too large for a new default. The vast majority of
repositories is smallish. For those, the long sequences of hex di
On 15.09.16 22:04, Junio C Hamano wrote:
> Lars Schneider writes:
>
>> Wouldn't that complicate the pathname parsing on the filter side?
>> Can't we just define in our filter protocol documentation that our
>> "pathname" packet _always_ has a trailing "\n"? That would mean the
>> receiver would
63 matches
Mail list logo