Junio C Hamano writes:
[...]
> The "the tip being merged into the mainline must always be
> fast-forwardable",
It's rather "the tip being merged into the mainline must be fast-forwardable the
first time it is merged".
> however, is not consistent with the topic branch workflow, and I do
> not
I apologize for the incorrect report sent earlier. I changed something about my
workflow, and it changed where build outputs were downloaded and I included an
old report.
-Stolee
---
pu c984b65d414a0da7af629eb476f12b27e13ede0b
jch 2bb3fc833ce3b23a27fdaba73982b617ba480bb7
nextf5cf6
Here is today's test coverage report.
Thanks,
-Stolee
[1] https://derrickstolee.github.io/git-test-coverage/reports/2019-07-10.htm
[2] https://derrickstolee.github.io/git-test-coverage/reports/2019-07-10.txt
---
pu 4b52dbde4091e50c06af0c7ea0e71426941019a6
jch 59741dc3e9aec4a485f18c8adb
On Wed, Jul 10, 2019 at 3:58 PM Junio C Hamano wrote:
>
> Johannes Schindelin writes:
>
> > Hi Junio,
> >
> > On Tue, 9 Jul 2019, Junio C Hamano wrote:
> >
> >> * mt/dir-iterator-updates (2019-06-25) 10 commits
> >> - clone: replace strcmp by fspathcmp
> >> - clone: use dir-iterator to avoid ex
Replace usage of opendir/readdir/closedir API to traverse directories
recursively, at copy_or_link_directory function, by the dir-iterator
API. This simplifies the code and avoids recursive calls to
copy_or_link_directory.
This process also makes copy_or_link_directory call die() in case of an
err
Add the possibility of giving flags to dir_iterator_begin to initialize
a dir-iterator with special options.
Currently possible flags are:
- DIR_ITERATOR_PEDANTIC, which makes dir_iterator_advance abort
immediately in the case of an error, instead of keep looking for the
next valid entry;
- DIR_IT
Make the copy_or_link_directory function no longer skip hidden
directories. This function, used to copy .git/objects, currently skips
all hidden directories but not hidden files, which is an odd behaviour.
The reason for that could be unintentional: probably the intention was
to skip '.' and '..' o
Replace the use of strcmp by fspathcmp at copy_or_link_directory, which
is more permissive/friendly to case-insensitive file systems.
Suggested-by: Nguyễn Thái Ngọc Duy
Signed-off-by: Matheus Tavares
---
builtin/clone.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin
Extract dir creation code snippet from copy_or_link_directory to its own
function named mkdir_if_missing. This change will help to remove
copy_or_link_directory's explicit recursion, which will be done in a
following patch. Also makes the code more readable.
Signed-off-by: Matheus Tavares
---
bu
dir_iterator_advance() is a large function with two nested loops. Let's
improve its readability factoring out three functions and simplifying
its mechanics. The refactored model will no longer depend on
level.initialized and level.dir_state to keep track of the iteration
state and will perform on a
Change warning(..., strerror(errno)) by warning_errno(...). This helps
to unify warning display besides simplifying a bit the code. Also,
improve warning messages by surrounding paths with quotation marks and
using more meaningful statements.
Signed-off-by: Matheus Tavares
---
dir-iterator.c | 2
From: Daniel Ferreira
Create t/helper/test-dir-iterator.c, which prints relevant information
about a directory tree iterated over with dir-iterator.
Create t/t0066-dir-iterator.sh, which tests that dir-iterator does
iterate through a whole directory tree as expected.
Signed-off-by: Daniel Ferre
There is currently an odd behaviour when locally cloning a repository
with symlinks at .git/objects: using --no-hardlinks all symlinks are
dereferenced but without it, Git will try to hardlink the files with the
link() function, which has an OS-specific behaviour on symlinks. On OSX
and NetBSD, it
From: Ævar Arnfjörð Bjarmason
Add tests for what happens when we perform a local clone on a repo
containing odd files at .git/object directory, such as symlinks to other
dirs, or unknown files.
I'm bending over backwards here to avoid a SHA-1 dependency. See [1]
for an earlier and simpler versio
This patchset contains:
- tests to the dir-iterator API;
- dir-iterator refactoring to make its state machine simpler
and feature adding with tests;
- a replacement of explicit recursive dir iteration at
copy_or_link_directory for the dir-iterator API;
- some refactoring and behavior changes at
On 2019-07-10 at 05:06:08, Mark Florian wrote:
> Hello!
>
> I learned today that `@` is a shortcut for `HEAD`. From `git help reivisions`:
>
> @ alone is a shortcut for HEAD.
>
> However, when I tried to use it in a command I frequently use, I got an error:
>
> $ git push -u origin @
>
Taylor Blau writes:
> Hi Gábor,
>
> On Wed, Jul 03, 2019 at 12:47:47PM +0200, SZEDER Gábor wrote:
>> Lately our GCC macOS build job on Travis CI has been erroring out
>> while installing dependencies with:
>>
>> +brew link gcc@8
>> Error: No such keg: /usr/local/Cellar/gcc@8
>> The command
Carvery Greeting,
I am Mr Bobolo mark, from West Africa am sorry to intrude into your
privacy I got your email address through internet via computerized search
after my prayers so I bring to you this transaction which I notify
from our bank an abandon fund which belongs to our late foreign custom
Martin Ågren writes:
> We treat the `value` pointer as a pointer to a struct and free its `s`
> field. But `value` is in fact an array of structs. As a result, we only
> free the first `s` out of `used_atom_cnt`-many and leak the rest. Make
> sure we free all items in `value`.
Thanks for spottin
Hi Junio,
On Wed, 10 Jul 2019, Junio C Hamano wrote:
> Junio C Hamano writes:
>
> >> In addition, your `+` scheme will break on Windows once it uses `git.exe`
> >> or any other non-MSYS2 helper...
> >
> > I am not sure what you mean here. Is your git.exe disabled not to
> > be able to do this:
gabrielreyes...@gmail.com
Gcash_+639267423833
> On Jul 9, 1 Reiwa, at 7:30 AM, Gabriel Camaisa Reyes
> wrote:
>
>
>
>
>
>
> gabrielreyes...@gmail.com
Welcome - Apple Support 1.pdf
Description: Adobe PDF document
gabrielreyes...@gmail.com
Johannes Schindelin writes:
>> * jl/status-reduce-vertical-blank (2019-06-21) 1 commit
>> - status: remove the empty line after hints
>>
>> Extra blank lines in "git status" output have been reduced.
>>
>> Needs to wait on nd/switch-and-restore to stabilize.
>
> Didn't that latter branch hit `
Hi Junio,
On Tue, 9 Jul 2019, Junio C Hamano wrote:
> * jl/status-reduce-vertical-blank (2019-06-21) 1 commit
> - status: remove the empty line after hints
>
> Extra blank lines in "git status" output have been reduced.
>
> Needs to wait on nd/switch-and-restore to stabilize.
Didn't that latt
Johannes Schindelin writes:
> Hi Junio,
>
> On Tue, 9 Jul 2019, Junio C Hamano wrote:
>
>> * mt/dir-iterator-updates (2019-06-25) 10 commits
>> - clone: replace strcmp by fspathcmp
>> - clone: use dir-iterator to avoid explicit dir traversal
>> - clone: extract function from copy_or_link_direc
Hi Junio,
On Tue, 9 Jul 2019, Junio C Hamano wrote:
> * mt/dir-iterator-updates (2019-06-25) 10 commits
> - clone: replace strcmp by fspathcmp
> - clone: use dir-iterator to avoid explicit dir traversal
> - clone: extract function from copy_or_link_directory
> - clone: copy hidden paths at lo
Heiko Voigt writes:
> behavior. How about '--all-include-head'. Then e.g.
>
> git rev-parse --all-include-head --all --not origin/master
>
> would include the head ref like you proposed below?
>
> What do you think? Or would you rather go the route of changing
> rev-parse behavior?
Depends o
We treat the `value` pointer as a pointer to a struct and free its `s`
field. But `value` is in fact an array of structs. As a result, we only
free the first `s` out of `used_atom_cnt`-many and leak the rest. Make
sure we free all items in `value`.
In the caller, `ref_array_clear()`, this means we
Josh Steadmon writes:
> Define a JSON schema[1] that can be used to validate trace2 event
> objects. This can be used to add regression tests to verify that the
> event output format does not change unexpectedly.
>
> Two versions of the schema are provided:
Actually, four versions of the schema
Junio C Hamano writes:
>> In addition, your `+` scheme will break on Windows once it uses `git.exe`
>> or any other non-MSYS2 helper...
>
> I am not sure what you mean here. Is your git.exe disabled not to
> be able to do this: "git.exe add hello+kitty.txt"? I think that is
> a more grave probl
Junio C Hamano writes:
>> +# the new branch should not have been created upstream
>> +test_must_fail git -C "$d" rev-parse refs/heads/atomic &&
>
> The new branch should not have been created; if this rev-parse
> succeeded, it would be a bug.
One thing I forgot. If refs/heads/atomic did
Emily Shaffer writes:
> +test_expect_success 'push --atomic also prevents branch creation, reports
> collateral' '
> + # Setup upstream repo - empty for now
> + d=$HTTPD_DOCUMENT_ROOT_PATH/atomic-branches.git &&
> + git init --bare "$d" &&
> + test_config -C "$d" http.receivepack
Bryan Turner writes:
> I think this is something I've seen come up on the list before[1]
> (Roland can correct me if I'm wrong). What I've seen asked for before
> is the ability to pass the combination "--ff-only --no-ff" and have
> that:
> * Ensure the branch to be merged is fast-forward from th
Hi Elijah,
Elijah Newren writes:
> Hi Roland,
>
> On Tue, Jul 9, 2019 at 9:17 AM Roland Jäger wrote:
>>
>> Thanks for answering Junio.
>>
>> I get what git does. But I believe that either the documentation ist
>> wrong/ambiguous or --no-ff and --ff-only should be able to be
>> combined and eith
Cher utilisateur de messagerie,
Dans nos efforts pour fournir un excellent service à tous nos utilisateurs,
nous prévoyons d'effectuer une mise à niveau du système. Le processus prend
environ 30 minutes. Ce message est diffusé depuis quelque temps déjà et nous
conseillons aux utilisateurs de se
Signed-off-by: claudiojpaz
---
po/es.po | 78
1 file changed, 39 insertions(+), 39 deletions(-)
diff --git a/po/es.po b/po/es.po
index 0a3e456d6..1e172caf0 100644
--- a/po/es.po
+++ b/po/es.po
@@ -845,7 +845,7 @@ msgstr "solo guardar"
#
On July 9, 2019 5:51 PM, Peff wrote:
> To: Randall S. Becker
> Cc: git@vger.kernel.org
> Subject: Re: [Question] Diff text filters and git add
>
> On Tue, Jul 09, 2019 at 05:43:05PM -0400, Randall S. Becker wrote:
>
> > I am trying to do something a bit strange and wonder about the best
> > way
Hi Junio,
On Mon, 8 Jul 2019, Junio C Hamano wrote:
> "Johannes Schindelin via GitGitGadget"
> writes:
>
> > From: Johannes Schindelin
> >
> > When running an external diff from, say, a diff tool, it is safe to
> > assume that we want to write the files in question. On Windows, that
> > means t
[cC:ing Brandon via his current email address, as per .mailmap]
On Wed, 10 Jul 2019, Matheus Tavares Bernardino wrote:
> On Mon, Jul 8, 2019 at 5:22 AM Daniel Zaoui wrote:
> >
> > Hi guys,
>
> Hi, Daniel
>
> > I work with submodules and use git grep a lot.
> >
> > I noted that when it is invoke
Hi Junio,
On Tue, 9 Jul 2019, Junio C Hamano wrote:
> Johannes Schindelin writes:
>
> > In addition, your `+` scheme will break on Windows once it uses
> > `git.exe` or any other non-MSYS2 helper...
>
> I am not sure what you mean here. Is your git.exe disabled not to
> be able to do this: "git
Cher utilisateur de messagerie,
Dans nos efforts pour fournir un excellent service à tous nos utilisateurs,
nous prévoyons d'effectuer une mise à niveau du système. Le processus prend
environ 30 minutes. Ce message est diffusé depuis quelque temps déjà et nous
conseillons aux utilisateurs de se
On 07/09, Junio C Hamano wrote:
> Thomas Gummerer writes:
>
> > Maybe it would be even better to name it 'struct gitdiff_data', as
> > it's really only used for those few functions?
>
> Is it really the case where "these three are only used by the
> codepath you made public"? If so, I agree tha
On Mon, Jul 08, 2019 at 10:16:50PM -0700, Junio C Hamano wrote:
> Junio C Hamano writes:
>
> > The "--all" in rev-list family (including "git log") unconditionally
> > include HEAD. The glitch here is that "--all" in rev-parse does
> > not. And 4d5e1b1319 was an attempt to "fix" that, i.e. make
> On 09 July 2019 at 22:51 Bryan Turner wrote:
>
> On Tue, Jul 9, 2019 at 1:33 PM Elijah Newren wrote:
> >
> > On Tue, Jul 9, 2019 at 10:00 AM wrote:
> > >
> > > Additionally I would also want to change the wording for --ff-only, as it
> > > currently reads as if it only performs a check (whic
On Mon, Jul 08, 2019 at 09:55:00PM -0700, Junio C Hamano wrote:
> Junio C Hamano writes:
>
> > Heiko Voigt writes:
> >
> >> In commit 4d5e1b1319 ("gitk: Show detached HEAD if --all is specified",
> >> 2014-09-09) the intention was to have detached HEAD shown when the --all
> >> argument is given
45 matches
Mail list logo