On Mon, Jul 8, 2019 at 5:22 AM Daniel Zaoui wrote:
>
> Hi guys,
Hi, Daniel
> I work with submodules and use git grep a lot.
>
> I noted that when it is invoked used with --recurse-submodules, the result is
> not as expected for the submodules. I get submodules results as if no files
> were mod
Cher utilisateur de messagerie,
Dans nos efforts pour fournir un excellent service à tous nos utilisateurs,
nous prévoyons d'effectuer une mise à niveau du système. Le processus prend
environ 30 minutes. Ce message est diffusé depuis quelque temps déjà et nous
conseillons aux utilisateurs de se
Hello!
I learned today that `@` is a shortcut for `HEAD`. From `git help reivisions`:
@ alone is a shortcut for HEAD.
However, when I tried to use it in a command I frequently use, I got an error:
$ git push -u origin @
fatal: invalid refspec '@'
I'm running git version 2.22.0 on L
Cher utilisateur de messagerie,
Dans nos efforts pour fournir un excellent service à tous nos utilisateurs,
nous prévoyons d'effectuer une mise à niveau du système. Le processus prend
environ 30 minutes. Ce message est diffusé depuis quelque temps déjà et nous
conseillons aux utilisateurs de se
Here are the topics that have been cooking. Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'. The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.
You can find the changes described
Actually, I was actually using git log (not git diff... sorry for the mistake)
because I also mine other information I(dates, author, summary, etc)
'git log -m --first-parent --pretty=fuller --decorate=short --name-only
REL1..REL2'
That being said, I can work with the git diff output to filte
On Tue, Jul 9, 2019 at 4:30 PM Bryan Turner wrote:
>
> On Tue, Jul 9, 2019 at 4:13 PM Elijah Newren wrote:
> >
> > Hi John,
> >
> > On Tue, Jul 9, 2019 at 3:57 PM McRoberts, John
> > wrote:
> > >
> > > I am responsible for generating a list of all files changed between two
> > > successive rele
On Tue, Jul 9, 2019 at 4:13 PM Elijah Newren wrote:
>
> Hi John,
>
> On Tue, Jul 9, 2019 at 3:57 PM McRoberts, John wrote:
> >
> > I am responsible for generating a list of all files changed between two
> > successive releases of software. I was using 'git diff' but have run into a
> > problem.
>
Thomas Gummerer writes:
> Maybe it would be even better to name it 'struct gitdiff_data', as
> it's really only used for those few functions?
Is it really the case where "these three are only used by the
codepath you made public"? If so, I agree that "gitdiff_data" is a
perfectly good name for
Hi John,
On Tue, Jul 9, 2019 at 3:57 PM McRoberts, John wrote:
>
> I am responsible for generating a list of all files changed between two
> successive releases of software. I was using 'git diff' but have run into a
> problem.
>
> Consider the following situation: A development branch comes off
Correct the api-trace2 documentation, which lists "signal" as an
expected field for the signal event type, but which actually outputs
"signo" as the field name.
Signed-off-by: Josh Steadmon
---
This patch has been split off from the "Add a JSON Schema for trace2
events" series. The documentation
trace_schema_validator can be used to verify that trace2 event output
conforms to the expectations set by the API documentation and codified
in event_schema.json (or strict_schema.json). This allows us to build a
regression test to verify that trace2 output does not change
unexpectedly.
Signed-off
Signed-off-by: Josh Steadmon
---
ci/run-build-and-tests.sh | 5 +
1 file changed, 5 insertions(+)
diff --git a/ci/run-build-and-tests.sh b/ci/run-build-and-tests.sh
index cdd2913440..0707c90549 100755
--- a/ci/run-build-and-tests.sh
+++ b/ci/run-build-and-tests.sh
@@ -14,6 +14,8 @@ make
mak
Define a JSON schema[1] that can be used to validate trace2 event
objects. This can be used to add regression tests to verify that the
event output format does not change unexpectedly.
Two versions of the schema are provided:
* event_schema.json is more permissive. It verifies that all expected
This is a proof of concept series that formalizes the structure of trace2 event
output using JSON-Schema [1].
It provides a validator (written in Go) that verifies the events in a given
trace2 event output file match the schema. I am happy to rewrite this validator
in some other language, provided
I am responsible for generating a list of all files changed between two
successive releases of software. I was using 'git diff' but have run into a
problem.
Consider the following situation: A development branch comes off of commit A
and files are changed three times. A tag (REL1) is placed on th
Derrick Stolee writes:
> From this list, do you think any of these settings are likely to
> become defaults? It seems that protocol.version = 2 may be a default
> now that _most_ services have an implementation, and it always falls
> back to protocol v1 without extra cost.
>
> When pack.useSparse
On Tue, Jul 09, 2019 at 05:43:05PM -0400, Randall S. Becker wrote:
> I am trying to do something a bit strange and wonder about the best way to
> go. I have a text filter that presents content of very special binary file
> formats using textconv. What I am wondering is whether using the textconv
>
Hi all,
I am trying to do something a bit strange and wonder about the best way to
go. I have a text filter that presents content of very special binary file
formats using textconv. What I am wondering is whether using the textconv
mechanism is sufficient to have git calculate the file signature o
On 07/09, Junio C Hamano wrote:
> Thomas Gummerer writes:
>
> > Make parse_git_header a "public" function in apply.h, so we can re-use
> > it in range-diff in a subsequent commit.
Eek, I just noticed that I forgot updating the name here. This and
the Subject should say 'parse_git_diff_header()'
Teach transport-helper how to notice if skipping a ref during push would
violate atomicity on the client side. We notice that a ref would be
rejected, and choose not to send it, but don't notice that if the client
has asked for --atomic we are violating atomicity if all the other
pushes we are send
On Tue, Jul 9, 2019 at 1:33 PM Elijah Newren wrote:
>
> On Tue, Jul 9, 2019 at 10:00 AM wrote:
> >
> > Additionally I would also want to change the wording for --ff-only, as it
> > currently reads as if it only performs a check (which would lead to the
> > expected behaviour) but does more than
On Tue, Jul 9, 2019 at 10:00 AM wrote:
>
> > On 09 July 2019 at 18:35 Elijah Newren wrote:
> >
...
> > Hope that helps,
> > Elijah
>
> I hope this is not-top-posting? I'm new to this and know nothing apparently.
Yep, you're doing good.
> If I were to write a patch then I would very much prefer
Firstly, sorry for the delay, I wasn't working for national holiday from
the 4th til yesterday.
> If I were tasked with developing this further, I would try to move as much
> of the setup into the initial test case (if there is already a `setup`
> test case; otherwise I would create one). In fact,
On 7/9/2019 3:21 PM, Junio C Hamano wrote:
> Derrick Stolee writes:
>
>> The other category that has been discussed already is that of "experimental
>> features that we generally think are helpful but change behavior slightly in
>> some cases".
>>
>> feature.experimental:
>> pac
Thomas Gummerer writes:
> Make parse_git_header a "public" function in apply.h, so we can re-use
> it in range-diff in a subsequent commit.
>
> Signed-off-by: Thomas Gummerer
> ---
Thanks for these refactoring patches on "apply" machinery in the
early part of the series. I noticed two small th
Derrick Stolee writes:
> The other category that has been discussed already is that of "experimental
> features that we generally think are helpful but change behavior slightly in
> some cases".
>
> feature.experimental:
> pack.useSparse = true
> status.aheadBehi
Hi Derrick,
I'm a little bit late to the part, but I think that this is a really
interesting feature with a lot of really interesting discussion so far.
I hope you don't mind me throwing in my $.02 as well :-).
On Mon, Jul 08, 2019 at 03:22:49PM -0400, Derrick Stolee wrote:
> On 7/1/2019 10:29 A
> On 09 July 2019 at 18:35 Elijah Newren wrote:
>
>
> Hi Roland,
>
> On Tue, Jul 9, 2019 at 9:17 AM Roland Jäger wrote:
> >
> > Thanks for answering Junio.
> >
> > I get what git does. But I believe that either the documentation ist
> > wrong/ambiguous or --no-ff and --ff-only should be able
Hi Roland,
On Tue, Jul 9, 2019 at 9:17 AM Roland Jäger wrote:
>
> Thanks for answering Junio.
>
> I get what git does. But I believe that either the documentation ist
> wrong/ambiguous or --no-ff and --ff-only should be able to be combined and
> either should be fixed - preferably the later. Wh
Hi Gábor,
On Wed, Jul 03, 2019 at 12:47:47PM +0200, SZEDER Gábor wrote:
> Lately our GCC macOS build job on Travis CI has been erroring out
> while installing dependencies with:
>
> +brew link gcc@8
> Error: No such keg: /usr/local/Cellar/gcc@8
> The command "ci/install-dependencies.sh" fail
Thanks for answering Junio.
I get what git does. But I believe that either the documentation ist
wrong/ambiguous or --no-ff and --ff-only should be able to be combined and
either should be fixed - preferably the later. What I want to say to git is "I
never accept a real merge; please make a me
usbu...@mailbox.org writes:
> I'm rather confused about --ff, --no-ff and --ff-only. They seam
> to be all mutual exclusive...
A clean result left by "git merge" can be either a fast-forward, or
a real merge (i.e. 2 possible outcomes).
The --ff option lets you say "If the other history I am atte
Johannes Schindelin writes:
> Using `.lock` is actually an even more established pattern. (I used `.new`
> because the intention is not to lock files, but I would be prepared to
> change the patch to that end.)
When I said that the plus convention is established in this project
and not limited t
Hi Junio,
On Mon, 8 Jul 2019, Junio C Hamano wrote:
> "Johannes Schindelin via GitGitGadget"
> writes:
>
> > From: Johannes Schindelin
> >
> > A `+` is not a valid part of a filename with Windows file systems (it is
> > reserved because the `+` operator meant file concatenation back in the
> >
On Sat, Jul 06, 2019 at 10:51:32PM -0700, Masaya Suzuki wrote:
> The credentials API calls credentials helpers in order. If a
> username/password pair is returned the helpers and if it's used for
> authentication successfully, it's announced to the helpers and they can
> store it for later use.
>
Hello,
I'm rather confused about --ff, --no-ff and --ff-only. They seam to be all
mutual exclusive while the man page documentation and help reads as if only the
first two are mutual exclusive, while the later is a check that can be enabled
additionally to the former ones. I'm not sure why I co
37 matches
Mail list logo