Hi Johannes,
Johannes Schindelin 於 2019年5月29日 週三 下午7:51寫道:
>
> Hi John Lin,
>
> You could already rebase it on top of
> https://github.com/gitgitgadget/git/tree/nd/switch-and-restore, say so in
> your cover letter, and send a new iteration.
Thanks for the suggestion. I already rebase on your
nd/
On 2019-05-30 at 18:16:17, Alex Levy wrote:
> I've found a workaround if I manually edit .git/config in each clone to
> reflect the correct URL. After doing that, running "git submodule update
> --init" works as expected.
>
> My understanding is that I shouldn't ever have to edit anything in th
On 2019-05-30 at 19:32:41, Johannes Schindelin wrote:
> Hi Gábor,
>
> do you have any idea why Travis is failing like this in the macOS/gcc
> job?
>
> > +case "$jobname" in
> > +brew link gcc@8
> > Error: No such keg: /usr/local/Cellar/gcc@8
> > The command "ci/install-dependencies.sh" failed and
Introduce a new macro ALLOC_GROW_BY which automatically zeros the added
array elements and takes care of updating the nr value. Use the macro in
code introduced earlier in this patchset.
Signed-off-by: Matthew DeVore
---
cache.h | 22 ++
list-objects-fil
Allow combining of multiple filters by simply repeating the --filter
flag. Before this patch, the user had to combine them in a single flag
somewhat awkwardly (e.g. --filter=combine:FOO+BAR), including
URL-encoding the individual filters.
To make this work, in the --filter flag parsing callback, r
Make the list-objects-filter.h API more opaque and easier to use. This
prepares for combined filter support, where filters will be created and
used in a new context.
Helped-by: Jeff Hostetler
Helped-by: Junio C Hamano
Signed-off-by: Matthew DeVore
---
list-objects-filter.c | 122 ++
The oidset *omits pointer must be accessed by the combine filter in a
type-agnostic way once the graph traversal is over. Store that pointer
in the general `filter` struct. This will be used in a follow-up patch
to implement the combine filter.
Signed-off-by: Matthew DeVore
---
list-objects-filt
Allow combining filters such that only objects accepted by all filters
are shown. The motivation for this is to allow getting directory
listings without also fetching blobs. This can be done by combining
blob:none with tree:. There are massive repositories that have
larger-than-expected trees - eve
Making errbuf an optional argument complicates error reporting. Fix this
by making all callers supply an errbuf, even if they may ignore it. This
will be important in follow-up patches where the filter-spec parsing has
more pitfalls and possible errors.
Signed-off-by: Matthew DeVore
---
list-obj
Make the filter_spec string a strbuf rather than a raw C string. A
future patch will need to grow this string dynamically.
Signed-off-by: Matthew DeVore
---
builtin/rev-list.c| 2 +-
list-objects-filter-options.c | 16 ++--
list-objects-filter-options.h | 2 +-
upload-p
Here is a roll-up with hopefully all comments applied or responded to. Notable
changes since the last one include:
- Added an ALLOC_GROW_BY which is used twice by this patchset to make growing
arrays safer and cleaner
- Cleaned up the URL-encoding by (1) using hex_to_bytes rather than rolling
This function always returns 0, so make it return void instead.
Signed-off-by: Matthew DeVore
---
list-objects-filter-options.c | 12 +---
list-objects-filter-options.h | 2 +-
2 files changed, 6 insertions(+), 8 deletions(-)
diff --git a/list-objects-filter-options.c b/list-objects-fi
Move the check that filter_options->choice is set to higher in the call
stack. This can only be set when the gentle parse function is called
from one of the two call sites.
This is important because in an upcoming patch this may or may not be an
error, and whether it is an error is only known to t
On Fri, May 31, 2019 at 05:10:42PM -0400, Jeff King wrote:
> On Fri, May 31, 2019 at 01:48:21PM -0700, Matthew DeVore wrote:
>
> > > > +static int digit_value(int c, struct strbuf *errbuf) {
> > > > + if (c >= '0' && c <= '9')
> > > > + return c - '0';
> > > > + if (c >=
On Fri, May 24, 2019 at 05:01:15PM -0400, Jeff Hostetler wrote:
> We are allowing an unlimited number of filters in the composition.
> In the code, the compose filter data has space for a LHS and RHS, so
> I'm assuming we're mapping
>
> --filter=f1 --filter=f2 --filter=f3 --filter=f4
> or --f
On Fri, May 31, 2019 at 01:48:21PM -0700, Matthew DeVore wrote:
> > > +static int digit_value(int c, struct strbuf *errbuf) {
> > > + if (c >= '0' && c <= '9')
> > > + return c - '0';
> > > + if (c >= 'a' && c <= 'f')
> > > + return c - 'a' + 10;
> > > + if (c >= 'A' && c <= 'F')
>
I’m an Azure DevOps support engineer for Microsoft. Prior to composing
this communication to the Git team I had a conversation with the
Product Group from Azure DevOps stating this could be expected
behavior, truth is they didn’t take the time to analyze this with me
stating our PR system does noth
On Thu, May 30, 2019 at 10:01:47AM -0400, Jeff Hostetler wrote:
> BTW, I don't think I've seen this mentioned anywhere and I don't
> remember if this got into the code or not. But we discussed having
> a repo-local config setting to remember the filter-spec used by the
> partial clone that would b
On Tue, May 28, 2019 at 02:53:59PM -0700, Emily Shaffer wrote:
> > + } else if (skip_prefix(arg, "combine:", &v0)) {
> > + int sub_parse_res = parse_combine_filter(
> > + filter_options, v0, errbuf);
> > + if (sub_parse_res)
> > + return sub
Hi Junio,
On Fri, 31 May 2019, Junio C Hamano wrote:
> Johannes Schindelin writes:
>
> >> * cc/list-objects-filter-wo-sparse-path (2019-05-29) 1 commit
> >> (merged to 'next' on 2019-05-30 at 5a294203ad)
> >> + list-objects-filter: disable 'sparse:path' filters
> >>
> >> Disable "--filter=sp
Before, the documentation would mix " and ' for code and config
snippets. Change these instances to ` so that they are marked up in
monospace.
Signed-off-by: Denton Liu
---
Documentation/config/alias.txt | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/Documentati
One can see that an alias that begins with a non-command first word,
such as `loud-rebase = -c commit.verbose=true rebase`, is permitted.
However, this isn't immediately obvious to users as alias instances
typically begin with a command.
Document the fact that an alias can begin with a non-command
When I first saw Johannes' email here[1], I was surprised that an alias
where the first-word is a command-line option to be passed into `git`
was permitted. I was only used to aliases where the first word is a
command.
Document this behaviour so that users will be able to discover that this
is a f
Hi Denton,
On Fri, 31 May 2019, Denton Liu wrote:
> Currently, if a user wishes to have individual settings per branch, they
> are required to manually keep track of the settings in their head and
> manually set the options on the command-line or change the config at
> each branch.
>
> Teach conf
On 5/31/2019 2:46 PM, Matthew DeVore wrote:
In the sparse filter data, array_frame array is used in a way such that
nr is the index of the last element. Fix this so that nr is actually the
number of elements in the array.
I don't remember why I did it that way.
Thanks for fixing!
Jeff
Currently, if a user wishes to have individual settings per branch, they
are required to manually keep track of the settings in their head and
manually set the options on the command-line or change the config at
each branch.
Teach config the "onbranch:" includeIf condition so that it can
condition
On 31.05.19 13:31, David wrote:
> # Summary
>
> I was trying to clone the AOSP source tree (Android Open Source Project)
> and I finally was able to formally identify what seems to be a severe
> regression (one that is blocking usage) in the last version of git
> (2.21.0).
>
> # Steps to reproduc
Hi Stolee,
On Fri, 31 May 2019, Derrick Stolee wrote:
> On 5/30/2019 2:24 PM, Derrick Stolee wrote:
> > Further, these tests failed
> >
> > t3400-rebase.sh (Wstat: 256 Tests: 28 Failed: 2)
> > Failed tests: 20, 28
> > Non-zero exit status: 1
> > t3420-rebase-autosta
Johannes Schindelin writes:
>> * cc/list-objects-filter-wo-sparse-path (2019-05-29) 1 commit
>> (merged to 'next' on 2019-05-30 at 5a294203ad)
>> + list-objects-filter: disable 'sparse:path' filters
>>
>> Disable "--filter=sparse:path=" that would allow reading from
>> paths on the filesyste
Hi Junio,
On Fri, 31 May 2019, Junio C Hamano wrote:
> [...] as I said in "What's cooking" report one issue ago, the criteria
> is no longer "this is obviously correct"---it is "this is obvious and
> trivial fix for a regression".
I heard that, just wanted to give you my stance ;-)
In Git for W
In the sparse filter data, array_frame array is used in a way such that
nr is the index of the last element. Fix this so that nr is actually the
number of elements in the array.
The filter_sparse_free function also has an unaddressed TODO to free the
memory associated with the sparse filter data.
On Fri, May 31, 2019 at 07:23:56PM +0200, Johannes Schindelin wrote:
> Hi Denton,
>
> On Fri, 31 May 2019, Denton Liu wrote:
>
> > On Fri, May 31, 2019 at 02:58:30PM +0200, Johannes Schindelin wrote:
> >
> > > On Thu, 30 May 2019, Denton Liu wrote:
> > >
[...]
>
> > > > I decided to go ahead a
---
Yesterday on #git, an user reported the following behaviour of
git clean:
$ git init
$ mkdir foo
$ touch a.txt b.txt bar.txt foo/qux.txt
$ git clean -f bar.txt foo/qux.txt
Removing bar.txt
Where the behaviour they expected would be:
$ git clean -f bar.txt foo/qux.tx
gitignore.txt: make slash-rules more readable
Remove meta-rule in a paragraph for trailing-slash.
Be precise whenever a trailing slash would make a
difference. Improve paragraph for pattern without slash.
Remove rule for leading slash because its now redundant.
Instead, add examples for leading
---
Documentation/gitignore.txt | 75 ++---
1 file changed, 54 insertions(+), 21 deletions(-)
diff --git a/Documentation/gitignore.txt b/Documentation/gitignore.txt
index b5bc9dbff0..ce944779a5 100644
--- a/Documentation/gitignore.txt
+++ b/Documentation/gitignore.
This is a patch that I'm separating from a longer patchset previously sent.
Thanks,
Matthew DeVore (1):
list-objects-filter-options: error is localizeable
list-objects-filter-options.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--
2.17.1
The "invalid filter-spec" message is user-facing and not a BUG, so make
it localizeable.
For reference, the message appears in this context:
$ git rev-list --filter=blob:nonse --objects HEAD
fatal: invalid filter-spec 'blob:nonse'
Signed-off-by: Matthew DeVore
---
list-objects-
On 5/30/2019 2:24 PM, Derrick Stolee wrote:
> Further, these tests failed
>
> t3400-rebase.sh (Wstat: 256 Tests: 28 Failed: 2)
> Failed tests: 20, 28
> Non-zero exit status: 1
> t3420-rebase-autostash.sh (Wstat: 256 Tests: 38 Failed: 6)
> Failed test
"Dr. Adam Nielsen" writes:
>>> + - The pattern `doc/frotz` and `/doc/frotz` have the same effect
>>> + in any `.gitignore` file. Both pattern contain a non-trailing
>>> + slash and thus match relative to the location of the
>>> + `.gitignore` file.
>>
>> ... this paragraph wouldn't have bee
Johannes Schindelin writes:
> On Thu, 30 May 2019, Junio C Hamano wrote:
>
>> * bb/unicode-12.1-reiwa (2019-05-29) 1 commit
>> (merged to 'next' on 2019-05-30 at 016465335c)
>> + unicode: update the width tables to Unicode 12.1
>> <<
>> * bb/unicode-12.1-reiwa (2019-05-29) 1 commit
>> - unico
Hi Denton,
On Fri, 31 May 2019, Denton Liu wrote:
> On Fri, May 31, 2019 at 02:58:30PM +0200, Johannes Schindelin wrote:
>
> > On Thu, 30 May 2019, Denton Liu wrote:
> >
> > > Currently, if a user wishes to have individual settings per branch,
> > > they are required to manually keep track of the
On 31.05.19 18:30, Junio C Hamano wrote:
"Dr. Adam Nielsen" writes:
gitignore.txt: make slash-rules more readable
Remove meta-rule in a paragraph for trailing-slash.
Be precise whenever a trailing slash would make a
difference. Improve paragraph for pattern without slash.
Remove rule for le
Hi Junio,
On Fri, 31 May 2019, Junio C Hamano wrote:
> Johannes Schindelin writes:
>
> >> The second round of release candidate has been tagged, after slipping
> >> for several days to merge a handful of last-minute regression fixes.
> >
> > You hinted in an earlier "What's cooking" that you'd m
Johannes Schindelin writes:
>> The second round of release candidate has been tagged, after
>> slipping for several days to merge a handful of last-minute
>> regression fixes.
>
> You hinted in an earlier "What's cooking" that you'd maybe go for an -rc3.
> Is that still the case?
That was back w
Good day
Blessings to you,am contacting you based on a mutual benefit
inheritance transaction of ($10.5 million US dollars) that has to do
with your last name contact me for more details. Contact email [
barristergracefol...@gmail.com]
Regards,
Barrister Grace Folly
//
"Dr. Adam Nielsen" writes:
> gitignore.txt: make slash-rules more readable
>
> Remove meta-rule in a paragraph for trailing-slash.
> Be precise whenever a trailing slash would make a
> difference. Improve paragraph for pattern without slash.
> Remove rule for leading slash because its now redun
Derrick Stolee writes:
>>> This global 'fetch_if_missing' swap seems very fragile. I'm guessing you
>>> are using it to prevent a loop when calling oid_object_info_extended()
>>> below. Can you instead pass a flag to the method that disables the
>>> fetch_if_missing behavior?
>> ...
>> The flag
Thanks, Patryk. It's always nice to see the feature I want is already
implemented! 😊
-Original Message-
From: Patryk Obara
Sent: Friday, May 31, 2019 11:05 AM
To: Cliff Schomburg ; git@vger.kernel.org
Subject: Re: Simple shortcut for "git push --set-upstream origin newBranchName"
On
On Fri, May 31, 2019 at 02:56:12PM +, Cliff Schomburg wrote:
> Wow, I did not see that in the man pages... but I see it now. Thanks!
>
> So I guess I would change my ask to this:
>
> "git push -u"
>
> Should default to "origin branch" if no parameters are provided. Thoughts?
I'll do you o
On 31/05/2019 16:56, Cliff Schomburg wrote:
Wow, I did not see that in the man pages... but I see it now. Thanks!
So I guess I would change my ask to this:
"git push -u"
Should default to "origin branch" if no parameters are provided.
I think most people will agree, considering it already w
Mijn naam is Eddy William. Ik ben van beroep advocaat. Ik wil je aanbieden
nabestaanden van mijn cliënt. Je ervaart de som van ($ 14,2 miljoen)
dollars die mijn cliënt voor zijn overlijden op de bank heeft achtergelaten.
Mijn klant is een burger van jouw land die stierf in auto-ongeluk met zijn vr
Wow, I did not see that in the man pages... but I see it now. Thanks!
So I guess I would change my ask to this:
"git push -u"
Should default to "origin branch" if no parameters are provided. Thoughts?
Thanks,
Cliff
-Original Message-
From: Patryk Obara
Sent: Friday, May 31, 2019 10
On 31/05/2019 16:45, Cliff Schomburg wrote:
I'm proposing a shortcut for this command.
What's wrong with "$ git push -u origin branch"?
--
Patryk Obara
Resending as plain text
From: Cliff Schomburg
Sent: Thursday, May 30, 2019 6:29 PM
To: git@vger.kernel.org
Subject: Simple shortcut for "git push --set-upstream origin newBranchName"
Hi all,
This is more of a suggestion than a bug report.
I create new topic branches quite frequently and push t
Hi Johannes,
On Fri, May 31, 2019 at 02:58:30PM +0200, Johannes Schindelin wrote:
> Hi,
>
> On Thu, 30 May 2019, Denton Liu wrote:
>
> > Currently, if a user wishes to have individual settings per branch, they
> > are required to manually keep track of the settings in their head and
> > manually
Hi,
On Thu, 30 May 2019, Denton Liu wrote:
> Currently, if a user wishes to have individual settings per branch, they
> are required to manually keep track of the settings in their head and
> manually set the options on the command-line or change the config at
> each branch.
>
> Teach config the
Hi Junio,
On Thu, 30 May 2019, Junio C Hamano wrote:
> * bb/unicode-12.1-reiwa (2019-05-29) 1 commit
> (merged to 'next' on 2019-05-30 at 016465335c)
> + unicode: update the width tables to Unicode 12.1
> <<
> * bb/unicode-12.1-reiwa (2019-05-29) 1 commit
> - unicode: update the width tables
Team,
here is the corresponding Git for Windows v2.22.0-rc2:
https://github.com/git-for-windows/git/releases/tag/v2.22.0-rc2.windows.1
So far, I am rather happy with the robustness of the release candidates,
but please y'all: test!
Thanks,
Johannes
On Thu, 30 May 2019, Junio C Hamano wrote:
>
# Summary
I was trying to clone the AOSP source tree (Android Open Source Project)
and I finally was able to formally identify what seems to be a severe
regression (one that is blocking usage) in the last version of git (2.21.0).
# Steps to reproduce
The AOSP projects recommend to use ubuntu
Hi Junio,
On Thu, 30 May 2019, Junio C Hamano wrote:
> Here are the topics that have been cooking. Commits prefixed with
> '-' are only in 'pu' (proposed updates) while commits prefixed with
> '+' are in 'next'. The ones marked with '.' do not appear in any of
> the integration branches, but I
Hi Stolee,
On Thu, 30 May 2019, Derrick Stolee wrote:
> On 5/30/2019 4:46 PM, Johannes Schindelin wrote:
> >
> > On Thu, 30 May 2019, Derrick Stolee wrote:
> >
> >> On 4/9/2019 12:11 PM, Christian Couder wrote:
> >>> From: Christian Couder
> >>>
> >>> +{
> >>> + int i, missing_nr = 0;
> >>> + in
gitignore.txt: make slash-rules more readable
Remove meta-rule in a paragraph for trailing-slash.
Be precise whenever a trailing slash would make a
difference. Improve paragraph for pattern without slash.
Remove rule for leading slash because its now redundant.
Instead, add examples for leading
62 matches
Mail list logo