Convert the sha1 member of this struct to be an array of struct
object_id instead. This change is needed to convert find_unique_abbrev.
Convert some instances of hard-coded constants to use the_hash_algo as
well.
Signed-off-by: brian m. carlson
---
builtin/ls-files.c | 2 +-
resolve-undo.c
Convert the various *_sha1 members to use struct object_id instead.
Signed-off-by: brian m. carlson
---
wt-status.c | 12 ++--
wt-status.h | 6 +++---
2 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/wt-status.c b/wt-status.c
index 5c685b6165..78be89a422 100644
--- a/wt-st
This is the twelfth in a series of patches to convert various parts of
the code to struct object_id.
Changes from v2:
* Rebase onto master (to fix "typename" → "type_name" changes).
* Replace some uses of hashcpy with memcpy.
* Replace some instances of "20" with references to the_hash_algo.
Chan
Convert find_unique_abbrev and find_unique_abbrev_r to each take a
pointer to struct object_id.
Signed-off-by: brian m. carlson
---
builtin/blame.c| 2 +-
builtin/branch.c | 2 +-
builtin/checkout.c | 6 +++---
builtin/describe.c | 4 ++--
builtin/log.c | 4 ++
This is needed to convert parts of the cache-tree code.
Signed-off-by: brian m. carlson
---
builtin/write-tree.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/builtin/write-tree.c b/builtin/write-tree.c
index bd0a78aa3c..299a121531 100644
--- a/builtin/write-tree.c
++
Convert struct object_request to use struct object_id by updating the
definition and applying the following semantic patch, plus the standard
object_id transforms:
@@
struct object_request E1;
@@
- E1.sha1
+ E1.oid.hash
@@
struct object_request *E1;
@@
- E1->sha1
+ E1->oid.hash
Signed-off-by: br
Signed-off-by: brian m. carlson
---
builtin/fsck.c | 2 +-
cache.h| 4 ++--
sha1_file.c| 10 +-
3 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/builtin/fsck.c b/builtin/fsck.c
index ef78c6c00c..eae018e3fb 100644
--- a/builtin/fsck.c
+++ b/builtin/fsck.c
@@ -51
Convert this function to take a pointer to struct object_id and rename
it check_object_signature. Introduce temporaries to convert the return
values of lookup_replace_object and lookup_replace_object_extended into
struct object_id.
The temporaries are needed because in order to convert
lookup_rep
Convert the remaining function, feed_object, to use struct object_id.
Signed-off-by: brian m. carlson
---
send-pack.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/send-pack.c b/send-pack.c
index 8d9190f5e7..19025a7aca 100644
--- a/send-pack.c
+++ b/send-pack.c
Signed-off-by: brian m. carlson
---
builtin/mktag.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/builtin/mktag.c b/builtin/mktag.c
index beb552847b..65bb41e3cd 100644
--- a/builtin/mktag.c
+++ b/builtin/mktag.c
@@ -18,13 +18,13 @@
/*
* We refuse to tag
Convert this struct to use a member of type object_id. Convert various
static functions as well.
Signed-off-by: brian m. carlson
---
builtin/index-pack.c | 34 +-
1 file changed, 17 insertions(+), 17 deletions(-)
diff --git a/builtin/index-pack.c b/builtin/index
Convert the write_archive_entry_fn_t type to use a pointer to struct
object_id. Convert various static functions in the tar and zip
archivers also.
Signed-off-by: brian m. carlson
---
archive-tar.c | 28 ++--
archive-zip.c | 16
archive.c | 12 ++
Convert this file to use struct object_id. Modify one use of
get_sha1_hex into parse_oid_hex; this is safe since we get the data from
a strbuf.
Signed-off-by: brian m. carlson
---
builtin/mktree.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/bui
Convert get_tree_entry and find_tree_entry to take pointers to struct
object_id.
Signed-off-by: brian m. carlson
---
archive.c | 4 ++--
blame.c| 6 ++
builtin/rm.c | 2 +-
builtin/update-index.c | 2 +-
line-log.c | 3 +--
match-trees.
Convert read_sha1_file to take a pointer to struct object_id and rename
it read_object_file. Do the same for read_sha1_file_extended.
Convert one use in grep.c to use the new function without any other code
change, since the pointer being passed is a void pointer that is already
initialized with
Convert unpack_entry and read_object to use struct object_id.
---
packfile.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/packfile.c b/packfile.c
index 5f08aa0a14..3e31ad7a0c 100644
--- a/packfile.c
+++ b/packfile.c
@@ -1452,7 +1452,7 @@ struct unpac
There were several instances of 32 sprinkled throughout this file, all
of which were used for allocating a buffer to store the header of an
object. Introduce a constant, MAX_HEADER_LEN, for this purpose.
Note that this constant is slightly larger than required; the longest
possible header is 28 (
Convert this function to take a pointer to struct object_id and rename
it to assert_oid_type.
Signed-off-by: brian m. carlson
---
builtin/commit-tree.c | 2 +-
cache.h | 2 +-
commit.c | 2 +-
sha1_file.c | 8
4 files changed, 7 insertions(+), 7 dele
This is necessary in order to convert find_unique_abbrev.
Signed-off-by: brian m. carlson
---
ref-filter.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/ref-filter.c b/ref-filter.c
index 45fc56216a..dbe554dffa 100644
--- a/ref-filter.c
+++ b/ref-filter.c
@@ -73
Signed-off-by: brian m. carlson
---
packfile.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/packfile.c b/packfile.c
index 7c1a2519fc..5f08aa0a14 100644
--- a/packfile.c
+++ b/packfile.c
@@ -1095,13 +1095,13 @@ static int retry_bad_packed_offset(struct packed_git
*p
Convert the declaration and definition of strbuf_add_unique_abbrev to
make it take a pointer to struct object_id. Predeclare the struct in
strbuf.h, as cache.h includes strbuf.h before it declares the struct,
and otherwise the struct declaration would have the wrong scope.
Apply the following sem
Convert the various open_istream variants to take a pointer to struct
object_id. Introduce a temporary, which will be removed later, to work
around the fact that lookup_replace_object still returns a pointer to
unsigned char.
Signed-off-by: brian m. carlson
---
streaming.c | 15 +--
Convert convert.c to struct object_id. Add a use of the_hash_algo to
replace hard-coded constants and change a strbuf_add to a strbuf_addstr
to avoid another hard-coded constant.
Note that a strict conversion using the hexsz constant would cause
problems in the future if the internal and user-vis
Convert the internals of this function to use struct object_id. This is
one of the last remaining callers of read_sha1_file_extended that has
not been converted yet.
Signed-off-by: brian m. carlson
---
tree-walk.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
d
Convert sha1_object_info and sha1_object_info_extended to take pointers
to struct object_id and rename them to use "oid" instead of "sha1" in
their names. Update the declaration and definition and apply the
following semantic patch, plus the standard object_id transforms:
@@
expression E1, E2;
@@
Convert both the argument and the return value to be pointers to struct
object_id. Update the callers and their internals to deal with the new
type. Remove several temporaries which are no longer needed.
Signed-off-by: brian m. carlson
---
builtin/mktag.c | 7 ++-
cache.h | 8 +
Convert the two members of this struct to be instances of struct
object_id. Adjust the various functions in this file accordingly.
Signed-off-by: brian m. carlson
---
replace_object.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/replace_object.c b/replace_o
Signed-off-by: brian m. carlson
---
archive-tar.c | 2 +-
archive-zip.c | 2 +-
builtin/index-pack.c | 2 +-
builtin/pack-objects.c | 2 +-
sha1_file.c| 2 +-
streaming.c| 6 +++---
streaming.h| 2 +-
7 files changed, 9 insertions(+), 9 dele
Convert the remaining caller of sha1_object_info_extended to use struct
object_id. Introduce temporaries, which will be removed later, since
there is a dependency loop between sha1_object_info_extended and
lookup_replace_object_extended. This allows us to convert the code in a
piecemeal fashion i
We were using the util pointer, which is a pointer to void, as an
unsigned char pointer. The pointer actually points to a struct
origin_data, which has a struct object_id as its first member, which in
turn has an unsigned char array as its first member, so this was valid.
Since we want to convert
Convert read_object_with_reference to take pointers to struct object_id.
Update the internals of the function accordingly.
Signed-off-by: brian m. carlson
---
builtin/cat-file.c | 2 +-
builtin/grep.c | 4 ++--
builtin/pack-objects.c | 2 +-
cache.h| 4 ++--
fast-
Convert this function to take a pointer to struct object_id and rename
it object_file_to_archive.
Signed-off-by: brian m. carlson
---
archive-tar.c | 2 +-
archive-zip.c | 4 ++--
archive.c | 10 +-
archive.h | 8
4 files changed, 12 insertions(+), 12 deletions(-)
di
Convert the remaining static functions to take pointers to struct
object_id.
Signed-off-by: brian m. carlson
---
builtin/notes.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/builtin/notes.c b/builtin/notes.c
index 39304ba743..08ab9d7130 100644
--- a/builtin/note
Convert the callback functions for read_tree_recursive to take a pointer
to struct object_id.
Signed-off-by: brian m. carlson
---
archive.c | 8
builtin/checkout.c | 4 ++--
builtin/log.c | 2 +-
builtin/ls-tree.c | 8
merge-recursive.c | 2 +-
tree.c
Convert the remaining portions of cache-tree.c to use struct object_id.
Convert several instances of 20 to use the_hash_algo instead.
Signed-off-by: brian m. carlson
---
cache-tree.c | 29 +++--
1 file changed, 15 insertions(+), 14 deletions(-)
diff --git a/cache-tree.c
Convert the index_bulk_checkin function, and the static functions it
calls, to use pointers to struct object_id.
Signed-off-by: brian m. carlson
---
bulk-checkin.c | 18 +-
bulk-checkin.h | 2 +-
sha1_file.c| 2 +-
3 files changed, 11 insertions(+), 11 deletions(-)
diff --
Convert write_index_as_tree and write_cache_as_tree to use struct
object_id.
Signed-off-by: brian m. carlson
---
builtin/am.c | 8
builtin/merge.c | 2 +-
builtin/write-tree.c | 2 +-
cache-tree.c | 10 +-
cache-tree.h | 4 ++--
sequencer.c
This is my submission as a microproject for the Google Summer of code.
I apologize for not setting the [GSoC] in my previous email
at <20180312020855.7950-1-viethtran1...@gmail.com>.
Please ignore it.
Add a new job named Pylint to .travis.yml in order to analyze git-p4 Python
code.
Although Travi
Add a new job named Pylint to .travis.yml in order to analyze git-p4 Python
code.
Although Travis CI have yet to implement continuous integration for multiple
languages. Python package can be installed using apt packages. From there,
pylint can be
installed using pip and used to analyze git-p4.py
I like having machine-specific config in ~/.config/git, I think I'll do that. I
didn't realize you could forward gpg-agent over a connection, I may look
further into that.
Thanks for the help!
Joshua Nelson
On Sunday, March 11, 2018 17:21:42 EDT brian m. carlson wrote:
> On Sat, Mar 10, 2018 a
Hi Dscho,
I`m yet to read (and reason about) your whole (very informative)
reply, but I just wanted to address this part first, as it might be a
clear end-game situation already, due to a mutual agreement, all the
rest being purely academic, interesting, but not any more (that)
important to di
Abdul Salif ,{ESQ}
Avenue Bassawaga
Ouagadougou, Burkina Faso
Email: (abdul-sa...@consultant.com)
Dear Friend,
Compliments of the day. I hope that this letter does not surprise you
because we have not met. However, I urge you to treat the information
with it's contains with due and utmost attenti
Hi Dscho,
On 11/03/2018 16:47, Johannes Schindelin wrote:
>
> > > > Phillip's method is essentially merging the new tips into the original
> > > > merge, pretending that the new tips were not rebased but merged into
> > > > upstream.
> > >
> > > [...]
> > >
> > > Here`s a starting point, two comm
Hi Dscho,
On 11/03/2018 13:11, Johannes Schindelin wrote:
>
> > > I did wonder about using 'pick ' for rebasing merges
> > > and keeping 'merge ...' for recreating them but I'm not sure if that
> > > is a good idea. It has the advantage that the user cannot specify the
> > > wrong parents for the
Hi Dscho,
On 11/03/2018 13:08, Johannes Schindelin wrote:
>
> > Hmm, funny enough, `pick ` was something I though about
> > originally, too, feeling that it might make more sense in terms on
> > what`s really going on, but I guess I wanted it incorporated into
> > `--recreate-merges` too much tha
On Sat, Mar 10, 2018 at 03:28:43PM +, NELSON, JOSHUA Y wrote:
> Currently, `commit.gpgsign` allows you to give either 'true' or 'false' as a
> value. If the key is not present, commits will fail:
>
> ```sh
> $ git commit -m "example"
> error: gpg failed to sign the data
> fatal: failed to wri
Hi Dscho,
On 11/03/2018 13:00, Johannes Schindelin wrote:
>
> > I actually like `pick` for _rebasing_ merge commits, as `pick` is
> > already used for rebasing non-merge commits, too, so it feels natural.
>
> Phillip is right, though: this would repeat the design mistake of
> --preserve-merges.
Hi Buga,
On Fri, 9 Mar 2018, Igor Djordjevic wrote:
> On 08/03/2018 20:58, Igor Djordjevic wrote:
> >
> > > Phillip's method is essentially merging the new tips into the original
> > > merge, pretending that the new tips were not rebased but merged into
> > > upstream.
> >
> > [...]
> >
> > He
Hi Buga,
On Thu, 8 Mar 2018, Igor Djordjevic wrote:
> On 07/03/2018 15:08, Johannes Schindelin wrote:
> >
> > > > Didn't we settle on Phillip's "perform successive three-way merges
> > > > between the original merge commit and the new tips with the old tips
> > > > as base" strategy?
> > >
> > >
In 36db1eddf9 ("git-svn: add --authors-prog option", 2009-05-14) the path
to authors-prog was made absolute because git-svn changes the current
directory in some situations. This makes sense if the program is part of
the repository but prevents searching via $PATH.
The old behaviour is still retai
The email address in --authors-file and --authors-prog can be empty but
git-svn translated it into a syntethic email address in the form
$USERNAME@$REPO_UUID. Now git-svn behaves like git-commit: If the email
is explicitly set to the empty string, the commit does not contain
an email address.
Sign
The first patch has been queued by Eric Wong but by Junio Hamano, so
I'm not sure what's the expected procedure. I#M posting it again just
in case.
The second patch has grown up with some documentation and some tests.
Andreas Heiduk (2):
git-svn: search --authors-prog in PATH too
git-svn: all
Change the USE_LIBPCRE flag from being an alias for USE_LIBPCRE1 to
being an alias for USE_LIBPCRE2.
When support for v2 was added in my 94da9193a6 ("grep: add support for
PCRE v2", 2017-06-01) the existing USE_LIBPCRE flag was left as
meaning v1, with a note that this would likely change in a fut
Change the check for PCRE v1 to disable the --with-libpcre1 option if
the pcre_version() function can't be found in the pcre library. I
unintentionally changed this in my 94da9193a6 ("grep: add support for
PCRE v2", 2017-06-01) while renaming moving some variables.
The intent of this check ever si
The --with-libpcre option is a synonym for the --with-libpcre1 flag,
but the configure script allowed for redundantly specifying both.
Nothing broke as a result of this, but it's confusing, so let's
disallow it.
Signed-off-by: Ævar Arnfjörð Bjarmason
---
configure.ac | 4
1 file changed, 4
This small series makes USE_LIBPCRE=YesPlease mean
USE_LIBPCRE2=YesPlease, instead of USE_LIBPCRE1=YesPlease is it does
now. Along the way I fixed a couple of minor issues in the PCRE
detection in the autoconf script.
Ævar Arnfjörð Bjarmason (3):
configure: fix a regression in PCRE v1 detection
Le 07/03/2018 à 22:56, Alban Gruin a écrit :
> Hi,
>
> I was reading the email related to the "convert interactive rebase to C"
> idea[1], and I have a few questions about it:
Hi,
I’m writing to you again, in order to have some more information about
the "convert interactive rebase to C" project
Hi Buga,
On Thu, 8 Mar 2018, Igor Djordjevic wrote:
> On 08/03/2018 16:16, Igor Djordjevic wrote:
> >
> > > Unless we reimplement the octopus merge (which works quite a bit
> > > differently from the "rebase merge commit" strategy, even if it is
> > > incremental, too), which has its own challen
Hi Jake,
On Thu, 8 Mar 2018, Jacob Keller wrote:
> On Thu, Mar 8, 2018 at 3:20 AM, Phillip Wood
> wrote:
> > I did wonder about using 'pick ' for rebasing merges
> > and keeping 'merge ...' for recreating them but I'm not sure if that
> > is a good idea. It has the advantage that the user canno
Hi Buga,
On Thu, 8 Mar 2018, Igor Djordjevic wrote:
> On 08/03/2018 12:20, Phillip Wood wrote:
> >
> > I did wonder about using 'pick ' for rebasing merges
> > and keeping 'merge ...' for recreating them but I'm not sure if that
> > is a good idea. It has the advantage that the user cannot speci
Hi Buga,
On Thu, 8 Mar 2018, Igor Djordjevic wrote:
> On 08/03/2018 13:16, Phillip Wood wrote:
> >
> > > I did wonder about using 'pick ' for rebasing merges
> > > and keeping 'merge ...' for recreating them but I'm not sure if that
> > > is a good idea. It has the advantage that the user cannot
Hi Junio,
On Thu, 8 Mar 2018, Junio C Hamano wrote:
> Johannes Schindelin writes:
>
> >> Non-textual semantic conflicts are made (in the best case just once)
> >> as a separate commit on top of mechanical auto-merge whose focus is
> >> predictability (rather than cleverness) done by Git, and th
62 matches
Mail list logo