On 2013-07-14 20:15, JonY wrote:
2013-03-08 Yaakov Selkowitz
* (gcc/testsuite/gcc.target/i386/pr25993.c): Skip unsupported test.
This patch was Dave Korn's.
Yaakov
On 2013-07-14 20:15, JonY wrote:
2013-03-08 Dave Korn
* (gcc/config.gcc): Include Cygwin specific file.
* (gcc/config/i386/cygwin.h): Link shared libgcc by default.
* (gcc/config/i386/cygwin.h): Add --large-address-aware, and use
--tsaware for exes
* (gcc/config/i38
On 7/17/2013 7:42 PM, Jakub Jelinek wrote:
> On Wed, Jul 17, 2013 at 07:39:00PM +0400, Kirill Yukhin wrote:
>> Is it ok to install?
> Yes.
>
Thanks!
Change into 4_8 branch: http://gcc.gnu.org/ml/gcc-cvs/2013-07/msg00477.html
K
"Maciej W. Rozycki" writes:
>> > Please also note that the writability of the individual new (HAS2008)
>> > FCSR bits is optional e.g. a conforming processor may have NAN2008
>> > hardwired to 1 and ABS2008 hardwired to 0 (or likewise with NAN2008
>> > writable).
>>
>> OK, I'd missed that thi
According to the announcement:
http://gcc.gnu.org/ml/gcc/2013-07/msg00232.html
I added myself and Shiva Chen as nds32 port maintainers.
Index: ChangeLog
===
--- ChangeLog (revision 201046)
+++ ChangeLog (working copy)
@@ -1,3
Hi Jason,
There follows a re-spin of the previous patches. I've addressed your
review comments and cleaned up much of the implementation (including
code location). I've also redesigned the `auto' param handling
(implicit function template generation) to work for plain functions
and member functi
---
gcc/cp/decl2.c | 5 +++--
gcc/cp/lambda.c | 9 -
gcc/cp/parser.c | 36 ++--
gcc/cp/pt.c | 4 +++-
4 files changed, 48 insertions(+), 6 deletions(-)
diff --git a/gcc/cp/decl2.c b/gcc/cp/decl2.c
index 1573ced..c166f6e 100644
--- a/gcc/cp/decl2.c
+
---
gcc/symtab.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/gcc/symtab.c b/gcc/symtab.c
index 85d47a8..1ada0f7 100644
--- a/gcc/symtab.c
+++ b/gcc/symtab.c
@@ -116,6 +116,15 @@ insert_to_assembler_name_hash (symtab_node node, bool
with_clones)
tree name = DEC
---
gcc/cp/cp-tree.h | 11
gcc/cp/decl.c| 4 +-
gcc/cp/parser.c | 57 ++---
gcc/cp/pt.c | 182 ++-
4 files changed, 231 insertions(+), 23 deletions(-)
diff --git a/gcc/cp/cp-tree.h b/gcc/cp/cp-tree.h
index a837d22.
On 26 June 2013 23:35, Yufeng Zhang wrote:
> This patch updates the AArch64 backend to support the small absolute and
> small PIC addressing models for ILP32; it also updates a number of other
> backend macros and hooks in order to support ILP32.
>
> OK for the trunk?
OK
/Marcus
On 2 July 2013 19:53, Yufeng Zhang wrote:
> Hi Andrew,
>
> Please find the updated patch in the attachment that addresses your
> comments.
>
> It now builds both ilp32 and lp64 multilibs by default, with the
> --with-multilib-list support remaining to provide options to turn off one of
> them.
>
>
On 26 June 2013 23:39, Yufeng Zhang wrote:
> This patch updates assign_parm_find_data_types to assign passed_mode and
> nominal_mode with the mode of the built pointer type instead of the
> hard-coded Pmode in the case of pass-by-reference. This is in line with the
> assignment to passed_mode and
On 26 June 2013 23:42, Yufeng Zhang wrote:
> gcc/
> * config/aarch64/aarch64.h (TARGET_CPU_CPP_BUILTINS): Define _ILP32
> and __ILP32__ when the ILP32 model is in use.
>
OK
/Marcus
Here are some more skips of tests that won't work on int16 targets.
In most cases constants too big, bitfields too long or arrays too large are
used. For gcc.dg/torture/pr56488.c there are some notes at
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56488#c4
that explain for why this test fails if
On 26 June 2013 23:41, Yufeng Zhang wrote:
> gcc/testsuite/
>
> * gcc.dg/20020219-1.c: Skip the test on aarch64*-*-* in ilp32.
> * gcc.target/aarch64/aapcs64/test_18.c (struct y): Change the field
> type from long to long long.
> * gcc.target/aarch64/atomic-op-long
Hi Jeff, Richard.
None of the RTL optimzers look at TRAP_IF w.r.t optimiizations.
I've decided to add some code to cprop.c and simplification primetives to
simply_rtx () this do work once
I fixed cprop to run on my testcase whicg only had functiions which 3 blocks
currently it think theses noth
> On 12 Jul 2013, at 19:49, Ian Bolton wrote:
>
> >
> > 2013-07-12 Ian Bolton
> >
> > gcc/
> > * config/aarch64/arm_neon.h (vabs_s64): New function.
> >
> > testsuite/
> > * gcc.target/aarch64/scalar_intrinsics.c (test_vabs_s64): Added
> new
> > test.
>
> OK
> /Marcus
I needed to upd
Hi,
Following the work in AArch64 GAS to unify the ABI command line
interface, this patch updates the compiler driver to pass -mabi=*
directly to the assembler.
The related GAS patch is here:
http://www.sourceware.org/ml/binutils/2013-07/msg00180.html
OK for the trunk (after the initial ILP3
2013/7/18 Georg-Johann Lay :
> Currently, the fixed-point rounding does not work correctly in the overflow
> case. This is because of misreading section 2.1.7.2 of TR 18037.
>
> Rounding builtins expand to saturated addition and AND so that the instruction
> sequence is
>
> add value1
> if not ove
On 19/07/13 11:26, Ian Bolton wrote:
On 12 Jul 2013, at 19:49, Ian Bolton wrote:
2013-07-12 Ian Bolton
gcc/
* config/aarch64/arm_neon.h (vabs_s64): New function.
testsuite/
* gcc.target/aarch64/scalar_intrinsics.c (test_vabs_s64): Added
new
test.
OK
/Marcus
I needed
On 07/18/2013 10:49 AM, Xinliang David Li wrote:
The difference is that the relative order of DECL_UIDs do not change
whether debug info is on or not, but there is no such guarantee when
hashing is involved.
Yea. I feel like an idiot for missing the hash vs comparison.
Add a ChangeLog and this
On 07/12/2013 01:13 PM, Marc Glisse wrote:
Initial patch (from last year) actual implemented that in forwprop.
Ah, reading the conversation from last year helped me understand a bit
better.
It's also worth noting that fold-const.c also does some type
hoisting/sinking. Ideally that code shoul
Hi Uros,
thanks for your reviews,
On 18 Jul 2013, at 12:39, Uros Bizjak wrote:
> On Thu, Jul 18, 2013 at 12:12 PM, Iain Sandoe wrote:
>>
>> So, I think we have to use the define_insn_and_split, or am I still missing
>> something?
>
> Just a wild guess, do you also need "&& reload_completed"
On Fri, Jul 19, 2013 at 02:47:51PM +0100, Iain Sandoe wrote:
> + /* Get a new pic base. */
> + emit_insn (gen_set_got_labelled (pic_offset_table_rtx, label_rtx));
> + /* Correct this with the offset from the new to the old. */
> + xops[0] = xops[1] = pic_offset_table_rtx;
> +
Fortran intrinsic_nearest testcase fails on AIX because the magic
single precision floating point value loaded as hex (z'7f7f') is
not preserved by PowerPC lfs instruction and nextafterf() does not
produce the expected result.
Index: intrinsic_nearest.x
Hi,
This patch is part of the ongoing work of ARM instruction classification
cleanup.
This patch deletes the "insn" attribute and moves the MOV/MVN instruction
classification to the "type" attribute, where it is split into several types
for a finer-grained classification.
This has been tested wi
On Thu, Jul 18, 2013 at 03:47:28PM -0400, Jason Merrill wrote:
> Please describe the hash table more up here. What are you tracking?
>
> >+ hashval_t h = iterative_hash_object (data->type, 0);
> >+ h = iterative_hash_object (data->decl, h);
>
> If you hash the decl as well as the type, the fin
Jeff Law wrote:
>On 07/12/2013 01:13 PM, Marc Glisse wrote:
>>> Initial patch (from last year) actual implemented that in forwprop.
>>
>> Ah, reading the conversation from last year helped me understand a
>bit
>> better.
>It's also worth noting that fold-const.c also does some type
>hoisting/sin
On Fri, 19 Jul 2013, Jeff Law wrote:
It's also worth noting that fold-const.c also does some type
hoisting/sinking.
fold-const.c does everything ;-)
Ideally that code should just be going away.
Like most of the code from fold-const.c that isn't about folding
constants, I guess, once it ha
On 07/19/2013 05:00 AM, Adam Butcher wrote:
+ warning (0, "Conversion of a generic lambda to a function pointer is not
currently implemented.");
...
+"Generic lambdas are only supported in C++1y mode.");
We generally don't capitalize diagnostics or end them with a
On 07/09/2013 01:53 AM, Bin Cheng wrote:
Hi,
FW: [PATCH GCC]Relax the probability condition in CE pass when optimizing
for code size
http://gcc.gnu.org/ml/gcc-patches/2013-03/msg00969.html
This is OK.
[PATCH ARM]Extend thumb1_reorg to save more comparison instructions
http://gcc.gnu.org/ml/g
On Thu, Jul 18, 2013 at 12:29:25PM -0400, Jason Merrill wrote:
> Hmm, that logic is difficult to follow. It needs comments at least
> explaining last_seen_* and why the loop in the suffix handling keeps
> going after we change the phase to RAW_STR.
>
> Maybe instead of tracking last_seen_* BUFF_A
On Jul 19, 2013, at 2:23 AM, Georg-Johann Lay wrote:
> Here are some more skips of tests that won't work on int16 targets.
>
> In most cases constants too big, bitfields too long or arrays too large are
> used. For gcc.dg/torture/pr56488.c there are some notes at
>
> http://gcc.gnu.org/bugzilla/
On Fri, Jul 19, 2013 at 07:33:19PM +0200, Jakub Jelinek wrote:
> On Thu, Jul 18, 2013 at 12:29:25PM -0400, Jason Merrill wrote:
> > Hmm, that logic is difficult to follow. It needs comments at least
> > explaining last_seen_* and why the loop in the suffix handling keeps
> > going after we change
On Fri, Jul 19, 2013 at 08:09:05PM +0100, James Greenhalgh wrote:
> + /* Forecfully avoid optimization. */ \
A typo.
> + asm volatile ("" : : : "memory"); \
> + test_vabs_##size (res1, pool1);\
> + for (i = 0;
On Fri, Jul 19, 2013 at 05:20:39PM +0200, Jakub Jelinek wrote:
> > >I have yet to handle
> > >freeing the hash table, but I think I'll need the GTY machinery for
> > >this (ubsan is not a pass, so I can't just call it at the end of the
> > >pas). Or maybe just create a destructor and use append_to
On Fri, Jul 19, 2013 at 08:50:42PM +0200, Jakub Jelinek wrote:
> On Fri, Jul 19, 2013 at 08:45:30PM +0200, Marek Polacek wrote:
> > > >+uptr_type (void)
> > > >+{
> > > >+ return build_nonstandard_integer_type (POINTER_SIZE, 1);
> > >
> > > Why not use uintptr_type_node?
> >
> > I suppose I coul
Hi,
This patch uses aarch64_fold_builtin to fold all remaining variants
of the vabs intrinsics to tree.
Testcase added, full testsuite run for aarch64-none-elf with no
issues.
OK?
Thanks,
James
---
gcc/
2013-07-19 James Greenhalgh
* config/aarch64/aarch64-builtins.c
(aarc
On Fri, Jul 19, 2013 at 3:47 PM, Iain Sandoe wrote:
> Hi Uros,
>
> thanks for your reviews,
>
> On 18 Jul 2013, at 12:39, Uros Bizjak wrote:
>
>> On Thu, Jul 18, 2013 at 12:12 PM, Iain Sandoe wrote:
>>>
>>> So, I think we have to use the define_insn_and_split, or am I still missing
>>> something
On Thu, Jul 18, 2013 at 03:47:28PM -0400, Jason Merrill wrote:
> On 07/05/2013 10:04 AM, Marek Polacek wrote:
> >+/* This type represents an entry in the hash table. */
>
> Please describe the hash table more up here. What are you tracking?
Ok, I've added two more comments.
> >+ hashval_t h =
On Fri, Jul 19, 2013 at 08:45:30PM +0200, Marek Polacek wrote:
> > >+uptr_type (void)
> > >+{
> > >+ return build_nonstandard_integer_type (POINTER_SIZE, 1);
> >
> > Why not use uintptr_type_node?
>
> I suppose I could. I just followed suit what asan.c does. I didn't
> address this in this pat
Hi all,
Add myself as Write After Approval.
Yvan
2013-07-19 Yvan Roux
* MAINTAINERS (Write After Approval): Add myself.
r201069.diff
Description: Binary data
On Fri, Jul 19, 2013 at 04:56:47PM +0200, Uros Bizjak wrote:
> > OK for trunk?
>
> Assuming that Jakub is OK with the patch, it is OK for trunk.
With the line wrapping fix and Uros' suggested improvement this is ok for
both trunk and branches.
Jakub
> GPL + exception seems like the way to go, except in those cases where
> the code is coming from a 3rd party.
Already pointed out and fixed, but I'll double check that they're all
GPL+E.
> I'm assuming you documented all the MSP430 options. I didn't check them
> closely. I'm also assuming t
Greetings,
I committed merge of r201068 (backport of the fix for PR57878 from
trunk) as r201071 to google/gcc-4_8 branch.
Thanks,
--
Paul Pluzhnikov
[ sorry for dup. ]
On Jul 19, 2013, at 2:23 AM, Georg-Johann Lay wrote:
> Here are some more skips of tests that won't work on int16 targets.
>
> In most cases constants too big, bitfields too long or arrays too large are
> used. For gcc.dg/torture/pr56488.c there are some notes at
>
> http://g
Hi,
The problem appears in revision 201034 in version 4.9. I attached a
one-line patch that fixes it. I also reported this problem
at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57809
I bootstrapped and ran the regression tests for this patch on x86_64-linux
and all tests pass.
In method "omeg
Hi,
The problem appears in revision 201034 in version 4.9. I attached a
one-line patch that fixes it. I also reported this problem
at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57803
I bootstrapped and ran the regression tests for this patch on x86_64-linux
and all tests pass.
In method "gfc_
Hi,
The problem appears in revision 201034 in version 4.9. I attached a
one-line patch that fixes it. I also reported this problem
at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57806
I bootstrapped and ran the regression tests for this patch on x86_64-linux
and all tests pass.
In method "prop
> Every pattern that is using (subreg:SI (thing:PSI)) needs to be
> explained on this list and given an explicit clearance. It really looks
> like you're just papering over problems elsewhere.
Most of them are just optimizations, but the problem with reload is
that an SImode register *can't* h
On Fri, Jul 19, 2013 at 08:12:54PM +0100, Marek Polacek wrote:
> On Fri, Jul 19, 2013 at 08:09:05PM +0100, James Greenhalgh wrote:
> > + /* Forecfully avoid optimization. */\
>
> A typo.
Good spot, thanks for taking a look at this.
Hopefully the attached has "force
Thank you! backported as r201068 in gcc-4_8-branch.
Thanks,
Wei.
On Thu, Jul 18, 2013 at 10:05 AM, Vladimir Makarov wrote:
> On 07/15/2013 02:26 PM, Wei Mi wrote:
>> Hi,
>>
>> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57878
>>
>> The bug occurs because tfreq is given higher priority than bigg
I was creating a new gimple/folding interface and wanted some opinions
on the interface.
typedef double_int (*nonzerobits_t)(tree var);
typedef tree (*valueizer_t)(tree var);
class gimple_combine
{
public:
gimple_combine(nonzerobits_t a, valueizer_t b) : nonzerobitsf(a),
valueizerv(b), allow_fu
We all missed it when just staring at the code :)
David
On Fri, Jul 19, 2013 at 5:45 AM, Jeff Law wrote:
> On 07/18/2013 10:49 AM, Xinliang David Li wrote:
>>
>> The difference is that the relative order of DECL_UIDs do not change
>> whether debug info is on or not, but there is no such guarante
Hi!
This is the C FE counterpart of the
http://gcc.gnu.org/ml/gcc-patches/2013-07/msg00520.html
changes. The OpenMP 4.0 standard in the end requires that the #pragma omp
declare simd clauses are parsed at the scope of the function parameters,
but lexically comes before the function return type, s
Although the gcc.dg/debug/dwarf2/dwarf2.exp generally requests dwarf-2
information, so that the test will work with targets that have a different
default output format, that doesn't happen where the test specifies specific
target options. In that case, we have to specify -gdwarf-2 in the individu
With 16 bit integers, (int) 0x0001 is just 0, so execution of that
test fails.
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-05-13 Joern Rennecke
* gcc.c-torture/execute/pr56799.x: New file.
Index: gcc.c-torture/execute/pr56799.x
Because we now issue the error message for the place of the macro definition,
the expected line number has to be updated.
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-05-26 Joern Rennecke
* gcc.dg/c99-stdint-1.c [avr-*-*]: Update line numbe
On 07/19/2013 03:01 PM, Marek Polacek wrote:
On Fri, Jul 19, 2013 at 08:50:42PM +0200, Jakub Jelinek wrote:
uintptr_type_node is a C/C++/ObjC/ObjC++ FE tree. So, if you use it just
in c-family/c-ubsan.c, that is just fine, but you can't use it in ubsan.c.
Any reason not to move it into the mi
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
Committed as obvious.
2013-06-14 Joern Rennecke
* gcc.dg/pr57154.c: Add dg-require-effective-target scheduling.
Index: gcc.dg/pr57154.c
=
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-06-24 Joern Rennecke
* gcc.dg/torture/stackalign/builtin-apply-2.c: Also skip for avr.
Index: gcc.dg/torture/stackalign/builtin-apply-2.c
==
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-05 Joern Rennecke
* gcc.dg/pr44214-1.c (v2df): Define size using sizeof (double).
* gcc.dg/pr44214-3.c (v2df): Likewise.
Index: gcc.dg/pr44214-1.c
==
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-05 Joern Rennecke
* gcc.dg/pr46647.c: xfail for avr*-*-*.
Index: gcc.dg/pr46647.c
===
--- gcc.dg/pr46647.c(revision 201032)
+
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-05 Joern Rennecke
* gcc.dg/pr53265.c: Disable test for avr*-*-*.
Index: gcc.dg/pr53265.c
===
--- gcc.dg/pr53265.c(revision 20
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-05 Joern Rennecke
* gcc.dg/strlenopt-10.c [avr*-*-*]: Reduce number of expected
memcpy by one.
* gcc.dg/strlenopt-11.c [avr*-*-*]: Likewise.
Expect l to be optimized away
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-05 Joern Rennecke
* c-c++-common/scal-to-vec1.c: Add !int16 and large_double conditions
to tests that assume int/double are larger than short/float.
Index: c-c++-common/scal-to-vec1.c
=
On 20 July 2013 00:42, James Greenhalgh wrote:
> Hopefully the attached has "forcefully" correct in both places and is
> otherwise typo free.
>
> OK?
OK
/Marcus
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
Committed as obvious.
2013-07-17 Joern Rennecke
* gcc.dg/tree-ssa/pr21090.c: Do vrp1 scan check only for
target { ! keeps_null_pointer_checks }.
* gcc.dg/tree-ssa/unreachable.c: Do opti
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-17 Joern Rennecke
* c-c++-common/simulate-thread/bitfields-2.c: Run test only for
target { ! int16 }.
* gcc.dg/tree-ssa/pr54245.c: Do slsr scan only for target { ! int16 }.
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-17 Joern Rennecke
* gcc.dg/torture/pr53366-1.c: Only run for target { size32plus }.
* gcc.dg/torture/pr56488.c: Likewise.
Index: gcc.dg/torture/pr53366-1.c
=
Tested for avr with --target_board=atmega128-sim and native on
i686-pc-linuc-gnu.
2013-07-17 Joern Rennecke
* gcc.dg/tree-ssa/pr42585.c: Add avr*-*-* to list of targets to
exclude from scan test.
Index: gcc.dg/tree-ssa/pr42585.c
==
71 matches
Mail list logo