> 2013-06-13 Bin Cheng
>
> * rtlanal.c (noop_move_p): Check the code to be executed for
> COND_EXEC.
OK if you use COND_EXEC_CODE instead of EXP and remove the useless assertion.
--
Eric Botcazou
On Wed, Jun 12, 2013 at 12:52:03PM -0500, Edmar Wienskoski wrote:
> The e500v2 (SPE) hardware is such that if the address of vector (double world
> load / stores) are not double world aligned the instruction will trap.
>
> So this alignment is not optional.
Vector type alignment is also specified
On Wed, Jun 12, 2013 at 10:18:29PM +, Joseph S. Myers wrote:
> In general I think no formatting fixes should be made to GCC testcases,
> including removal of trailing whitespace; it's good if they cover a range
> of coding styles and oddities as that reflects how GCC is used in
> practice.
On Thu, Jun 13, 2013 at 3:27 AM, Bin Cheng wrote:
> Hi,
> This is a case of NOP_EXPR and CONVERT_EXPR not compared equal in
> operand_equal_p, resulting in below two nodes are considered different:
>
> NODE 0:
> type size
> unit size
> align 16 symtab 0 alias set 4
Fat pointer types are pointer types to (slices of) arrays and they are said
"fat" because they contain a pointer to the array and a pointer to the bounds.
We were using a trick on platforms which pass them by reference to improve the
debug info at -O0, but this pessimizes when optimization is ena
On Thu, Jun 13, 2013 at 8:44 AM, Marc Glisse wrote:
> On Wed, 12 Jun 2013, Jeff Law wrote:
>
>>> 2013-06-13 Marc Glisse
>>>
>>> * tree-ssa-forwprop.c (simplify_bitwise_binary,
>>> associate_plusminus):
>>> Generalize to complex and vector.
>>> * tree.c (build_all_ones_cst): New f
On Wed, Jun 12, 2013 at 10:08 PM, Ondřej Bílka wrote:
> A followup to previous patch is more general pass that changes leading
> spaces to tabs followed by at most 8 spaces.
>
> http://kam.mff.cuni.cz/~ondra/0004-Formatted-by-leading_space.patch
Btw, rather than these kind of patches I'd apprecia
On Thu, Jun 13, 2013 at 09:45:23AM +0200, Marek Polacek wrote:
> On Wed, Jun 12, 2013 at 10:18:29PM +, Joseph S. Myers wrote:
> > In general I think no formatting fixes should be made to GCC testcases,
> > including removal of trailing whitespace; it's good if they cover a range
> > of coding
On 06/13/2013 02:38 AM, Paolo Carlini wrote:
If we really have to add a testcase - I'm not sure - please double
check that it passes testing with -Wall, no unused vars.
Patch as went in had still the testcase wrong, triggering at least 3
warnings with -Wall. All in all, I decided to also remove
On Mon, May 27, 2013 at 11:15 AM, Alexander Ivchenko wrote:
> Hi,
>
> While discussing the issue with the command line option for sincos here:
> http://gcc.1065356.n5.nabble.com/PATCH-bionic-Add-foptimize-sincos-tp940918.html
>
> Richard wrote:
>> I'd rather think about a way to specify, for all k
On Fri, May 31, 2013 at 4:12 PM, David Malcolm wrote:
> On Tue, 2013-05-28 at 12:30 -0600, Jeff Law wrote:
>> On 05/28/2013 11:00 AM, David Malcolm wrote:
>> > On Tue, 2013-05-28 at 06:39 -0600, Jeff Law wrote:
>> >> On 05/25/2013 07:02 AM, David Malcolm wrote:
>> >>> I can think of three approach
On Sat, Jun 8, 2013 at 2:26 AM, Xinliang David Li wrote:
> On Fri, Jun 7, 2013 at 6:47 AM, Richard Biener
> wrote:
>> On Fri, Jun 7, 2013 at 3:30 PM, Xinliang David Li wrote:
>>> On Fri, Jun 7, 2013 at 2:05 AM, Richard Biener
>>> wrote:
On Thu, Jun 6, 2013 at 5:10 PM, Dehao Chen wrote:
>>
On Wed, Jun 12, 2013 at 4:48 AM, Alan Modra wrote:
> The following patch fixes PR57134 by
> a) excluding bitfield expansion when EXPAND_MEMORY, and
> b) passing down the EXPAND_MEMORY modifier in a couple of places where
> this does not currently happen on recursive calls to expand_expr().
>
> (a)
> -Original Message-
> From: Richard Biener [mailto:richard.guent...@gmail.com]
> Sent: Thursday, June 13, 2013 3:51 PM
> To: Bin Cheng
> Cc: gcc-patches@gcc.gnu.org
> Subject: Re: [PATCH GCC]Consider NOP_EXPR and CONVERT_EXPR as equal nodes
in
> operand_equal_p
>
> On Thu, Jun 13, 2013
> -Original Message-
> From: Eric Botcazou [mailto:ebotca...@adacore.com]
> Sent: Thursday, June 13, 2013 3:36 PM
> To: Bin Cheng
> Cc: gcc-patches@gcc.gnu.org
> Subject: Re: [PATCH GCC]Check the code to be executed for COND_EXEC in
> noop_move_p
>
> > 2013-06-13 Bin Cheng
> >
> >
On Thu, Jun 13, 2013 at 10:08:23AM +0200, Richard Biener wrote:
> On Wed, Jun 12, 2013 at 10:08 PM, Ondřej Bílka wrote:
> > A followup to previous patch is more general pass that changes leading
> > spaces to tabs followed by at most 8 spaces.
> >
> > http://kam.mff.cuni.cz/~ondra/0004-Formatted-b
A rather simple patch. I wonder why we didn't get in trouble before -
the "*dummy = NULL;" part should affect also other optional allocatable
dummy arguments.
Build and regtested on x86-64-gnu-linux.
OK for the trunk?
Tobias
PS: Pending patches:
* Unreviewed: Print exception status at STOP,
... in any case, I propose to also add to /cpp0x this testcase suggested
by Daniel.
Thanks,
Paolo.
7
Index: g++.dg/cpp0x/dyncast1.C
===
--- g++.dg/cpp0x/dyncast1.C (revision 0)
+++ g++.dg/cpp0x/dyncast1.C (w
"Bernhard Reutner-Fischer" writes:
> On 12 June 2013 20:20:50 Richard Sandiford wrote:
>> Matthias Klose writes:
>> > Index: config/mips/t-linux64
>> > ===
>> > --- config/mips/t-linux64 (revision 200012)
>> > +++ config/mips/t-lin
On Wed, 12 Jun 2013, Richard Biener wrote:
>
> The following patch re-writes LTO type merging completely with the
> goal to move as much work as possible to the compile step, away
> from WPA time. At the same time the merging itself gets very
> conservative but also more general - it now merges
Hi,
compount literals are constructed COMDAT but not PUBLIC by C frontned.
A while ago I discussed with with Jason? (I believe) and the reason for that
is that they allow sharing even if it is not done by linker.
This however breaks our partitioning code that assumes that COMDAT is always
exported.
> "Phil" == Phil Muldoon writes:
Phil> Attached is an updated patch correcting the issues that you pointed
Phil> out.
The patch itself looks fine to me, but I don't think I can approve it.
Tom
On 06/12/2013 08:49 PM, Paolo Carlini wrote:
+ /* Add any qualifier conversions. */
+ return build_nop (type, expr);
For a cast to reference type, this will produce an rvalue rather than an
lvalue.
Perhaps we should hand off to build_static_cast in the case described by
the com
Hi,
Jason Merrill ha scritto:
>On 06/12/2013 08:49 PM, Paolo Carlini wrote:
>> +/* Add any qualifier conversions. */
>> +return build_nop (type, expr);
>
>For a cast to reference type, this will produce an rvalue rather than
>an lvalue.
Ah, thanks a lot for the clarification. Admitte
On 06/13/2013 04:30 AM, Paolo Carlini wrote:
On 06/13/2013 02:38 AM, Paolo Carlini wrote:
If we really have to add a testcase - I'm not sure - please double
check that it passes testing with -Wall, no unused vars.
Patch as went in had still the testcase wrong, triggering at least 3
warnings wit
On 07/06/13 04:00, Alan Modra wrote:
> force_const_mem() isn't supposed to handle VOIDmode or BLKmode, so the
> check for VOIDmode when aligning is needless. If we ever did get one
> of these modes in a constant pool, this
>
> pool->offset += GET_MODE_SIZE (mode);
Hi Alan,
the assertion is tr
In order to check powerpc64le abi symbols. Bootstrapped etc.
powerpc64-linux. OK to apply?
* configure.host (abi_baseline_pair): Match powerpc64*.
I think that I can approve this.
- David
Hi,
for now only a few words about your first two points (goes without saying that
further contributions from you about the special functions TR or anything C++11
and C++14 are more than welcome!)
>On 06/13/2013 04:30 AM, Paolo Carlini wrote:
>> On 06/13/2013 02:38 AM, Paolo Carlini wrote:
>>
On Thu, Jun 13, 2013 at 04:29:44PM +0200, Andreas Krebbel wrote:
> On 07/06/13 04:00, Alan Modra wrote:
> > force_const_mem() isn't supposed to handle VOIDmode or BLKmode, so the
> > check for VOIDmode when aligning is needless. If we ever did get one
> > of these modes in a constant pool, this
>
On Thu, Jun 13, 2013 at 05:10:51PM +0930, Alan Modra wrote:
> On Wed, Jun 12, 2013 at 12:52:03PM -0500, Edmar Wienskoski wrote:
> > The e500v2 (SPE) hardware is such that if the address of vector (double
> > world
> > load / stores) are not double world aligned the instruction will trap.
> >
> >
On Fri, Jun 14, 2013 at 01:07:01AM +0930, Alan Modra wrote:
> @@ -5774,10 +5818,11 @@ offsettable_ok_by_alignment (rtx op, HOST_WIDE_INT
>type = TREE_TYPE (decl);
>
>dalign = TYPE_ALIGN (type);
> + dalign = DATA_ABI_ALIGNMENT (type, dalign);
>if (CONSTANT_CLASS_P (dec
On Thu, Jun 13, 2013 at 1:43 AM, Richard Biener
wrote:
> On Sat, Jun 8, 2013 at 2:26 AM, Xinliang David Li wrote:
>> On Fri, Jun 7, 2013 at 6:47 AM, Richard Biener
>> wrote:
>>> On Fri, Jun 7, 2013 at 3:30 PM, Xinliang David Li
>>> wrote:
On Fri, Jun 7, 2013 at 2:05 AM, Richard Biener
>>>
It looks like a NULL in INIT_INDEX is a specially handled case. Perhaps you
should document that INIT_INDEX can be null and what it means.
Also, you don't need to document what internal variable name you are using as
a return value (VALUE_TREE). Perhaps instead of "The return value..." you cou
On 06/13/2013 09:11 AM, Aldy Hernandez wrote:
> The whole slew of these cases have a lot of duplicated code. For instance,
> BUILT_IN_CILKPLUS_SEC_REDUCE_MIN is the same as
> BUILT_IN_CILKPLUS_SEC_REDUCE_MAX, the only difference being GT_EXPR vs
> LT_EXPR. Surely you could do something like:
>
>
Can you create a helper function to flag the error and perhaps also
put that check inside can_inline_edge_p ?
David
On Wed, Jun 12, 2013 at 6:00 PM, Sriraman Tallam wrote:
> Hi Honza,
>
>I have isolated the ipa-inline.c part into a separate patch with a
> test and attached it here. The patc
On Thu, 13 Jun 2013, Richard Biener wrote:
> Btw, rather than these kind of patches I'd appreciate if someone would look
> at a simple pre(post?)-commit hook that enforces those whitespace rules.
In the cpp testsuite we definitely want tests with bad whitespace (e.g.
gcc.dg/cpp/backslash*.c) and
> Can you create a helper function to flag the error and perhaps also
> put that check inside can_inline_edge_p ?
>
> David
>
>
> On Wed, Jun 12, 2013 at 6:00 PM, Sriraman Tallam wrote:
> > Hi Honza,
> >
> >I have isolated the ipa-inline.c part into a separate patch with a
> > test and atta
On Thu, Jun 13, 2013 at 10:07 AM, Jan Hubicka wrote:
>> Can you create a helper function to flag the error and perhaps also
>> put that check inside can_inline_edge_p ?
>>
>> David
>>
>>
>> On Wed, Jun 12, 2013 at 6:00 PM, Sriraman Tallam wrote:
>> > Hi Honza,
>> >
>> >I have isolated the ipa
> On Thu, Jun 13, 2013 at 10:07 AM, Jan Hubicka wrote:
> >> Can you create a helper function to flag the error and perhaps also
> >> put that check inside can_inline_edge_p ?
> >>
> >> David
> >>
> >>
> >> On Wed, Jun 12, 2013 at 6:00 PM, Sriraman Tallam
> >> wrote:
> >> > Hi Honza,
> >> >
> >>
Mikael Morin wrote:
This fixes the problem, but shouldn't the fix be in gfc_expr_attr instead?
I tried it - but it does not work: In many case, one actually needs a
function, e.g. for procedure pointers or for C_FUNLOC. Thus, I had to
add an additional flag to tell whether the function or the
Hello,
an incredibly suprising patch: I am adapting yet more fold-const
transformations to vectors... (it varies, the last patch was in forwprop)
I was quite conservative with respect to complex: I didn't want to create
a BIT_NOT_EXPR of a complex.
As an aside, while writing this patch, I n
On Thu, Jun 13, 2013 at 10:19 AM, Jan Hubicka wrote:
>> On Thu, Jun 13, 2013 at 10:07 AM, Jan Hubicka wrote:
>> >> Can you create a helper function to flag the error and perhaps also
>> >> put that check inside can_inline_edge_p ?
>> >>
>> >> David
>> >>
>> >>
>> >> On Wed, Jun 12, 2013 at 6:00 P
On 06/13/13 12:06, Marc Glisse wrote:
Hello,
an incredibly suprising patch: I am adapting yet more fold-const
transformations to vectors... (it varies, the last patch was in forwprop)
I was quite conservative with respect to complex: I didn't want to
create a BIT_NOT_EXPR of a complex.
As an a
If you want to flag errors for all possible wrongly used always_inline
attribute, should this change be done in can_inline_edge_p? Or keep
your current change, but also add a warning (something like 'always
inline function is ignored etc') in inline_always_inline_functions
when inline transformatio
On Fri, 2013-06-07 at 16:14 +0100, James Greenhalgh wrote:
> Beyond that, the path search code is modified from Steve's patch
> to only perform one depth first search, and the path copy code
> is modified to purge the region entry and exit edges for those
> which traditional jump-threading may co
> * tree-inline.c (expand_call_inline): Allow the error to be flagged
> in early inline pass.
> * ipa-inline.c (inline_always_inline_functions): Pretend always_inline
> functions are inlined during failures to flag an error.
> * gcc.target/i386/inline_error.c: New test
> If you want to flag errors for all possible wrongly used always_inline
> attribute, should this change be done in can_inline_edge_p? Or keep
> your current change, but also add a warning (something like 'always
> inline function is ignored etc') in inline_always_inline_functions
> when inline tra
I had a thinko in processing the switches for quad memory, in that it cleared
quad memory on 32-bit, and then OR'ed in the switches from the -mcpu, when it
should have cleared it after the OR.
I have committed this patch as obvious (after checking it out to make sure it
fixes the problem and build
yes, what you said makes sense.
thanks,
David
On Thu, Jun 13, 2013 at 12:45 PM, Jan Hubicka wrote:
>> If you want to flag errors for all possible wrongly used always_inline
>> attribute, should this change be done in can_inline_edge_p? Or keep
>> your current change, but also add a warning (som
it. Also, not sure what to do for lastprivate, probably use the magic
arrays and just in the epilogue of the loop compute which of the array items
belonged to the last iteration somehow.
Can't you do (for lastprivate(abc) something like:
if (i == 1024) {
abc = magic_a
On Thu, Jun 13, 2013 at 03:15:45PM -0500, Aldy Hernandez wrote:
>
> >it. Also, not sure what to do for lastprivate, probably use the magic
> >arrays and just in the epilogue of the loop compute which of the array items
> >belonged to the last iteration somehow.
>
> Can't you do (for lastprivate(
On 06/12/13 16:36, Jakub Jelinek wrote:
On Wed, Jun 12, 2013 at 10:38:00AM -0700, Richard Henderson wrote:
On 06/12/2013 10:30 AM, Jakub Jelinek wrote:
So the built-ins would take address of this decl, something else?
Perhaps address, perhaps just referenced uninitialized?
True, assuming no
Le 13/06/2013 11:13, Tobias Burnus a écrit :
> A rather simple patch. I wonder why we didn't get in trouble before -
> the "*dummy = NULL;" part should affect also other optional allocatable
> dummy arguments.
>
> Build and regtested on x86-64-gnu-linux.
> OK for the trunk?
>
OK; thanks.
Mikael
>
> Ok, not streaming and comparing TREE_USED gets it improved to
I will try to gather better data tomorrow. My mozilla build died on disk space,
but according to stats we are now at about 7GB of GGC memory after merging.
I was playing with the following patch that implements testing whether type
> >
> > Ok, not streaming and comparing TREE_USED gets it improved to
>
> I will try to gather better data tomorrow. My mozilla build died on disk
> space,
> but according to stats we are now at about 7GB of GGC memory after merging.
> I was playing with the following patch that implements testi
On Thu, Jun 13, 2013 at 05:42:17PM +0200, Jakub Jelinek wrote:
> On Fri, Jun 14, 2013 at 01:07:01AM +0930, Alan Modra wrote:
> > @@ -5774,10 +5818,11 @@ offsettable_ok_by_alignment (rtx op, HOST_WIDE_INT
> >type = TREE_TYPE (decl);
> >
> >dalign = TYPE_ALIGN (type);
> > + dal
Hi again,
On 06/13/2013 03:51 PM, Jason Merrill wrote:
Perhaps we should hand off to build_static_cast in the case described
by the comment, rather than duplicate the logic.
Thus I have regression tested successfully the below.
Thanks,
Paolo.
/cp
2013-06-13 Paolo
On Thu, Jun 13, 2013 at 08:29:08PM +0100, Steve Ellcey wrote:
> On Fri, 2013-06-07 at 16:14 +0100, James Greenhalgh wrote:
>
> > Beyond that, the path search code is modified from Steve's patch
> > to only perform one depth first search, and the path copy code
> > is modified to purge the region e
Hi,
I applied this nice batch of improvements coming from Daniel.
Thanks,
Paolo.
//
2013-06-13 Daniel Krugler
* include/std/type_traits (is_function): Support ref-qualified
functions.
(is_copy_constructible, is_move_constructible, is_copy_assigna
OK.
Jason
Hey guys,
I'm a first time patch submitter, please be gentle. It probably goes
without saying, but I do not have svn write access.
The patch attached is related to PR38836. This patch removes the
following x86 builtins from the documentation:
__builtin_ia32_cmpnlts *
__builtin_ia32_loadaps
__bui
When doing a -j16 build of top of the trunk from a little while ago, with our
wide-int patches in it, I hit:
g++ -c -g -DIN_GCC -fno-exceptions -fno-rtti -fasynchronous-unwind-tables
-W -Wall -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -pedantic
-Wno-long-long -Wno-variadic-macro
On Thu, Jun 13, 2013 at 12:40 PM, Jan Hubicka wrote:
>> * tree-inline.c (expand_call_inline): Allow the error to be flagged
>> in early inline pass.
>> * ipa-inline.c (inline_always_inline_functions): Pretend always_inline
>> functions are inlined during failures to flag an
Richard Sandiford writes:
> I can't approve the Makefile.in bits. I've cc'ed Ian, who's the libgcc
> maintainer. Ian: the problem is that "_muldi3.o" on 64-bit targets
> is actually an implementation of __multi3. Jürgen wants to have a
> __muldi3 too, with the same implementation as on 32-bit
> > >
> > > Ok, not streaming and comparing TREE_USED gets it improved to
> >
> > I will try to gather better data tomorrow. My mozilla build died on disk
> > space,
> > but according to stats we are now at about 7GB of GGC memory after merging.
> > I was playing with the following patch that im
65 matches
Mail list logo