RE: [PATCH] Fix stack red zone bug (PR38644)

2011-10-09 Thread Jiangning Liu
> -Original Message- > From: Richard Henderson [mailto:r...@redhat.com] > Sent: Saturday, October 01, 2011 3:05 AM > To: Jiangning Liu > Cc: 'Jakub Jelinek'; 'Richard Guenther'; Andrew Pinski; gcc- > patc...@gcc.gnu.org > Subject: Re: [PATCH] Fix stack red zone bug (PR38644) > > On 09/29

RE: [PATCH] Fix stack red zone bug (PR38644)

2011-10-09 Thread Jiangning Liu
> -Original Message- > From: Richard Guenther [mailto:richard.guent...@gmail.com] > Sent: Friday, September 30, 2011 8:57 PM > To: Jiangning Liu; Jakub Jelinek; Richard Guenther; Andrew Pinski; gcc- > patc...@gcc.gnu.org; richard.sandif...@linaro.org > Subject: Re: [PATCH] Fix stack red z

Out-of-order update of new_spill_reg_store[]

2011-10-09 Thread Richard Sandiford
This patch fixes an ordering problem in reload: the output reloads are emitted in reverse operand order, but new_spill_reg_store[] is updated in forward reload order. This causes problems if the same register is used for two reloads. I saw this hit on mips64-linux-gnu/-mabi=64 as a failure in exe

Re: PATCH RFA: New configure option --with-native-system-header-dir

2011-10-09 Thread Ian Lance Taylor
Ian Lance Taylor writes: > So, it seems to me that we should: > > * Remove SYSTEM_INCLUDE_DIR, which is undefined and unnecessary. > > * Move the definition of NATIVE_SYSTEM_HEADER_DIR into config.gcc > (named native_system_header_dir). The default is /usr/include. > This appears to

Re: [google] record compiler options to .note sections

2011-10-09 Thread Jakub Jelinek
On Sun, Oct 09, 2011 at 09:18:25AM +0800, Dehao Chen wrote: > Unfortunately -frecord-gcc-switches cannot serve our purpose because > the recorded switches are mergable, i.e. the linker will merge all > options to a set of strings. However, object files may have distinct > compile options. We want t

RE: [PATCH] Fix stack red zone bug (PR38644)

2011-10-09 Thread Jiangning Liu
> -Original Message- > From: Richard Sandiford > Date: Fri, Sep 30, 2011 at 8:46 PM > Subject: Re: [PATCH] Fix stack red zone bug (PR38644) > To: Jiangning Liu > Cc: Jakub Jelinek , Richard Guenther > , Andrew Pinski , > gcc-patches@gcc.gnu.org > > > "Jiangning Liu" writes: > >> You

Fix for PR libobjc/49883 ("clang + gcc 4.6 runtime = broken") and a small related clang fix

2011-10-09 Thread Nicola Pero
This patch fixes PR libobjc/49883. To fix it, I installed clang and tried out what happens if you compile Objective-C code using clang and targetting the GCC runtime. Unfortunately, the report was correct in that clang is producing incorrect code and abusing the higher bits of the class->info

Re: [RFC] Slightly fix up vgather* patterns

2011-10-09 Thread Uros Bizjak
On Sat, Oct 8, 2011 at 5:43 PM, Jakub Jelinek wrote: > The AVX2 docs say that the insns will #UD if any of the mask, src and index > registers are the same, but e.g. on > #include > > __m256 m; > float f[1024]; > > __m256 > foo (void) > { >  __m256i mi = (__m256i) m; >  return _mm256_mask_i32gat

Re: [patch] C6X unwinding/exception handling

2011-10-09 Thread Matthias Klose
This did break libobjc and libjava on arm-linux-gnueabi. libobjc now has an undefined reference to _Unwind_decode_target2, which can be avoided with --- libobjc/exception.c.orig2011-07-21 15:33:57.0 + +++ libobjc/exception.c 2011-10-09 10:53:12.554940776 + @@ -182,7 +182,7 @@

[Patch, Fortran, committed] PR 50659: [4.4/4.5/4.6/4.7 Regression] ICE with PROCEDURE statement

2011-10-09 Thread Janus Weil
Hi all, I have just committed as obvious a patch for an ICE-on-valid problem with PROCEDURE statements: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=179723 The problem was the following: When setting up an external procedure or procedure pointer (declared via a PROCEDURE statement), we copy

[C++ Patch] PR 50660

2011-10-09 Thread Paolo Carlini
Hi, another duplicated diagnostic message. This one happens for snippets like the below due to the temporary for the const ref: int g(const int&); int m2() { return g(__null); } 50660.C:4:18: warning: passing NULL to non-pointer argument 1 of ‘int g(const int&)’ 50660.C:4:18: warning: passin

Re: Rename vshuffle/vec_shuffle to vec_perm

2011-10-09 Thread Joseph S. Myers
On Fri, 7 Oct 2011, Richard Henderson wrote: > I've added documentation for the (existing) variable permute > rtl named pattern (vec_perm). I've also added documentation for > the (intended) constant permute rtl named pattern (vec_perm_const). That looks like it broke "make pdf" (something did a

Re: [Patch, Fortran] Add c_float128{,_complex} as GNU extension to ISO_C_BINDING

2011-10-09 Thread Mikael Morin
On Wednesday 28 September 2011 16:28:24 Tobias Burnus wrote: > This patch makes the GCC extension __float128 (_Complex) available in > the C bindings via C_FLOAT128 and C_FLOAT128_COMPLEX. > > Additionally, I have improved the diagnostic for explicitly use > associating -std= versioned symbols. An

[CRIS] Hookize PREFERRED_RELOAD_CLASS

2011-10-09 Thread Anatoly Sokolov
Hello. This patch removes obsolete PREFERRED_RELOAD_CLASS macro from CRIS back end in the GCC and introduces equivalent TARGET_PREFERRED_RELOAD_CLASS target hook. Regression tested on cris-axis-elf. OK to install? * config/cris/cris.c (cris_preferred_reload_class): New function.

[C++ Patch] Trailing comma in enum

2011-10-09 Thread Magnus Fromreide
Hi. As I understand it C++11 allows trailing commas in enum definitions. Thus I think the following little patch should be included. On a side note I have to say that the effects of pedwarn_cxx98 are unexpected, especially in light of the comment above the function body. /MF 2011-10-09 Magnus Fr

[Patch] Don't ignore testsuite errors in Makefile

2011-10-09 Thread Mikael Morin
Hello, currently, the testsuite return value is ignored by make. It is a little annoying if one wants to check automatically for regressions as we have to parse the testsuite output. This patch reverts to the normal make behaviour, which is to not ignore commands' return values. Note: As a resu

[patch] Fix PR tree-optimization/50635

2011-10-09 Thread Ira Rosen
Hi, In vectorizer pattern recognition when a pattern def_stmt already exists, we need to mark it properly for the current pattern. Another problem is that we don't really have to check that TYPE_OUT is a vector type. It is set by the pattern detection procedures, and if the type is invalid we fail

[committed] small change (was: Re: [Patch, Fortran] PR 35831: [F95] Shape mismatch check missing for dummy procedure argument)

2011-10-09 Thread Mikael Morin
On Tuesday 04 October 2011 20:54:21 Janus Weil wrote: > >>> The patch was regtested on x86_64-unknown-linux-gnu. Ok for trunk? > >> > >> The patch is basically OK. > > > > Otherwise I'll just start by committing the > > patch as posted ... > > Just did so (r179520). > Hello, I've just commit

Re: [Patch, fortran] [00/14] PR fortran/50420 Support coarray subreferences

2011-10-09 Thread Tobias Burnus
On 07.10.2011 16:38, Mikael Morin wrote: The full patchset has passed the fortran testsuite successfully. OK for trunk? OK for the whole patch set. Thanks for finding and fixing the issue! Tobias Patches layout 01..04/14: Add support for non-full arrays in descriptor initialization code.

[committed] Fix bogus e-mail address in ChangeLogs

2011-10-09 Thread Mikael Morin
Hello, it seems that a bogus e-mail address (mistake of mine in the first place) has been promoted lately to being the main way to (miss-)communicate with me. Committed as revision 179727. Mikael Index: ChangeLog === --- ChangeLog

Re: [Patch, Fortran, committed] PR 50585: [4.6/4.7 Regression] ICE with assumed length character array argument

2011-10-09 Thread Tobias Burnus
On 08.10.2011 11:51, Janus Weil wrote: Thanks! What's about the .texi change for -fwhole-file? Will do. Should I include a note about deprecation? And if yes, do you have a suggestion for the wording? How about the following attachment? Tobias diff --git a/gcc/fortran/invoke.texi b/gcc/fortra

[committed] More e-mail address fixes in ChangeLogs: dead e-mail address

2011-10-09 Thread Mikael Morin
That address is long dead. Committed as revision 179728. Mikael Index: ChangeLog-2008 === --- ChangeLog-2008 (révision 179727) +++ ChangeLog-2008 (révision 179728) @@ -45,7 +45,7 @@ * trans-intrinsic.c (conv_same_strlen_check): New

[PATCH] RFC: Cache LTO streamer mappings

2011-10-09 Thread Andi Kleen
From: Andi Kleen Currently the LTO file mappings use a simple one-off cache. This doesn't match the access pattern very well. This patch adds a real LRU of LTO mappings with a total limit. Each file is completely mapped now instead of only specific sections. This addresses one of the FIXME comme

Re: [committed] More e-mail address fixes in ChangeLogs: dead e-mail address

2011-10-09 Thread Richard Guenther
On Sun, Oct 9, 2011 at 7:04 PM, Mikael Morin wrote: > That address is long dead. > Committed as revision 179728. We usually don't retroactively change ChangeLogs this way. Please refrain from making further changes like this. Thanks, Richard. > Mikael >

[Patch, Fortran] Fix PR 50564

2011-10-09 Thread Thomas Koenig
Hello world, the attached patch fixes the PR by removing common function elimination in FORALL statements. In the course of fixing this PR, I had originally fixed the ICE only to find that the transformation (where f is a function) forall (i=1:2) a(i) = f(i) + f(i) end forall to forall (i=1

Avoid double mangling at WHOPR

2011-10-09 Thread Jan Hubicka
Hi, whopr currently produce local_static.1234.43124 type symbols. This is because everything gets mangled at WPA time and then again at ltrans time. This simply avoids the second mangling. This save some space & makes WHOPR/non_WHOPR symbol tables comparable more directly. Bootstrapped/regtested

Re: [committed] More e-mail address fixes in ChangeLogs: dead e-mail address

2011-10-09 Thread Mikael Morin
On Sunday 09 October 2011 19:30:20 Richard Guenther wrote: > We usually don't retroactively change ChangeLogs this way. On the other hand, ChangeLogs usually don't need to be changed. > Please refrain from making further changes like this. OK, I will. Is there a reason for such a policy? Mikael

[patch bfd]: Some adjustments on coff-link.c

2011-10-09 Thread Kai Tietz
Hello, this patch improves COFF linker for undefined weak symbols and avoids writing symbols for discarded sections - if linker tells so -, and for IR generated sections. ChangeLog 2011-10-09 Kai Tietz * cofflink.c (coff_link_check_ar_symbols): Allow adding of archive-file if

Re: [Patch] Don't ignore testsuite errors in Makefile

2011-10-09 Thread Jakub Jelinek
On Sun, Oct 09, 2011 at 04:32:12PM +0200, Mikael Morin wrote: > currently, the testsuite return value is ignored by make. It is a little > annoying if one wants to check automatically for regressions as we have to > parse the testsuite output. > This patch reverts to the normal make behaviour, wh

RE: Intrinsics for N2965: Type traits and base classes

2011-10-09 Thread Michael Spertus
Here is a new diff that works for non-class types (fixing Benjamin's failing test), fixes some spacing and alphabetization, and doesn't inadvertently break the __underlying_type trait. Index: libstdc++-v3/include/tr2/type_traits ===

Re: Intrinsics for N2965: Type traits and base classes

2011-10-09 Thread Jason Merrill
On 10/09/2011 08:13 PM, Michael Spertus wrote: +dfs_calculate_bases_pre (tree binfo, void *data_) +{ + (void)data_; You can use ATTRIBUTE_UNUSED to mark an unused parameter. I'd still like to see some testcases for the intrinsic, independent of the library. Jason

Re: [Patch, Fortran] PR 50547 / cleanup in resolve_formal_arglist

2011-10-09 Thread Tobias Burnus
On 02.10.2011 01:43, Janus Weil wrote: Hi all, while working on PR50547, I noticed some strange things about resolve_formal_arglist, so I decided to clean it up a little. The attached patch does a couple of things: Regtested on x86_64-unknown-linux-gnu. Ok for trunk? OK. Thanks for the cleanu

[PATCH, testsuite]: Remove *.gdb files from testsuite dir

2011-10-09 Thread Uros Bizjak
Hello! Attached patch removes *.gdb temporary files from testsuite directory. 2011-10-09 Uros Bizjak * lib/gcc-gdb-test.exp (gdb-test): Delete $cmd_file before return. Tested on x86_64-pc-linux-gnu {,-m32}. OK for mainline and branches? Uros. Index: gcc-gdb-test.exp

Re: [PATCH, testsuite, i386] FMA3 testcases + typo fix in MD

2011-10-09 Thread Kirill Yukhin
Hi guys, This is a Ping. Could anyboady with appropriate rights commit that? Thanks, K On Thu, Oct 6, 2011 at 11:46 PM, Uros Bizjak wrote: > On Thu, Oct 6, 2011 at 3:48 PM, Kirill Yukhin wrote: >>> >>> BTW, don't you also need "-mfmpath=sse" in dg-options? >>> >> >> According to doc/invoke.texi

Improve ggc-page fragmentation

2011-10-09 Thread Andi Kleen
I ran into problems with virtual memory fragmentation ggc-page on large LTO builds. The memory was so fragmented that builds failed because the compiler would use more than the 64k mappings Linux allows each process by default. For more details see PR 50636 This patchkit includes various improv

[PATCH 3/5] On a Linux kernel ask explicitely for a huge page in ggc

2011-10-09 Thread Andi Kleen
From: Andi Kleen Benchmarks show slightly faster build times on a kernel build, near the measurement error unfortunately. This will only work with a recent glibc that defines MADV_HUGEPAGE. 2011-10-08 Andi Kleen * ggc-page.c (alloc_page): Add madvise for hugepage --- gcc/ggc-page.c

[PATCH 2/5] Increase the GGC quite size to 2MB

2011-10-09 Thread Andi Kleen
From: Andi Kleen Using 2MB allows modern kernels to use 2MB huge pages on x86. gcc/: 2011-10-08 Andi Kleen * ggc-page.c (GGC_QUIRE_SIZE): Increase to 512 --- gcc/ggc-page.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/gcc/ggc-page.c b/gcc/ggc-page.c ind

[PATCH 5/5] Add error checking to lto_section_read

2011-10-09 Thread Andi Kleen
From: Andi Kleen Various callers of lto_section_read segfault on a NULL return when the mmap fails. Add some internal_errors to give a better message to the user. gcc/lto/: 2011-10-09 Andi Kleen * lto.c (lto_section_read): Call internal_error on IO or mmap errors. --- gcc/lto/lto.c

[PATCH 4/5] Add a freeing threshold for the garbage collector.

2011-10-09 Thread Andi Kleen
From: Andi Kleen Add a threshold to avoid freeing pages back too early to the OS. This avoid virtual memory map fragmentation. Based on a idea from Honza ggc/doc/: 2011-10-08 Andi Kleen PR other/50636 * invoke.texi (ggc-free-threshold, ggc-free-min): Add. ggc/: 2011-10-08

[PATCH 1/5] Use MADV_DONTNEED for freeing in garbage collector

2011-10-09 Thread Andi Kleen
From: Andi Kleen Use the Linux MADV_DONTNEED call to unmap free pages in the garbage collector.Then keep the unmapped pages in the free list. This avoid excessive memory fragmentation on large LTO bulds, which can lead to gcc bumping into the Linux vm_max_map limit per process. Based on a idea f

Re: [Patch] Don't ignore testsuite errors in Makefile

2011-10-09 Thread Mikael Morin
On Sunday 09 October 2011 21:12:12 Jakub Jelinek wrote: > On Sun, Oct 09, 2011 at 04:32:12PM +0200, Mikael Morin wrote: > > currently, the testsuite return value is ignored by make. It is a little > > annoying if one wants to check automatically for regressions as we have > > to parse the testsuite

Re: [C++ Patch] PR 38980

2011-10-09 Thread Jason Merrill
OK. Jason

Re: [C++ Patch] PR 50660

2011-10-09 Thread Jason Merrill
Hmm, I guess it's unlikely that a conversion is going to hit both that warning and another one. OK. Jason

Re: [C++ Patch] PR 50660

2011-10-09 Thread Jason Merrill
On 10/09/2011 11:40 PM, Jason Merrill wrote: Hmm, I guess it's unlikely that a conversion is going to hit both that warning and another one. OK. Wait...how about changing conversion_null_warnings to stop looking through references? Does that break anything? Jason

Re: [C++ Patch] PR 50660

2011-10-09 Thread Paolo Carlini
On 10/10/2011 12:41 AM, Jason Merrill wrote: On 10/09/2011 11:40 PM, Jason Merrill wrote: Hmm, I guess it's unlikely that a conversion is going to hit both that warning and another one. OK. Wait...how about changing conversion_null_warnings to stop looking through references? Does that break a

Re: [wwwdocs] Re: [2/2] tree-ssa-strlen optimization pass

2011-10-09 Thread Gerald Pfeifer
Hi Jakub, this is a minor update on top of yours that I just applied. Thanks for taking the time to write this up. Gerald Index: changes.html === RCS file: /cvs/gcc/wwwdocs/htdocs/gcc-4.7/changes.html,v retrieving revision 1.46 dif

Re: [C++-11] User defined literals

2011-10-09 Thread Ed Smith-Rowland
On 10/08/2011 07:15 PM, Jason Merrill wrote: On 10/08/2011 07:25 PM, Ed Smith-Rowland wrote: Also, In spite of the documentation cp_parser_template_parameter_list returns a TREE_VEC not a TREE_LIST. This happens inside end_template_parm_list called inside the former. So parameter_list is a TREE_

Re: [4/4] Make SMS schedule register moves

2011-10-09 Thread Ayal Zaks
On Wed, Sep 28, 2011 at 4:49 PM, Richard Sandiford wrote: > Ayal Zaks writes: >>> >> +  /* The cyclic lifetime of move->new_reg starts and ends at move->def >>> >> +     (the instruction that defines move->old_reg). >>> > >>> > So instruction I_REG_MOVE (new_reg=reg) must be scheduled before the

Re: [C++ Patch] PR 50660

2011-10-09 Thread Paolo Carlini
On 10/10/2011 12:41 AM, Jason Merrill wrote: On 10/09/2011 11:40 PM, Jason Merrill wrote: Hmm, I guess it's unlikely that a conversion is going to hit both that warning and another one. OK. Wait...how about changing conversion_null_warnings to stop looking through references? Does that break

Re: [wwwdocs] add libstdc++/1773 change to gcc-4.7/changes.html

2011-10-09 Thread Gerald Pfeifer
On Tue, 4 Oct 2011, Jonathan Wakely wrote: > I've committed this, which documents the fix for > http://gcc.gnu.org/PR1773 in gcc-4.7/changes.html, and also replaces > some > characters with the > entity. Interesting that the latter was not caught by the validator? Thanks for addressing it, Jonath

Re: [google] record compiler options to .note sections

2011-10-09 Thread Dehao Chen
On Sun, Oct 9, 2011 at 5:28 PM, Jakub Jelinek wrote: > On Sun, Oct 09, 2011 at 09:18:25AM +0800, Dehao Chen wrote: >> Unfortunately -frecord-gcc-switches cannot serve our purpose because >> the recorded switches are mergable, i.e. the linker will merge all >> options to a set of strings. However,

Re: [CRIS] Hookize PREFERRED_RELOAD_CLASS

2011-10-09 Thread Hans-Peter Nilsson
> Date: Sun, 9 Oct 2011 17:47:22 +0400 > From: Anatoly Sokolov > OK to install? > > * config/cris/cris.c (cris_preferred_reload_class): New function. > (TARGET_PREFERRED_RELOAD_CLASS): Define. > * config/cris/cris.h (OUTPUT_ADDR_CONST_EXTRA): Remove.