Hi, Jason
> On 9/9/20 6:25 AM, Hu Jiangping wrote:
> > This patch check the command 'make check-g++' to 'make check-c++' in
> > install.texi since there is no 'make check-g++' target in the object
> > directory.
>
> make check-g++ work
This patch check the command 'make check-g++' to 'make check-c++' in
install.texi since there is no 'make check-g++' target in the object
directory. It also adds some description in the above text, to clarity
and emphasis the difference of the 'make check-' targets in
between object directory and t
Hi, Richard
> On Tue, Sep 8, 2020 at 11:35 AM Hu Jiangping
> wrote:
> >
> > This patch add a new check-g++ target to the Makefile under toplevel,
> > as synonym of the check-c++ target.
> >
> > It is to be consistent with the check-g++ target under the gcc
Hi, H-P
> > > On Sat, 29 Aug 2020, Hu Jiangping wrote:
> > >
> > > > This patch add 'cd' command before 'make check-gcc' command
> > > > when run the testsuite on selected tests.
> > >
> > > No, don't do that; th
under toplevel,
but now it gives 'No rule to make target.' error.
ChangeLog:
2020-09-08 Hu Jiangping
Makefile.tpl (check-g++): New target. As synonym of check-c++.
Makefile.in: Regenerated.
Bootstraped on aarch64. Ok for master?
Regards!
Hujp
---
Makefi
Hi, H-P
Thanks for comment.
> On Sat, 29 Aug 2020, Hu Jiangping wrote:
>
> > This patch add 'cd' command before 'make check-gcc' command
> > when run the testsuite on selected tests.
>
> No, don't do that; those targets work fine from the toplev
> I think the pages under gcc.gnu.org/projects/ are all hopelessly
> out-of-date and more recent (but still usually out-of-date) info
> is found on the wiki.
>
> So I'm not sure these kind of changes make sense.
>
> Eventually we should remove those pages? Or do we want
> to keep them for histor
Although vectorization.html is not up-to-date, it is still
easy to be searched, and the deprecated flag in it may
confuse users. This patch simply adds a note to the head
of the page, hoping to help users who read it.
OK for master?
Regards!
Hujp
---
htdocs/projects/tree-ssa/vectorization.html
Hi, Jakub
Thank you for your detailed explanation.
I will try to compare the results of rtl expand as Richard have
suggested, to see if I can find anything. May be I can make
another patch.
Thanks again.
Regards!
Hujp
> On Thu, Aug 27, 2020 at 11:13:50AM +0000, Hu, Jiangping wrote:
>
This patch add 'cd' command before 'make check-gcc' command
when run the testsuite on selected tests.
Richard and I agree it would be good for clarity and
emphasis to have the cd in the example as well, although
the text above the example was trying to restrict that to
objdir/gcc.
Tested on x86_6
Hi, Richard, Jakub
Thanks for reply.
I'm not sure about if the case should fail.
So, I add Jakub who committed this testcase.
I thought the case should success, but for changes of gcc of
years, now it failed. So I think that may be some optimization
are unnecessary for this testcase, and I foun
Hi,
This patch add 'cd' command before 'make check-gcc' command
when run the testsuite on selected tests.
I think the implicit meaning of the original text is to
execute the cd command to move to the gcc subdirectory of
the object directory before executing the make command.
However, due to the f
This patch add -fno-tree-fre to dg-options in gcc.dg/guality/sra-1.c,
to make the following testcases passed.
FAIL: gcc.dg/guality/sra-1.c -Og -DPREVENT_OPTIMIZATION line 43 a.i == 4
FAIL: gcc.dg/guality/sra-1.c -Og -DPREVENT_OPTIMIZATION line 43 a.j == 14
FAIL: gcc.dg/guality/s
This patch add the return type for some functions in gimple.texi,
to make the context unified. OK for trunk?
Tested on x86_64.
Regards!
Hujp
---
gcc/doc/gimple.texi | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/gcc/doc/gimple.texi b/gcc/doc/gimple.texi
index 5e0fc2e0
Hi,
This patch deletes 2 unnecessary codes in function
aarch64_if_then_else_costs, which were duplicated
where the function starts.
Tested on aarch64. OK for trunk?
Regards!
Hujp
---
gcc/config/aarch64/aarch64.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/gcc/config/aarch64/aarch64.c
Hi!
This patch makes the -falign-foo=0 work as described in the
documentation. Thanks for all the suggestions.
v4: do changes for coding conventions
v3: make change more readable and self-consistent
Changelog:
2020-07-27 Hu Jiangping
PR driver/96247
* opts.c
> > This patch makes the -falign-foo=0 work as described in the
> > documentation. Thanks for all the suggestions, Richard and Segher!
>
> Hello.
>
> I'm the author of the original code.
>
> >
> > v3: make change more readable and self-consistent
> > v2: at a high level handles -falign-foo=0 lik
Tested on x86_64.
> -Original Message-
> From: Gcc-patches On Behalf Of Hu
> Jiangping
> Sent: Monday, July 27, 2020 3:46 PM
> To: gcc-patches@gcc.gnu.org; richard.sandif...@arm.com;
> seg...@kernel.crashing.org
> Subject: [PATCH v3] driver: fix a problem with impl
Hi!
This patch makes the -falign-foo=0 work as described in the
documentation. Thanks for all the suggestions, Richard and Segher!
v3: make change more readable and self-consistent
v2: at a high level handles -falign-foo=0 like -falign-foo
Regards!
Hujp
---
gcc/opts.c | 24 +++-
> In addition to Segher's comments, I wonder if it would be better
> to pass &opts->x_flag_align_foo and &opts->x_str_align_jumps to
> check_alignment_argument and do the check there instead.
> The condition for whether to do this would then be:
>
> align_result.length () == 1 && align_result[0]
Add CC to Richard.
> Thanks, Richard!
>
> I think your suggestion is very good, so I made a new patch.
>
> v2: at a high level handles -falign-foo=0 like -falign-foo
> v1: at the target level overides the -falign-foo=0 option values
>
> Obviously, v2 is better than v1. In addition, anthor optio
Thanks, Richard!
I think your suggestion is very good, so I made a new patch.
v2: at a high level handles -falign-foo=0 like -falign-foo
v1: at the target level overides the -falign-foo=0 option values
Obviously, v2 is better than v1. In addition, anthor option
to reject 0 that discussed in the
> Sorry for the slow response on this. Like you say, it seems to be a pretty
> pervasive problem. In fact I couldn't see anywhere that actually treated -
> falign-foo=0 as anything other than -falign-foo=1.
>
> Technically using an alignment of one for zero is within what the
> documentation all
PING.
> -Original Message-
> From: Gcc-patches On Behalf Of Hu
> Jiangping
> Sent: Tuesday, July 14, 2020 3:55 PM
> To: gcc-patches@gcc.gnu.org
> Subject: [PATCH] target: fix default value checking of x_str_align_functions
> in
> aarch64.c
>
> Hi,
>
&
Hi,
Different from Patch v1 which removed the page, I add a big banner to
say that the page is no longer up-to-date, just as Richard and Gerald
recommended. OK for push?
Regards!
Hujp
---
htdocs/projects/tree-ssa/tree-browser.html | 5 +
1 file changed, 5 insertions(+)
diff --git a/htdocs/
Hi,
This patch deal with the -falign-X=0 options. According to man pages,
if zero is specified, a machine-dependent default value should be used.
But in fact, zero was used in internal process, it is inconsistent.
Tested on aarch64-linux cross compiler, Is that OK?
BTW, the similar problems exis
> On Thu, 9 Jul 2020, Richard Sandiford wrote:
> >> I'm trying Tree Browser during debugging, but failed.
> >> I found that tree-browser.c and tree-browser.def have been removed at
> >> 2015-07-25. So, to avoid misunderstanding, can we remove this
> >> tree-browser page too?
> > Thanks for the patc
Hi,
I'm trying Tree Browser during debugging, but failed.
I found that tree-browser.c and tree-browser.def have been
removed at 2015-07-25. So, to avoid misunderstanding,
can we remove this tree-browser page too?
Regards.
hujp
---
htdocs/projects/tree-ssa/index.html| 6 -
htdocs/proje
Hi,
this patch fix a typo in contribute.html.
Best Regards.
Hujp
---
htdocs/contribute.html | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/htdocs/contribute.html b/htdocs/contribute.html
index 80a4470e..a913565b 100644
--- a/htdocs/contribute.html
+++ b/htdocs/contribute.ht
29 matches
Mail list logo