On Mon, Apr 14, 2025 at 7:36 AM H.J. Lu wrote:
>
> Don't use red-zone when there are no caller-saved registers and APX is
> enabled since 128-byte red-zone is too small for 31 GPRs.
>
> gcc/
>
> PR target/119784
> * config/i386/i386.cc (ix86_using_red_zone): Don't use red-zone
>
This changes the `dg-options` line so UTF-32 with byte order native to the
machine is used as wide encoding, avoiding.
We still do not handle mismatch in the byte order of the Unicode encodings
(UTF32-BE on little-endian machines). This would require larger changes,
as for example `unicode-data.h`
Hi Jerry,
thank you very much for the review.
I would love to fix the nits you found, but I don't see, what you see. Can you
elaborate? May be some mail client has removed something, or I am missing
something. Are you commenting on
> gfc_error (
> "%s argument at %L must be a scalar %s vari
On Sun, Apr 13, 2025 at 12:13 PM François Dumont
wrote:
>
> On 11/04/2025 08:36, Tomasz Kaminski wrote:
>
>
>
> On Thu, Apr 10, 2025 at 10:47 PM Jonathan Wakely
> wrote:
>
>> On 10/04/25 22:36 +0200, François Dumont wrote:
>> >After running the test with -fno-exceptions option we rather need thi
On Sat, Apr 12, 2025 at 4:01 PM Jonathan Wakely wrote:
> My recent r15-9381-g648d5c26e25497 change assumes that a contiguous
> iterator with the correct value_type can be converted to a const charT*
> but that's not true for volatile charT*. The optimization should only be
> done if it can be con
On Apr 12, 2025, Jeff Law wrote:
>> for gcc/ChangeLog
>> PR target/118182
>> * config/riscv/vector.md (@pred_broadcast): Expand to
>> _zero and _imm variants without vec_duplicate.
> I'd said this should tend to wait for gcc-16 since it doesn't fix a
> regression.
That works for me.
Technicall
The only pattern for which the len may be zero is cmpstrsni. The other
pattern using rx_cmpstrn is cmpstrsi for which len is a constant -1,
so we'll be moving the setpsw instructions from rx_cmpstrn to
cmpstrnsi as follows:
1. Adjust the predicate on the length operand from "register_operand"
> Were you able to actually trigger cases where operands[3] is a
> CONST_INT? Again, it's not entirely clear if that can actually happen
> given the operand predicates on the cmpstrnsi expander.
(sorry for the long delay; I'm just getting back to reviewing my pending
GCC patches)
Good call. N
Look like those operand modifiers are only for internal usage
in .md files, so for simplicity, I'll just remove them from extend.texi.
Ready push to trunk.
gcc/ChangeLog:
PR documentation/108134
* doc/extend.texi: Remove documents from r11-344-g0fec3f62b9bfc0.
---
gcc/doc/extend
> +@opindex fipa-reorder-for-locality
> +@item -fipa-reorder-for-locality
> +Group call chains close together in the binary layout to improve code code
> +locality. This option is incompatible with an explicit
> +@option{-flto-partition=} option since it enforces a custom partitioning
> +scheme.
On 4/10/25 5:59 AM, Andre Vehreschild wrote:
Hi all,
I again have a series of patches. This time to improve the teams support in
gfortran.
1/5: Improves/Unifies handling of STAT= and ERRMSG= handling, which is part of
all TEAM statements. I wanted to prevent repeating myself over and over so I
Don't use red-zone when there are no caller-saved registers and APX is
enabled since 128-byte red-zone is too small for 31 GPRs.
gcc/
PR target/119784
* config/i386/i386.cc (ix86_using_red_zone): Don't use red-zone
with APX and no caller-saved registers.
gcc/testsuite/
Hi Jakub,
> On Fri, Apr 11, 2025 at 10:50:25AM +0200, Rainer Orth wrote:
>> 2025-04-08 Rainer Orth
>>
>> gcc/cobol:
>> PR cobol/119217
>> * dts.h (csub_match): Initialize rm_so, rm_eo fields explicitly.
>>
>
>> # HG changeset patch
>> # Parent 6f227ddea0046a0164509bdb8069e9618
Hi Simon,
>
>> Shouldn't that be
>>
>> --- a/gcc/cobol/parse.y
>> +++ b/gcc/cobol/parse.y
>> @@ -337,7 +337,7 @@
>> %token INVALID
>> %token NUMBER NEGATIVE
>> %token NUMSTR"numeric literal"
>> -%token OVERFLOW
>> +%token OVERFLOW_kw "OVERFLOW"
>>
This test was failing because it was checking that eax was being cleared. For
sysv abi, eax contains the number of XMM registers used in the call, but msabi
just passes the float arguments twice, both in xmm and general purpose
registers.
This patch adds tests for both sysv and msabi functions be
Hello.
Please skip v14 and review v15. A diff with v13 is attached.
The full v15 is at
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=114065, but my SMTP
server refused them as attachments.
Patch 1 implements the new
Ada.Calendar_Conversions.To_{Duration,Struct_Timespec}64 with
System.C_Time, as alr
Alternatively, rather than passing the most general template + args to
push_tinst_level, we can pass the partially instantiated template +
innermost args via just:
gcc/cp/ChangeLog:
* constraint.cc (satisfy_declaration_constraints): Pass the
original T and ARGS to push_tinst_level
Apple Rosetta 2 x86-64 emulator is known to not support SAHF
instruction, which otherwise might be generated when targetting
-march=x86-64-v2.
PR target/119781
gcc/ChangeLog:
* doc/invoke.texi: Document lack of SAHF on Apple Rosetta 2.
Signed-off-by: Dimitri John Ledkov
---
gc
On Sun, Apr 13, 2025 at 9:30 AM Dimitri John Ledkov
wrote:
>
> Apple Rosetta 2 x86-64 emulator is known to not support SAHF
> instruction, which otherwise might be generated when targetting
> -march=x86-64-v2.
This seems out of place. Since we don't document all of the CPUs that
implement v2/v3 h
Hi!
On 2025-03-18T14:54:23+0100, Jakub Jelinek wrote:
> The following patch offers [...] dg-output-file
> directive where one can supply a text file with expected output
> --- gcc/doc/sourcebuild.texi.jj 2025-03-11 09:18:21.750133577 +0100
> +++ gcc/doc/sourcebuild.texi 2025-03-18 14:41:5
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the Swedish team of translators. The file is available at:
https://translationproject.org/latest/gcc/sv.po
(This file, 'gcc-15.1-b20250406.sv.po'
Bootstrapped and regtested on x86_64-pc-linux-gnu, OK for trunk?
-- >8 --
Currently, pruned lambda captures are still leftover in the function's
BLOCK and topmost BIND_EXPR; this doesn't cause any issues for normal
compilation, but does break modules streaming as we try to reconstruct a
FIELD_DEC
On 11/04/2025 08:36, Tomasz Kaminski wrote:
On Thu, Apr 10, 2025 at 10:47 PM Jonathan Wakely
wrote:
On 10/04/25 22:36 +0200, François Dumont wrote:
>After running the test with -fno-exceptions option we rather need
this
>patch.
>
>Ok to commit ?
>
>François
gcc/ChangeLog:
* config/s390/s390.cc: Add z17 scheduler description.
* config/s390/s390.h: Ditto.
* config/s390/s390.md: Ditto.
* config/s390/9175.md: New file.
---
gcc/config/s390/9175.md | 316
gcc/config/s390/s390.cc | 3
The recently announced IBM z17 processor implements the architecture
already supported as arch15. This patch adds support for z17 as an
alternative architecture name for arch15.
gcc/ChangeLog:
* common/config/s390/s390-common.cc: Rename arch15 to z17.
* config.gcc: Add z17.
Am 11.04.25 um 19:15 schrieb Harald Anlauf:
There is a duplicate "and and" here:
+ gfc_error ("Mismatch between subroutine and and "
+ "function at %L", &actual->where);
OK with this fixed.
Ah, yes :-)
Thanks for the patch!
Commit
26 matches
Mail list logo