On Sun, Oct 16, 2011 at 8:33 PM, Andi Kleen wrote:
> On Sun, Oct 16, 2011 at 12:38:16PM +0200, Richard Guenther wrote:
>> On Sun, Oct 16, 2011 at 7:30 AM, Andi Kleen wrote:
>> > Andi Kleen writes:
>> >
>> >> From: Andi Kleen
>> >>
>> >> Use the Linux MADV_DONTNEED call to unmap free pages in th
On Sun, Oct 16, 2011 at 5:47 PM, Jakub Jelinek wrote:
> Hi!
>
> gimplify_parameters uses create_tmp_reg, but sometimes it decides to make
> it addressable (if the PARM_DECL is addressable). If so, it must not be
> DECL_GIMPLE_REG_P.
>
> Alternatively we could call create_tmp_reg only if !TREE_ADD
On Sun, Oct 16, 2011 at 1:03 PM, Gabriel Dos Reis
wrote:
> On Sun, Oct 16, 2011 at 5:42 AM, Richard Guenther
> wrote:
>> On Sun, Oct 16, 2011 at 12:31 PM, Paolo Carlini
>> wrote:
>>> On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote:
On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini
wr
This patch fixes the failures described in
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49960
It also fixes bzips when run with autopar enabled.
In both cases the self dependences are not handled correctly.
In the first case, a non affine access is analyzed:
in the second, the distance vector is n
Add function merging. First, let function mangled names match.
Second, overwrite existing struct functions for merged functions.
Third, add filtering for already emitted functions.
The result is ICEs in the call graph code.
Add tests for overload sets with more than one member.
Bootstrapped on
Dear Janus,
Of course you can commit to 4.6. Be quick, though; 4.6.2 was due for
release now-ish -
"GCC 4.6 branch remains open under normal release branch rules,
accepting regression and documentation fixes. GCC 4.6.2 is
tentatively planned for late September or early October."
Thanks
Paul
O
OK.
Jason
Factor the vector and chain output routines to remove boolean control
parameters. The functions pph_out_tree_vec_1 and pph_out_chain_1 split
their conditional parts of their implementation into their use cases,
calling each other as needed.
pph_out_tree_vec - nothing special
pph_out_tree_vec_uncha
On Oct 16, 2011, at 4:28 AM, Mikael Pettersson wrote:
> This fixes a bootstrap failure on trunk with objc enabled
> Ok for trunk?
Ok.
Steven Bosscher wote:
This patch corrects these things. Regression-tested.
OK for trunk? (I will not be able to commit for a few
days due to business travel, unless somebody is _really_
fast :-)
Looks OK to me. Fast enough for you?
Yes indeed. Committed as rev. 180063.
Thanks a lot!
On 10/16/2011 09:12 PM, Paolo Carlini wrote:
48489.C:11:11: error: ‘struct Derived’ has no member named ‘setValue’
of course there is a typo here, should read
48489.C:11:11: error: ‘struct Concrete’ has no member named ‘setValue’
Paolo.
[...]
> Does the attached testcase checked what you mention ?
... with the testcase attached.
--
Fabien
// { dg-do run }
template
struct A
{
int f() { return 1; }
};
template
struct B : A
{
int f() { return 2; }
using A::f;
void g()
{
if (A::f() != 1 )
__builtin_a
2011/10/12 Jason Merrill :
>>> Copying the decl is unlikely to do what we want, I think. Does putting
>>> the
>>> target decl directly into the method vec work?
>>
>> Unfortunately not, it ends up with the same error: undefined
>> reference.
>
> Hunh, that's surprising.
I have found it quite surp
On Sun, Oct 16, 2011 at 8:35 PM, Uros Bizjak wrote:
>> As explained in length in the PR [1], we fail to mark signal frames
>> correctly, leading to the abort in EH support library.
>>
>> As suggested by Eric, attached patch marks fs->signal_frame in the
>> same way as other dwarf2 targets.
>>
>>
> This patch corrects these things. Regression-tested.
> OK for trunk? (I will not be able to commit for a few
> days due to business travel, unless somebody is _really_
> fast :-)
Looks OK to me. Fast enough for you?
Ciao!
Steven
Hello world,
working on PR 50690, I noticed a few things which are
not quite right in front-end optimization statement
walking:
- BLOCKs were walked via their namespaces, not directly.
This caused out-of-order walking, which was confusing.
- current_ns was not marked static.
- ASSOCIATE lists
Hi Paul,
> This is OK for trunk. Thanks fo rthe patch.
Thanks. Committed to trunk as r180062. What about 4.6?
Cheers,
Janus
> On Sun, Oct 16, 2011 at 2:58 PM, Janus Weil wrote:
>> Hi all,
>>
>> here is a patch which fixes the regression in comment #2 of the PR in
>> the subject line. What i
The attach patch fixes the construction of a format string
from a user-defined operator or from a string with a kind
type prefix. In short, the patch allows
print 2.ip.8 ! .ip. is a user-defined operator
print 1_'(A)' ! 1_ designates a default character type
Prior to this patch gfortran would t
>> while working on PR50547, I noticed some strange things about
>> resolve_formal_arglist, so I decided to clean it up a little. The
>> attached patch does a couple of things:
>>
>> Regtested on x86_64-unknown-linux-gnu. Ok for trunk?
>
> OK. Thanks for the cleanup.
Thanks. Committed as r180061.
Hi,
in this diagnostic PR the issue it that for:
struct Base{ };
struct Concrete : Base
{
void setValue();
};
int main()
{
Concrete d;
d.Base::setValue();
}
the error message is:
48489.C:11:11: error: ‘struct Derived’ has no member named ‘setValue’
instead of:
48489.C:11:11: error: ‘struct
On Wed, Sep 28, 2011 at 11:47 AM, Alan Modra wrote:
> * config/rs6000/rs6000.c (rs6000_make_savres_rtx): Delete unneeded
> declaration.
> (rs6000_emit_stack_reset): Only return insn emitted when it adjusts sp.
> (rs6000_make_savres_rtx): Rename to rs6000_emit_savres_rt
On Sun, Oct 16, 2011 at 8:09 AM, Uros Bizjak wrote:
> As explained in length in the PR [1], we fail to mark signal frames
> correctly, leading to the abort in EH support library.
>
> As suggested by Eric, attached patch marks fs->signal_frame in the
> same way as other dwarf2 targets.
>
> 2011-10
On Sun, Oct 16, 2011 at 12:38:16PM +0200, Richard Guenther wrote:
> On Sun, Oct 16, 2011 at 7:30 AM, Andi Kleen wrote:
> > Andi Kleen writes:
> >
> >> From: Andi Kleen
> >>
> >> Use the Linux MADV_DONTNEED call to unmap free pages in the garbage
> >> collector.Then keep the unmapped pages in the
Dear Janus,
This is OK for trunk. Thanks fo rthe patch.
Cheers
Paul
On Sun, Oct 16, 2011 at 2:58 PM, Janus Weil wrote:
> Hi all,
>
> here is a patch which fixes the regression in comment #2 of the PR in
> the subject line. What it does is setting the 'ts.is_c_interop' flag
> correctly for con
Looking at the new gcc-4.6/porting_to.html last week, I noticed that
in the original version there as well as the older instance for GCC 4.4
we would skip headers and directly move from to .
I addressed this when committing the GCC 4.6 flavor, and the patch
below which I committed does the same
On Sat, 15 Oct 2011, Walter Lee wrote:
> Here are the wwwdocs changes, with the news date TBD.
This is approved (once the actual code has gone in).
Thanks,
GeraldIndex: backends.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/backends.htm
Hi!
gimplify_parameters uses create_tmp_reg, but sometimes it decides to make
it addressable (if the PARM_DECL is addressable). If so, it must not be
DECL_GIMPLE_REG_P.
Alternatively we could call create_tmp_reg only if !TREE_ADDRESSABLE and
call create_tmp_var instead for TREE_ADDRESSABLE (+ se
> Tested on x86_64-linux, --with-cpu=corei7 and ppc64-linux, --with-cpu=G5.
>
> Committed.
This may have caused http://gcc.gnu.org/ml/gcc-bugs/2011-10/msg01534.html
Dominique
Hi,
This patch fixes another occurrence of the same bug as in PR 50635.
Bootstrapped and tested on powerpc64-suse-linux.
Committed.
Ira
ChangeLog:
PR tree-optimization/50727
* tree-vect-patterns.c (vect_operation_fits_smaller_type): Add
DEF_STMT to the list of statement
Paolo Bonzini schrieb:
-moptimize-noreturn-calls
Optimize noreturn calls. This might make debugging harder but
will save storing the return address when calling roreturn
functions.
Enabled at levels -O2, -O3, -Os.
But the "makes debugging harder" clause is true for almo
> -moptimize-noreturn-calls
> Optimize noreturn calls. This might make debugging harder but
> will save storing the return address when calling roreturn
> functions.
>
> Enabled at levels -O2, -O3, -Os.
>
> But the "makes debugging harder" clause is true for almost any
This is the failure of the new assertion added in the REG_ARGS_SIZE case of
distribute_notes in the combiner on a degenerated case (complete folding of a
dynamic stack allocation). Fixed by dropping the note if the resulting insn
is a no-op move.
Tested on i586-suse-linux, applied on the mainl
Hi Tobias,
> I think that's the wrong solution to the problem: I think it makes more
> sense to fix the handling for OMP workshare to handle BLOCK correctly
> rather than to move the variable to the function scope and then to
> fiddle with the private attribute.
What is the reason for that?
I d
On Sun, Oct 16, 2011 at 09:56:57AM +0200, Ira Rosen wrote:
> by moving?
Yeah.
> Could you please add some more explanations here? I found it very
> difficult to follow. It would be nice to have an example here (similar
> to vect_recog_bool_pattern) to illustrate what these statements and
> operan
Hi all,
here is a patch which fixes the regression in comment #2 of the PR in
the subject line. What it does is setting the 'ts.is_c_interop' flag
correctly for constants with kind-parameter specification (such as
'0.0_c_double'), as is already being done for variables.
Regtested on x86_64-unknow
The declaration of the Implementation_Defined pragma was moved from the outer
scope to the scope of the nested package Implementation.
Tested on x86_64-pc-linux-gnu, committed on trunk
2011-10-16 Matthew Heaney
* a-cusyqu.ads, a-cbsyqu.ads, a-cuprqu.ads, a-cbprqu.ads (package
Reorder chunks in link.c so that the correct configuration is selected when
compiling with --with-gnu-ld on AIX.
No change in behaviour.
Note that in particular it's important that we use native AIX switches even
when using GNU ld. This is important with response files as they must be
interpreted
This fixes a bootstrap failure on trunk with objc enabled, caused by a
recent change which introduced for-loops that compare a size_t index
variable with a TREE_VEC_LENGTH limit. TREE_VEC_LENGTH returns a signed
integer, resulting in a signed/unsigned comparison. The C++ front-end
fails to catch
> On Sun, Oct 16, 2011 at 1:12 AM, Andi Kleen wrote:
> > From: Andi Kleen
> >
> > Some external tools special case __gnu_lto* symbols, and the new
> > __gnu_slim_lto
> > was the only LTO symbol not matching this pattern. Since I don't think
> > there are any users rename it to __gnu_lto_slim
> >
On Sun, Oct 16, 2011 at 5:42 AM, Richard Guenther
wrote:
> On Sun, Oct 16, 2011 at 12:31 PM, Paolo Carlini
> wrote:
>> On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote:
>>>
>>> On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini
>>> wrote:
Hi,
in this simple documentation PR, Tom no
Hi,
This patch allows to vectorize a subchain of interleaved loads in
basic block SLP (in loop vectorization this would be more complicated
because of loop peeling). This patch also swaps operands if necessary
(and possible) to make operations isomorphic.
Bootstrapped and tested on powerpc64-suse
On Sun, Oct 16, 2011 at 12:31 PM, Paolo Carlini
wrote:
> On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote:
>>
>> On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini
>> wrote:
>>>
>>> Hi,
>>>
>>> in this simple documentation PR, Tom noticed that we have a (very long
>>> standing) inconsistency between th
On Sun, Oct 16, 2011 at 7:30 AM, Andi Kleen wrote:
> Andi Kleen writes:
>
>> From: Andi Kleen
>>
>> Use the Linux MADV_DONTNEED call to unmap free pages in the garbage
>> collector.Then keep the unmapped pages in the free list. This avoid
>> excessive memory fragmentation on large LTO bulds, whi
On 10/16/2011 12:28 PM, Gabriel Dos Reis wrote:
On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini wrote:
Hi,
in this simple documentation PR, Tom noticed that we have a (very long
standing) inconsistency between the default value of -fmessage-length for
C++ as documented and as implemented: in fa
On Sun, Oct 16, 2011 at 1:12 AM, Andi Kleen wrote:
> From: Andi Kleen
>
> Some external tools special case __gnu_lto* symbols, and the new
> __gnu_slim_lto
> was the only LTO symbol not matching this pattern. Since I don't think
> there are any users rename it to __gnu_lto_slim
>
> Passes bootst
On Sun, Oct 16, 2011 at 5:03 AM, Paolo Carlini wrote:
> Hi,
>
> in this simple documentation PR, Tom noticed that we have a (very long
> standing) inconsistency between the default value of -fmessage-length for
> C++ as documented and as implemented: in fact it's 0 in cxx-pretty-print.c,
> like al
Hi,
in this simple documentation PR, Tom noticed that we have a (very long
standing) inconsistency between the default value of -fmessage-length
for C++ as documented and as implemented: in fact it's 0 in
cxx-pretty-print.c, like all the other front-ends. At the time of the PR
people briefly
On 10/14/2011 12:00 PM, Richard Guenther wrote:
> On Fri, Oct 14, 2011 at 1:12 AM, Tom de Vries wrote:
>> On 10/12/2011 02:19 PM, Richard Guenther wrote:
>>> On Wed, Oct 12, 2011 at 8:35 AM, Tom de Vries
>>> wrote:
Richard,
I have a patch for PR50672.
When compiling the
Hi,
this patch makes cgrpahunit to output all thunks and aliases after the function,
not before. Outputting before leads to better code layout and we might omit
tailjump when thunk is just one, but it breaks one pass assembler and comdat
group symbols.
This is the easiest fix and I will play with
Hi Steve,
> resolve_ref() calls resolve_substring() but failed to check
> its return value. This patch does the check.
Looks pretty obvious. Please commit.
Thanks for the patch,
Janus
> 2011-10-15 Steven G. Kargl
>
> * resolve.c (resolve_ref): Check return value of resolve_substrin
Hello!
As explained in length in the PR [1], we fail to mark signal frames
correctly, leading to the abort in EH support library.
As suggested by Eric, attached patch marks fs->signal_frame in the
same way as other dwarf2 targets.
2011-10-16 Uros Bizjak
Eric Botcazou
*
gcc-patches-ow...@gcc.gnu.org wrote on 14/10/2011 04:43:48 PM:
> All,
>
> The attached patch corrects the expected output of the
> gcc.dg/vect/pr30858.c testcase.
>
> Historically it has expected the output "Unknown def-use cycle pattern."
> just once.
>
> However, recent changes to GCC for ARM
On 12 October 2011 17:54, Jakub Jelinek wrote:
> Hi!
Hi,
>
> This patch allows vectorization of some loops that use
> bool (which is especially important now that we use bool more often
> even for stmts that weren't originally using bool in the sources),
> in particular (when bool is cast to an
Andi Kleen writes:
> From: Andi Kleen
>
> Use the Linux MADV_DONTNEED call to unmap free pages in the garbage
> collector.Then keep the unmapped pages in the free list. This avoid
> excessive memory fragmentation on large LTO bulds, which can lead
> to gcc bumping into the Linux vm_max_map limit
54 matches
Mail list logo