From: Niklas Haas
This is a purely cosmetic commit aimed at replacing accesses to
SwsInternal.opts by direct access to SwsContext wherever convenient.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/options.c | 2 +-
libswscale/swscale.c
From: Niklas Haas
Used by the graph API swscale wrapper, for now.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/swscale_internal.h | 3 +++
libswscale/utils.c| 8
2 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/libswscale/swscal
From: Niklas Haas
Group them into an enum rather than random #defines, and document their
behavior a bit more obviously.
Of particular note, I discovered that SWS_DIRECT_BGR is not referenced
anywhere else in the code base. As such, I have moved it to the deprecated
section, alongside SWS_ERROR_
From: Niklas Haas
As part of a larger, ongoing effort to modernize and partially rewrite
libswscale, it was decided and generally agreed upon to introduce a new
public API for libswscale. This API is designed to be less stateful, more
explicitly defined, and considerably easier to use than the ex
From: Niklas Haas
With the ability to set the thread count as well. This benchmark includes
the constant overhead of context initialization.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/tests/swscale.c | 93 --
1 file changed,
From: Niklas Haas
This interface has been designed from the ground up to serve as a new
framework for dispatching various scaling operations at a high level. This
will eventually replace the old ad-hoc system of using cascaded contexts,
as well as allowing us to plug in more dynamic scaling passe
From: Niklas Haas
This rewrite cleans up the code to use AVFrames and the new swscale API. The
log format has also been simplified and expanded to account for the new
options. (Not yet implemented)
The self testing code path has also been expanded to test the new swscale
implementation against t
On Thu, 21 Nov 2024 14:19:22 +0100 Niklas Haas wrote:
> Changes since v7:
> - renamed sws_init_single_context() to ff_sws_init_single_context()
> - simplified vshift()
> - renamed legacy wrapper functions inside graph.c for clarity
> - moved the legacy SwsContext inside the legacy wrappers
> - sli
From: Niklas Haas
---
libswscale/graph.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libswscale/graph.c b/libswscale/graph.c
index cadb5954af..ee9d9847a9 100644
--- a/libswscale/graph.c
+++ b/libswscale/graph.c
@@ -470,7 +470,7 @@ static int init_passes(SwsGraph *graph)
This patch comes after:
[PATCH 1/2] Update R-V V vvc_mc vset to support more lengths
[PATCH 2/2] lavc/vvc_mc: R-V V dmvr.
Rémi Denis-Courmont 于2024年11月19日周二 04:10写道:
> Le sunnuntaina 17. marraskuuta 2024, 15.17.49 EET flow gg a écrit :
> > > Generally speaking, I think that moving code should be
On Thu, 21 Nov 2024 01:30:30 +0100 Michael Niedermayer
wrote:
> On Sat, Nov 16, 2024 at 12:25:02PM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > Used by the graph API swscale wrapper, for now.
> >
> > Sponsored-by: Sovereign Tech Fund
> > Signed-off-by: Niklas Haas
> > ---
> > libsws
Hello,
Axis Communications AB would like to contribute a packetizer and
depacketizer in avformat implementing the RTP for AV1 specification.
This is my first contribution and I have read the chapter about
submitting patches a couple of times. Nevertheless, I am sorry there are
mistakes in th
Add RTP packetizer and depacketizer according to (most)
of the official AV1 RTP specification. This enables
streaming via RTSP between ffmpeg and ffmpeg and has
also been tested to work with AV1 RTSP streams via
GStreamer.
It also adds the required SDP additions.
Signed-off-by: Chris Hodges
---
> On Oct 13, 2024, at 01:18, Marth64 wrote:
>
> Written in the dominant style of the surrounding code block.
>
> Signed-off-by: Marth64
> ---
> libavformat/smoothstreamingenc.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/libavformat/smoothstreamingenc.c
> b/li
Hello.
Recently I teached cinelerra-gg to use qsv encoders in ffmpeg (libavcodec)
and some test were working but some not.
We nailed it down to top-field first material, like HDV files. bff files
like consumer version of DV and progressive worked fine.
I looked at source and ... I thought cond
> On Nov 21, 2024, at 15:02, Marth64 wrote:
>
> Hi Zhao Zhili:
>
>> We don’t use braces in such case generally.
>> And please split assignment and check
>> into two lines next time.
>
> I agree but was trying to fix it in the style of the
> surrounding code for consistency. The function
> mos
This patch set adds decoding support for the Quram Qmage image format,
a Korean image compressor used in Samsung phones for startup/shutdown
animations and static pictures.
Internally the image format uses RGB 565 with an optional alpha plane.
The ffmpeg decoder currently ignores the alpha plane.
On Thu, 21 Nov 2024 01:26:36 +0100 Michael Niedermayer
wrote:
> Hi
>
>
> On Sat, Nov 16, 2024 at 12:25:01PM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > Group them into an enum rather than random #defines, and document their
> > behavior a bit more obviously.
> >
>
> > Of particular n
On Thu, 21 Nov 2024 14:07:26 +0100
"J. Dekker" wrote:
> compn writes:
> These mails simply leave me confused:
My apologies. I was trying to clarify things but this mail I wrote was
so bad it only caused grief. It was not my intent and thats why I asked
people to ignore my mail.
> - Why is Mich
Changes since v7:
- renamed sws_init_single_context() to ff_sws_init_single_context()
- simplified vshift()
- renamed legacy wrapper functions inside graph.c for clarity
- moved the legacy SwsContext inside the legacy wrappers
- slightly refactored SwsPass to allocate output buffers "lazily", and
Hi Zhao Zhili:
> We don’t use braces in such case generally.
> And please split assignment and check
> into two lines next time.
I agree but was trying to fix it in the style of the
surrounding code for consistency. The function
mostly uses braces after single quote and
the assignment/check patte
compn writes:
> On Tue, 12 Nov 2024 21:17:01 +0200
> Rémi Denis-Courmont wrote:
>
>> Le sunnuntaina 3. marraskuuta 2024, 19.25.50 EET Michael Niedermayer
>> a écrit :
>> > Hi
>> >
>> > On Sun, Nov 03, 2024 at 08:56:36PM +0900, Rémi Denis-Courmont wrote:
>> > [...]
>> >
>> > > >Thats besides
On Sun, 3 Nov 2024 at 11:24, Michael Niedermayer wrote:
>
> Fixes: runtime error: signed integer overflow
> Fixes:
> 42536949/clusterfuzz-testcase-minimized-fuzzer_loadfile-6199846684393472
> Found-by: ossfuzz
> Reported-by: Kacper Michajlow
> Tested-by: Kacper Michajlow
> Signed-off-by: Michael
From: Niklas Haas
Most logic from this filter has been co-opted into swscale itself,
allowing the resulting filter to be substantially simpler as it no
longer has to worry about context initialization, interlacing, etc.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libavfilt
From: Niklas Haas
Following in the footsteps of the work in the previous commit, it's now
relatively straightforward to expose the options struct publicly as
SwsContext. This is a step towards making this more user friendly, as
well as following API conventions established elsewhere.
Sponsored-b
On Thu, 21 Nov 2024 02:12:28 +0100 Michael Niedermayer
wrote:
> > +static int validate_params(SwsContext *ctx)
> > +{
> > +#define VALIDATE(field, min, max) \
> > +if (ctx->field < min || ctx->field > max) { \
> > +av_log(ctx, AV_LOG_ERROR, "'%s' (%d) out of range [%d, %d]\n", \
> > +
On Thu, 21 Nov 2024 02:22:26 +0100 Michael Niedermayer
wrote:
> On Sat, Nov 16, 2024 at 12:25:06PM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > With the ability to set the thread count as well. This benchmark includes
> > the constant overhead of context initialization.
> >
> > Sponso
On Thu, 21 Nov 2024 00:42:23 +0100 Michael Niedermayer
wrote:
> Hi Niklas
>
> On Sat, Nov 16, 2024 at 12:24:59PM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > Following in the footsteps of the work in the previous commit, it's now
> > relatively straightforward to expose the options st
On Thu, 21 Nov 2024 02:03:56 +0100 Michael Niedermayer
wrote:
> On Sat, Nov 16, 2024 at 12:25:03PM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > This interface has been designed from the ground up to serve as a new
> > framework for dispatching various scaling operations at a high leve
On 11/21/2024 1:52 PM, Thierry Foucu wrote:
On Wed, Nov 20, 2024, 12:27 PM James Almer wrote:
From: Thierry Foucu
Fixes ticket #11312.
Signed-off-by: James Almer
---
libavformat/isom.h | 1 +
libavformat/mov.c | 4
2 files changed, 5 insertions(+)
diff --git a/libavformat/isom.h
On Wed, Nov 20, 2024, 12:27 PM James Almer wrote:
> From: Thierry Foucu
>
> Fixes ticket #11312.
>
> Signed-off-by: James Almer
> ---
> libavformat/isom.h | 1 +
> libavformat/mov.c | 4
> 2 files changed, 5 insertions(+)
>
> diff --git a/libavformat/isom.h b/libavformat/isom.h
> index f
On Thu, 2024-11-21 at 11:50 +0300, Andrew Randrianasulu wrote:
> Hello.
>
>
> Recently I teached cinelerra-gg to use qsv encoders in ffmpeg
> (libavcodec)
> and some test were working but some not.
>
> We nailed it down to top-field first material, like HDV files. bff
> files
> like consumer ve
Marton Balint (12024-11-10):
> The filter currently use inaccurate frequencies, this is inpreparation for
uses
> fixing that.
... by using numbers that will map to the equivalent value in the future
code.
LGTM otherwise.
Sorry for the delay.
Regards,
--
Nicolas George
Marton Balint (12024-11-10):
> Signed-off-by: Marton Balint
> ---
> libavfilter/asrc_sine.c | 34 +++---
> 1 file changed, 23 insertions(+), 11 deletions(-)
Not sure sampling is the right word, but I cannot come with a better
suggestion at the time. Not important.
LG
Instead of expecting the DASH muxer manually setting this, just do it here.
This is required to write a simple edit list for audio tracks with triming
samples, where negative CTS offsets can't be used.
Signed-off-by: James Almer
---
libavformat/movenc.c | 2 +-
libavformat/tests/movenc.c
From: Darren Mo
Fixes tickets #7855 and #11312.
Signed-off-by: James Almer
---
libavformat/isom.h| 3 +
libavformat/mov.c | 181 --
tests/ref/fate/copy-trac236 | 4 +-
tests/ref/fate/filter-fps
On Sat, Nov 16, 2024 at 10:02 AM James Almer wrote:
> From: Pavel Koshevoy
>
> This avoids unpleasant surprises to av_frame_get_buffer callers
> that explicitly specified 64-byte alignment and didn't get
> AVFrame.data pointers that are 64-byte aligned.
>
> For example, see https://github.com/se
On 11/21/2024 6:17 PM, Michael Niedermayer wrote:
On Thu, Nov 21, 2024 at 12:23:41AM -0300, James Almer wrote:
From: Darren Mo
Fixes tickets #7855 and #11312.
Co-authored-by: James Almer
Signed-off-by: James Almer
---
This is an alternative, better approach to the same issue.
libavformat
From: Fei Wang
The changes to output frame props in query_frame overlapped since
b14ed6ea58. Move the copy frame props before the changes.
Signed-off-by: Fei Wang
---
libavfilter/qsvvpp.c | 23 ---
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/libavfilter/
On Thu, Nov 21, 2024 at 01:13:45PM +0100, Niklas Haas wrote:
> On Thu, 21 Nov 2024 00:42:23 +0100 Michael Niedermayer
> wrote:
> > Hi Niklas
> >
> > On Sat, Nov 16, 2024 at 12:24:59PM +0100, Niklas Haas wrote:
> > > From: Niklas Haas
> > >
> > > Following in the footsteps of the work in the prev
On 11/22/2024 12:17 AM, Pavel Koshevoy wrote:
On Sat, Nov 16, 2024 at 10:02 AM James Almer wrote:
From: Pavel Koshevoy
This avoids unpleasant surprises to av_frame_get_buffer callers
that explicitly specified 64-byte alignment and didn't get
AVFrame.data pointers that are 64-byte aligned.
F
On 11/21/24 23:13, Jerome Martinez wrote:
Le 21/11/2024 à 20:02, Lynne via ffmpeg-devel a écrit :
+ if (f->num_h_slices <= 0 && f->num_v_slices <= 0) {
f->num_h_slices = 32;
- if (f->num_v_slices <= 0)
f->num_v_slices = 32;
+ } else if (f->num_h_
On Thu, Nov 21, 2024 at 04:56:09PM -0500, Vittorio Giovara wrote:
> On Wed, Nov 20, 2024 at 8:51 PM Michael Niedermayer
[...]
> > And also the
> > friendly discussions we have recently, i just cant stop enjoying
> > discussing with so many nice developers as we have recently active
> > here.
> >
>
On Thu, 21 Nov 2024 20:43:22 +0200
Rémi Denis-Courmont wrote:
> Le torstaina 21. marraskuuta 2024, 17.19.57 EET compn a écrit :
> > > - Why is Michael asking what my profession is?
> >
> > Michael was asking your profession to find out if you administrate
> > servers as part of your profession
Le torstaina 21. marraskuuta 2024, 22.34.42 EET compn a écrit :
> > Why does Michael need to ask the profession of an immediate colleague of
> > his? How can he claim that the answer (or lack therof) is a "red flag"
> > when he knows the answer full well on account of working for the very
> > same
On Thu, Nov 21, 2024 at 3:53 PM compn wrote:
> On Thu, 21 Nov 2024 22:42:58 +0200
> Rémi Denis-Courmont wrote:
>
> > Le torstaina 21. marraskuuta 2024, 22.34.42 EET compn a écrit :
> > > > Why does Michael need to ask the profession of an immediate
> colleague of
> > > > his? How can he claim th
On Wed, Nov 20, 2024 at 8:51 PM Michael Niedermayer
wrote:
> On Wed, Nov 20, 2024 at 06:26:25PM -0500, Vittorio Giovara wrote:
> > On Wed, Nov 20, 2024 at 6:20 PM Michael Niedermayer <
> mich...@niedermayer.cc>
> > wrote:
> >
> > > Hi
> > >
> > > On Wed, Nov 20, 2024 at 04:12:39PM -0500, Vittorio
Le torstaina 21. marraskuuta 2024, 17.19.57 EET compn a écrit :
> > - Why is Michael asking what my profession is?
>
> Michael was asking your profession to find out if you administrate
> servers as part of your profession.
You are dodging the question.
Why does Michael need to ask the professio
On 21 Nov 2024, at 22:11, Peter Ross wrote:
> Fixes CID 1634888
> ---
> libavformat/mm.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/libavformat/mm.c b/libavformat/mm.c
> index 74e2716926..07ba6ac4f5 100644
> --- a/libavformat/mm.c
> +++ b/libavformat/mm.c
> @@ -190,6 +190,7 @@ st
On Thu, Nov 21, 2024 at 12:23:41AM -0300, James Almer wrote:
> From: Darren Mo
>
> Fixes tickets #7855 and #11312.
>
> Co-authored-by: James Almer
> Signed-off-by: James Almer
> ---
> This is an alternative, better approach to the same issue.
>
> libavformat/isom.h
Fixes CID 1634888
---
libavformat/mm.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/libavformat/mm.c b/libavformat/mm.c
index 74e2716926..07ba6ac4f5 100644
--- a/libavformat/mm.c
+++ b/libavformat/mm.c
@@ -190,6 +190,7 @@ static int read_packet(AVFormatContext *s,
default :
On Thu, 21 Nov 2024 16:49:25 -0500
Vittorio Giovara wrote:
> On Thu, Nov 21, 2024 at 3:53 PM compn wrote:
>
> > On Thu, 21 Nov 2024 22:42:58 +0200
> > Rémi Denis-Courmont wrote:
> >
> > > Le torstaina 21. marraskuuta 2024, 22.34.42 EET compn a écrit :
> > > > > Why does Michael need to ask
On Wed, Nov 20, 2024, 7:24 PM James Almer wrote:
> From: Darren Mo
>
> Fixes tickets #7855 and #11312.
>
> Co-authored-by: James Almer
> Signed-off-by: James Almer
> ---
> This is an alternative, better approach to the same issue.
>
> libavformat/isom.h| 3 +
> l
---
libavcodec/ffv1enc_vulkan.c | 23 +--
1 file changed, 17 insertions(+), 6 deletions(-)
diff --git a/libavcodec/ffv1enc_vulkan.c b/libavcodec/ffv1enc_vulkan.c
index a3c10524fe..b37c24484f 100644
--- a/libavcodec/ffv1enc_vulkan.c
+++ b/libavcodec/ffv1enc_vulkan.c
@@ -1437,13
On 11/21/2024 6:18 PM, James Almer wrote:
On 11/21/2024 6:17 PM, Michael Niedermayer wrote:
On Thu, Nov 21, 2024 at 12:23:41AM -0300, James Almer wrote:
From: Darren Mo
Fixes tickets #7855 and #11312.
Co-authored-by: James Almer
Signed-off-by: James Almer
---
This is an alternative, better
On Wed, Nov 20, 2024 at 7:16 PM Michael Niedermayer
wrote:
> Hi
>
> On Tue, Nov 19, 2024 at 11:30:03AM -0500, Vittorio Giovara wrote:
> > On Sat, Nov 16, 2024 at 7:42 PM Michael Niedermayer <
> mich...@niedermayer.cc>
> > wrote:
> >
> > > Not sure we have such a list elsewhere, i failed to find i
On Thu, Nov 21, 2024 at 04:45:20PM +1100, Peter Ross wrote:
> ---
> libavcodec/Makefile | 1 +
> libavcodec/allcodecs.c | 1 +
> libavcodec/codec_desc.c | 7 +
> libavcodec/codec_id.h | 1 +
> libavcodec/qmagedata.h | 133 +++
> libavcodec/qmagedec.c | 836 +++
On Wed, Nov 20, 2024 at 7:10 PM Michael Niedermayer
wrote:
> Hi
>
> On Wed, Nov 20, 2024 at 03:59:36PM -0500, Vittorio Giovara wrote:
> > Why was this pushed without full approval?
>
> I had already the feeling some people live in a parallel universe. I guess
> that confirms it.
>
> this patch wa
Le 21/11/2024 à 20:02, Lynne via ffmpeg-devel a écrit :
+if (f->num_h_slices <= 0 && f->num_v_slices <= 0) {
f->num_h_slices = 32;
-if (f->num_v_slices <= 0)
f->num_v_slices = 32;
+} else if (f->num_h_slices) {
+} else if (f->num_h_sli
On Thu, 21 Nov 2024 22:42:58 +0200
Rémi Denis-Courmont wrote:
> Le torstaina 21. marraskuuta 2024, 22.34.42 EET compn a écrit :
> > > Why does Michael need to ask the profession of an immediate colleague of
> > > his? How can he claim that the answer (or lack therof) is a "red flag"
> > > when he
60 matches
Mail list logo