[FFmpeg-devel] [PATCH v3 3/7] avcodec/mediacodecenc: use bsf to handle crop

2022-12-09 Thread Zhao Zhili
From: Zhao Zhili It's well known that mediacodec encoder requires 16x16 alignment. Use our bsf to fix the crop info. --- v3: don't change the dimension for AV_PIX_FMT_MEDIACODEC. It can have side effect. configure | 2 + libavcodec/mediacodecenc.c | 78

[FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Niklas Haas
So, as was discussed at the last meeting, we should move towards removing YUVJ. I want to gather feedback on what appears to be to the major hurdle, and possible ways to solve it. The basic major issue is how to handle the case of combining limited range input with an encoder for a format that onl

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Jean-Baptiste Kempf
3. :) On Fri, 9 Dec 2022, at 12:49, Niklas Haas wrote: > So, as was discussed at the last meeting, we should move towards > removing YUVJ. I want to gather feedback on what appears to be to the > major hurdle, and possible ways to solve it. > > The basic major issue is how to handle the case of co

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Niklas Haas
On Fri, 09 Dec 2022 13:10:02 +0100 Andreas Rheinhardt wrote: > This is incorrect: Here are the pixel formats advertised by the mjpeg > encoder: > > .p.pix_fmts = (const enum AVPixelFormat[]) { > AV_PIX_FMT_YUVJ420P, AV_PIX_FMT_YUVJ422P, AV_PIX_FMT_YUVJ444P, > AV_PIX_FMT_Y

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Paul B Mahol
On 12/9/22, Niklas Haas wrote: > On Fri, 09 Dec 2022 13:10:02 +0100 Andreas Rheinhardt > wrote: >> This is incorrect: Here are the pixel formats advertised by the mjpeg >> encoder: >> >> .p.pix_fmts = (const enum AVPixelFormat[]) { >> AV_PIX_FMT_YUVJ420P, AV_PIX_FMT_YUVJ422P, AV_P

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Hendrik Leppkes
On Fri, Dec 9, 2022 at 12:49 PM Niklas Haas wrote: > > So, as was discussed at the last meeting, we should move towards > removing YUVJ. I want to gather feedback on what appears to be to the > major hurdle, and possible ways to solve it. > > The basic major issue is how to handle the case of comb

Re: [FFmpeg-devel] [PATCH v3] lavc: convert frame threading to the receive_frame() pattern

2022-12-09 Thread Timo Rothenpieler
On 07/12/2022 23:22, Michael Niedermayer wrote: On Wed, Dec 07, 2022 at 02:20:23PM +0100, Timo Rothenpieler wrote: From: Anton Khirnov Reorganize the code such that the frame threading code does not call the decoders directly, but instead calls back into the generic decoding code. This avoids

Re: [FFmpeg-devel] [PATCH v3] lavc: convert frame threading to the receive_frame() pattern

2022-12-09 Thread James Almer
On 12/9/2022 10:09 AM, Timo Rothenpieler wrote: On 07/12/2022 23:22, Michael Niedermayer wrote: On Wed, Dec 07, 2022 at 02:20:23PM +0100, Timo Rothenpieler wrote: From: Anton Khirnov Reorganize the code such that the frame threading code does not call the decoders directly, but instead calls

[FFmpeg-devel] [PATCH v4] lavc: convert frame threading to the receive_frame() pattern

2022-12-09 Thread Timo Rothenpieler
From: Anton Khirnov Reorganize the code such that the frame threading code does not call the decoders directly, but instead calls back into the generic decoding code. This avoids duplicating the logic that wraps the decoder invocation and will be useful in the following commits. --- libavcodec/d

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Diederick C. Niehorster
On Fri, Dec 9, 2022 at 1:45 PM Niklas Haas wrote: > Oh, you are right. So that presents an alternative to 4 - rather than an > encoder flag, we can tie the auto-conversion in fftools to be tied to > the strict_std_compliance check. > > I will try implementing this approach, it may be the best com

[FFmpeg-devel] [PATCH v2 1/2] lavc: add new unsafe_output hwaccel_flag

2022-12-09 Thread Timo Rothenpieler
--- doc/APIchanges | 3 +++ libavcodec/avcodec.h | 16 libavcodec/options_table.h | 1 + libavcodec/version.h | 4 ++-- 4 files changed, 22 insertions(+), 2 deletions(-) diff --git a/doc/APIchanges b/doc/APIchanges index ab7ce15fae..328028f293 100644 --

[FFmpeg-devel] [PATCH v2 2/2] avcodec/nvdec: make explicit copy of frames unless user requested otherwise

2022-12-09 Thread Timo Rothenpieler
--- libavcodec/nvdec.c | 13 +++-- 1 file changed, 11 insertions(+), 2 deletions(-) diff --git a/libavcodec/nvdec.c b/libavcodec/nvdec.c index fbaedf0b6b..a477449d14 100644 --- a/libavcodec/nvdec.c +++ b/libavcodec/nvdec.c @@ -51,6 +51,8 @@ typedef struct NVDECDecoder { CudaFunctio

Re: [FFmpeg-devel] [PATCH] avformat/file: add fd protocol

2022-12-09 Thread Anton Khirnov
Quoting Zhao Zhili (2022-11-18 19:48:02) > From: Zhao Zhili > > Unlike the pipe protocol, fd protocol has seek support if it > corresponding to a regular file. > --- > Sometimes it's the only way to access files via file descriptor, e.g., > requesting a shared file on Android: > https://developer

[FFmpeg-devel] [PATCH 2/2] doc/protocols: Remove IPFS urls to specific content in examples

2022-12-09 Thread Derek Buitenhuis
We shouldn't be providing links to unverified and non-FFmpeg-controlled content in our documentation. Signed-off-by: Derek Buitenhuis --- doc/protocols.texi | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/doc/protocols.texi b/doc/protocols.texi index b9c9485646..d1c6fced7

[FFmpeg-devel] [PATCH] avformat: Rename IPFS to IPFS gateway

2022-12-09 Thread Derek Buitenhuis
It is a URL rewriter for IPFS gateways, not an actual implementation of IPFS, and naming it as such was both incorrect and misleading. Signed-off-by: Derek Buitenhuis --- As was discussed at the developer meeting last week, presented here for comments. Personally I think libavformat is no place

Re: [FFmpeg-devel] [PATCH] avformat: Rename IPFS to IPFS gateway

2022-12-09 Thread Nicolas George
Derek Buitenhuis (12022-12-09): > It is a URL rewriter for IPFS gateways, not an actual implementation of > IPFS, and naming it as such was both incorrect and misleading. > > Signed-off-by: Derek Buitenhuis > --- > As was discussed at the developer meeting last week, presented here for > comment

Re: [FFmpeg-devel] [PATCH] avformat: Rename IPFS to IPFS gateway

2022-12-09 Thread Derek Buitenhuis
On 12/9/2022 3:45 PM, Nicolas George wrote: >> -static int ipfs_read(URLContext *h, unsigned char *buf, int size) >> +static int ipfs_gateway_read(URLContext *h, unsigned char *buf, int size) > > There is no need to rename local symbols. My intent was to rename in case we ever got an actual IPFS

Re: [FFmpeg-devel] [PATCH] avformat: Rename IPFS to IPFS gateway

2022-12-09 Thread Nicolas George
Derek Buitenhuis (12022-12-09): > My intent was to rename in case we ever got an actual IPFS implementation, > but I have no strong opinion on whether to keep this part of the patch or > not. Even if we do, the names are local, they do not conflict. > My personal preference is verbosity here, but

Re: [FFmpeg-devel] [PATCH v3] lavc: convert frame threading to the receive_frame() pattern

2022-12-09 Thread Michael Niedermayer
On Fri, Dec 09, 2022 at 02:09:45PM +0100, Timo Rothenpieler wrote: > On 07/12/2022 23:22, Michael Niedermayer wrote: > > On Wed, Dec 07, 2022 at 02:20:23PM +0100, Timo Rothenpieler wrote: > > > From: Anton Khirnov > > > > > > Reorganize the code such that the frame threading code does not call th

Re: [FFmpeg-devel] Towards YUVJ removal

2022-12-09 Thread Michael Niedermayer
On Fri, Dec 09, 2022 at 12:49:41PM +0100, Niklas Haas wrote: > So, as was discussed at the last meeting, we should move towards > removing YUVJ. I want to gather feedback on what appears to be to the > major hurdle, and possible ways to solve it. > > The basic major issue is how to handle the case

Re: [FFmpeg-devel] AVX512 NUCs for FATE and development

2022-12-09 Thread Michael Niedermayer
On Thu, Dec 08, 2022 at 09:40:12PM +, Kieran Kunhya wrote: > I intend to buy this RAM: > https://www.amazon.co.uk/Crucial-CT2K16G4SFRA32A-PC4-25600-SODIMM-260-Pin/dp/B08C4X9VR5 > > 2x £529 for NUCs > 2x £102.48 for RAM > 2x £69 for M.2 NVMe SSD > > £1400 total. iam in favor of this too I wou

Re: [FFmpeg-devel] [PATCH v2 1/2] lavc: add new unsafe_output hwaccel_flag

2022-12-09 Thread Philip Langdale
On Fri, 9 Dec 2022 15:16:16 +0100 Timo Rothenpieler wrote: > --- > doc/APIchanges | 3 +++ > libavcodec/avcodec.h | 16 > libavcodec/options_table.h | 1 + > libavcodec/version.h | 4 ++-- > 4 files changed, 22 insertions(+), 2 deletions(-) > > diff

Re: [FFmpeg-devel] [PATCH v2 2/2] avcodec/nvdec: make explicit copy of frames unless user requested otherwise

2022-12-09 Thread Philip Langdale
On Fri, 9 Dec 2022 15:16:17 +0100 Timo Rothenpieler wrote: > --- > libavcodec/nvdec.c | 13 +++-- > 1 file changed, 11 insertions(+), 2 deletions(-) > > diff --git a/libavcodec/nvdec.c b/libavcodec/nvdec.c > index fbaedf0b6b..a477449d14 100644 > --- a/libavcodec/nvdec.c > +++ b/libavco

Re: [FFmpeg-devel] [PATCH v4] lavc: convert frame threading to the receive_frame() pattern

2022-12-09 Thread Michael Niedermayer
On Fri, Dec 09, 2022 at 02:37:04PM +0100, Timo Rothenpieler wrote: > From: Anton Khirnov > > Reorganize the code such that the frame threading code does not call the > decoders directly, but instead calls back into the generic decoding > code. This avoids duplicating the logic that wraps the deco

Re: [FFmpeg-devel] [PATCH v2 2/2] avcodec/nvdec: make explicit copy of frames unless user requested otherwise

2022-12-09 Thread Timo Rothenpieler
On 09.12.2022 20:20, Philip Langdale wrote: On Fri, 9 Dec 2022 15:16:17 +0100 Timo Rothenpieler wrote: --- libavcodec/nvdec.c | 13 +++-- 1 file changed, 11 insertions(+), 2 deletions(-) diff --git a/libavcodec/nvdec.c b/libavcodec/nvdec.c index fbaedf0b6b..a477449d14 100644 --- a

[FFmpeg-devel] [PATCH] avformat/oggenc: ignore empty packets

2022-12-09 Thread James Almer
Some encoders, like flac, can send side data only packets at the end. Eventually, said extradata update should ideally be used to update the header when writting to seekable output, but for now, ignore them. Should fix the undefined behavior of passing NULL to memcpy(). Signed-off-by: James Almer