On Sat, May 02, 2015 at 10:13:30AM -0700, Muhammad Faiz wrote:
>
> From c79989a2069966331ec65f9734554e4a2de065b9 Mon Sep 17 00:00:00 2001
> From: Muhammad Faiz
> Date: Fri, 1 May 2015 16:44:59 +0700
> Subject: [PATCH] avfilter/avf_showcqt: optimize gamma calculation
applied
thanks
[]
--
Le 03/05/2015 04:57, Michael Niedermayer a écrit :
i dont think its a good idea to replace a named variable in a
for () statement by a construct so long that it needs a linebreak
in the text output [...]
I hesitated and this is a very good point, so I replaced by 2 named
variables:
- plane_co
On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote:
> Le 03/05/2015 04:57, Michael Niedermayer a écrit :
> >i dont think its a good idea to replace a named variable in a
> >for () statement by a construct so long that it needs a linebreak
> >in the text output [...]
>
> I hesitated an
Hi!
Attached patch fixes cropdetect here for yuv422p10le (no
other formats tested), I don't know if the change to
diff makes sense or not.
Please comment, Carl Eugendiff --git a/libavfilter/vf_cropdetect.c b/libavfilter/vf_cropdetect.c
index 485ae69..6d0081e 100644
--- a/libavfilter/vf_cropdetec
Le 03/05/2015 13:55, Michael Niedermayer a écrit :
On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote:
- plane_count which is the count of planes
thats a bad name for packed formats
Good point, but this is not worse than the previous name used ;-).
and actually you use "alpha_pla
On 05/02/2015 08:24 PM, Clément Bœsch wrote:
On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote:
On 04/28/2015 02:14 PM, Clément Bœsch wrote:
Then FATE test patch should be applied after the CC patch.
New patch attached. I have used other ass api.
+fate-sub-cc: CMD = fmtstdout ass -f
This check was removed in commit 08aec6f6, but
s->last_picture.f->data[0] is still used in handle_p_frame_apng
unconditionally.
This fixes a segmentation fault.
Signed-off-by: Andreas Cadhalpun
---
libavcodec/pngdec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcode
Hi,
First patch here. I wrote this format to be able to get the keyframe
indexes faster than seemed possible with ffprobe, and also to get more
familiar with ffmpeg.
ffmpeg -i input.mkv -c copy -f keyframes -keyframes_filename keyframes.txt
/dev/null
Could something like this be included in ffmp
In this case ptr could be set to a position outside the image_buf in
png_handle_row, leading to memory corruption and thus crashes.
Signed-off-by: Andreas Cadhalpun
---
libavcodec/pngdec.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/libavcodec/pngdec.c b/libavcodec/pngdec.c
index 2
On Sun, May 03, 2015 at 04:21:39PM +0200, Andreas Cadhalpun wrote:
> This check was removed in commit 08aec6f6, but
> s->last_picture.f->data[0] is still used in handle_p_frame_apng
> unconditionally.
>
> This fixes a segmentation fault.
>
> Signed-off-by: Andreas Cadhalpun
applied
thanks
[..
During the loop ret can get changed. Since it is not set on all failure
paths, decode_frame_common can return 0 even though an error occurred.
Signed-off-by: Andreas Cadhalpun
---
libavcodec/pngdec.c | 15 ++-
1 file changed, 10 insertions(+), 5 deletions(-)
diff --git a/libavcodec/
On Sun, May 03, 2015 at 02:59:59PM +0200, Jerome Martinez wrote:
> Le 03/05/2015 13:55, Michael Niedermayer a écrit :
> >On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote:
> >>- plane_count which is the count of planes
> >thats a bad name for packed formats
>
> Good point, but this i
On Sun, May 03, 2015 at 02:05:44PM +0200, Carl Eugen Hoyos wrote:
> Hi!
>
> Attached patch fixes cropdetect here for yuv422p10le (no
> other formats tested), I don't know if the change to
> diff makes sense or not.
>
> Please comment, Carl Eugen
LGTM
i think the div change is not needed but i m
On Sun, 3 May 2015 03:10:05 +0200
Michael Niedermayer wrote:
> do people prefer this to be enabled or disabled by default ?
>
> Signed-off-by: Michael Niedermayer
> ---
> ffplay.c |5 +
> 1 file changed, 5 insertions(+)
>
> diff --git a/ffplay.c b/ffplay.c
> index eea00e6..48b09ee 10
On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote:
> In this case ptr could be set to a position outside the image_buf in
> png_handle_row, leading to memory corruption and thus crashes.
>
> Signed-off-by: Andreas Cadhalpun
> ---
> libavcodec/pngdec.c | 6 ++
> 1 file changed
On Sun, May 03, 2015 at 08:04:52PM +0200, wm4 wrote:
> On Sun, 3 May 2015 03:10:05 +0200
> Michael Niedermayer wrote:
>
> > do people prefer this to be enabled or disabled by default ?
> >
> > Signed-off-by: Michael Niedermayer
> > ---
> > ffplay.c |5 +
> > 1 file changed, 5 insertio
On Sun, May 03, 2015 at 05:50:26PM +0200, Andreas Cadhalpun wrote:
> During the loop ret can get changed. Since it is not set on all failure
> paths, decode_frame_common can return 0 even though an error occurred.
>
> Signed-off-by: Andreas Cadhalpun
> ---
> libavcodec/pngdec.c | 15 ++--
On 03.05.2015 20:09, Michael Niedermayer wrote:
> On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote:
>> In this case ptr could be set to a position outside the image_buf in
>> png_handle_row, leading to memory corruption and thus crashes.
>>
>> Signed-off-by: Andreas Cadhalpun
>> -
On Sun, May 03, 2015 at 06:46:15PM +0530, Anshul wrote:
>
>
> On 05/02/2015 08:24 PM, Clément Bœsch wrote:
> >On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote:
> >>
> >>On 04/28/2015 02:14 PM, Clément Bœsch wrote:
> >>>Then FATE test patch should be applied after the CC patch.
> >>>
> >>New
On Sun, 3 May 2015, Michael Niedermayer wrote:
Signed-off-by: Michael Niedermayer
---
ffplay.c | 45 +++--
1 file changed, 23 insertions(+), 22 deletions(-)
diff --git a/ffplay.c b/ffplay.c
index 826a473..eea00e6 100644
--- a/ffplay.c
+++ b/ffplay.c
@@
On Sun, May 03, 2015 at 08:41:35PM +0200, Andreas Cadhalpun wrote:
> On 03.05.2015 20:09, Michael Niedermayer wrote:
> > On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote:
> >> In this case ptr could be set to a position outside the image_buf in
> >> png_handle_row, leading to memor
On Sun, 3 May 2015, Michael Niedermayer wrote:
On Sun, May 03, 2015 at 08:04:52PM +0200, wm4 wrote:
On Sun, 3 May 2015 03:10:05 +0200
Michael Niedermayer wrote:
do people prefer this to be enabled or disabled by default ?
Signed-off-by: Michael Niedermayer
---
ffplay.c |5 +
1
On Sun, May 03, 2015 at 09:16:55PM +0200, Marton Balint wrote:
>
> On Sun, 3 May 2015, Michael Niedermayer wrote:
>
> >Signed-off-by: Michael Niedermayer
> >---
> >ffplay.c | 45 +++--
> >1 file changed, 23 insertions(+), 22 deletions(-)
> >
> >diff --git
index_scale is set to matroska->time_scale of type uint64_t.
When index_scale is int, the assignment can overflow and e.g. result
in index_scale = 0. This causes a floating point exception due to the
division by index_scale.
Signed-off-by: Andreas Cadhalpun
---
libavformat/matroskadec.c | 2 +-
On Sun, May 03, 2015 at 08:53:14PM +0200, Clément Bœsch wrote:
> On Sun, May 03, 2015 at 06:46:15PM +0530, Anshul wrote:
> >
> >
> > On 05/02/2015 08:24 PM, Clément Bœsch wrote:
> > >On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote:
> > >>
> > >>On 04/28/2015 02:14 PM, Clément Bœsch wrote:
This fixes a segmentation fault.
Signed-off-by: Andreas Cadhalpun
---
libavformat/matroskadec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/matroskadec.c b/libavformat/matroskadec.c
index 27d184e..31723b3 100644
--- a/libavformat/matroskadec.c
+++ b/libavforma
On Sun, May 03, 2015 at 11:07:20PM +0200, Andreas Cadhalpun wrote:
> index_scale is set to matroska->time_scale of type uint64_t.
>
> When index_scale is int, the assignment can overflow and e.g. result
> in index_scale = 0. This causes a floating point exception due to the
> division by index_sca
On 03/05/15 3:55 AM, Ronald S. Bultje wrote:
> Hi,
>
> On Sun, May 3, 2015 at 2:15 AM, James Almer wrote:
>
>> Signed-off-by: James Almer
>> ---
>> libavcodec/avcodec.h | 3 +++
>> libavcodec/version.h | 4 ++--
>> libavcodec/vp9.c | 22 ++
>> 3 files changed, 19 inse
28 matches
Mail list logo