On Sun, May 03, 2015 at 02:59:59PM +0200, Jerome Martinez wrote: > Le 03/05/2015 13:55, Michael Niedermayer a écrit : > >On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote: > >>- plane_count which is the count of planes > >thats a bad name for packed formats > > Good point, but this is not worse than the previous name used ;-). > and actually you use "alpha_plane" even for color_space = 1 (so no planes) > > Attached is a new patch with channel_count name. > "channel" wording taken from > https://www.ffmpeg.org/ffmpeg-all.html#extractplanes . > should I also change, in another patch, chroma_planes and > alpha_plane to chroma_channels and alpha_channel for more coherency? > > > > > > >>- quant_table_index_count which is the count of quant_table indexes > >any reason not to call it quant_table_count ? (its shorter and seems > >not to contain less information) > > quant_table_count is already defined as the count of quantization > tables (in the header), we can not reuse that name for something > different. > here, it is the count of quantization table indexes, which is > different (it is possible to have 1000 quantization tables, but we > can have only up to 3 quantization indexes in the slice) if I well > understood. > I would like to have something shorter too, but I preferred not to > modify quant_table_index[i][j] > > quant_table_count is the count of quant_tables > quant_table_index_count is the count of quant_table_index.
> [...] > ffv1.lyx | 801 > ++++----------------------------------------------------------- > 1 file changed, 53 insertions(+), 748 deletions(-) > affdeba58b36c8bae4d42b4789768e6c12e2c29b > 0001-Reduce-redundancy-in-xxPlane-and-xxLine.patch > From 9f4b73e4153b6c4829d814da15bf22695f1e3df9 Mon Sep 17 00:00:00 2001 > From: =?UTF-8?q?J=C3=A9r=C3=B4me=20Martinez?= <jer...@mediaarea.net> > Date: Sun, 3 May 2015 14:57:27 +0200 > Subject: [PATCH] Reduce redundancy in xxPlane() and xxLine(). > > LumaPlane(), CbPlane(), CrPlane() and AlphaPlane() are actually same; > the order of planes is already defined in the General section and has > no impact on the bitstream. Reduced to one Plane( p ) call. > LumaLine(), CbLine(), CrLine() and AlphaLine() are actually same; > the order of lines is already defined in the General section and has > no impact on the bitstream. Reduced to one Line( p, y ) call. > plane_count name may be misleading (it is the count of > quant_table_index, which is not always the count of planes) and > does not exist in the bistream, replaced by the sum of existing > bitstream elements. > colorspace_type related "if" sorted in ascending order. applied i think 1 + ( chroma_planes ? 2 : 0 ) + ( alpha_plane + ? 1 : 0 ) should be simplified to 1 + 2*chroma_planes + alpha_plane thanks [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB Dictatorship naturally arises out of democracy, and the most aggravated form of tyranny and slavery out of the most extreme liberty. -- Plato
signature.asc
Description: Digital signature
_______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel