(this time with the attached git-format patch !)
The Id3v2 tag is set to a wrong size (14 bytes too large), when a CTOC
frame is included. It makes decoders believe the first MP3 frame is inside
the ID3v2 tag, and hence mungle the first mp3 frame.
The code source uses a hardcoded "16" magic value
On 09-01-2020 12:09 pm, m...@atomas.com wrote:
The Id3v2 tag is set to a wrong size, when a CTOC frame is written.
The code source uses a hardcoded "16" magic value that is incorrect. (it
should be "2")
This patch fixes this bug *without* using magic values.
See:
https://github.com/gbouthen
The Id3v2 tag is set to a wrong size, when a CTOC frame is written.
The code source uses a hardcoded "16" magic value that is incorrect. (it
should be "2")
This patch fixes this bug *without* using magic values.
See:
https://github.com/gbouthenot/mp3splitter-js/issues/2
https://github.com/openau
Barring further reviews, I'll retest and push the patchset on Monday.
On 06-01-2020 11:44 am, Gyan wrote:
Ping for the remainder of patchset. Expression parsing and backup has
been factorized so code duplication is minimized.
On 01-01-2020 01:12 am, Gyan Doshi wrote:
Retains parsed expressio
On 1/8/20 5:53 AM, Marton Balint wrote:
> ff_rename always logs the error message.
>
> Signed-off-by: Marton Balint
> ---
> libavformat/dashenc.c | 10 --
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
> index b84736881f..
From: Xingwen Fang
When the block size is illegal, we don't need to read the
block data. Otherwise, there will be abnormal memory access
in dsp.mlp_filter_channel.
Signed-off-by: Xingwen Fang
---
libavcodec/mlpdec.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/libavcodec/mlpdec.c b
From: Limin Wang
Fixes CID 1457606 and 1457607
Signed-off-by: Limin Wang
Signed-off-by: Limin Wang
---
libavfilter/vf_showinfo.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavfilter/vf_showinfo.c b/libavfilter/vf_showinfo.c
index 5fff123..79b79db 100644
--- a/li
From: Limin Wang
Signed-off-by: Limin Wang
---
libavcodec/utils.c | 63 --
1 file changed, 33 insertions(+), 30 deletions(-)
diff --git a/libavcodec/utils.c b/libavcodec/utils.c
index fd5565a..ab48754 100644
--- a/libavcodec/utils.c
+++ b/lib
On Wed, Jan 8, 2020 at 3:00 PM Wonkap Jang wrote:
> This commit reuses the configuration options for VP8 that enables
> temporal scalability for VP9. It also adds a way to enable three
> preset temporal structures (refer to the documentation for more
> detail) that can be used in offline encoding
On Thu, Jan 9, 2020 at 12:32 AM Max Dmitrichenko wrote:
> > Historically, QSV failed at accepting the array-textures that are used
> > by a D3D11 decoder, which is why this was not included.
> >
> >
>
> right but not anymore,
> therefore this patch.
>
Cool. Whats the requirement on that? New MFX
On Wed, 1 Jan 2020, Marton Balint wrote:
On Wed, 1 Jan 2020, Michael Niedermayer wrote:
On Mon, Dec 30, 2019 at 11:23:40PM +0100, Marton Balint wrote:
Also add helper functions to allocate and free such a struct, and make it
usable by providing a new av_eval_expr2 function for which you c
Signed-off-by: Marton Balint
---
libavformat/avio.c | 15 +++
libavformat/internal.h | 14 +-
2 files changed, 16 insertions(+), 13 deletions(-)
diff --git a/libavformat/avio.c b/libavformat/avio.c
index 2dd2312296..8c2c85f171 100644
--- a/libavformat/avio.c
+++ b/lib
ff_rename always logs the error message.
Signed-off-by: Marton Balint
---
libavformat/dashenc.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index b84736881f..6b82ca9450 100644
--- a/libavformat/dashenc.c
+++ b/libav
Also simplify it and make it always log the error.
This fixes for example the image2 muxer when used with an URL which also
contains the protocol:
ffmpeg -f lavfi -i testsrc -vframes 10 -atomic_writing 1 file:out%d.png
Signed-off-by: Marton Balint
---
libavformat/avio.c | 14 --
On Mon, Dec 23, 2019 at 8:24 PM Hendrik Leppkes wrote:
> On Mon, Dec 23, 2019 at 7:40 PM Artem Galin wrote:
> >
> > This enables DX11 support for QSV with higher priority than DX9.
> > In case of multiple GPUs configuration, DX9 API does not allow to get
> > access to QSV device in some cases -
In order for rate control to correctly allocate bitrate to each temporal
layer, correct temporal layer id has to be set to each frame. This
commit provides the ability to set correct temporal layer id for each
frame.
---
libavcodec/libvpxenc.c | 13 -
1 file changed, 12 insertions(+),
This commit reuses the configuration options for VP8 that enables
temporal scalability for VP9. It also adds a way to enable three
preset temporal structures (refer to the documentation for more
detail) that can be used in offline encoding.
---
libavcodec/libvpxenc.c | 251
Documentation change for adding support for encoding
with temporal scalability in VP9.
---
doc/encoders.texi | 18 +++---
1 file changed, 15 insertions(+), 3 deletions(-)
diff --git a/doc/encoders.texi b/doc/encoders.texi
index 61e674cf96..88429aed4c 100644
--- a/doc/encoders.texi
+++
On Mon, 30 Dec 2019 at 16:40, Philip Langdale wrote:
>
> On Sat, 21 Dec 2019 14:54:38 -0800
> Philip Langdale wrote:
>
> > On Fri, 20 Dec 2019 16:07:18 -0800
> > Josh Allmann wrote:
> >
> > > One concern I had was about the long-term stability of this
> > > behavior. Right now, it works, but per
On Wed, 1 Jan 2020, Marton Balint wrote:
On Tue, 31 Dec 2019, Michael Niedermayer wrote:
On Tue, Dec 31, 2019 at 12:37:02PM +0100, Nicolas George wrote:
Marton Balint (12019-12-28):
v2: simplified example
Signed-off-by: Marton Balint
---
doc/muxers.texi | 11 +++
libavfor
On 29/12/2019 16:30, Linjie Fu wrote:
> Add function pointer field in vaapi_profile_map[], set profile_parser
> for HEVC_REXT to find the exact va_profile.
>
> Also add format map support.
>
> Signed-off-by: Linjie Fu
> ---
> libavcodec/vaapi_decode.c | 77
> +--
On 29/12/2019 16:30, Linjie Fu wrote:
> Add vaapi_parse_rext_profile and use profile constraint flags to
> determine the exact va_profile for HEVC_REXT.
>
> Add build object in Makefile for h265_profile_level dependency.
>
> Signed-off-by: Linjie Fu
> ---
> libavcodec/Makefile | 2 +-
> li
On Tue, Oct 08, 2019 at 07:41:15AM +0200, Andreas Rheinhardt wrote:
> If the size of the input packet is zero, av_grow_packet() used to call
> av_new_packet() which would initialize the packet and (in particular)
> reset the pos field. This behaviour (which was never documented and
> arguably alway
On Wed, Jan 08, 2020 at 07:29:13PM +0100, Andreas Rheinhardt wrote:
> This fixes ticket #7997 as well as the vsynth*-prores_# FATE-tests
> (where * ranges over { 1, 2, 3, _lena } and # over { , _int, _444,
> _444_int }).
>
> (Given that prev_dc is in the range -0xC000..0x3FFF, no overflow can
> ha
On 29/12/2019 16:30, Linjie Fu wrote:
> Parse all the constraint flags according to ITU-T Rec. H.265 (02/2018).
>
> They have to be passed to hw decoders to determine the exact profile for Range
> Extension HEVC.
>
> Signed-off-by: Linjie Fu
> ---
> libavcodec/hevc_ps.c | 44 +++
From: Andriy Gelman
libx265.c references a member x265_picture.quantOffsets (for ROI
support) which was added in X265_BUILD 70. Increase the minimum libx265
version to fix compilation.
Signed-off-by: Andriy Gelman
---
ubuntu 16.04 LTS is using X265_BUILD 79
configure | 2 +-
1 file changed,
On Wed, Jan 08, 2020 at 01:23:39AM +0100, Marton Balint wrote:
> Also simplify it, move it to avio.c and make it always log the error.
I think at least moving and changing should be seperate so the diff shows
what is changed
thx
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF13361
On 29/12/2019 16:29, Linjie Fu wrote:
> Add VAPictureParameterBufferHEVCRext and VASliceParameterBufferHEVCRext.
>
> Pass Range Extension flags to support the decode for HEVC REXT.
>
> Signed-off-by: Linjie Fu
> ---
> libavcodec/vaapi_hevc.c | 79
> +
On Wed, Jan 08, 2020 at 10:25:59AM +0800, Ting Fu wrote:
> Tested using this command:
> /ffmpeg -pix_fmt yuv420p -s 1920*1080 -i ArashRawYuv420.yuv \
> -vcodec rawvideo -s 1920*1080 -pix_fmt rgb24 -f null /dev/null
>
> The fps increase from 389 to 640 on Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
>
On Mon, Dec 30, 2019 at 11:31:24AM +0100, Nicolas Gaullier wrote:
> This will allow avformat_find_stream_info() get side data from the codec
> context.
> ---
> doc/APIchanges | 3 +++
> libavformat/avformat.h | 11 +++
> libavformat/utils.c| 15 +++
> libavformat/
On 29/12/2019 16:28, Linjie Fu wrote:
> Add some packed 4:2:2 10-bit pixel formats for hardware decode support
> in VAAPI and QSV.
>
> Signed-off-by: Linjie Fu
> ---
> libavutil/pixdesc.c | 23 +++
> libavutil/pixfmt.h | 5 +
> libavutil/versio
On 08/01/2020 16:47, Eran Gonen wrote:
> ---
> doc/bitstream_filters.texi | 5 ++
> libavcodec/h265_metadata_bsf.c | 106 +++--
> 2 files changed, 105 insertions(+), 6 deletions(-)
To repeat my previous comment, I don't think this belongs in h265_metadata
since
On Fri, 20 Dec 2019, Michael Niedermayer wrote:
On Tue, Dec 17, 2019 at 03:15:09PM +0200, Martin Storsjö wrote:
Keep all the existing data fields as they are (there's lots and
lots of nontrivial calculation and heuristics based on them in
their current form), but derive the duration as the diff
On Wed, Jan 08, 2020 at 04:32:39PM +0900, Ted Lee wrote:
> Dear FFmpeg developers,
>
> I'm glad to have a chance to contribute to FFmpeg.
>
> Since this is the first time for me, please give feedback if I missed
> something. I will reflect on that.
>
> *Summary:*
>
>- Test signal: 790_pomny
This fixes ticket #7997 as well as the vsynth*-prores_# FATE-tests
(where * ranges over { 1, 2, 3, _lena } and # over { , _int, _444,
_444_int }).
(Given that prev_dc is in the range -0xC000..0x3FFF, no overflow can
happen upon multiplication with 2.)
Signed-off-by: Andreas Rheinhardt
---
Actual
---
doc/bitstream_filters.texi | 5 ++
libavcodec/h265_metadata_bsf.c | 106 +++--
2 files changed, 105 insertions(+), 6 deletions(-)
diff --git a/doc/bitstream_filters.texi b/doc/bitstream_filters.texi
index 8fe5b3ad75..2e874bf6ff 100644
--- a/doc/bitstream_filt
Yes. Fixing the identifier misprint
On Wed, Jan 8, 2020 at 5:52 PM Limin Wang wrote:
> On Wed, Jan 08, 2020 at 05:20:07PM +0200, Eran Gonen wrote:
> > ---
> > doc/bitstream_filters.texi | 5 ++
> > libavcodec/h265_metadata_bsf.c | 106 +++--
> > 2 files changed
From: Limin Wang
Signed-off-by: Limin Wang
---
libavfilter/vf_showinfo.c | 37 +
1 file changed, 37 insertions(+)
diff --git a/libavfilter/vf_showinfo.c b/libavfilter/vf_showinfo.c
index 5fff123..fc24e29 100644
--- a/libavfilter/vf_showinfo.c
+++ b/libavfilt
From: Limin Wang
Signed-off-by: Limin Wang
---
libavcodec/hevc_sei.c | 31 +++
libavcodec/hevc_sei.h | 6 ++
libavcodec/hevcdec.c| 14 ++
tests/ref/fate/hevc-monochrome-crop | 3 +++
4 files changed, 54 in
On Wed, Jan 08, 2020 at 05:20:07PM +0200, Eran Gonen wrote:
> ---
> doc/bitstream_filters.texi | 5 ++
> libavcodec/h265_metadata_bsf.c | 106 +++--
> 2 files changed, 105 insertions(+), 6 deletions(-)
>
> diff --git a/doc/bitstream_filters.texi b/doc/bitstream_f
From: Limin Wang
Signed-off-by: Limin Wang
---
libavcodec/h264_sei.c | 30 +--
libavcodec/h264_sei.h | 2 +
libavcodec/h264_slice.c | 14
tests/ref/fate/mov-zombie | 195 ++
4 files changed, 171 insertions(+), 70 deletions(-)
d
From: Limin Wang
Signed-off-by: Limin Wang
---
doc/APIchanges | 3 +++
libavutil/frame.c | 1 +
libavutil/frame.h | 8
libavutil/version.h | 2 +-
4 files changed, 13 insertions(+), 1 deletion(-)
diff --git a/doc/APIchanges b/doc/APIchanges
index 3c24dc6..8af9005 100644
--- a
---
doc/bitstream_filters.texi | 5 ++
libavcodec/h265_metadata_bsf.c | 106 +++--
2 files changed, 105 insertions(+), 6 deletions(-)
diff --git a/doc/bitstream_filters.texi b/doc/bitstream_filters.texi
index 8fe5b3ad75..abd20e19d5 100644
--- a/doc/bitstream_filt
On Wed, Jan 08, 2020 at 16:32:39 +0900, Ted Lee wrote:
> Dear FFmpeg developers,
> I'm glad to have a chance to contribute to FFmpeg.
Welcome.
> *Summary:*
>
>- Test signal: 790_pomnyun_taebaek2.mp3
> - MP3 file with the same left channel and right channel except for
> the first 7
Thanks for your feedback.
@item vps_id_offset
@item sps_id_offset
@item pps_id_offset
Replace the original VPS/SPS/PPS identifier by adding an offset.
Offset sounds just as good to me. Is this clear?
On Wed, Jan 8, 2020 at 4:46 PM Moritz Barsnick wrote:
> On Wed, Jan 08, 2020 at 15:42:09 +0100
> -Ursprüngliche Nachricht-
> Von: ffmpeg-devel Im Auftrag von Moritz
> Barsnick
> Gesendet: Mittwoch, 8. Januar 2020 15:25
> An: FFmpeg development discussions and patches
> Betreff: [SCISYS Possible Spam] Re: [FFmpeg-devel] [PATCH v6] avformat/mov:
> Memory optimization with QuickTime/M
On Wed, Jan 08, 2020 at 15:42:09 +0100, Anton Khirnov wrote:
> If negative values are allowed, then 'offset' would be more accurate.
That's the word I was looking for, nice. Even valid if only positive
offsets are allowed. (I understand you implemented wrap-around. Perhaps
sufficient to write that
It's limited to [0 - 16] (positive)
On Wed, Jan 8, 2020 at 4:42 PM Anton Khirnov wrote:
> Quoting Eran Gonen (2020-01-08 15:25:20)
> > I will fix the style and documentation and resubmit.
> > { "increase_vps_id", "Increase the vps id",
> > Is this naming more clear to you?
>
> If negative values
On Wed, Jan 08, 2020 at 16:25:20 +0200, Eran Gonen wrote:
> { "increase_vps_id", "Increase the vps id",
> Is this naming more clear to you?
If that's what it does, then this is indeed clearer to me.
But since it's not boolean, it's a number, it should perhaps reflect
that. I can't come up with so
Quoting Eran Gonen (2020-01-08 15:25:20)
> I will fix the style and documentation and resubmit.
> { "increase_vps_id", "Increase the vps id",
> Is this naming more clear to you?
If negative values are allowed, then 'offset' would be more accurate.
--
Anton Khirnov
___
On Wed, Jan 08, 2020 at 13:26:35 +, Jörg Beckmann wrote:
> Invents a new option "discard_fragments" for the MP4/Quicktime/MOV decoder.
Strictly speaking, it's a demuxer and not a decoder. ;-)
> If this option is set to "on", old fragments are discarded as far as possible
> on each call to swi
I will fix the style and documentation and resubmit.
{ "increase_vps_id", "Increase the vps id",
Is this naming more clear to you?
On Wed, Jan 8, 2020 at 4:18 PM Moritz Barsnick wrote:
> On Wed, Jan 08, 2020 at 16:10:12 +0200, Eran Gonen wrote:
> > Advance pps id means advance pps id. What would
On Wed, Jan 08, 2020 at 16:10:12 +0200, Eran Gonen wrote:
> Advance pps id means advance pps id. What would you suggest?
You mean, mathematically speaking, "increase"?
You didn't fix the "if(" -> "if (" style isse.
And as Hendrik mentioned (I missed that originally): The
"hevc_metadata" section
It would, I'll change it.
Thanks,
Eran
On Wed, Jan 8, 2020 at 3:32 PM Andreas Rheinhardt <
andreas.rheinha...@gmail.com> wrote:
> On Wed, Jan 8, 2020 at 2:18 PM Eran Gonen
> wrote:
>
> > ---
> > libavcodec/h265_metadata_bsf.c | 117 +++--
> > 1 file changed, 111 ins
Advance pps id means advance pps id. What would you suggest?
On Wed, Jan 8, 2020 at 4:04 PM Hendrik Leppkes wrote:
> On Wed, Jan 8, 2020 at 2:18 PM Eran Gonen
> wrote:
> > @@ -547,6 +642,16 @@ static const AVOption h265_metadata_options[] = {
> > OFFSET(crop_bottom), AV_OPT_TYPE_INT,
>
On Wed, Jan 8, 2020 at 2:18 PM Eran Gonen wrote:
> @@ -547,6 +642,16 @@ static const AVOption h265_metadata_options[] = {
> OFFSET(crop_bottom), AV_OPT_TYPE_INT,
> { .i64 = -1 }, -1, HEVC_MAX_HEIGHT, FLAGS },
>
> +{ "advance_vps_id", "Advance the vps id",
> +OFFSET(ad
On Wed, Jan 08, 2020 at 06:07:29AM +0100, Anton Khirnov wrote:
> Quoting lance.lmw...@gmail.com (2020-01-07 06:03:48)
> > From: Limin Wang
> >
> > Signed-off-by: Limin Wang
> > ---
> > doc/APIchanges | 3 +++
> > libavutil/frame.c | 1 +
> > libavutil/frame.h | 8
> > libavuti
Default to use multiplication factors for Main profile.
Introduced since cd3578a8e4e11e0ba021e621367a7974d6de5da0.
Fixed the notation at the same time.
Signed-off-by: Linjie Fu
---
libavcodec/h265_profile_level.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavcode
On Wed, Jan 8, 2020 at 2:18 PM Eran Gonen wrote:
> ---
> libavcodec/h265_metadata_bsf.c | 117 +++--
> 1 file changed, 111 insertions(+), 6 deletions(-)
>
> diff --git a/libavcodec/h265_metadata_bsf.c
> b/libavcodec/h265_metadata_bsf.c
> index b3a1fda144..796046ac7f 1
Invents a new option "discard_fragments" for the MP4/Quicktime/MOV decoder.
If this option is set to "on", old fragments are discarded as far as possible
on each call to switch_root(). If set to "off", nothing changes at all. If set
to "auto" (the default), this function is turned on for streams c
---
libavcodec/h265_metadata_bsf.c | 117 +++--
1 file changed, 111 insertions(+), 6 deletions(-)
diff --git a/libavcodec/h265_metadata_bsf.c b/libavcodec/h265_metadata_bsf.c
index b3a1fda144..796046ac7f 100644
--- a/libavcodec/h265_metadata_bsf.c
+++ b/libavcodec/h265
> -Original Message-
> From: ffmpeg-devel On Behalf Of Mark
> Thompson
> Sent: Tuesday, January 7, 2020 8:07 AM
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH v2 1/2] configure: Change the configure
> check for tonemap_vaapi
>
> On 30/12/2019 07:32, Xinpeng Sun wrote:
On Wed, 8 Jan 2020, Jörg Beckmann wrote:
-Ursprüngliche Nachricht-
Von: ffmpeg-devel Im Auftrag von Martin
Storsjö
Gesendet: Mittwoch, 8. Januar 2020 12:39
An: FFmpeg development discussions and patches
Betreff: Re: [FFmpeg-devel] Patch "configure: Check for the SetDllDirectory and
Get
> -Ursprüngliche Nachricht-
> Von: ffmpeg-devel Im Auftrag von Martin
> Storsjö
> Gesendet: Mittwoch, 8. Januar 2020 12:39
> An: FFmpeg development discussions and patches
> Betreff: Re: [FFmpeg-devel] Patch "configure: Check for the SetDllDirectory
> and
> GetModuleHandle functions" by
On Wed, 8 Jan 2020, Jörg Beckmann wrote:
Hi,
with this patch, FFmpeg does not compile for me on Cygwin anymore:
---
fftools/cmdutils.c: In function 'get_preset_file':
fftools/cmdutils.c:2043:22: error: 'MAX_PATH' undeclared (first use in this
function); did
After 06ec9c4746ebc1d3b613c1847e434bbd0b4407b4 we check for these
functions in configure (which will succeed in cygwin), but cmdutils.c
only includes windows.h if _WIN32 is defined (which it isn't in cygwin).
Retain the old intent from before 06ec9c4746ebc1d3b613c1847e434bbd0b4407b4,
that these fu
On Tue, Jan 07, 2020 at 15:24:53 +0200, Eran Gonen wrote:
> Thanks, I will fix that. What's the formatter parameters for that? (AStyle
> or other)
See https://www.ffmpeg.org/developer.html#Coding-Rules-1
$ indent -i4 -kr -nut
(approximately)
I haven't used astyle so much (only trial-and-error), b
On Tue, Jan 7, 2020 at 4:49 AM Zhong Li wrote:
> Haven't tested but patch LGTM
>
Thanks Li for the feedback.
>
> Asaf Kave 于2019年12月29日周日 下午10:08写道:
> >
> > ---
> > libavcodec/hevc_refs.c | 15
> > libavcodec/hevcdec.c | 173 -
> > libavcodec/h
On Wed, Jan 8, 2020 at 9:12 AM Eran Gonen wrote:
> Would it make more sense if I'll change it to advance sps id? offering no
> risk for multiple ps
>
>
That would be safe (if you reduce the id modulo the number of allowed
values afterwards).
- Andreas
PS: Avoid top-posting on this list.
___
Would it make more sense if I'll change it to advance sps id? offering no
risk for multiple ps
On Tue, Jan 7, 2020 at 3:54 PM Eran Gonen wrote:
> Hi,
> This filter allows editing hevc headers and change metadata. Most
> modifications doesn't make sense for all multiple PS streams (even if they
>
70 matches
Mail list logo