On Wed, May 04, 2016 at 05:07:10AM +0200, Michael Niedermayer wrote:
> doesnt this require an update to teh docs ?
Indeed, thanks for commenting.
But I wonder how should I format reference to "aspect" correctly and pretty.
Now I have come up with this, which I think is not perfect. Any help is v
> -const char aux_data[] = LIBAVCODEC_IDENT;
> +const char *aux_data = avctx->flags & AV_CODEC_FLAG_BITEXACT ?
> + NULL : LIBAVCODEC_IDENT;
> const int aux_data_size = sizeof(aux_data);
> const int header_size = 100 + aux_data_size;
> int64_t max_fra
Odd. I know I’m not doing this right, I’m not versed in git yet, I’m stuck in
oldschool land with svn and cvs ideals..
[administrator@dev ffmpeg]$ git pull
Already up-to-date.
[administrator@dev ffmpeg]$ git diff > ../src_movie.c.diff.new
[administrator@dev ffmpeg]$ rm libavfilter/src_movie.c
[
On Wed, May 04, 2016 at 03:06:31AM +0300, Andrey Utkin wrote:
> It is impossible to pass "aspect" parameter to encoder from ffmpeg CLI
> because option from lavc/options_table.h is eclipsed by option with same
> name in ffmpeg_opt.c, which has different meaning (DAR, not SAR).
> ---
>
> v2: Update
On 5/3/2016 9:39 PM, Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
> libavcodec/vc2enc.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/libavcodec/vc2enc.c b/libavcodec/vc2enc.c
> index 943198b..6226558 100644
> --- a/libavcodec/vc2enc.c
> ++
On Wed, May 04, 2016 at 01:39:21AM +0100, Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
> libavcodec/vc2enc.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/libavcodec/vc2enc.c b/libavcodec/vc2enc.c
> index 943198b..6226558 100644
> --- a/lib
On Wed, May 04, 2016 at 12:15:26AM +, Felt, Patrick wrote:
> Afternoon all,
> I apologize if this isn’t right way to submit a patch. Attached is a patch
> for src_movie.c that modifies it to allow for one to use the
> process_command() infrastructure to swap the input file on the fly. I’ve
On Tue, May 03, 2016 at 08:58:07PM -0400, Ronald S. Bultje wrote:
> Hi,
>
> On Tue, May 3, 2016 at 8:29 PM, Michael Niedermayer
> wrote:
>
> > On Tue, May 03, 2016 at 03:21:00PM -0400, Ronald S. Bultje wrote:
> > > I have no idea why the first hunk uses ost->enc_ctx, because as far as
> > > I un
On 3 May 2016 at 18:25, Christophe Gisquet
wrote:
> 2016-05-03 19:06 GMT+02:00 Christophe Gisquet <
> christophe.gisq...@gmail.com>:
> > +memset(pb->buf_ptr, 0, pad_c);
>
> Commit squashing fail, attached patch should fix that. This
> unfortunately requires updating the fate tests as I ge
Hi,
On Tue, May 3, 2016 at 8:29 PM, Michael Niedermayer
wrote:
> On Tue, May 03, 2016 at 03:21:00PM -0400, Ronald S. Bultje wrote:
> > I have no idea why the first hunk uses ost->enc_ctx, because as far as
> > I understand, that is never used in case of -c:v copy, but this code
> > block is only
Signed-off-by: Rostislav Pehlivanov
---
libavcodec/vc2enc.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/libavcodec/vc2enc.c b/libavcodec/vc2enc.c
index 943198b..6226558 100644
--- a/libavcodec/vc2enc.c
+++ b/libavcodec/vc2enc.c
@@ -994,7 +994,8 @@ static av_cold int vc2_
On Tue, May 03, 2016 at 03:21:00PM -0400, Ronald S. Bultje wrote:
> I have no idea why the first hunk uses ost->enc_ctx, because as far as
> I understand, that is never used in case of -c:v copy, but this code
> block is only entered if encoding_needed=0, which means stream_copy=1.
when the code w
Afternoon all,
I apologize if this isn’t right way to submit a patch. Attached is a patch
for src_movie.c that modifies it to allow for one to use the process_command()
infrastructure to swap the input file on the fly. I’ve added a few options to
the filter and exposed filename to the process
It is impossible to pass "aspect" parameter to encoder from ffmpeg CLI
because option from lavc/options_table.h is eclipsed by option with same
name in ffmpeg_opt.c, which has different meaning (DAR, not SAR).
---
v2: Updated tests reference results as suggested by Michael Niedermayer.
libavcode
On Tue, May 03, 2016 at 07:26:55PM +0200, Christophe Gisquet wrote:
> 2016-05-03 19:06 GMT+02:00 Christophe Gisquet :
> [SNIP]
>
> Incorrect padding used (0 instead of 0xFF), fixed in that patch series.
>
> --
> Christophe
> fate/vcodec.mak | 17 -
> ref/vsy
Le 3 mai 2016 22:15, "Rostislav Pehlivanov" a écrit :
>
> On 3 May 2016 at 19:16, Christophe Gisquet
> wrote:
> >
> >
> > Btw, afaik, the padding is 0xFF, so expecting 0 in the buffer there
> > can't do the job.
> >
> >
> I don't get it, you keep saying that the padding must be 0xff yet the
patch
On 3 May 2016 at 19:16, Christophe Gisquet
wrote:
>
>
> Btw, afaik, the padding is 0xFF, so expecting 0 in the buffer there
> can't do the job.
>
>
I don't get it, you keep saying that the padding must be 0xff yet the patch
you posted puts 0x00. Where did you even read that the padding must be
0xf
On 5/2/2016 9:42 PM, foo86 wrote:
> ---
> libavcodec/dca_core.c | 25 ++---
> libavcodec/dca_exss.c | 3 +--
> libavcodec/dca_xll.c | 9 +++--
> libavcodec/dcadec.c | 29 ++---
> libavcodec/dcadec.h | 19 +--
> 5 files changed,
On 3/30/2016 6:23 AM, Carl Eugen Hoyos wrote:
> On Tuesday 29 March 2016 04:31:53 pm Carl Eugen Hoyos wrote:
>> > Hi!
>> >
>> > Could attached maybe fix ticket #5388?
> New patch attached that should improve conformance.
>
> Please comment, Carl Eugen
>
>
> patchmpegtsmpeg.diff
>
>
> diff --gi
Ronald S. Bultje gmail.com> writes:
> > > I have no idea but attached covers this case.
> >
> > Fine with me (although the coding style looks slightly strange).
>
> I agree that coding style should be changed.
I believe it is more readable as it is in the patch (and
is used in many places in F
Michael Niedermayer niedermayer.cc> writes:
> > Subject: [PATCH] lavf/mpegtsenc: Define service_type "HEVC
> > digital television service".
> >
> > Fixes ticket #5455.
>
> should be ok
Patch applied.
Thank you, Carl Eugen
___
ffmpeg-devel mailing
I have no idea why the first hunk uses ost->enc_ctx, because as far as
I understand, that is never used in case of -c:v copy, but this code
block is only entered if encoding_needed=0, which means stream_copy=1.
My point being: review from someone that knows this really well would
be appreciated.
--
Hi,
On Tue, May 3, 2016 at 3:22 PM, wm4 wrote:
> On Tue, 3 May 2016 18:29:44 +0200
> Carl Eugen Hoyos wrote:
>
> > On Tuesday 03 May 2016 06:11:59 pm Ronald S. Bultje wrote:
> > > Hi,
> > >
> > > On Tue, May 3, 2016 at 11:54 AM, Carl Eugen Hoyos
> wrote:
> > > > On Tuesday 03 May 2016 03:04:50
On Tue, 3 May 2016 18:29:44 +0200
Carl Eugen Hoyos wrote:
> On Tuesday 03 May 2016 06:11:59 pm Ronald S. Bultje wrote:
> > Hi,
> >
> > On Tue, May 3, 2016 at 11:54 AM, Carl Eugen Hoyos wrote:
> > > On Tuesday 03 May 2016 03:04:50 pm Ronald S. Bultje wrote:
> > > > > +if (av_pix_f
On Freitag, 22. April 2016 19:09:02 CEST Gerion Entrup wrote:
> Currently on audio tracks:
> Applying option b:a (video bitrate (please use -b:v)) with argument 240k.
>
> but b:a is the recommendation:
> Applying option ab (audio bitrate (please use -b:a)) with argument 240k.
>
> Feel free to cha
On Tue, 3 May 2016 11:17:54 -0400
Richard Kern wrote:
> ping
I could push all patches tomorrow.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
Hi,
2016-05-03 19:24 GMT+02:00 Hendrik Leppkes :
>> +// The reference decoder ignores it, and its typical length is 0
>> +memset(put_bits_ptr(pb), 0, s->prefix_bytes);
>> skip_put_bytes(pb, s->prefix_bytes);
>> +
>
> I don't suppose we have a function to just write zero bytes instead
Hi,
On Tue, May 3, 2016 at 1:49 PM, Ronald S. Bultje wrote:
> ---
> doc/filters.texi | 13
> libavfilter/colorspacedsp.c | 12
> libavfilter/colorspacedsp.h | 6 ++
> libavfilter/colorspacedsp_template.c | 128
> +++
---
doc/filters.texi | 13
libavfilter/colorspacedsp.c | 12
libavfilter/colorspacedsp.h | 6 ++
libavfilter/colorspacedsp_template.c | 128 +++
libavfilter/vf_colorspace.c | 58 +++-
5 files
---
doc/filters.texi | 13
libavfilter/colorspacedsp.c | 12
libavfilter/colorspacedsp.h | 6 ++
libavfilter/colorspacedsp_template.c | 128 +++
libavfilter/vf_colorspace.c | 58 +++-
5 files
On Tue, May 3, 2016 at 7:06 PM, Christophe Gisquet
wrote:
> The slice prefix is 0 in the reference encoder and the decoder ignores it.
> Writing 0 there seems like the best temporary solution.
>
> The padding could have contained uninitialized data, but its standardized
> value
> is 0xFF, hence t
The encoder was leaving uninitialized data in the padding of slices,
while the specs seem to mandate the use of 0xFF. This is also the case
for the slice prefix, but it seems completely unused.
To validate this, classical vsynth encoding/decoding fate tests for
all supported chroma formats are add
The slice prefix is 0 in the reference encoder and the decoder ignores it.
Writing 0 there seems like the best temporary solution.
The padding could have contained uninitialized data, but its standardized value
is 0xFF, hence the memset value.
Overall this allows producing bistreams with no rando
2016-05-03 19:06 GMT+02:00 Christophe Gisquet :
[SNIP]
Incorrect padding used (0 instead of 0xFF), fixed in that patch series.
--
Christophe
From 22ff25711062fb1ca30da1674fd622fd6f81c8e3 Mon Sep 17 00:00:00 2001
From: Christophe Gisquet
Date: Mon, 2 May 2016 21:57:29 +0200
Subject: [PATCH 2/2]
2016-05-03 19:06 GMT+02:00 Christophe Gisquet :
> +memset(pb->buf_ptr, 0, pad_c);
Commit squashing fail, attached patch should fix that. This
unfortunately requires updating the fate tests as I generated them
from this squashing.
--
Christophe
From 3008fd916cca5b9ab22e96536e778d63ba25ed2
hi Ronald,
On Tue, May 3, 2016 at 7:34 AM, Ronald S. Bultje wrote:
> ---
> doc/filters.texi | 13
> libavfilter/colorspacedsp.c | 12
> libavfilter/colorspacedsp.h | 6 ++
> libavfilter/colorspacedsp_template.c | 128
>
On Tue, May 03, 2016 at 02:27:00PM +0200, Carl Eugen Hoyos wrote:
> On Tuesday 03 May 2016 02:22:21 pm Carl Eugen Hoyos wrote:
> > Hi!
> >
> > Please merge or review.
>
> Sorry, new patch attached.
>
> Carl Eugen
> mpegtsenc.c |6 +-
> 1 file changed, 5 insertions(+), 1 deletion(-)
> 22
---
tests/fate/vcodec.mak | 17 -
tests/ref/vsynth/vsynth1-vc2-420p | 4
tests/ref/vsynth/vsynth1-vc2-420p10 | 4
tests/ref/vsynth/vsynth1-vc2-420p12 | 4
tests/ref/vsynth/vsynth1-vc2-422p | 4
tests/ref/vsynth/vsynth1-v
On 02.05.2016 15:53, Michael Niedermayer wrote:
On Sun, May 01, 2016 at 01:42:58PM +0200, Thomas Volkert wrote:
From: Thomas Volkert
---
Changelog | 2 +-
MAINTAINERS| 1 +
libavformat/Makefile | 1 +
libavformat/rtpenc.c | 15 +
li
On Sonntag, 24. April 2016 01:44:51 CEST Michael Niedermayer wrote:
> On Tue, Apr 19, 2016 at 04:37:16PM +0200, Gerion Entrup wrote:
> > On Dienstag, 19. April 2016 13:25:53 CEST Moritz Barsnick wrote:
> > +static int request_frame(AVFilterLink *outlink)
> > +{
> > +AVFilterContext *ctx = outli
On Tuesday 03 May 2016 06:11:59 pm Ronald S. Bultje wrote:
> Hi,
>
> On Tue, May 3, 2016 at 11:54 AM, Carl Eugen Hoyos wrote:
> > On Tuesday 03 May 2016 03:04:50 pm Ronald S. Bultje wrote:
> > > > +if (av_pix_fmt_desc_get(st->codecpar->format)->flags
> > > > && AV_PIX_FMT_FLAG_ALPH
Hi,
On Tue, May 3, 2016 at 11:54 AM, Carl Eugen Hoyos wrote:
> On Tuesday 03 May 2016 03:04:50 pm Ronald S. Bultje wrote:
>
> > > +if (av_pix_fmt_desc_get(st->codecpar->format)->flags
> &&
> > > AV_PIX_FMT_FLAG_ALPHA)
>
> > I think you want s/&&/&/?
>
> Definitely, new patch atta
On Tuesday 03 May 2016 03:04:50 pm Ronald S. Bultje wrote:
> > +if (av_pix_fmt_desc_get(st->codecpar->format)->flags &&
> > AV_PIX_FMT_FLAG_ALPHA)
> I think you want s/&&/&/?
Definitely, new patch attached.
Thank you, Carl Eugen
From 359b2b5a46d8274ac66f9c47a88e2ead25f7479c Mon
ping
> On Apr 27, 2016, at 10:53 AM, Rick Kern wrote:
>
> Updates from code review:
> Have allow_sw for both OS X and iOS
> Changed "entropy" option to "coder" to match libx264
> Updated configure for CONFIG_VT_BT2020 macro
> Bool option usage
> Formatting
>
>
> Rick Kern (12):
> lavc/videoto
On Tue, May 03, 2016 at 03:57:39PM +0200, Michael Niedermayer wrote:
> reverts one hunk from 7966ddfc0bb7ee87dc2606b7b146701db6f6c717
> The new code from 7966ddfc0bb7ee87dc2606b7b146701db6f6c717 only covers
> extradata based SPS
>
> Fixes: ffplay -ss 13 58af5798-fa2c-42a2-997d-dc8e49de2d8a.flv
>
---
doc/filters.texi | 13
libavfilter/colorspacedsp.c | 12
libavfilter/colorspacedsp.h | 6 ++
libavfilter/colorspacedsp_template.c | 128 +++
libavfilter/vf_colorspace.c | 53 ++-
5 files c
Signed-off-by: Michael Niedermayer
---
tests/fate/h264.mak|2 +
tests/ref/fate/h264-brokensps-2580 | 84
2 files changed, 86 insertions(+)
create mode 100644 tests/ref/fate/h264-brokensps-2580
diff --git a/tests/fate/h264.mak b/tests/fa
reverts one hunk from 7966ddfc0bb7ee87dc2606b7b146701db6f6c717
The new code from 7966ddfc0bb7ee87dc2606b7b146701db6f6c717 only covers
extradata based SPS
Fixes: ffplay -ss 13 58af5798-fa2c-42a2-997d-dc8e49de2d8a.flv
Signed-off-by: Michael Niedermayer
---
libavcodec/h264.c | 20 ++
From: Jan Sebechlebsky
TeeSlave.bsfs is array of pointers to AVBitStreamFilterContext,
so element size should be really size of a pointer, not size
of TeeSlave structure.
Signed-off-by: Jan Sebechlebsky
---
I've rewritten sizeof as suggested :)
libavformat/tee.c | 2 +-
1 file changed, 1 ins
---
Updated detection algorithm.
libavformat/dtsdec.c | 47 ---
1 file changed, 40 insertions(+), 7 deletions(-)
diff --git a/libavformat/dtsdec.c b/libavformat/dtsdec.c
index ef28391..702a417 100644
--- a/libavformat/dtsdec.c
+++ b/libavformat/dtsdec
Hi,
On Tue, May 3, 2016 at 4:18 AM, Carl Eugen Hoyos wrote:
> On Monday 02 May 2016 08:57:31 pm wm4 wrote:
> > On Mon, 2 May 2016 08:36:16 -0400
> >
> > "Ronald S. Bultje" wrote:
> > > Hi,
> > >
> > > On Mon, May 2, 2016 at 5:49 AM, Carl Eugen Hoyos
> wrote:
> > > > On Wednesday 13 April 2016
On Tuesday 03 May 2016 02:22:21 pm Carl Eugen Hoyos wrote:
> Hi!
>
> Please merge or review.
Sorry, new patch attached.
Carl Eugen
From 82b71db1a741578341599bbfea632f8131b0f28f Mon Sep 17 00:00:00 2001
From: smallishzulu
Date: Tue, 3 May 2016 14:25:22 +0200
Subject: [PATCH] lavf/mpegtsenc: Defin
Hi!
Please merge or review.
Carl Eugen
From 4d6b1a89da80419ec3ae32289c03ec55803760e4 Mon Sep 17 00:00:00 2001
From: smallishzulu
Date: Tue, 3 May 2016 14:19:23 +0200
Subject: [PATCH] lavf/mpegtsenc: Define service_type "HEVC digital television
service".
Fixes ticket #5455.
---
libavformat/mpe
Carl Eugen Hoyos ag.or.at> writes:
> Attached patch fixes ticket #5174, there seems to be nothing
> invalid about a cursor outside of the screen or an empty cursor.
Pushed, and ticket closed.
Carl Eugen
___
ffmpeg-devel mailing list
ffmpeg-devel@ffm
Michael Niedermayer niedermayer.cc> writes:
> > mpegtsenc.c |7 ++-
> > 1 file changed, 6 insertions(+), 1 deletion(-)
> > 8097182ebab7bd4a96a32ccc1996f2f7b97cf97d patchmpegtsmpeg.diff
> > diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c
> > index 51677ea..29bccb5 100644
>
On 5/3/16, Carl Eugen Hoyos wrote:
> Paul B Mahol gmail.com> writes:
>
>> >> > So how should this be implemented?
>> >>
>> >> Perhaps predictor, if too big should be just clipped.
>> >
>> > Why do you think there is a too big predictor?
>> > Two additional bytes are inserted at the beginning of
>
On Mon, May 02, 2016 at 09:43:20AM +0200, Hendrik Leppkes wrote:
> On Mon, May 2, 2016 at 2:54 AM, Michael Niedermayer
> wrote:
> > This also switches the public git URL to use the same server as ffmpeg-web
> > & fateserver git
> > That way all git server URLs are also much more consistent
>
> L
Dnia 3 maja 2016 11:54 Piotr Bandurski napisał(a):
>
> > Hi,
>
> > as long as we are throwing out questions.
> >
> > the m70x stuff is similar to m10x . and uses same binary codec:
> >
> > VIDC.M101=mvcVfw.dll VFW M101 Matrox Uncompressed SD
> > VIDC.m102=mvcVfwHD.dll Matrox Uncompresse
Hi,
> as long as we are throwing out questions.
>
> the m70x stuff is similar to m10x . and uses same binary codec:
>
> VIDC.M101=mvcVfw.dll VFW M101 Matrox Uncompressed SD
> VIDC.m102=mvcVfwHD.dll Matrox Uncompressed HD
> VIDC.m103=mvcVfwYUVA.dll Matrox Uncompressed SD + Alpha
> VIDC.m104=mvcV
Paul B Mahol gmail.com> writes:
> >> > So how should this be implemented?
> >>
> >> Perhaps predictor, if too big should be just clipped.
> >
> > Why do you think there is a too big predictor?
> > Two additional bytes are inserted at the beginning of
> > every frame.
> > Should the demuxer be pat
On 5/3/16, Carl Eugen Hoyos wrote:
> Paul B Mahol gmail.com> writes:
>
>> On 5/3/16, Carl Eugen Hoyos ag.or.at> wrote:
>> > Paul B Mahol gmail.com> writes:
>> >
>> >> > I added the following comment locally:
>> >> > // Levana Ovia Baby Monitor prepends each audio
>> >> > frame with these two by
Matthias Hunstock fem.tu-ilmenau.de> writes:
> Am 28.04.2016 um 17:27 schrieb Carl Eugen Hoyos:
>
> > I hope attached patch fixes an issue seen in a decklink user
> > report where the bit_rate was negative.
> I'd really like to reproduce and have a further look.
This is all information I have
Hendrik Leppkes gmail.com> writes:
> EAC3 is indeed a registered type, please do try to confirm
> next time before sending such patches.
> You can look them up here:
> https://smpte-ra.org/registered-mpeg-ts-ids
Thank you for the link, patch applied.
Carl Eugen
___
On Tue, May 3, 2016 at 10:03 AM, Carl Eugen Hoyos wrote:
> Hi!
>
> Attached patch does not fix ticket #5501 but it helps the user by producing a
> useful warning message that suggests to increase analyeduration to allow
> decoding (this is not possible without the patch).
> The file starts with 13
Paul B Mahol gmail.com> writes:
> On 5/3/16, Carl Eugen Hoyos ag.or.at> wrote:
> > Paul B Mahol gmail.com> writes:
> >
> >> > I added the following comment locally:
> >> > // Levana Ovia Baby Monitor prepends each audio
> >> > frame with these two bytes
> >>
> >> Sorry, life sucks. This patch
On 5/3/16, Carl Eugen Hoyos wrote:
> Paul B Mahol gmail.com> writes:
>
>> > I added the following comment locally:
>> > // Levana Ovia Baby Monitor prepends each audio frame
>> > with these two bytes
>>
>> Sorry, life sucks. This patch is unacceptable.
>
> So how should this be implemented?
Perh
On Monday 02 May 2016 08:57:31 pm wm4 wrote:
> On Mon, 2 May 2016 08:36:16 -0400
>
> "Ronald S. Bultje" wrote:
> > Hi,
> >
> > On Mon, May 2, 2016 at 5:49 AM, Carl Eugen Hoyos wrote:
> > > On Wednesday 13 April 2016 10:27:03 am you wrote:
> > > > Maybe it should just check whether the pixel forma
Am 28.04.2016 um 17:27 schrieb Carl Eugen Hoyos:
> I hope attached patch fixes an issue seen in a decklink user report where
> the bit_rate was negative. Or should the division be changed to 1ULL/...?
> Completely untested.
>
> Please review, Carl Eugen
It seems that av_image_get_buffer_size
Paul B Mahol gmail.com> writes:
> > I added the following comment locally:
> > // Levana Ovia Baby Monitor prepends each audio frame
> > with these two bytes
>
> Sorry, life sucks. This patch is unacceptable.
So how should this be implemented?
Carl Eugen
_
Hi!
Attached patch does not fix ticket #5501 but it helps the user by producing a
useful warning message that suggests to increase analyeduration to allow
decoding (this is not possible without the patch).
The file starts with 13MB "header" that breaks auto-detection.
I did not check any specif
On 5/1/16, Christophe Gisquet wrote:
> 2016-05-01 15:33 GMT+02:00 Christophe Gisquet
> :
>> This is done by actually handling the "prev_values" in the cascaded LMS
>> data
>> as if it were int16_t, thus requiring switching at various locations the
>> computations.
>
> Patch update since Michael's
71 matches
Mail list logo