Re: [PATCH 1/4] usb: cdns3: gadget: Replace trace_printk by dev_dbg

2020-07-24 Thread Felipe Balbi
Nicolas Boichat writes: > On Thu, Jul 23, 2020 at 9:17 PM Felipe Balbi wrote: >> >> Nicolas Boichat writes: >> >> > trace_printk should not be used in production code, replace it >> > call with dev_dbg. >> > >> > Signed-off-by: Nicolas Boichat >> > >> > --- >> > >> > Unclear why a trace_printk

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit Bharadwaj
On 24/07/20 10:06 am, Rohit K Bharadwaj wrote: > changed usage of slave (deprecated) to secondary > > Signed-off-by: Rohit K Bharadwaj > --- > v3: change patch subject, add version history > v2: add changelog text in body of mail > v1: fix style issues by changing usage of slave to secondary > >

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Greg KH
On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharadwaj wrote: > On 24/07/20 10:06 am, Rohit K Bharadwaj wrote: > > changed usage of slave (deprecated) to secondary > > > > Signed-off-by: Rohit K Bharadwaj > > --- > > v3: change patch subject, add version history > > v2: add changelog text in b

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit Bharadwaj
On 24/07/20 1:58 pm, Greg KH wrote: > On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharadwaj wrote: >> On 24/07/20 10:06 am, Rohit K Bharadwaj wrote: >>> changed usage of slave (deprecated) to secondary >>> >>> Signed-off-by: Rohit K Bharadwaj >>> --- >>> v3: change patch subject, add version h

Re: [PATCH] staging: octeon: Indent with tabs instead of spaces

2020-07-24 Thread Dan Carpenter
On Wed, Jul 22, 2020 at 10:19:50PM +0500, Muhammad Usama Anjum wrote: > Remove a coding style error. It makes code more readable. > > Signed-off-by: Muhammad Usama Anjum > --- This isn't a part of the official style guide so the original is fine. regards, dan carpenter

Re: [RESEND PATCH] media: atomisp: Replace trace_printk by pr_info

2020-07-24 Thread Nicolas Boichat
On Fri, Jul 10, 2020 at 3:03 PM Greg Kroah-Hartman wrote: > > On Fri, Jul 10, 2020 at 02:45:29PM +0800, Nicolas Boichat wrote: > > trace_printk should not be used in production code, replace it > > call with pr_info. > > > > Signed-off-by: Nicolas Boichat > > --- > > Sent this before as part of a

[PATCH] Staging: rtl8188eu: rtw_mlme: Fix uninitialized variable authmode

2020-07-24 Thread Dinghao Liu
The variable authmode will keep uninitialized if neither if statements used to initialize this variable are not triggered. Then authmode may contain a garbage value and influence the execution flow of this function. Fix this by initializing it to zero. Signed-off-by: Dinghao Liu --- drivers/sta

[PATCH 1/6] drivers: android: Fix a variable declaration coding style issue

2020-07-24 Thread Mrinal Pandey
Add a blank line after variable declarations as suggested by checkpatch. Signed-off-by: Mrinal Pandey --- drivers/android/binder_alloc.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c index 42c672f1584e..0294cef7402c 100644 ---

[PATCH 2/6] drivers: android: Remove the use of else after return

2020-07-24 Thread Mrinal Pandey
Remove the unnecessary else branch after return statement as suggested by checkpatch. Signed-off-by: Mrinal Pandey --- drivers/android/binder.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index f50c5f182bb5..5fdf982ec8

[PATCH 3/6] drivers: android: Remove braces for a single statement if-else block

2020-07-24 Thread Mrinal Pandey
Remove braces for both if and else block as suggested by checkpatch. Signed-off-by: Mrinal Pandey --- drivers/android/binder.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index 5fdf982ec83b..3cf13ff16934 100644 ---

[PATCH 6/6] drivers: android: Fix the SPDX comment style

2020-07-24 Thread Mrinal Pandey
C source files should have `//` as SPDX comment and not `/**/`. Fix this by running checkpatch on the file. Signed-off-by: Mrinal Pandey --- drivers/android/binderfs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/android/binderfs.c b/drivers/android/binderfs.c inde

[PATCH 4/6] drivers: android: Fix a variable declaration coding style issue

2020-07-24 Thread Mrinal Pandey
Add a blank line after variable declarations as suggested by checkpatch. Signed-off-by: Mrinal Pandey --- drivers/android/binder.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index 3cf13ff16934..75832f236bf9 100644 --- a/drivers/android

[PATCH 5/6] drivers: android: Fix a variable declaration coding style issue

2020-07-24 Thread Mrinal Pandey
Add a blank line after variable declarations as suggested by checkpatch. Signed-off-by: Mrinal Pandey --- drivers/android/binderfs.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/android/binderfs.c b/drivers/android/binderfs.c index 7cf566aafe1f..8a98a36ff71a 100644 --- a/drivers/a

Re: [PATCH] Staging: rtl8188eu: rtw_mlme: Fix uninitialized variable authmode

2020-07-24 Thread Greg Kroah-Hartman
On Fri, Jul 24, 2020 at 08:29:55PM +0800, Dinghao Liu wrote: > The variable authmode will keep uninitialized if neither if > statements used to initialize this variable are not triggered. > Then authmode may contain a garbage value and influence the > execution flow of this function. > > Fix this

Re: [PATCH] change slave occurence to secondary everywhere

2020-07-24 Thread Dan Carpenter
On Thu, Jul 23, 2020 at 08:28:11PM +0530, Rohit K Bharadwaj wrote: > @@ -744,7 +744,7 @@ static void tegra_init_i2c_slave(struct nvec_chip *nvec) > } > > #ifdef CONFIG_PM_SLEEP > -static void nvec_disable_i2c_slave(struct nvec_chip *nvec) > +static void nvec_disable_i2c_secondary(struct nvec_ch

Re: [PATCH] change slave occurence to secondary everywhere

2020-07-24 Thread Dan Carpenter
The patch prefix isn't right. On Thu, Jul 23, 2020 at 08:45:13PM +0530, Rohit K Bharadwaj wrote: > changed usage of slave (deprecated) to secondary > > Signed-off-by: Rohit K Bharadwaj > --- > drivers/staging/nvec/nvec.c | 12 ++-- > 1 file changed, 6 insertions(+), 6 deletions(-) > >

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Dan Carpenter
On Fri, Jul 24, 2020 at 10:06:34AM +0530, Rohit K Bharadwaj wrote: > @@ -784,7 +784,7 @@ static int tegra_nvec_probe(struct platform_device *pdev) > platform_set_drvdata(pdev, nvec); > nvec->dev = dev; > > - if (of_property_read_u32(dev->of_node, "slave-addr", &nvec->i2c_addr)) {

[staging:staging-testing] BUILD SUCCESS b5dbbadb0eb93aaca51d5effeed96b94af150e07

2020-07-24 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing branch HEAD: b5dbbadb0eb93aaca51d5effeed96b94af150e07 Staging: rtl8188eu: Fix a constant comparison coding style issue elapsed time: 952m configs tested: 74 configs skipped: 1 The following config

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit K Bharadwaj
On 24/07/20 7:39 pm, Dan Carpenter wrote: > On Fri, Jul 24, 2020 at 10:06:34AM +0530, Rohit K Bharadwaj wrote: >> @@ -784,7 +784,7 @@ static int tegra_nvec_probe(struct platform_device *pdev) >> platform_set_drvdata(pdev, nvec); >> nvec->dev = dev; >> >> -if (of_property_read_u32(de

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Greg KH
On Fri, Jul 24, 2020 at 09:21:47PM +0530, Rohit K Bharadwaj wrote: > On 24/07/20 7:39 pm, Dan Carpenter wrote: > > On Fri, Jul 24, 2020 at 10:06:34AM +0530, Rohit K Bharadwaj wrote: > >> @@ -784,7 +784,7 @@ static int tegra_nvec_probe(struct platform_device > >> *pdev) > >>platform_set_drvdata

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Marc Dietrich
Hi Rohit, On Fri, 24 Jul 2020, Rohit Bharadwaj wrote: On 24/07/20 1:58 pm, Greg KH wrote: On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharadwaj wrote: On 24/07/20 10:06 am, Rohit K Bharadwaj wrote: changed usage of slave (deprecated) to secondary Signed-off-by: Rohit K Bharadwaj --- v3

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Marc Dietrich
On Fri, 24 Jul 2020, Marc Dietrich wrote: Hi Rohit, On Fri, 24 Jul 2020, Rohit Bharadwaj wrote: On 24/07/20 1:58 pm, Greg KH wrote: On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharadwaj wrote: On 24/07/20 10:06 am, Rohit K Bharadwaj wrote: changed usage of slave (deprecated) to seco

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit K Bharadwaj
On 24/07/20 10:06 pm, Marc Dietrich wrote: > > > On Fri, 24 Jul 2020, Marc Dietrich wrote: > >> Hi Rohit, >> >> On Fri, 24 Jul 2020, Rohit Bharadwaj wrote: >> >>> On 24/07/20 1:58 pm, Greg KH wrote: On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharadwaj wrote: > On 24/07/20 10:06 am,

[driver-core:driver-core-testing] BUILD SUCCESS a24c6f7bc923d5e2f3139855eb09b0d480d6b410

2020-07-24 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git driver-core-testing branch HEAD: a24c6f7bc923d5e2f3139855eb09b0d480d6b410 debugfs: Add access restriction option elapsed time: 1338m configs tested: 74 configs skipped: 1 The following configs have been buil

Re: [PATCH] Staging: rtl8188eu: rtw_mlme: Fix uninitialized variable authmode

2020-07-24 Thread Larry Finger
On 7/24/20 8:28 AM, Dinghao Liu wrote: The variable authmode will keep uninitialized if neither if statements used to initialize this variable are not triggered. Besides Greg's comment, you need to re-parse this sentence. I realize that English is probably not your first language, but this one

[PATCH] Fix coding style issues

2020-07-24 Thread Anant Thazhemadam
Coding style issues found were rectified Signed-off-by: Anant Thazhemadam --- drivers/staging/rtl8188eu/core/rtw_security.c | 92 ++- 1 file changed, 47 insertions(+), 45 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_security.c b/drivers/staging/rtl8188eu/core/rt

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Marc Dietrich
Hi Rohit, On Fri, 24 Jul 2020, Rohit K Bharadwaj wrote: On 24/07/20 10:06 pm, Marc Dietrich wrote: On Fri, 24 Jul 2020, Marc Dietrich wrote: Hi Rohit, On Fri, 24 Jul 2020, Rohit Bharadwaj wrote: On 24/07/20 1:58 pm, Greg KH wrote: On Fri, Jul 24, 2020 at 01:44:27PM +0530, Rohit Bharad

[PATCH v9 08/12] device core: Introduce DMA range map, supplanting dma_pfn_offset

2020-07-24 Thread Jim Quinlan
The new field 'dma_range_map' in struct device is used to facilitate the use of single or multiple offsets between mapping regions of cpu addrs and dma addrs. It subsumes the role of "dev->dma_pfn_offset" which was only capable of holding a single uniform offset and had no region bounds checking.

[PATCH v9 00/12] PCI: brcmstb: enable PCIe for STB chips

2020-07-24 Thread Jim Quinlan
Patchset Summary: Enhance a PCIe host controller driver. Because of its unusual design we are foced to change dev->dma_pfn_offset into a more general role allowing multiple offsets. See the 'v1' notes below for more info. NOTE: ChristophH wanted the dma_set_offset_range() function

Re: [PATCH] Fix coding style issues

2020-07-24 Thread Greg Kroah-Hartman
On Sat, Jul 25, 2020 at 01:55:19AM +0530, Anant Thazhemadam wrote: > Coding style issues found were rectified > > Signed-off-by: Anant Thazhemadam > --- > drivers/staging/rtl8188eu/core/rtw_security.c | 92 ++- > 1 file changed, 47 insertions(+), 45 deletions(-) > > diff --git a

RE

2020-07-24 Thread Mrs. Maureen Hinckley
I am Maureen Hinckley and my foundation is donating (Five hundred and fifty thousand USD) to you. Contact us via my email at (maurhin...@gmail.com) for further details. Best Regards, Mrs. Maureen Hinckley, Copyright ©2020 The Maureen Hinckley Foundation All Rights Reserved. ___

[PATCH v4] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit K Bharadwaj
changed usage of slave (which is deprecated) to secondary without breaking the driver Tested-by: Dan Carpenter Acked-by: Marc Dietrich Signed-off-by: Rohit K Bharadwaj --- v4: undo the changes (which broke the driver) to this line: if (of_property_read_u32(dev->of_node, "slave-addr", &nvec->i

Re: [PATCH v3] staging: nvec: change usage of slave to secondary

2020-07-24 Thread Rohit K Bharadwaj
On 25/07/20 2:12 am, Marc Dietrich wrote: > > Hi Rohit, > > On Fri, 24 Jul 2020, Rohit K Bharadwaj wrote: > >> On 24/07/20 10:06 pm, Marc Dietrich wrote: >>> >>> >>> On Fri, 24 Jul 2020, Marc Dietrich wrote: >>> Hi Rohit, On Fri, 24 Jul 2020, Rohit Bharadwaj wrote: > On 2