On Thu, 26 Mar 2020, Simran Singhal wrote:
> Some functions like kmalloc/kzalloc return NULL on failure.
> When NULL represents failure, !x is commonly used.
Try for a shorter subject line. "Simplify NULL tests" would do. Then the
log message should be in the imperative.
julia
>
> This wa
writes:
> From: Ajay Singh
>
> Remove labels and not relevant property from DT binding documentation
> examples as suggested in [1].
>
> 1. https://patchwork.ozlabs.org/patch/1252837
Just a nitpick but patchwork links are not that reliable in the long
run. Instead using a lore link is better as
It's old, obsolete, and no one wants to take care of it anymore.
It's been in staging for 5 months with no one paying attention to it, so
let's just delete it for now.
If someone has this hardware, and wants the driver back, the deletion
can be easily reverted.
Cc: Joe Perches
Cc: Jaroslav Kyse
Hi Kalle,
On 26/03/20 1:15 pm, Kalle Valo wrote:
>
> writes:
>
>> From: Ajay Singh
>>
>> Remove labels and not relevant property from DT binding documentation
>> examples as suggested in [1].
>>
>> 1. https://patchwork.ozlabs.org/patch/1252837
>
> Just a nitpick but patchwork links are not th
Em Thu, 26 Mar 2020 00:13:43 +0200
Laurent Pinchart escreveu:
> Hi Mauro,
>
> On Wed, Mar 25, 2020 at 10:38:20PM +0100, Mauro Carvalho Chehab wrote:
> > Em Wed, 25 Mar 2020 16:36:31 -0300 Helen Koike escreveu:
> > > On 3/25/20 1:03 PM, Mauro Carvalho Chehab wrote:
> > > > That's the second p
Cleanup line over 80 characters by removing unnecessary test
'pDM_Odm->RSSI_Min <= 25'. The above test 'pDM_Odm->RSSI_Min > 25'
already guarantees that it is <= 25.
Signed-off-by: Michael Straube
---
v1 -> v2: Remove 'pDM_Odm->RSSI_Min <= 25' test.
drivers/staging/rtl8188eu/hal/odm.c | 2 +-
1
On 2020-03-26 01:08, Joe Perches wrote:
On Wed, 2020-03-25 at 22:59 +0100, Michael Straube wrote:
Cleanup line over 80 characters by removing unnecessary parentheses.
[]
diff --git a/drivers/staging/rtl8188eu/hal/odm.c
b/drivers/staging/rtl8188eu/hal/odm.c
[]
@@ -590,7 +590,7 @@ void odm
Hi Mauro,
On Thu, Mar 26, 2020 at 09:28:32AM +0100, Mauro Carvalho Chehab wrote:
> Em Thu, 26 Mar 2020 00:13:43 +0200 Laurent Pinchart escreveu:
> > On Wed, Mar 25, 2020 at 10:38:20PM +0100, Mauro Carvalho Chehab wrote:
> > > Em Wed, 25 Mar 2020 16:36:31 -0300 Helen Koike escreveu:
> > > > On 3/
This adds minimal support for accessing the HDMI audio provided through the
I2S port available on ADV7481 and ADV7482 decoder devices by ADI.
The port carries audio signal from the decoded HDMI stream.
Currently, the driver only supports I2S in TDM, 8 channels a 24bit at 48kHz.
Furthermore, only l
Signed-off-by: Alexander Riesen
Reviewed-by: Laurent Pinchart
---
drivers/media/i2c/adv748x/adv748x-core.c | 24
drivers/media/i2c/adv748x/adv748x-csi2.c | 2 +-
2 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/media/i2c/adv748x/adv748x-core.c
b
To follow the established practice of not depending on others to
pull everything in. While at it, make sure it stays like this.
Signed-off-by: Alexander Riesen
Reviewed-by: Laurent Pinchart
---
drivers/media/i2c/adv748x/adv748x-afe.c | 6 ++
drivers/media/i2c/adv748x/adv748x-core.c | 6 ++-
The regmap provides a convenient utility for this.
The hdmi_* and dpll_* register modification macros added for symmetry
with the existing operations (io_*, sdp_*).
Signed-off-by: Alexander Riesen
Reviewed-by: Laurent Pinchart
--
v3: remove _update name in favor of existing _clrset
---
drivers
Signed-off-by: Alexander Riesen
---
drivers/media/i2c/adv748x/adv748x.h | 32 +
1 file changed, 32 insertions(+)
diff --git a/drivers/media/i2c/adv748x/adv748x.h
b/drivers/media/i2c/adv748x/adv748x.h
index 0a9d78c2870b..1a1ea70086c6 100644
--- a/drivers/media/i2c/adv
As there is nothing else (the consumers are supposed to do that) which
enables the clock, do it in the driver.
Signed-off-by: Alexander Riesen
--
v3: added
---
drivers/media/i2c/adv748x/adv748x-dai.c | 14 +-
1 file changed, 13 insertions(+), 1 deletion(-)
diff --git a/drivers/medi
As all known variants of the Salvator board have the HDMI decoder
chip (the ADV7482) connected to the SSI4 on R-Car SoC, the ADV7482
endpoint and the connection definitions are placed in the common board
file.
For the same reason, the CLK_C clock line and I2C configuration (similar
to the ak4613,
To avoid setting it up even if the hardware is not actually connected
to anything physically.
Besides, the bindings explicitly notes that port definitions are
"optional if they are not connected to anything at the hardware level".
Signed-off-by: Alexander Riesen
---
drivers/media/i2c/adv748x/ad
As the driver has some support for the audio interface of the device,
the bindings file should mention it.
Signed-off-by: Alexander Riesen
Reviewed-by: Rob Herring
Reviewed-by: Laurent Pinchart
--
v3: remove optionality off MCLK clock cell to ensure the description
matches the hardware no
This adds an implemention of SoC DAI driver which provides access to the
I2S port of the device.
Signed-off-by: Alexander Riesen
--
v3: fix clock registration in case of multiple adv748x devices
Suggested-by: Geert Uytterhoeven
v4: use clk_hw instead of clk
Suggested-by: Stephen Boyd
Assignment to a typed pointer is sufficient in C.
No cast is needed.
The following Coccinelle script was used to detect this:
@r@
expression x;
void* e;
type T;
identifier f;
@@
(
*((T *)e)
|
((T *)x)[...]
|
((T*)x)->f
|
- (T*)
e
)
Signed-off-by: Simran Singhal
---
drivers/staging/rtl8
Yes, they have the same root cause.
On Thu, Mar 26, 2020 at 6:45 PM Andrey Konovalov wrote:
>
> On Thu, Mar 26, 2020 at 3:52 AM Qiujun Huang wrote:
> >
> > #syz test: https://github.com/google/kasan.git e17994d1
>
> Hi Qiujun,
>
> I've already duped this bug to "KASAN: slab-out-of-bounds Read in
OK, then there's probably no need to test this one, if the other one
was fixed by your patch.
On Thu, Mar 26, 2020 at 12:48 PM Qiujun Huang wrote:
>
> Yes, they have the same root cause.
>
> On Thu, Mar 26, 2020 at 6:45 PM Andrey Konovalov
> wrote:
> >
> > On Thu, Mar 26, 2020 at 3:52 AM Qiujun
Em Thu, 26 Mar 2020 12:13:33 +0200
Laurent Pinchart escreveu:
> > > I'm not sure to follow you. Are you implying that this patch series,
> > > which Helen has tested against a real user, not an experienced kernel
> > > hacker, may make the configuration options more difficult for kernel
> > > hac
We can't handle the case length > WLAN_DATA_MAXLEN.
Because the size of rxfrm->data is WLAN_DATA_MAXLEN(2312), and we can't
read more than that.
Thanks-to: Hillf Danton
Reported-and-tested-by: syzbot+7d42d68643a35f71a...@syzkaller.appspotmail.com
Signed-off-by: Qiujun Huang
---
drivers/staging/
NULL check before kfree is unnecessary so remove it.
The following Coccinelle script was used to detect this:
@@ expression E; @@
- if (E != NULL) { kfree(E); }
+ kfree(E);
@@ expression E; @@
- if (E != NULL) { kfree(E); E = NULL; }
+ kfree(E);
+ E = NULL;
Signed-off-by: Simran Singhal
---
dri
That's a third part of the patch series with improve the media Kconfig
settings.
The entire series is
at:
https://git.linuxtv.org/mchehab/experimental.git/log/?h=media-kconfig
patch 1 addresses a report from Helen that an user might not notice
that drivers are filtered. So, it adds an ex
Most of media Kconfig/Makefile files already has SPDX,
but there are a few ones still missing. Add it to them.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/media/dvb-frontends/Kconfig | 2 ++
drivers/media/mc/Kconfig| 2 ++
drivers/media/platform/sunxi/Kco
From: George Spelvin
The code in lib/ is the desired polynomial, and even includes
the 1-bit left shift in the table rather than needing to code
it explicitly.
While I'm in Kconfig, add a description of what a WILC1000 is.
Kconfig questions that require me to look up a data sheet to
find out tha
On Mon, Mar 23, 2020 at 10:35:18AM +0300, Dan Carpenter wrote:
> On Fri, Mar 20, 2020 at 06:10:56PM +0100, Oscar Carter wrote:
> > -#define RSR_ADDRBROAD 0x80
> > -#define RSR_ADDRMULTI 0x40
> > +#define RSR_ADDRBROAD BIT(7)
> > +#define RSR_ADDRMULTI BIT(6)
> > #define RSR
On Mon, Mar 23, 2020 at 10:32:14AM +0300, Dan Carpenter wrote:
> On Fri, Mar 20, 2020 at 07:13:26PM +0100, Oscar Carter wrote:
> > +#include
> > #include "mac.h"
> > #include "baseband.h"
> > #include "rf.h"
> > @@ -468,7 +469,7 @@ int vnt_vt3184_init(struct vnt_private *priv)
> > i
On Wed, Mar 25, 2020 at 09:19:24AM +, Quentin Deslandes wrote:
> On 03/24/20 16:18:30, Dan Carpenter wrote:
> > That's a bit over engineering something which is pretty trivial.
> > Normally, we would just make the size a define instead of a magic number
> > 14.
>
> My bad, I meant "define", not
Use DIV_ROUND_UP macro instead of specific code with the same purpose.
Also, remove the unused variables.
Signed-off-by: Oscar Carter
---
Changelog v1 -> v2
- Rebase the original patch [1] against the staging-next branch of the greg's
staging.git tree.
[1] https://lore.kernel.org/lkml/202003
On 3/25/20 2:43 PM, Simran Singhal wrote:
Simplify function returns by merging assignment and return into
one command line.
"Simplify function returns by merging assignment and return into one line".
You could change the subject also to "Simplify function return logic".
thanks,
-lakshmi
___
This patch fixes remaining warnings in rtl871x_xmit.c of
rtl8712 staging driver
The following warnings are resolved:
WARNING: line over 80 characters
\#74: FILE: drivers/staging//rtl8712/rtl871x_xmit.c:74:
+ * Please allocate memory with the sz = (struct xmit_frame) *
NR_XMITFRAME,
WARNIN
Buenos días
Os informamos que se encuentra abierto el plazo de inscripción para la
Convocatoria de Cursos Bonificables para empleados (ABRIL 2020).
Todos los cursos son totalmente Bonificables con cargo al Crédito de Formación
2020 que disponen las empresas.
Dada la situación en la que nos e
From: Johan Hovold
[ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
Newer GCC warns about a possible truncation of a generated sysfs path
name as we're concatenating a directory path with a file name and
placing the result in a buffer that is half the size of the maximum
length of th
From: Johan Hovold
[ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
Newer GCC warns about possible truncations of two generated path names as
we're concatenating the configurable sysfs and debugfs path prefixes
with a filename and placing the results in buffers of the same size as
th
From: Jérôme Pouiller
[ Upstream commit bab0a0b03442a62fe3abefcb2169e0b9ff95990c ]
After hif_shutdown(), communication with the chip is no more possible.
It the only request that never reply. Therefore, hif_cmd.lock is never
unlocked. hif_shutdown() unlock itself hif_cmd.lock to avoid a potentia
From: Johan Hovold
[ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
Newer GCC warns about a possible truncation of a generated sysfs path
name as we're concatenating a directory path with a file name and
placing the result in a buffer that is half the size of the maximum
length of th
From: Johan Hovold
[ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
Newer GCC warns about a possible truncation of a generated sysfs path
name as we're concatenating a directory path with a file name and
placing the result in a buffer that is half the size of the maximum
length of th
From: Johan Hovold
[ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
Newer GCC warns about possible truncations of two generated path names as
we're concatenating the configurable sysfs and debugfs path prefixes
with a filename and placing the results in buffers of the same size as
th
From: Johan Hovold
[ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
Newer GCC warns about possible truncations of two generated path names as
we're concatenating the configurable sysfs and debugfs path prefixes
with a filename and placing the results in buffers of the same size as
th
From: Johan Hovold
[ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
Newer GCC warns about a possible truncation of a generated sysfs path
name as we're concatenating a directory path with a file name and
placing the result in a buffer that is half the size of the maximum
length of th
From: Johan Hovold
[ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
Newer GCC warns about a possible truncation of a generated sysfs path
name as we're concatenating a directory path with a file name and
placing the result in a buffer that is half the size of the maximum
length of th
From: Johan Hovold
[ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
Newer GCC warns about possible truncations of two generated path names as
we're concatenating the configurable sysfs and debugfs path prefixes
with a filename and placing the results in buffers of the same size as
th
From: Johan Hovold
[ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
Newer GCC warns about possible truncations of two generated path names as
we're concatenating the configurable sysfs and debugfs path prefixes
with a filename and placing the results in buffers of the same size as
th
generic-64bit_defconfig
x86_64 randconfig-a001-20200326
x86_64 randconfig-a002-20200326
x86_64 randconfig-a003-20200326
i386 randconfig-a001-20200326
i386 randconfig-a002-20200326
i386 randconfig-a003-20200326
Dear Friend,
How are you and your entire family? I hope you and your entire family are doing
everything possible to stay safe and protected from the coronavirus pandemic. I
am your friend Mr. Ismael from the Arab Republic of Syrian. I am eagerly
looking for an investment opportunity in your coun
Dear Friend,
How are you and your entire family? I hope you and your entire family are doing
everything possible to stay safe and protected from the coronavirus pandemic. I
am your friend Mr. Ismael from the Arab Republic of Syrian. I am eagerly
looking for an investment opportunity in your coun
Dear Friend,
How are you and your entire family? I hope you and your entire family are doing
everything possible to stay safe and protected from the coronavirus pandemic. I
am your friend Mr. Ismael from the Arab Republic of Syrian. I am eagerly
looking for an investment opportunity in your coun
On Thu, Mar 26, 2020 at 07:23:42PM -0400, Sasha Levin wrote:
> From: Johan Hovold
>
> [ Upstream commit ae62cf5eb2792d9a818c2d93728ed92119357017 ]
>
> Newer GCC warns about possible truncations of two generated path names as
> we're concatenating the configurable sysfs and debugfs path prefixes
On Thu, Mar 26, 2020 at 07:23:41PM -0400, Sasha Levin wrote:
> From: Johan Hovold
>
> [ Upstream commit f16023834863932f95dfad13fac3fc47f77d2f29 ]
>
> Newer GCC warns about a possible truncation of a generated sysfs path
> name as we're concatenating a directory path with a file name and
> placi
From: Ajay Singh
Moved 'drivers/staging/wilc1000/wlan.h' to
'drivers/net/wireless/microchip/wilc1000/wlan.h'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/wlan.h| 397 ++
1 file changed, 397 insertions(+)
create mode 100644 drivers/net/wireless/microch
From: Ajay Singh
Moved 'drivers/staging/wilc1000/wlan.c' to
'drivers/net/wireless/microchip/wilc1000/wlan.c'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/wlan.c| 1238 +
1 file changed, 1238 insertions(+)
create mode 100644 drivers/net/wireless/microc
From: Ajay Singh
Moved 'drivers/staging/wilc1000/hif.h' to
'drivers/net/wireless/microchip/wilc1000/hif.h'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/microchip/wilc1000/hif.h | 214 ++
1 file changed, 214 insertions(+)
create mode 100644 drivers/net/wireless/microchip
From: Ajay Singh
This patch series is to review and move wilc1000 driver out of staging.
Most of the review comments received in [1] & [2] are addressed in the
latest code. Please review and provide your inputs.
[1].
https://lore.kernel.org/linux-wireless/1537957525-11467-1-git-send-email-ajay.
From: Ajay Singh
Moved 'drivers/staging/wilc1000/cfg80211.c' to
'drivers/net/wireless/microchip/wilc1000/cfg80211.c'.
Signed-off-by: Ajay Singh
---
.../wireless/microchip/wilc1000/cfg80211.c| 1849 +
1 file changed, 1849 insertions(+)
create mode 100644 drivers/net/wireles
From: Ajay Singh
Moved 'drivers/staging/wilc1000/fw.h' to
'drivers/net/wireless/microchip/wilc1000/fw.h'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/microchip/wilc1000/fw.h | 119 +++
1 file changed, 119 insertions(+)
create mode 100644 drivers/net/wireless/microchip/w
From: Ajay Singh
Moved 'drivers/staging/wilc1000/netdev.h' to
'drivers/net/wireless/microchip/wilc1000/netdev.h'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/netdev.h | 294 ++
1 file changed, 294 insertions(+)
create mode 100644 drivers/net/wireless/mic
From: Ajay Singh
Moved 'drivers/staging/wilc1000/wlan_cfg.h' to
'drivers/net/wireless/microchip/wilc1000/wlan_cfg.h'.
Signed-off-by: Ajay Singh
---
.../wireless/microchip/wilc1000/wlan_cfg.h| 54 +++
1 file changed, 54 insertions(+)
create mode 100644 drivers/net/wireless/
From: Ajay Singh
Moved 'drivers/staging/wilc1000/wlan_cfg.c' to
'drivers/net/wireless/microchip/wilc1000/wlan_cfg.c'.
Signed-off-by: Ajay Singh
---
.../wireless/microchip/wilc1000/wlan_cfg.c| 413 ++
1 file changed, 413 insertions(+)
create mode 100644 drivers/net/wireless
From: Ajay Singh
Moved 'drivers/staging/wilc1000/mon.c' to
'drivers/net/wireless/microchip/wilc1000/mon.c'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/microchip/wilc1000/mon.c | 260 ++
1 file changed, 260 insertions(+)
create mode 100644 drivers/net/wireless/microchip
From: Ajay Singh
This file describes the binding details to connect wilc1000 device. It's
moved from staging to 'Documentation/devicetree/bindings/net/wireless'
path.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip,wilc1000.yaml | 71 +++
1 file changed, 71 insert
From: Ajay Singh
Moved 'drivers/staging/wilc1000/sdio.c' to
'drivers/net/wireless/microchip/wilc1000/sdio.c'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/sdio.c| 1023 +
1 file changed, 1023 insertions(+)
create mode 100644 drivers/net/wireless/microc
From: Ajay Singh
Moved 'drivers/staging/wilc1000/hif.c' to
'drivers/net/wireless/microchip/wilc1000/hif.c'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/microchip/wilc1000/hif.c | 1959 +
1 file changed, 1959 insertions(+)
create mode 100644 drivers/net/wireless/microchi
From: Ajay Singh
Moved 'drivers/staging/wilc1000/cfg80211.h' to
'drivers/net/wireless/microchip/wilc1000/cfg80211.h'.
Signed-off-by: Ajay Singh
---
.../wireless/microchip/wilc1000/cfg80211.h| 29 +++
1 file changed, 29 insertions(+)
create mode 100644 drivers/net/wireless/
From: Ajay Singh
Moved 'drivers/staging/wilc1000/wlan_if.h' to
'drivers/net/wireless/microchip/wilc1000/wlan_if.h'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/wlan_if.h | 803 ++
1 file changed, 803 insertions(+)
create mode 100644 drivers/net/wireless/m
From: Ajay Singh
Moved 'drivers/staging/wilc1000/netdev.c' to
'drivers/net/wireless/microchip/wilc1000/netdev.c'.
Signed-off-by: Ajay Singh
---
.../net/wireless/microchip/wilc1000/netdev.c | 934 ++
1 file changed, 934 insertions(+)
create mode 100644 drivers/net/wireless/mic
From: Ajay Singh
Added Makefile and Kconfig files for compiling wilc1000 module from
'drivers/net/wireless/microchip/'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/Kconfig | 1 +
drivers/net/wireless/Makefile | 1 +
drivers/net/wireless/microchip/Kconf
From: Ajay Singh
Moved 'drivers/staging/wilc1000/spi.c' to
'drivers/net/wireless/microchip/wilc1000/spi.c'.
Signed-off-by: Ajay Singh
---
drivers/net/wireless/microchip/wilc1000/spi.c | 945 ++
1 file changed, 945 insertions(+)
create mode 100644 drivers/net/wireless/microchip
69 matches
Mail list logo