Add a test for successful call to cdev_alloc() to avoid
potential null dereference. Issue reported by smatch.
Signed-off-by: Michael Straube
---
drivers/staging/pi433/pi433_if.c | 4
1 file changed, 4 insertions(+)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433
On Fri, 23 Nov 2018 22:23:12 -0200
Matheus Tavares wrote:
> Move ad2s90 resolver driver out of staging to the main tree.
>
> Signed-off-by: Matheus Tavares
> Signed-off-by: Victor Colombo
Hi.
One totally trivial comment inline, but if you want to clean
that up, do it after we have moved this
On Sat, 24 Nov 2018 11:18:57 -0200
Marcelo Schmitt wrote:
> Add a of_device_id struct variable and subsequent call to
> MODULE_DEVICE_TABLE macro to complete device tree support.
>
> Signed-off-by: Marcelo Schmitt
Applied to the togreg branch of iio.git and pushed out as testing
for the autobui
Hi!
> Use the gpiod interface instead of the deprecated old non-descriptor
> interface in olpc_dcon_xo_1.c.
>
> Signed-off-by: Nishad Kamdar
You may want to cc: lkund...@v3.sk, he was doing great work on OLPC
lately...
Best regards,
On Thu, 22 Nov 2018 10:53:47 -0200
Marcelo Schmitt wrote:
> Previously, there was an implicit creation of a kfifo which was replaced
> by a call to triggered_buffer_setup, which is already implemented in iio
> infrastructure.
>
> Signed-off-by: Marcelo Schmitt
I'm a little surprised that this
On Thu, 22 Nov 2018 11:01:00 +
"Popa, Stefan Serban" wrote:
> On Mi, 2018-11-21 at 16:04 -0200, Giuliano Belinassi wrote:
> > Previously, the AD7780 driver only supported gpio for the 'powerdown'
> > pin. This commit adds suppport for the 'gain' and 'filter' pin.
> Hey,
>
> Comments inline
This switches the fbtft driver to use GPIO descriptors
rather than numerical gpios.
Nishad Kamdar (26):
Staging: fbtft: fbtft-core: Switch to the gpio descriptor interface
Staging: fbtft: fbtft-bus: Switch to the gpio descriptor interface
Staging: fbtft: fbtft-io: Switch to the gpio descript
This switches the fbtft-core to use GPIO descriptors
rather than numerical gpios: Utilize the GPIO library's
intrinsic handling of OF GPIOs and polarity.
If the line is flagged active low, gpiolib will deal with
this.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fbtft-core.c | 127
This switches the fbtft-bus to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fbtft-bus.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-bus.c
b/drivers/staging/fbtft/fbtft-bus.c
ind
This switches the fbtft-io to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fbtft-io.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-io.c b/drivers/staging/fb
This switches the flexfb.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/flexfb.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/fbtft/flexfb.c b/drivers/staging/fbtft/flexfb.c
index 2
This switches the fbtft-device.c to use GPIO descriptors
rather than numerical gpios: Remove gpios from platform
device structure. Neither assign statically numbers to gpios
in platform device nor allow gpios to be parsed as module
parameters.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbt
This switches the fb_sh1106.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_sh1106.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fb_sh1106.c
b/drivers/staging/fbtft/fb_sh1106.c
index 0
This switches the fb_upd161704.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_upd161704.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_upd161704.c
b/drivers/staging/fbtft/fb_u
This switches the fb_uc1611.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_uc1611.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_uc1611.c
b/drivers/staging/fbtft/fb_uc1611.c
ind
This switches the fb_s6d1211.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_s6d1121.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_s6d1121.c
b/drivers/staging/fbtft/fb_s6d1121
This switches the fb_ili9320.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ili9320.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fb_ili9320.c
b/drivers/staging/fbtft/fb_ili9320.c
ind
This switches the fb_ili9340.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ili9340.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fb_ili9340.c
b/drivers/staging/fbtft/fb_ili9340.c
ind
This switches the fb_ssd1325.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1325.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1325.c
b/drivers/staging/fbtft/fb_ssd1325
This switches the fb_ili9325.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ili9325.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ili9325.c
b/drivers/staging/fbtft/fb_ili9325
This switches the fb_ssd1289.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1289.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1289.c
b/drivers/staging/fbtft/fb_ssd1289
This switches the fb_ssd1351.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1351.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fb_ssd1351.c
b/drivers/staging/fbtft/fb_ssd1351.c
ind
This switches the fb_uc1701.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_uc1701.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_uc1701.c
b/drivers/staging/fbtft/fb_uc1701.c
i
This switches the fb_ssd1306.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1306.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1306.c
b/drivers/staging/fbtft/fb_ssd1306.c
This switches the fb_bd663474.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_bd663474.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_bd663474.c
b/drivers/staging/fbtft/fb_bd66
This switches the fb_ssd1331.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1331.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1331.c
b/drivers/staging/fbtft/fb_ss
This switches the fb_ili9163.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ili9163.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ili9163.c
b/drivers/staging/fbtft/fb_ili9163
This switches the fb_agm1264k-fl.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_agm1264k-fl.c | 52 +-
1 file changed, 26 insertions(+), 26 deletions(-)
diff --git a/drivers/staging/fbtft/fb_agm1264k-fl.c
This switches the fb_pcd8544.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_pcd8544.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_pcd8544.c
b/drivers/staging/fbtft/fb_pcd8544.c
On Tue, 20 Nov 2018 17:43:46 +0200
Stefan Popa wrote:
> Move ad7606 ADC driver out of staging and into the mainline.
>
> Signed-off-by: Stefan Popa
One idle thought, how much would the performance suffer if we moved
the parallel path over to the new gpiod_get/set_raw_array_value and friends?
This switches the fb_ssd1305.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ssd1305.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1305.c
b/drivers/staging/fbtft/fb_ssd1305.c
This switches the fb_tls8204.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_tls8204.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_tls8204.c
b/drivers/staging/fbtft/fb_tls8204
This switches the fb_watterott.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_watterott.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_watterott.c
b/drivers/staging/fbtft/fb_wat
This switches the fb_ra8875.c to use GPIO descriptors
rather than numerical gpios.
Signed-off-by: Nishad Kamdar
---
drivers/staging/fbtft/fb_ra8875.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ra8875.c
b/drivers/staging/fbtft/fb_ra8875.c
ind
On Tue, 20 Nov 2018 22:22:30 +0530
Shreeya Patel wrote:
> When the kernel starts up, it kicks off compiled-in drivers
> that match “compatible” entries it finds in the device tree.
> At a later stage (when /lib/modules is available), all kernel modules
> that match “compatible” entries in the dev
On Tue, 20 Nov 2018 22:24:36 +0530
Shreeya Patel wrote:
> Make the driver use device tree instead of the platform data.
> Hence, use devm_gpiod_get_optional function to get the data from
> device tree for ldac-pin and accordingly make the needed changes
> in the driver.
>
> Signed-off-by: Shreey
On Tue, 20 Nov 2018 22:26:58 +0530
Shreeya Patel wrote:
> There is no need to store irq_flags into the structure as it
> is always set to the same thing. Hence switch irq_flags to a
> local variable.
>
> Signed-off-by: Shreeya Patel
Applied to the togreg branch of iio.git and pushed out as test
On Tue, 20 Nov 2018 22:28:36 +0530
Shreeya Patel wrote:
> Most of the drivers in IIO uses irq_type as the name for
> storing the interrupt type and hence change the name from
> irq_flags to irq_type for maintaining the consistency.
>
> Signed-off-by: Shreeya Patel
Applied to the togreg branch o
On Wed, 21 Nov 2018 15:02:52 +0530
Shreeya Patel wrote:
> On Wed, 2018-11-21 at 08:21 +, Ardelean, Alexandru wrote:
> > On Tue, 2018-11-20 at 22:30 +0530, Shreeya Patel wrote:
> > > ADT7316 driver no more uses platform data and hence use device tree
> > > data instead of platform data for a
/0day-ci/linux/commits/Nishad-Kamdar/Staging-fbtft-Switch-to-the-gpio-descriptor-interface/20181125-232835
config: x86_64-randconfig-x001-201847 (attached as .config)
compiler: gcc-7 (Debian 7.3.0-1) 7.3.0
reproduce:
# save the attached .config to linux build tree
make ARCH=x86_64
All
On 11/11/18 11:29 AM, Alexey Skidanov wrote:
Create chunk heap of specified size and base address by adding
"ion_chunk_heap=size@start" kernel boot parameter.
Signed-off-by: Alexey Skidanov
---
drivers/staging/android/ion/ion_chunk_heap.c | 40
1 file changed, 40
On 11/25/18 10:51 PM, Laura Abbott wrote:
> On 11/11/18 11:29 AM, Alexey Skidanov wrote:
>> Create chunk heap of specified size and base address by adding
>> "ion_chunk_heap=size@start" kernel boot parameter.
>>
>> Signed-off-by: Alexey Skidanov
>> ---
>> drivers/staging/android/ion/ion_chunk_
On 11/25/18 1:22 PM, Alexey Skidanov wrote:
On 11/25/18 10:51 PM, Laura Abbott wrote:
On 11/11/18 11:29 AM, Alexey Skidanov wrote:
Create chunk heap of specified size and base address by adding
"ion_chunk_heap=size@start" kernel boot parameter.
Signed-off-by: Alexey Skidanov
---
drivers/
On 11/25/18 11:40 PM, Laura Abbott wrote:
> On 11/25/18 1:22 PM, Alexey Skidanov wrote:
>>
>>
>> On 11/25/18 10:51 PM, Laura Abbott wrote:
>>> On 11/11/18 11:29 AM, Alexey Skidanov wrote:
Create chunk heap of specified size and base address by adding
"ion_chunk_heap=size@start" kernel b
From: Dexuan Cui
We can concurrently try to open the same sub-channel from 2 paths:
path #1: vmbus_onoffer() -> vmbus_process_offer() -> handle_sc_creation().
path #2: storvsc_probe() -> storvsc_connect_to_vsp() ->
-> storvsc_channel_init() -> handle_multichannel_storage() ->
-
From: Dexuan Cui
Commit d86adf482b84 ("scsi: storvsc: Enable multi-queue support") removed
the usage of the API in Jan 2017, and the API is not used since then.
netvsc and storvsc have their own algorithms to determine the outgoing
channel, so this API is useless.
And the API is potentially uns
From: "K. Y. Srinivasan"
Miscellaneous fixes.
Dexuan Cui (2):
Drivers: hv: vmbus: check the creation_status in
vmbus_establish_gpadl()
Drivers: hv: vmbus: offload the handling of channels to two workqueues
drivers/hv/channel.c | 8 ++
drivers/hv/channel_mgmt.c | 188
From: Dexuan Cui
vmbus_process_offer() mustn't call channel->sc_creation_callback()
directly for sub-channels, because sc_creation_callback() ->
vmbus_open() may never get the host's response to the
OPEN_CHANNEL message (the host may rescind a channel at any time,
e.g. in the case of hot removing
From: Dexuan Cui
This is a longstanding issue: if the vmbus upper-layer drivers try to
consume too many GPADLs, the host may return with an error
0xC044 (STATUS_QUOTA_EXCEEDED), but currently we forget to check
the creation_status, and hence we can pass an invalid GPADL handle
into the OPEN_C
On Mon, Nov 26, 2018 at 02:29:57AM +, k...@linuxonhyperv.com wrote:
From: Dexuan Cui
vmbus_process_offer() mustn't call channel->sc_creation_callback()
directly for sub-channels, because sc_creation_callback() ->
vmbus_open() may never get the host's response to the
OPEN_CHANNEL message (th
On Mon, Nov 26, 2018 at 12:26:17AM +, k...@linuxonhyperv.com wrote:
From: Dexuan Cui
We can concurrently try to open the same sub-channel from 2 paths:
path #1: vmbus_onoffer() -> vmbus_process_offer() -> handle_sc_creation().
path #2: storvsc_probe() -> storvsc_connect_to_vsp() ->
On Fri, 2018-11-23 at 22:23 -0200, Matheus Tavares wrote:
> Move ad2s90 resolver driver out of staging to the main tree.
>
Acked-by: Alexandru Ardelean
> Signed-off-by: Matheus Tavares
> Signed-off-by: Victor Colombo
> ---
> Changes in v3:
> - none
>
> Changes in v2:
> - Disabled git move
52 matches
Mail list logo