On Tue, 20 Nov 2018 22:28:36 +0530
Shreeya Patel <shreeya.patel23...@gmail.com> wrote:

> Most of the drivers in IIO uses irq_type as the name for
> storing the interrupt type and hence change the name from
> irq_flags to irq_type for maintaining the consistency.
> 
> Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com>
Applied to the togreg branch of iio.git and pushed out as testing for
the autobuilders to play with.

Thanks,

Jonathan

> ---
>  drivers/staging/iio/addac/adt7316.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/staging/iio/addac/adt7316.c 
> b/drivers/staging/iio/addac/adt7316.c
> index dfae22619287..9c72538baf9e 100644
> --- a/drivers/staging/iio/addac/adt7316.c
> +++ b/drivers/staging/iio/addac/adt7316.c
> @@ -2102,7 +2102,7 @@ int adt7316_probe(struct device *dev, struct 
> adt7316_bus *bus,
>       struct adt7316_chip_info *chip;
>       struct iio_dev *indio_dev;
>       unsigned short *adt7316_platform_data = dev->platform_data;
> -     int irq_flags = IRQF_TRIGGER_LOW;
> +     int irq_type = IRQF_TRIGGER_LOW;
>       int ret = 0;
>  
>       indio_dev = devm_iio_device_alloc(dev, sizeof(*chip));
> @@ -2147,18 +2147,18 @@ int adt7316_probe(struct device *dev, struct 
> adt7316_bus *bus,
>  
>       if (chip->bus.irq > 0) {
>               if (adt7316_platform_data[0])
> -                     irq_flags = adt7316_platform_data[0];
> +                     irq_type = adt7316_platform_data[0];
>  
>               ret = devm_request_threaded_irq(dev, chip->bus.irq,
>                                               NULL,
>                                               adt7316_event_handler,
> -                                             irq_flags | IRQF_ONESHOT,
> +                                             irq_type | IRQF_ONESHOT,
>                                               indio_dev->name,
>                                               indio_dev);
>               if (ret)
>                       return ret;
>  
> -             if (irq_flags & IRQF_TRIGGER_HIGH)
> +             if (irq_type & IRQF_TRIGGER_HIGH)
>                       chip->config1 |= ADT7316_INT_POLARITY;
>       }
>  

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to