On Sat, 17 Mar 2018 01:36:18 +0530
Himanshu Jha wrote:
> Rename the macro definitions with suitable names specifying their
> purpose.
>
> * ADIS16201_STARTUP_DELAY_MS: Remove the comment specifying the delay in
> microseconds and rename it with addtition of _MS suffix.
>
> * ADIS16201_MSC_CTR
On Sat, 17 Mar 2018 01:36:19 +0530
Himanshu Jha wrote:
> Remove few unnecessary comments since the macro definitions clearly
> justify their purpose.
>
> Signed-off-by: Himanshu Jha
Seems like a good balance between enough information and too much noise
so applied to the togreg branch of iio.gi
On Sat, 17 Mar 2018 01:36:20 +0530
Himanshu Jha wrote:
> Add a _REG suffix to distinguish between registers and the register bit
> fileds.
>
> Signed-off-by: Himanshu Jha
Other than the typo in the patch title, this looks good (I fixed that up when
applying). Applied.
Jonathan
> ---
> v2:
>
On Sat, 17 Mar 2018 01:36:21 +0530
Himanshu Jha wrote:
> Group register definitions with its register field bits to improve
> readability and easy identification. A small comment is also added to
> denote the purpose/functionality of the grouped register definitions.
>
> Signed-off-by: Himanshu
On Sat, 17 Mar 2018 01:36:22 +0530
Himanshu Jha wrote:
> Clarify the conversion and formation of resultant data in the
> adis16201_read_raw() with sufficient comments and remove the unnecessary
> comments.
>
> Signed-off-by: Himanshu Jha
It is a little illogical to have comments for all but one
On Sat, 17 Mar 2018 01:36:23 +0530
Himanshu Jha wrote:
> Use sign_extned32() for 32 bit sign extending rather than hard coding.
>
> Signed-off-by: Himanshu Jha
Great, applied.
Thanks,
Jonathan
> ---
> v2:
>-no change in this patch.
>
> drivers/staging/iio/accel/adis16201.c | 5 ++---
>
On Sat, 17 Mar 2018 01:36:24 +0530
Himanshu Jha wrote:
> Prefer reverse christmas tree ordering of declarations to improve
> readability.
>
> Signed-off-by: Himanshu Jha
As ever, this sort of change is only worth doing if you are working on the
relevant code anyway. You are, so good to tidy up
On Sat, 17 Mar 2018 01:36:25 +0530
Himanshu Jha wrote:
> In adis16201_read_raw() adjust an argument to match an open parentheses
> using tabs and spaces.
>
> Signed-off-by: Himanshu Jha
Applied, thanks
Jonathan
> ---
> v2:
>-aligned perfectly to match open parentheses.
>
> drivers/stagi
On Sat, 17 Mar 2018 01:36:26 +0530
Himanshu Jha wrote:
> Move the adis16201 driver out of staging directory and merge to the
> mainline IIO subsystem.
>
> Signed-off-by: Himanshu Jha
Hi Himanshu,
You have made great progress on this, but this final posting of a patch moving
a driver out of sta
On Fri, 16 Mar 2018 19:48:33 -0300
Rodrigo Siqueira wrote:
> The original code does not correctly handle the error related to I2C
> read and write. This patch fixes the error handling related to all
> read/write functions for I2C. This patch is an adaptation of the John
> Syne patches.
>
> Signe
On Fri, 16 Mar 2018 19:48:51 -0300
Rodrigo Siqueira wrote:
> The function ade7854_i2c_read_reg_32() have to invoke the
> i2c_master_recv() for read 32 bits values, however, the counter is set
> to 3 which means 24 bits. This patch fixes the wrong size of 24 bits, to
> 32 bits. Finally, this patch
On 10 March 2018 21:27:31 GMT+05:30, Jonathan Cameron
Hi Jonathan
>On Sat, 10 Mar 2018 15:50:23 +0530
>Shreeya Patel wrote:
>
>> Move the adis16209 driver out of staging directory and merge to the
>> mainline IIO subsystem.
>>
>> Signed-off-by: Shreeya Patel
>As this has a clear dependency
On Fri, 16 Mar 2018 19:49:08 -0300
Rodrigo Siqueira wrote:
> The write operation using I2C has many code duplications and four
> different interfaces per data size. This patch introduces a single
> function that centralizes the main tasks.
>
> The central function inserted by this patch can easi
On Fri, 16 Mar 2018 19:49:24 -0300
Rodrigo Siqueira wrote:
> The write operation using SPI has a many code duplications (similar to
> I2C) and four different interfaces per data size. This patch introduces
> a single function that centralizes the main task related to SPI.
>
> Signed-off-by: Rodr
On Fri, 16 Mar 2018 19:49:40 -0300
Rodrigo Siqueira wrote:
> This patch removes code duplications related to the write_reg_*
> functions and centralizes them in a single function. Also, it eliminates
> the legacy functions and replaces them by a unique signature that is
> used by SPI and I2C.
>
On Fri, 16 Mar 2018 19:49:59 -0300
Rodrigo Siqueira wrote:
> The read operation for the I2C function has many duplications that can
> be generalized into a single function. This patch reworks the read
> operation for I2C to centralizes all similar code in a single function.
> Part of the rework i
On Fri, 16 Mar 2018 19:50:29 -0300
Rodrigo Siqueira wrote:
> The original code had a read function per data size; after updates, all
> read functions tasks were centralized in a single function, but the old
> signature was kept to maintain the module working without problems. This
> patch removes
On Sun, 18 Mar 2018 15:18:44 +0530
Shreeya Patel wrote:
> On 10 March 2018 21:27:31 GMT+05:30, Jonathan Cameron
>
> Hi Jonathan
>
> >On Sat, 10 Mar 2018 15:50:23 +0530
> >Shreeya Patel wrote:
> >
> >> Move the adis16209 driver out of staging directory and merge to the
> >> mainline IIO subs
On Sat, 17 Mar 2018 23:11:45 -0700
John Syne wrote:
> Hi Jonathan,
Hi John and All,
I'd love to get some additional input on this from anyone interested.
There are a lot of weird and wonderful derived quantities in an energy
meter and it seems we need to make some fundamental changes to support
This patch series is meant clean the ad2s1200 driver, and move it
to mainline. In short the following is done:
1. Clean up of minor code style issues
2. Fix minor bugs
3. Replace legacy GPIO ABI with modern ABI
4. Change the channel definitions of angular position and angular
velocity to match t
This patches sorts all the includes in alphabetic order.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
Reorders the variable declarations to prefer a reverse Christmas tree
order to improve readability.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers
Reorders the variable declarations to prefer a reverse Christmas tree
order to improve readability.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers
This patches sorts all the includes in alphabetic order.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
Please forget the previous 3 emails, I forgot the message-id and
reply-to business.
This patch series is meant to move the ad2s1200 driver to mainline. In short
the following is done:
1. Clean up of minor code style issues
2. Fix minor bugs
3. Replace legacy GPIO ABI with modern ABI
4. Change the
Add blank lines to improve readability.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
index 94d0a66532fd..20df16b7852b 100644
Add missing kernel docs to the ad2s1200 driver state.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
index 20df16b7852b..00efb
Add variable to hold &spi->dev in ad2s1200_probe. This value is repeatedly
used in ad2s1200_probe.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 13 -
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
The manual states that the data is contained in the upper 12 bits
of the 16 bits read by spi. The code that extracts these 12 bits
is correct for both be and le machines, but this is not clear
from a first glance.
To improve readability the relevant expressions are replaced
with equivalent express
The legacy, integer based gpio ABI is replaced with the descriptor
based ABI.
For compatibility, it is first tried to use the platform data to
request the gpio's. Otherwise, it looks for the "sample" and "rdvel"
gpio function.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1
After a successful spi transaction, a udelay(1) is needed.
This doesn't happen for the default case of the switch statement
in ad2s1200_read_raw. This patch makes sure that it does.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 8 +---
1 file changed, 5 insertio
The sysfs iio ABI states that a unit of radians per second is
expected, but the 12-bit angular velocity register has rps as its unit.
So a fractional scaling factor of approximately 2 * Pi is added to the
angular velocity channel.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad
The angle channel is not defined in sysfs iio ABI. So it is replaced
with an inclination channel, because it is defined in the ABI, and has the
semantics of an angle.
In addition, a fractional scaling factor of 360 / (2^12 -1) is added,
to scale the 12-bits angular position to degrees, conform the
Signed-off-by: David Veenstra
---
drivers/iio/Kconfig | 1 +
drivers/iio/Makefile | 1 +
drivers/iio/resolver/Kconfig | 17 +
drivers/iio/resolver/Makefile | 5 +
drivers/{staging => }/iio/r
hv_pci_onchannelcallback() is not called in atomic context.
The call chain ending up at hv_pci_onchannelcallback() is:
[1] hv_pci_onchannelcallback() <- hv_pci_probe()
hv_pci_probe() is only set as ".probe" in hv_driver
structure "hv_pci_drv".
Despite never getting called from atomic context,
h
new_pcichild_device() is not called in atomic context.
The call chain ending up at new_pcichild_device() is:
[1] new_pcichild_device() <- pci_devices_present_work()
pci_devices_present_work() is only set in INIT_WORK().
Despite never getting called from atomic context,
new_pcichild_device() calls
On 03/16/2018 02:51 PM, Geert Uytterhoeven wrote:
Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
In most cases this other symbol is an architecture or platform specific
symbol, or PCI.
Generic symbols a
On Mon, 12 Feb 2018 22:03:07 +0100
Boris Brezillon wrote:
> mtd_erase() can return an error before ->fail_addr is initialized to
> MTD_FAIL_ADDR_UNKNOWN. Move this initialization at the very beginning
> of the function.
Applied the patchset after addressing Miquel's comments.
>
> Signed-off-by
Hi Geert,
On Fri, 16 Mar 2018 14:51:47 +0100
Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symb
> -Original Message-
> From: linux-kernel-ow...@vger.kernel.org
> On Behalf
> Of Arvind Yadav
> Sent: Saturday, March 17, 2018 11:48 PM
> To: Stephen Hemminger ; Haiyang Zhang
>
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org
> Subject: [PATCH] vmbus: use put_device() if
> -Original Message-
> From: linux-kernel-ow...@vger.kernel.org
> On Behalf
> Of Jia-Ju Bai
> Sent: Sunday, March 18, 2018 7:53 AM
> To: KY Srinivasan ; Haiyang Zhang
> ; Stephen
> Hemminger ; bhelg...@google.com
> Cc: de...@linuxdriverproject.org; linux-...@vger.kernel.org;
> linux-ker
> -Original Message-
> From: linux-kernel-ow...@vger.kernel.org
> On Behalf
> Of Jia-Ju Bai
> Sent: Sunday, March 18, 2018 7:53 AM
> To: KY Srinivasan ; Haiyang Zhang
> ; Stephen
> Hemminger ; bhelg...@google.com
> Cc: de...@linuxdriverproject.org; linux-...@vger.kernel.org;
> linux-ker
On Fri 16 Mar 06:51 PDT 2018, Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symbol, or PCI.
>
>
On Fri, Mar 16, 2018 at 02:51:34PM +0100, Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symbol, or
On Fri, Mar 16, 2018 at 02:51:52PM +0100, Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symbol, or
> -Original Message-
> From: Jia-Ju Bai
> Sent: Sunday, March 18, 2018 7:53 AM
> To: KY Srinivasan ; Haiyang Zhang
> ; Stephen Hemminger
> ; bhelg...@google.com
> Cc: de...@linuxdriverproject.org; linux-...@vger.kernel.org; linux-
> ker...@vger.kernel.org; Jia-Ju Bai
> Subject: [PATCH 1
> -Original Message-
> From: devel On Behalf
> Of Arvind Yadav
> Sent: Saturday, March 17, 2018 11:48 PM
> To: Stephen Hemminger ; Haiyang Zhang
>
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org
> Subject: [PATCH] vmbus: use put_device() if device_register fail
>
> if
On 16 March 2018 at 14:51, Geert Uytterhoeven wrote:
> Remove dependencies on HAS_DMA where a Kconfig symbol depends on another
> symbol that implies HAS_DMA, and, optionally, on "|| COMPILE_TEST".
> In most cases this other symbol is an architecture or platform specific
> symbol, or PCI.
>
> Gene
> -Original Message-
> From: linux-kernel-ow...@vger.kernel.org
> On Behalf
> Of KY Srinivasan
> Sent: Sunday, March 18, 2018 8:02 PM
> To: Arvind Yadav ; Stephen Hemminger
> ; Haiyang Zhang
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org
> Subject: RE: [PATCH] vmbus: us
On 2018/3/19 10:52, KY Srinivasan wrote:
-Original Message-
From: Jia-Ju Bai
Sent: Sunday, March 18, 2018 7:53 AM
To: KY Srinivasan ; Haiyang Zhang
; Stephen Hemminger
; bhelg...@google.com
Cc: de...@linuxdriverproject.org; linux-...@vger.kernel.org; linux-
ker...@vger.kernel.org; Ji
On Fri, Mar 16, 2018 at 11:32:34AM +0300, Dan Carpenter wrote:
> On Fri, Mar 16, 2018 at 01:58:23PM +0900, Ji-Hun Kim wrote:
> > There is no failure checking on the param value which will be allocated
> > memory by kmalloc. Add a null pointer checking statement. Then goto error:
> > and return -ENO
> -Original Message-
> From: netdev-ow...@vger.kernel.org [mailto:netdev-ow...@vger.kernel.org]
> On Behalf Of Geert Uytterhoeven
> Sent: Friday, March 16, 2018 3:52 PM
> To: Christoph Hellwig ; Marek Szyprowski
> ; Robin Murphy ;
> Felipe Balbi ; Greg Kroah-Hartman
> ; James E . J . Bottom
There is no failure checking on the param value which will be allocated
memory by kmalloc. Add a null pointer checking statement. Then goto error:
and return -ENOMEM error code when kmalloc is failed.
Signed-off-by: Ji-Hun Kim
---
Changes since v1:
- Return with -ENOMEM directly, instead of got
> -Original Message-
> From: Michael Kelley (EOSG)
> Sent: Sunday, March 18, 2018 8:40 PM
> To: KY Srinivasan ; Arvind Yadav
> ; Stephen Hemminger
> ; Haiyang Zhang
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org
> Subject: RE: [PATCH] vmbus: use put_device() if device_r
54 matches
Mail list logo