On Mon, Oct 16, 2017 at 05:58:12AM +, 冯锐 wrote:
> > On Fri, Oct 13, 2017 at 10:54:22AM +0100, Lee Jones wrote:
> > > On Fri, 13 Oct 2017, Greg KH wrote:
> > >
> > > > On Fri, Oct 13, 2017 at 04:50:35PM +0800, rui_f...@realsil.com.cn wrote:
> > > > > From: rui_feng
> > > > >
> > > > > Add suppo
On Mon, Oct 16, 2017 at 02:41:38AM +, Pkshih wrote:
> 2) The rtlwifi in staging
>In staging, the module phydm v13 contains bugs, so I want to upgrade
>to v21 (Realtek internal version number). This upgrade contains a
>big patch that the difference between v13 and v21, and there are
On Mon, Oct 16, 2017 at 02:41:38AM +, Pkshih wrote:
>
>
> > -Original Message-
> > From: Greg Kroah-Hartman [mailto:gre...@linuxfoundation.org]
> > Sent: Thursday, October 12, 2017 6:35 PM
> > To: Kalle Valo
> > Cc: Larry Finger; Dan Carpenter; Pkshih; 莊彥宣; Johannes Berg; Souptick
>
The core module used to have two functions to find a certain
channel. One by name and one by interface. Since no channel is
searched by its interface name anymore the by_name suffix is
rendered redundant. This patch renames the function accordingly.
Signed-off-by: Christian Gromm
---
v2: fix patc
This patch stores a channel's name inside the most_channel structure,
hence making it accessible outside of function most_register_interface.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
driv
This patch renames and moves the source files of the driver. Additionally,
it adapts the ABI, Makefiles and Kconfig files of the kernel's build
system.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visi
This patch removes the initialization of the priv pointer of the
most_interface structure.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/usb/usb.c | 2 --
1 file changed,
This patch removes the struct device from the most_aim as it is not
needed.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 17 -
drivers/staging/mo
This patch renames the member "ptr" of struct pipe to "aim". This is
needed to increase the readability of the code.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c |
This patch renames the structure most_c_obj to most_channel. This is done
to enhance readability.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 100 ++
From: Andrey Shvetsov
This patch fixes the offset and data handling when traversing
the list of devices that are attached to the bus.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/st
This patch adds a check for the pointer returned by the function
match_component. It is needed to prevent a NULL pointer dereference in
case the provided component name does not match any list entry.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create p
This patch creates the structure comp to bundle the module variables.
For an improved readability some variables are renamed.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most
This patch updates and corrects the comment sections of the code.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 87 +++--
This patch triggers the host to send a control request to
clear the endpoint's Halt feature.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/usb/usb.c | 15 +++
This patch renames the struct members "aim0" and "aim0" to "pipe0" and "pipe1".
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 104 ++--
This patch replaces the confusing name of struct "most_c_aim_obj"
with "pipe" to better express the function that is behind the
structure.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers
The following patch adapts the driver to use the device model by:
- adopting the MOST bus_type
- registering the core as a busdriver
- removing private kobject/kset usage
- removing private lists and structures to track registered modules
and making use of
This patch introduces the structure "mostcore" to bundle core specific
data structures.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 64 -
This patch introduces struct interface_private as a replacement for
the struct most_inst_obj. This structure holds private data that is
only needed by the core module and will be accessed by a pointer from
within the most_interface structure. As a result of this replacement
the bus helper functions
This patch creates a new attribute group to manage the attributes
of a registered aim module in sysfs and changes the show and store
functions accordingly.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement
From: Andrey Shvetsov
This patch keeps the usage file up to date.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
.../staging/most/Documentation/driver_usage.txt| 192 +++--
This patch set integrates the MOST driver to the Linux kernel's device
model and provides bug fixes. Part of this process is moving and renaming
files to get a clearer directory layout.
Andrey Shvetsov (2):
staging: most: update driver usage file
staging: most: core: fix list traversing
Chris
This patch makes the core keep track of the registered modules.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 6 +++---
drivers/staging/most/core.h | 1 +
2 files
This patch fixes the type used to manage the channels of an
registered MOST interface.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.h | 2 +-
1 file changed, 1 inser
This patch includes the header device.h and removes the forward
declaration of kobject.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.h | 2 +-
1 file changed, 1 inse
This patch stops the core from generating a module owned class
and registering it with the kernel.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 13 +
This patch removes the context pointer that was meant to provide the
opportunity to store context information.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.h | 1 -
A module that is meant to make up the userspace experience of the driver
is no longer referred to as AIM. Instead it is denoted as a component of
the core. Further, it is understood as an integral part of the core, the
purpose of which is to meaningfully enhance the core with new features
(interfac
This patch fixes coding style violations.
Signed-off-by: Christian Gromm
---
v2: fix patch numeration
v3: - add cover letter
- create patches with -M switch to make file movement visible
drivers/staging/most/core.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git
From: Suniel Mahesh
Bool tests don't need comparisons.
This fixes the following coccinelle warning:
WARNING: Comparison of bool to 0/1
Signed-off-by: Suniel Mahesh
---
Note:
- Patch was tested and built(ARCH=arm) on latest
linux-next.
- No build issues reported, however it was not
tested o
From: Suniel Mahesh
This fixes the following coccinelle warning:
WARNING: return of 0/1 in function 'ssi_is_hw_key' with return type bool.
Signed-off-by: Suniel Mahesh
---
Note:
- Patch was tested and built(ARCH=arm) on latest
linux-next.
- No build issues reported, however it was not
teste
The common-clk core expects clk consumers to always call enable/disable
in a balanced manner. The atomisp driver does not call gmin_flisclk_ctrl()
in a balanced manner, so add a clock_on bool and skip redundant calls.
This fixes kernel oops like this one:
[ 19.811613] gc0310_s_config S
[ 19.8
Dan Carpenter writes:
> On Mon, Oct 16, 2017 at 02:41:38AM +, Pkshih wrote:
>> 2) The rtlwifi in staging
>>In staging, the module phydm v13 contains bugs, so I want to upgrade
>>to v21 (Realtek internal version number). This upgrade contains a
>>big patch that the difference betwe
Oleksij Rempel writes:
>> 4) As Kalle mentioned, rtlwifi contains many magic numbers, and I
>>plan to fix them after rtl8723de and rtl8821ce. Because the drivers
>>are developing, the changes will make us hard to integrate. However,
>>I don't have plan to process the magic numbers in
Am 16.10.2017 um 15:07 schrieb Kalle Valo:
> Oleksij Rempel writes:
>
>>> 4) As Kalle mentioned, rtlwifi contains many magic numbers, and I
>>>plan to fix them after rtl8723de and rtl8821ce. Because the drivers
>>>are developing, the changes will make us hard to integrate. However,
>>>
Hi PK,
you got good answers already so only short reply from me:
Pkshih writes:
> 3) Coming drivers -- rtl8723de and rtl8821ce
>We're developing the two drivers, and rtl8723de and rtl8821ce will
>be ready on 2017Q4 and 2018Q1 respectively. The drivers are based on
>rtl8822be that in
checkpatch message: 'CHECK: Unnecessary parentheses around'.
Signed-off-by: Frank A. Cancio Bello
---
FYI:
* I read 'Ignore checkpatch.pl if it complains about parens around
boolean expressions or ternary conditionals in return values, like this: return
((depth > 1) ? (depth - 1) : dept
This patch has the same subject line as the one I previously commented on
(modulo the typo in that one).
On Mon, 16 Oct 2017, Frank A. Cancio Bello wrote:
> checkpatch message: 'CHECK: Unnecessary parentheses around'.
Again, say what and why you have done.
julia
> Signed-off-by: Frank A. Canci
> -Original Message-
> From: Lee Jones [mailto:lee.jo...@linaro.org]
> Sent: Friday, October 13, 2017 4:15 PM
> To: Limonciello, Mario
> Cc: rui_f...@realsil.com.cn; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@driverdev.osuosl.org; ricky...@realtek.com;
> wei_w...@re
On Mon, Oct 16, 2017 at 02:34:48PM +0200, Hans de Goede wrote:
> The common-clk core expects clk consumers to always call enable/disable
> in a balanced manner. The atomisp driver does not call gmin_flisclk_ctrl()
> in a balanced manner, so add a clock_on bool and skip redundant calls.
>
> This fi
On Mon, Oct 16, 2017 at 03:38:11PM +0530, suni...@techveda.org wrote:
> From: Suniel Mahesh
>
> Bool tests don't need comparisons.
This commit log could be a bit longer. You may like to read
Documentation/process/submitting-patches.rst (section 2).
> This fixes the following coccinelle warning:
On Mon, Oct 16, 2017 at 03:39:57PM +0530, suni...@techveda.org wrote:
> From: Suniel Mahesh
>
> This fixes the following coccinelle warning:
> WARNING: return of 0/1 in function 'ssi_is_hw_key' with return type bool.
Perhaps
Coccinelle emits WARNING: return of 0/1 in function 'ssi_is_hw_key' wi
On Mon, Oct 16, 2017 at 10:18:14PM +0200, Julia Lawall wrote:
> This patch has the same subject line as the one I previously commented on
> (modulo the typo in that one).
>
Thanks Julia for your quick response. Before work on your suggestions I have a
question regarding the above comment:
Do yo
On Mon, 16 Oct 2017, Frank A. Cancio Bello wrote:
> On Mon, Oct 16, 2017 at 10:18:14PM +0200, Julia Lawall wrote:
> > This patch has the same subject line as the one I previously commented on
> > (modulo the typo in that one).
> >
>
> Thanks Julia for your quick response. Before work on your sug
On Sat, 14 Oct 2017, Dexuan Cui wrote:
> Last month the vector management code was reworked, and as a result of the
> changes, e.g. commit 22d0b12f3560 ("genirq/irqdomain: Add force
> reactivation flag to irq domains"), commit 4900be83602b ("x86/vector/msi:
> Switch to global reservation mode") etc
On 10/10/2017 02:11 AM, Mark Brown wrote:
> On Mon, Oct 09, 2017 at 05:10:37PM -0700, Laura Abbott wrote:
>> On 10/09/2017 03:08 PM, Mark Brown wrote:
>>> On Mon, Oct 09, 2017 at 02:25:47PM -0700, Laura Abbott wrote:
>
Anyway, to move this forward I think we need to see a proof of concept
>>>
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Larry Finger
Cc: Florian Schilhabel
Cc: Greg Kroah-Hartman
Cc: Tejaswini Poluri
Cc: Scott Matheina
As part of removing the timer_list.data field, this converts the wilc1000
driver to using from_timer and an explicit per-timer data field, since
there doesn't appear to be a way to sanely resolve vif from hif_drv.
Cc: Aditya Shankar
Cc: Ganesh Krishna
Cc: Greg Kroah-Hartman
Cc: linux-wirel...@v
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Greg Kroah-Hartman
Cc: Derek Robson
Cc: simran singhal
Cc: Riccardo Marotti
Cc: Fabrizio Perria
Cc:
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly. Also removes redundant initialization
of fw transaction timer, which already gets initialized per-transaction
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Greg Kroah-Hartman
Cc: Juliana Rodrigues
Cc: Ivan Safonov
Cc: Gargi Sharma
Cc: sayli karnik
Cc: Yam
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Lidza Louina
Cc: Mark Hounschell
Cc: Greg Kroah-Hartman
Cc: driverdev-devel@linuxdriverproject.org
Cc
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Greg Kroah-Hartman
Cc: Derek Robson
Cc: Suniel Mahesh
Cc: Malcolm Priestley
Cc: Gargi Sharma
Cc: Ju
In preparation for unconditionally passing the struct timer_list pointer
to all timer callbacks, switch to using the new timer_setup() and
from_timer() to pass the timer pointer explicitly. Adds pointer back to
comedi device from private struct.
Cc: Ian Abbott
Cc: H Hartley Sweeten
Cc: Greg Kroa
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly.
Cc: Mauro Carvalho Chehab
Cc: Greg Kroah-Hartman
Cc: Alan Cox
Cc: Daeseok Youn
Cc: Arnd Bergmann
Cc: li
In preparation for unconditionally passing the struct timer_list pointer to
all timer callbacks, switch to using the new timer_setup() and from_timer()
to pass the timer pointer explicitly. Also drops unused odm timer code.
Cc: Greg Kroah-Hartman
Cc: Larry Finger
Cc: Kalle Valo
Cc: Ping-Ke Shih
> -Original Message-
> From: Greg Kroah-Hartman [mailto:gre...@linuxfoundation.org]
> Sent: Monday, October 16, 2017 3:50 PM
> To: Pkshih
> Cc: Larry Finger; Kalle Valo; Dan Carpenter; 莊彥宣; Johannes Berg; Souptick
> Joarder;
> de...@driverdev.osuosl.org; linux-wirel...@vger.kernel.org;
> -Original Message-
> From: Kalle Valo [mailto:kv...@codeaurora.org]
> Sent: Monday, October 16, 2017 9:23 PM
> To: Pkshih
> Cc: Larry Finger; Greg Kroah-Hartman; Dan Carpenter; 莊彥宣; Johannes Berg;
> Souptick Joarder;
> de...@driverdev.osuosl.org; linux-wirel...@vger.kernel.org;
> kern
Remove unnecessary parentheses to comply with preferred coding style for
the linux kernel and avoid the following checkpatch's message:
'CHECK: Unnecessary parentheses around'
Credits to checkpatch.
Signed-off-by: Frank A. Cancio Bello
---
Changes in v2:
* I rewrote the log message to im
60 matches
Mail list logo