This patch replaces the confusing name of struct "most_c_aim_obj"
with "pipe" to better express the function that is behind the
structure.

Signed-off-by: Christian Gromm <christian.gr...@microchip.com>
---
v2: fix patch numeration
v3: - add cover letter
    - create patches with -M switch to make file movement visible

 drivers/staging/most/core.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/most/core.c b/drivers/staging/most/core.c
index 2abd0a1..35fedd5 100644
--- a/drivers/staging/most/core.c
+++ b/drivers/staging/most/core.c
@@ -37,7 +37,7 @@
 static struct ida mdev_id;
 static int dummy_num_buffers;
 
-struct most_c_aim_obj {
+struct pipe {
        struct most_aim *ptr;
        int refs;
        int num_buffers;
@@ -62,8 +62,8 @@ struct most_channel {
        spinlock_t fifo_lock;
        struct list_head halt_fifo;
        struct list_head list;
-       struct most_c_aim_obj aim0;
-       struct most_c_aim_obj aim1;
+       struct pipe aim0;
+       struct pipe aim1;
        struct list_head trash_fifo;
        struct task_struct *hdm_enqueue_task;
        wait_queue_head_t hdm_fifo_wq;
-- 
1.9.1

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to