On Thu, Sep 28, 2017 at 02:28:04AM +0300, Dmitry Osipenko wrote:
> >> + if (is_baseline_profile)
> >> + frame->aux_paddr = 0xF4DEAD00;
> >
> > The handling of is_baseline_profile is strange to me. It feels like we
> > should always check it before we use ->aux_paddr but we don't ever do
Remove unnecessary parenthesis
Signed-off-by: Keerthi Reddy
---
drivers/staging/fsl-mc/bus/fsl-mc-msi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/bus/fsl-mc-msi.c
b/drivers/staging/fsl-mc/bus/fsl-mc-msi.c
index 038da4d..f74a6f1 100644
--- a/drive
On 09/27/2017 11:46 PM, Mauro Carvalho Chehab wrote:
> The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
> match criteria requires just a device name.
>
> So, it doesn't make sense to enclose those into structs,
On 28.09.2017 10:23, Dan Carpenter wrote:
> On Thu, Sep 28, 2017 at 02:28:04AM +0300, Dmitry Osipenko wrote:
+ if (is_baseline_profile)
+ frame->aux_paddr = 0xF4DEAD00;
>>>
>>> The handling of is_baseline_profile is strange to me. It feels like we
>>> should always check it bef
Hi Mauro,
On Wed, Sep 27, 2017 at 06:46:56PM -0300, Mauro Carvalho Chehab wrote:
> The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
> match criteria requires just a device name.
>
> So, it doesn't make sense to
Patch series performs minor coccicheck and checkpatch cleanups.
Aishwarya Pant (3):
staging: rtl8188eu: remove unneeded conversions to bool
staging: rtl8188eu: remove implicit bool->int conversions
staging: rtl8188eu: wrap lines in 80 characters
drivers/staging/rtl8188eu/core/rtw_mlme_ext.
Patch suppresses the following warning issued by coccicheck:
WARNING: conversion to bool not needed here
Signed-off-by: Aishwarya Pant
Acked-by: Julia Lawall
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/sta
Perform cleanup for all function declarations in core/rtw_mlme_ext wherever
checkpatch complains about lines being over 80 characters long.
Signed-off-by: Aishwarya Pant
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 51 ++-
1 file changed, 34 insertions(+), 17 delet
Implicit type conversions are bad; they hinder readability of code and have
potential to cause bugs. Here the variable wait_ack is always supplied a bool
value while in function declarations it is defined as an int type. Fix it by
defining wait_ack a bool type in all usages.
Signed-off-by: Aishwar
On Wed, Sep 27, 2017 at 12:57:28PM -0500, Ioana Radulescu wrote:
> diff --git a/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> b/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> index f809682..26922fc 100644
> --- a/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> +++ b/drivers/staging/fsl-mc/bu
(Resending for Mauro, while dropping the non-list recipients. The original
likely had too many recipients.)
The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
match criteria requires just a device name.
So, it does
On Thu, Sep 28, 2017 at 03:48:36PM +0300, Dan Carpenter wrote:
> On Wed, Sep 27, 2017 at 12:57:28PM -0500, Ioana Radulescu wrote:
> > diff --git a/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> > b/drivers/staging/fsl-mc/bus/dpio/dpio-service.c
> > index f809682..26922fc 100644
> > --- a/drivers
Hi Mauro,
On Wed, Sep 27, 2017 at 06:46:56PM -0300, Mauro Carvalho Chehab wrote:
> The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
> match criteria requires just a device name.
>
> So, it doesn't make sense to
On 09/28/2017 02:53 PM, Mauro Carvalho Chehab wrote:
> (Resending for Mauro, while dropping the non-list recipients. The original
> likely had too many recipients.)
>
> The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_D
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Thursday, September 28, 2017 3:49 PM
> To: Ruxandra Ioana Radulescu
> Cc: gre...@linuxfoundation.org; de...@driverdev.osuosl.org;
> a...@arndb.de; stuyo...@gmail.com; Roy Pledge ;
> linux-ker...@vger.kerne
On Thu, Sep 28, 2017 at 01:07:48PM +, Ruxandra Ioana Radulescu wrote:
> > -Original Message-
> > From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> > Sent: Thursday, September 28, 2017 3:49 PM
> > To: Ruxandra Ioana Radulescu
> > Cc: gre...@linuxfoundation.org; de...@driverdev.osu
Hi Mauro,
On Wed, Sep 27, 2017 at 06:46:56PM -0300, Mauro Carvalho Chehab wrote:
> The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
> match criteria requires just a device name.
>
> So, it doesn't make sense to
On Wed, Sep 27, 2017 at 01:14:38PM -0400, David Kershner wrote:
> + if (chipset_dev->poll_jiffies != POLLJIFFIES_CONTROLVM_SLOW)
> + chipset_dev->poll_jiffies = POLLJIFFIES_CONTROLVM_SLOW;
> + } else {
> + if (chipset_dev->poll_jiffies != POLLJIFFIES_
On Wed, Sep 27, 2017 at 01:14:49PM -0400, David Kershner wrote:
> Clean up unneeded parenthesis reported by checkpatch.pl.
>
> Signed-off-by: David Kershner
> Reviewed-by: Tim Sell
> ---
> drivers/staging/unisys/visorhba/visorhba_main.c | 8
> 1 file changed, 4 insertions(+), 4 deletio
On Wed, Sep 27, 2017 at 01:14:43PM -0400, David Kershner wrote:
> From: Sameer Wadgaonkar
>
> Validate that the channel contents match the channel type that we are
> matching.
>
What are the user visible effects of this change? Does it have security
implications? Does it prevent a crash? Is
> -Original Message-
> From: gre...@linuxfoundation.org [mailto:gre...@linuxfoundation.org]
> Sent: Thursday, September 28, 2017 4:18 PM
> To: Ruxandra Ioana Radulescu
> Cc: Dan Carpenter ;
> de...@driverdev.osuosl.org; a...@arndb.de; stuyo...@gmail.com; Roy
> Pledge ; linux-ker...@vger.ke
On Wed, Sep 27, 2017 at 01:14:50PM -0400, David Kershner wrote:
> Clean up unneeded parenthesis reported by checkpatch.pl.
>
> Signed-off-by: David Kershner
> Reviewed-by: Tim Sell
> ---
> drivers/staging/unisys/visornic/visornic_main.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions
For some dpio functions, a cpu id parameter value of -1 is
valid and means "any". But when trying to validate this param
value against an upper limit, in this case num_possible_cpus(),
we risk obtaining the wrong result due to an implicit cast.
Avoid an incorrect check result by explicitly compari
Explicitly converting from __le16 to CPU u16 to resolve sparse error in
prism2sta.c. Original error:
drivers/staging//wlan-ng/prism2sta.c:1450:29: warning: incorrect type in
assignment (different base types)
drivers/staging//wlan-ng/prism2sta.c:1450:29:expected unsigned short
[unsigned] [usert
Hi all, this is Philip who maintains the 0-Day kernel test service. Thanks for
subscribing to 0-Day kernel testing. We will have lab power down from Oct 1
to Oct 5, so that the service will be shut down from Asia Pacific Time Sep 30
3PM
and will recover from Oct 6 as soon as we can. Sorry for any
25 matches
Mail list logo