On Fri, May 22, 2015 at 01:12:19AM +0300, Dmitry Kalinkin wrote:
> On Tue, May 19, 2015 at 12:18 PM, Dan Carpenter
> wrote:
> > On Mon, May 18, 2015 at 09:56:33PM +0300, Dmitry Kalinkin wrote:
> >>
> >> + for_each_sg(sgt->sgl, sg, sg_count, i) {
> >> + struct vme_dma_attr *pci_at
Removal of lustre-added typedefs is worthwhile, actually.
I scraped the surface some time ago, but could not complete it back then.
On May 21, 2015, at 5:47 PM, Michael Shuey wrote:
> I've been killing off a *lot* of checkpatch warnings, and I'm probably
> getting a tad overzealous. I'll drop t
On May 22, 2015, at 1:06 AM, Julia Lawall wrote:
> On Thu, 21 May 2015, Michael Shuey wrote:
>
>> That's a task (of many) I've been putting on the back burner until the code
>> is cleaner. It's also a HUGE change, since there are debug macros
>> everywhere, and they all check a #define'd mask t
Howdy!
I’m currently working on a platform_driver, where I want an attribute_group to
be in effect for every platforn_device that went through the corresponding
.probe() call. Now
http://kroah.com/log/blog/2013/06/26/how-to-create-a-sysfs-file-correctly/
suggests to set this in the struct devi
On Thu, May 21, 2015 at 03:50:23PM -0400, Mike Shuey wrote:
> This patch series cleans up code in staging/lustre/lnet - mostly spacing
> and dead function cleanup. Should apply against linux-next 20150518.
Why are you sending a v4 of this? We don't actually enjoy reviewing the
same patchset over
On Fri, 22 May 2015, Drokin, Oleg wrote:
Removal of lustre-added typedefs is worthwhile, actually.
I scraped the surface some time ago, but could not complete it back then.
On May 21, 2015, at 5:47 PM, Michael Shuey wrote:
I've been killing off a *lot* of checkpatch warnings, and I'm probab
On Thu, May 21, 2015 at 03:50:34PM -0400, Mike Shuey wrote:
> @@ -2758,7 +2763,7 @@ void kiblnd_shutdown(lnet_ni_t *ni)
> i = 2;
> while (atomic_read(&net->ibn_npeers) != 0) {
> i++;
> - CDEBUG(((i & (-i)) == i) ? D_WARNING : D_N
On Thu, May 21, 2015 at 03:50:49PM -0400, Mike Shuey wrote:
> Cleaning up more checkpatch.pl issues.
>
One thing per patch. Better changelogs. Yada yada yada.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverde
This patch does a lot of stuff all at once and it is hard to review. It
could easily be broken into patches which are easy to review.
> @@ -1378,15 +1378,15 @@ ksocknal_create_conn(lnet_ni_t *ni, ksock_route_t
> *route,
> ksocknal_txlist_done(ni, &zombies, 1);
> ksocknal_peer_decref(
Looks good.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
This patch seems fine but it would also be better if it were broken up
into easy to review patches.
[patch 1] delete LNET_USE_LIB_FREELIST code
This is theortetically what this patch does except it does tons
of other things as well.
Patches which delete whole functions, #defines o
On Thu, May 21, 2015 at 03:50:28PM -0400, Mike Shuey wrote:
> diff --git a/drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h
> b/drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h
> index cd664d0..7f52c69 100644
> --- a/drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h
> +++ b/drivers/staging
On Wed, May 20, 2015 at 10:51:34PM +, Dilger, Andreas wrote:
> On 2015/05/20, 1:42 PM, "Dan Carpenter" wrote:
>
> >In Smatch, it the equivalent warning is turned off by default because
> >there are too many false positives, but you can enable it with the
> >--spammy flag.
> >
> >kchecker --sp
>This patch does a lot of stuff all at once and it is hard to review. It
>could easily be broken into patches which are easy to review.
I have more very large patches. With breaking them up that means you are
going to see hundreds of patches coming from me.
>Ok in this next section we move func
>> typedef struct lnet_peer {
>> -struct list_headlp_hashlist; /* chain on peer hash */
>> -struct list_headlp_txq;/* messages blocking for tx
>> credits */
>> -struct list_headlp_rtrq; /* messages blocking for
>> router credits */
>
The Comedi "8255.h" header doesn't use anything from "comedidev.h" apart
from `struct comedi_device` and `struct comedi_subdevice`, which are
only used to construct corresponding pointer types within the parameter
lists of function prototypes. Just declare those structure types
incompletely and do
Several Comedi driver modules call `subdev_8255_init()` or
`subdev_8255_mm_init()` to set up a digital I/O subdevice based on the
"8255" chip. One of the parameters to these functions is an optional
pointer to an I/O callback function to perform the actual register
accesses (an internal default ca
The Comedi "8255" module is both a standalone Comedi device driver
module for simple devices with one or more 8255 "Programmable Peripheral
Interface" chips at known I/O base addresses (configured at run-time),
and a helper module to configure a 8255-based digital I/O subdevice for
other Comedi dri
The Comedi "8255" driver does not clean up properly on failure. It can
leave requested I/O port regions unreleased. Specifically, the Comedi
"attach" handler (`dev_8255_attach()`) requests a specified I/O port
region before calling `subdev_8255_init()` to set up the subdevice. If
that fails, the
These patches are for the Comedi "8255" driver module (including the
creation of a new "comedi_8255" module split off from it).
Patch 1 fixes a problem cleaning up on failure in the Comedi "8255" driver.
Patch 2 is just a minor change to header file inclusion.
Patch 3 is a documentation fix.
Pa
On Fri, May 22, 2015 at 03:08:44PM +, Simmons, James A. wrote:
> >This patch does a lot of stuff all at once and it is hard to review. It
> >could easily be broken into patches which are easy to review.
>
> I have more very large patches. With breaking them up that means you are
> going to se
On Fri, 2015-05-22 at 15:12 +, Simmons, James A. wrote:
> >> typedef struct lnet_peer {
> >> - struct list_headlp_hashlist; /* chain on peer hash */
> >> - struct list_headlp_txq;/* messages blocking for tx
> >> credits */
> >> - struct list_headlp_rtrq
On Fri, 2015-05-22 at 08:08 +, Drokin, Oleg wrote:
> On May 22, 2015, at 1:06 AM, Julia Lawall wrote:
>
> > On Thu, 21 May 2015, Michael Shuey wrote:
> >
> >> That's a task (of many) I've been putting on the back burner until the code
> >> is cleaner. It's also a HUGE change, since there are
'struct timeval last_tv' is used to get the time of last signal change
and 'struct timeval last_intr_tv' is used to get the time of last UART
interrupt.
32-bit systems using 'struct timeval' will break in the year 2038, so we
have to replace that code with more appropriate types.
Here struct timeva
The Comedi "addi_watchdog.h" header doesn't use anything form
"comedidev.h" apart from `struct comedi_subdevice`, which it only uses
to construct a corresponding pointer type within the parameter list of a
function prototype. Just declare the structure type incompletely and
don't bother including
A few coding style cleanups for the Comedi amplc_dio200* modules, and to
make the "amplc_dio200.h" header file self-reliant.
1) staging: comedi: amplc_dio200.h: reformat copyright comment
2) staging: comedi: amplc_dio200.h: make self-reliant
3) staging: comedi: amplc_dio200.c: reformat copyright c
Reformat the copyright comment at the top of the file to use the
preferred block comment style.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/amplc_dio200_pci.c | 35 ---
1 file changed, 18 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/comedi/dri
Use braces when the single statement following an `if` (or `else`)
spans more than one line (including any preceding comments).
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/amplc_dio200_common.c | 17 +++--
1 file changed, 11 insertions(+), 6 deletions(-)
diff --git
Reformat the copyright comment at the top of the file to use the
preferred block comment style.
Signed-off-by: Ian Abbott
---
.../staging/comedi/drivers/amplc_dio200_common.c | 38 +++---
1 file changed, 19 insertions(+), 19 deletions(-)
diff --git a/drivers/staging/comedi/dri
Reformat the copyright comment at the top of the file to use the
preferred block comment style.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/amplc_dio200.h | 40 +--
1 file changed, 20 insertions(+), 20 deletions(-)
diff --git a/drivers/staging/comedi/dri
The Comedi "amplc_dio200.h" header file included by drivers for Amplicon
DIO200 series cards does not compile cleanly when it is the first header
included by the ".c" file. It uses `struct comedi_device *` in the
parameter lists of some function prototypes, so just declare `struct
comedi_device` a
Reformat the copyright comment at the top of the file to use the
preferred block comment style.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/amplc_dio200.c | 37 ++-
1 file changed, 19 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/comedi/dri
The Comedi "comedi_8254.h" header file is included by various Comedi
drivers with timer/counters based on the 8254 chip. The drivers do not
compile cleanly if this header file is included first. It uses pointers
to the `struct comedi_device`, `struct comedi_subdevice`, and `struct
comedi_insn` st
The Comedi "comedi_isadma.h" header is included by the source for the
"comedi_isadma" helper module and other modules that use it. It does
not compile cleanly when it is the first header file included. It uses
the `dma_addr_t` type, so include to declare it. (Also,
that indirectly takes care of
Attn:Client
Your name is among last 10 victims listed to compensate by World Bank/IMF by
ATM/DEBIT CARD valued 1.5 million contact Dr. George UWA with your Full Name
,Home/Office Address and Your Direct Telephone through email below
(worldbnk...@gmail.com )
Regards
Harris Hugo
__
Attn:Client
Your name is among last 10 victims listed to compensate by World Bank/IMF by
ATM/DEBIT CARD valued 1.5 million contact Dr. George UWA with your Full Name
,Home/Office Address and Your Direct Telephone through email below
(worldbnk...@gmail.com )
Regards
Harris Hugo
__
There is no reason to have a one line exported function
libcfs_sock_release. Instead we can call sock_release directly.
Signed-off-by: James Simmons
---
.../staging/lustre/include/linux/libcfs/libcfs.h |1 -
.../staging/lustre/lnet/klnds/socklnd/socklnd.c|2 +-
.../staging/lustre/l
Point to the right place for GNU license. Update Intel copyright.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lnet/lnet/lib-socket.c | 10 +++---
1 files changed, 3 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/lustre/lnet/lnet/lib-socket.c
b/drivers/staging/lust
Another one of those silly one line wrappers which is not
needed. Replace libcfs_sock_abort_accept wrapper with a
direct call to wake_up_all on the lnet_acceptor_state sock.
Signed-off-by: James Simmons
---
.../staging/lustre/include/linux/libcfs/libcfs.h |1 -
drivers/staging/lustre/lnet/
With all the TCPIP handling done in the lnet layer we should
rename all the functions with the prefix lnet_*. One other
change done was changing the remove argument of lnet_sock_getaddr
from a int to a bool.
Signed-off-by: James Simmons
---
.../staging/lustre/include/linux/libcfs/libcfs.h |
Since libcfs no longer builds for user land we can
move the TCPIP abstraction that exist to the LNET
layer which is the only place that uses it. Also
the migrated code will use native linux kernel
APIs directly instead of with wrappers.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd
Handle all the style issues reported by checkpatch.pl.
Remove general white spaces, spaces in function calls,
etc.
Signed-off-by: James Simmons
---
.../staging/lustre/lnet/klnds/socklnd/socklnd.c|4 +-
drivers/staging/lustre/lnet/lnet/lib-socket.c | 210 +---
2 file
Instead of handling calls to struct proto ourselves we can use
equivalent kernel wrappers. No wrapper exist for unlocked ioctl
handling so we create one here for our use. I expect some day
that function will be integrated into sock.c.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lnet/
Minor changes to remove excessive whitespace and improve
readability of functions.
Signed-off-by: Chris Hanna
---
drivers/staging/lustre/lustre/osc/lproc_osc.c | 56 +++---
drivers/staging/lustre/lustre/osc/osc_cache.c | 112 ++--
drivers/staging/lustre/lustre/osc/osc_io.c |
On Friday 22 May 2015 17:58:42 Ksenija Stanojevic wrote:
> 'struct timeval last_tv' is used to get the time of last signal change
> and 'struct timeval last_intr_tv' is used to get the time of last UART
> interrupt.
> 32-bit systems using 'struct timeval' will break in the year 2038, so we
> have t
On May 22, 2015, at 11:42 AM, Joe Perches wrote:
> On Fri, 2015-05-22 at 08:08 +, Drokin, Oleg wrote:
>> On May 22, 2015, at 1:06 AM, Julia Lawall wrote:
>>
>>> On Thu, 21 May 2015, Michael Shuey wrote:
>>>
That's a task (of many) I've been putting on the back burner until the code
>>>
On Fri, May 22, 2015 at 03:08:44PM +, Simmons, James A. wrote:
> >This patch does a lot of stuff all at once and it is hard to review. It
> >could easily be broken into patches which are easy to review.
>
> I have more very large patches. With breaking them up that means you are
> going to se
On Fri, 2015-05-22 at 21:16 +, Drokin, Oleg wrote:
> On May 22, 2015, at 11:42 AM, Joe Perches wrote:
>
> > On Fri, 2015-05-22 at 08:08 +, Drokin, Oleg wrote:
> >> On May 22, 2015, at 1:06 AM, Julia Lawall wrote:
> >>
> >>> On Thu, 21 May 2015, Michael Shuey wrote:
> >>>
> That's a
On May 22, 2015, at 7:57 PM, Joe Perches wrote:
> On Fri, 2015-05-22 at 21:16 +, Drokin, Oleg wrote:
>> On May 22, 2015, at 11:42 AM, Joe Perches wrote:
>>
>>> On Fri, 2015-05-22 at 08:08 +, Drokin, Oleg wrote:
On May 22, 2015, at 1:06 AM, Julia Lawall wrote:
> On Thu, 21
On May 22, 2015, at 8:18 PM, Joe Perches wrote:
I wonder what is more clear about that in your opinion ve
lustre_error/lustre_debug?
>>>
>>> The fact that you have to explain this shows that it's
>>> at least misleading unless you completely understand the
>>> code.
>>
>> Or you know,
On Sat, 2015-05-23 at 00:07 +, Drokin, Oleg wrote:
> On May 22, 2015, at 7:57 PM, Joe Perches wrote:
> > On Fri, 2015-05-22 at 21:16 +, Drokin, Oleg wrote:
> >> On May 22, 2015, at 11:42 AM, Joe Perches wrote:
> >>> On Fri, 2015-05-22 at 08:08 +, Drokin, Oleg wrote:
> On May 22, 20
On Sat, 2015-05-23 at 00:25 +, Drokin, Oleg wrote:
> On May 22, 2015, at 8:18 PM, Joe Perches wrote:
> I wonder what is more clear about that in your opinion ve
> lustre_error/lustre_debug?
> >>>
> >>> The fact that you have to explain this shows that it's
> >>> at least misleading u
Since it is not actually doing a printk - at least, not necessarily - I like
lustre_logmsg. lustre_output seems too vague.
- Patrick
From: HPDD-discuss [hpdd-discuss-boun...@lists.01.org] on behalf of Joe Perches
[j...@perches.com]
Sent: Friday, May 22,
change cast to __le16 to fix the following warning:
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:1488:20: warning: cast to
restricted __le16
Signed-off-by: Juston Li
---
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dr
On 2014-12-07 20:14, Greg Kroah-Hartman wrote:
On Sun, Dec 07, 2014 at 06:14:42PM +0100, Stanislaw Gruszka wrote:
On Sat, Dec 06, 2014 at 09:06:29PM -0800, Greg Kroah-Hartman wrote:
> On Sun, Dec 07, 2014 at 04:38:16AM +, parths...@laer.in wrote:
> > On 2014-12-06 17:51, Greg Kroah-Hartman w
Many lines of code extend beyond the maximum line length.
Some of these are possibly justified by use type.
For instance:
structure definitions where comments are added per member like
struct foo {
type member;/* some long description */
}
And lines that don't fit the typica
56 matches
Mail list logo