This is only an API consolidation to make things more readable.
Instances of var * HZ / 1000 are replaced by msecs_to_jiffies(var).
As msecs_to_jiffies will return > 0 if it is passed a value > 0 the
== 0 check is not needed.
Signed-off-by: Nicholas Mc Guire
---
Converting milliseconds to ji
The check for return of schedule_timeout() has no effect on the
effective control flow of sleep_schedulable() so it can be dropped.
Signed-off-by: Nicholas Mc Guire
---
The current codes return check for schedule_timeout() has no effect
and can probably be dropped unless it is intended as a pla
This is only an API consolidation to make things more readable.
Instances of var * HZ / 1000 are replaced by msecs_to_jiffies(var).
Signed-off-by: Nicholas Mc Guire
---
Converting milliseconds to jiffies by "val * HZ / 1000" is technically
ok but msecs_to_jiffies(val) is the cleaner solution
This is only an API consolidation to make things more readable.
Instances of var * HZ / 1000 are replaced by msecs_to_jiffies(var).
Signed-off-by: Nicholas Mc Guire
---
Converting milliseconds to jiffies by "val * HZ / 1000" is technically
ok but msecs_to_jiffies(val) is the cleaner solution
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/comedi/drivers/jr3_pci.c | 16
1 file
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/comedi/drivers/dyna_pci10xx.c |4
1 file change
2015-01-30 22:10 GMT+01:00 Dan Carpenter :
> On Fri, Jan 30, 2015 at 12:25:53PM -0800, Greg Kroah-Hartman wrote:
>> On Fri, Jan 30, 2015 at 11:18:31PM +0300, Dan Carpenter wrote:
>> > Richard, asked some questions out of band.
>> >
Hi all!
As Dan said, I email him before. But it was not really me
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8188eu/hal/phy.c | 15 +--
1 file chang
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8188eu/core/rtw_sta_mgt.c |3 +--
1 file changed,
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8188eu/hal/rtl8188e_cmd.c |7 +--
1 file chan
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 13 ++---
1 f
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 25
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8188eu/core/rtw_mlme.c |5 +
1 file changed,
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192e/rtl8192e/rtl_dm.c |9 ++---
1 file chan
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192e/rtl8192e/rtl_pci.c |2 --
1 file changed, 2
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192e/rtl819x_BAProc.c |2 --
1 file changed, 2 d
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac_wx.c |2 --
1 f
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c |4 ++--
1 file ch
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192u/ieee80211/rtl819x_BAProc.c |2 --
1 file ch
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192u/r8192U_core.c | 10 +++---
1 file changed
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8192u/r8192U_dm.c |3 +--
1 file changed, 1 inser
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8712/rtl871x_security.c |3 ---
1 file changed, 3
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_mlme.c | 21 ++---
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_mlme_ext.c |7 +--
1 file cha
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_recv.c | 19 +++
1
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_security.c |3 ---
1 file changed
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_sta_mgt.c |2 --
1 file changed,
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/core/rtw_wlan_util.c |4 +---
1 file chang
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/hal/HalDMOutSrc8723A_CE.c |6 ++
1 fil
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
.../staging/rtl8723au/hal/rtl8723a_bt-coexist.c| 27 +++---
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c | 10 ++
1 f
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/rtl8723au/hal/usb_ops_linux.c |9 +++--
1 file c
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/slicoss/slicoss.c | 12 ++--
1 file changed, 2
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/speakup/varhandlers.c |6 ++
1 file changed, 2 i
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt6655/device_main.c |3 +--
1 file changed, 1 inser
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt6655/dpc.c |4 +---
1 file changed, 1 insertion(+)
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt6656/dpc.c |4 +---
1 file changed, 1 insertion(+)
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt6656/int.c |3 +--
1 file changed, 1 insertion(+),
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt6656/rxtx.c |5 +
1 file changed, 1 insertion(
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/xgifb/vb_init.c |4 +---
1 file changed, 1 insertion
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/xgifb/vb_setmode.c |9 +++--
1 file changed, 3 i
> I have also removed all the code that thereby serves no purpose.
[ snip ]
> @@ -743,7 +743,7 @@ static u8 phy_path_a_iqk(struct adapter *adapt, bool
> config_pathb)
> reg_eac = phy_query_bb_reg(adapt, rRx_Power_After_IQK_A_2, bMaskDWord);
> reg_e94 = phy_query_bb_reg(adapt, rTx_Pow
On Sat, Jan 31, 2015 at 03:44:33PM +0100, Rickard Strandqvist wrote:
> Variable was assigned a value that was never used.
> I have also removed all the code that thereby serves no purpose.
>
> This was found using a static code analysis program called cppcheck
>
> Signed-off-by: Rickard Strandqvi
On Sat, Jan 31, 2015 at 03:45:33PM +0100, Rickard Strandqvist wrote:
> while (phead != plist) {
> - psta = container_of(plist, struct sta_info , list);
> + container_of(plist, struct sta_info, list);
Argh!!! No.
For this one, I didn't need an context to see that it
On Sat, Jan 31, 2015 at 05:24:42PM +0530, varsharamt wrote:
> The task was to fix a warning which was shown while compiling a driver
> called NVEC. I wrote a brief description about how to enable support for
> a nVidya complaint embedded controller.
This makes no sense, what "task"?
> Signed-off
On 01/31/2015 10:19 AM, Dan Carpenter wrote:
On Sat, Jan 31, 2015 at 03:45:33PM +0100, Rickard Strandqvist wrote:
while (phead != plist) {
- psta = container_of(plist, struct sta_info , list);
+ container_of(plist, struct sta_info, list);
Argh!!! No.
For
Fixed a coding style issue.
Signed-off-by: Kolbeinn Karlsson
---
drivers/staging/rtl8192e/rtllib_module.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib_module.c
b/drivers/staging/rtl8192e/rtllib_module.c
index 91e98e8..0cf3809 100644
---
On 31 January 2015 at 17:29, Greg KH wrote:
> On Sat, Jan 31, 2015 at 05:24:42PM +0530, varsharamt wrote:
>> The task was to fix a warning which was shown while compiling a driver
>> called NVEC. I wrote a brief description about how to enable support for
>> a nVidya complaint embedded controller
Am Samstag 31 Januar 2015, 20:11:29 schrieb Julian Andres Klode:
> On 31 January 2015 at 17:29, Greg KH wrote:
> > On Sat, Jan 31, 2015 at 05:24:42PM +0530, varsharamt wrote:
> >> The task was to fix a warning which was shown while compiling a driver
> >> called NVEC. I wrote a brief description
This patch fixes the checkpatch.pl warning:
WARNING: else is not generally useful after a break or return
559: FILE: drivers/staging/vt6656/rxtx.c:559:
return vnt_rxtx_datahead_g_fb(tx_context, &buf->data_head);
} else {
Signed-off-by: Derrick Greenspan
---
Changes in v2:
- Hopefully fixed whit
On 31/01/15 15:16, Rickard Strandqvist wrote:
Variable was assigned a value that was never used.
I have also removed all the code that thereby serves no purpose.
This was found using a static code analysis program called cppcheck
Signed-off-by: Rickard Strandqvist
---
drivers/staging/vt665
This patch fixes the checkpatch.pl warning:
WARNING: line over 80 characters
All line over 80 characters in driver/staging/speakup/* are fixed.
Aditional changes suggest by mailing list are also fixed.
Signed-off-by: Shirish Gajera
---
drivers/staging/speakup/main.c | 12
On 31/01/15 19:05, Derrick Greenspan wrote:
This patch fixes the checkpatch.pl warning:
WARNING: else is not generally useful after a break or return
559: FILE: drivers/staging/vt6656/rxtx.c:559:
Checkpatch does not check that the if and else has different function scope.
It isn't erroneous
Fixed the checkpatch error:
ERROR: space prohibited before that ',' (ctx:WxE)
6: FILE: drivers/staging/speakup/i18n.h:6:
+ MSG_FIRST_INDEX ,
^
Signed-off-by: Derrick Greenspan
---
drivers/staging/speakup/i18n.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
On Sat, Jan 31, 2015 at 02:05:21PM -0500, Derrick Greenspan wrote:
> This patch fixes the checkpatch.pl warning:
>
> WARNING: else is not generally useful after a break or return
> 559: FILE: drivers/staging/vt6656/rxtx.c:559:
> return vnt_rxtx_datahead_g_fb(tx_context, &buf->data_head);
> } else
From: Haiyang Zhang
Date: Thu, 29 Jan 2015 12:34:49 -0800
> The existing code frees the skb in EAGAIN case, in which the skb will be
> retried from upper layer and used again.
> Also, the existing code doesn't free send buffer slot in error case, because
> there is no completion message for unsen
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Saturday, January 31, 2015 1:29 AM
> To: Dexuan Cui
> Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@re
On Sat, Jan 31, 2015 at 04:20:48PM +0100, Rickard Strandqvist wrote:
> Variable was assigned a value that was never used.
> I have also removed all the code that thereby serves no purpose.
>
> This was found using a static code analysis program called cppcheck
>
> Signed-off-by: Rickard Strandqvi
On Sat, Jan 31, 2015 at 11:41:04AM -0600, Larry Finger wrote:
> On 01/31/2015 10:19 AM, Dan Carpenter wrote:
> >On Sat, Jan 31, 2015 at 03:45:33PM +0100, Rickard Strandqvist wrote:
> >>while (phead != plist) {
> >>- psta = container_of(plist, struct sta_info , list);
> >>+ c
On Sat, Jan 31, 2015 at 03:45:33PM +0100, Rickard Strandqvist wrote:
> Variable was assigned a value that was never used.
> I have also removed all the code that thereby serves no purpose.
>
> This was found using a static code analysis program called cppcheck
>
> Signed-off-by: Rickard Strandqvi
60 matches
Mail list logo