Many of the functions and variables in the driver have been renamed and are now
more understandable, as well as defines added for various constants. Update /
remove some comments to reflect this.
Also many comments were unnecessary dialogue describing what is evident
from the code, or comments wer
The for loop in this function increments two variables and has an unusual
starting index of 1 (not 0). Make it look more familiar.
Reported-by: Dan Carpenter
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c |6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git
Hi,
in theory, I'd like the first five patches to go in together through Grant's
tree, but in practice that might not be necessary; changes in of_node
reference counting are only relevant if CONFIG_OF_DYNAMIC is enabled.
Since patch 2 depends on (or would trivially conflict with) 30e94a564d07
in t
In preparation for the following patch, stop decrementing the endpoint node
refcount in the loop. This temporarily leaks a reference to the endpoint node,
which will be fixed by having of_graph_get_next_endpoint decrement the refcount
of its prev argument instead.
Signed-off-by: Philipp Zabel
---
Note that while of_graph_get_next_endpoint decrements the reference count
of the child node passed to it, of_node_put(child) still has to be called
manually when breaking out of the loop.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
include/linux/of_graph.h | 11 +++
1 fi
In preparation for a following patch, stop decrementing the endpoint node
refcount in the loop. This temporarily leaks a reference to the endpoint node,
which will be fixed by having of_graph_get_next_endpoint decrement the refcount
of its prev argument instead.
Signed-off-by: Philipp Zabel
---
C
This patch adds a function to get a port device tree node by port id,
or reg property value.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
drivers/of/base.c| 26 ++
include/linux/of_graph.h | 7 +++
2 files changed, 33 insertions(+)
diff --git
Using the for_each_... macro should make the code bit shorter and
easier to read. This patch also properly decrements the endpoint node
reference count before returning out of the loop.
Signed-off-by: Philipp Zabel
---
drivers/staging/imx-drm/imx-drm-core.c | 9 +++--
1 file changed, 3 inser
Using the for_each_... macro should make the code a bit shorter and
easier to read.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
drivers/gpu/drm/drm_of.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.
Decrementing the reference count of the previous endpoint node allows to
use the of_graph_get_next_endpoint function in a for_each_... style macro.
Prior to this patch, all current users of this function that actually pass
a non-NULL prev parameter should be changed to not decrement the passed
prev
Using the for_each_... macro should make the code bit shorter and
easier to read. Since we can break out of the loop, we keep the
call to of_node_put after the loop.
Signed-off-by: Philipp Zabel
---
Changes since v3:
- Kept of_node_put after the loop, as in the earlier soc_camera patch.
This
On Mon, Sep 29, 2014 at 10:15:44AM +0200, Philipp Zabel wrote:
> In preparation for a following patch, stop decrementing the endpoint node
> refcount in the loop. This temporarily leaks a reference to the endpoint node,
> which will be fixed by having of_graph_get_next_endpoint decrement the
> ref
Dear Sir,
I am requesting for your help, to assist me in getting £42,000,000.00 to your
account. please do indicate your interest for more information's.
REPLY ( klimowi...@yahoo.com.hk )
Yours Truly,
From Daniel Klimowicz
___
devel mailing list
d
Am Montag, den 29.09.2014, 12:13 +0300 schrieb Dan Carpenter:
> On Mon, Sep 29, 2014 at 10:15:44AM +0200, Philipp Zabel wrote:
> > In preparation for a following patch, stop decrementing the endpoint node
> > refcount in the loop. This temporarily leaks a reference to the endpoint
> > node,
> > wh
On 09/29/2014 01:17 AM, Greg KH wrote:
On Sun, Sep 28, 2014 at 08:39:51PM -0500, Larry Finger wrote:
A new version of this driver has been merged into the wireless-testing tree
as commit 21e4b0726dc671c423e2dc9a85364716219c4502. It is both possible and
desirable to delete the staging version to
On Mon, Sep 29, 2014 at 11:45:23AM +0200, Philipp Zabel wrote:
> Am Montag, den 29.09.2014, 12:13 +0300 schrieb Dan Carpenter:
> > On Mon, Sep 29, 2014 at 10:15:44AM +0200, Philipp Zabel wrote:
> > > In preparation for a following patch, stop decrementing the endpoint node
> > > refcount in the loo
On Sun, Sep 28, 2014 at 08:39:51PM -0500, Larry Finger wrote:
> A new version of this driver has been merged into the wireless-testing tree
> as commit 21e4b0726dc671c423e2dc9a85364716219c4502. It is both possible and
> desirable to delete the staging version to avoid build errors in linux-next.
>
Hi,
now the first three patches of the previous series are combined into one. This
patch touches of, media, and staging. Since it is rebased onto Grant's tree, it
now trivially conflicts with 30e94a564d07 (staging: imx-drm: Lines over 80
characters fixed.)
This series converts all existing users
This patch adds a function to get a port device tree node by port id,
or reg property value.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
drivers/of/base.c| 26 ++
include/linux/of_graph.h | 7 +++
2 files changed, 33 insertions(+)
diff --git
Using the for_each_... macro should make the code bit shorter and
easier to read. This patch also properly decrements the endpoint node
reference count before returning out of the loop.
Signed-off-by: Philipp Zabel
---
drivers/staging/imx-drm/imx-drm-core.c | 9 +++--
1 file changed, 3 inser
Note that while of_graph_get_next_endpoint decrements the reference count
of the child node passed to it, of_node_put(child) still has to be called
manually when breaking out of the loop.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
include/linux/of_graph.h | 11 +++
1 fi
Using the for_each_... macro should make the code a bit shorter and
easier to read.
Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
---
drivers/gpu/drm/drm_of.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.
Using the for_each_... macro should make the code bit shorter and
easier to read. Since we can break out of the loop, we keep the
call to of_node_put after the loop.
Signed-off-by: Philipp Zabel
---
drivers/staging/imx-drm/imx-drm-core.c | 11 ---
1 file changed, 4 insertions(+), 7 delet
Decrementing the reference count of the previous endpoint node allows to
use the of_graph_get_next_endpoint function in a for_each_... style macro.
All current users of this function that pass a non-NULL prev parameter
(that is, soc_camera and imx-drm) are changed to not decrement the passed
prev a
On 09/29/2014 12:05 PM, Greg KH wrote:
On Sun, Sep 28, 2014 at 08:39:51PM -0500, Larry Finger wrote:
A new version of this driver has been merged into the wireless-testing tree
as commit 21e4b0726dc671c423e2dc9a85364716219c4502. It is both possible and
desirable to delete the staging version to
This patch remove a checkstyle warning in netlink_k.c.
Note: This is my homework of the day.
Signed-off-by: Thibaut Robert
---
drivers/staging/gdm72xx/netlink_k.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/gdm72xx/netlink_k.c
b/drivers/stag
On Sun, Sep 28, 2014 at 10:16:43PM -0700, K. Y. Srinivasan wrote:
> After the packet is successfully sent, we should not touch the skb
> as it may have been freed. This patch is based on the work done by
> Long Li .
>
> In this version of the patch I have fixed issues pointed out by David.
> Dav
On Mon, 2014-09-29 at 20:15 +0200, Thibaut Robert wrote:
> This patch remove a checkstyle warning in netlink_k.c.
> Note: This is my homework of the day.
The "Note: " line isn't useful for a commit message.
Neither is the checkpatch warning bit.
Maybe the commit message could be something like:
"
Hi,
Le samedi 27 septembre 2014 à 10:52 +0200, Heinrich Schuchardt a écrit :
> sync.h recommends to use get_unused_fd which does not set
> O_CLOEXEC while the rest of the android tree uses
> get_unused_fd_flags and sets O_CLOEXEC.
>
> The patch adjust the comment.
>
I'd like to add this patch t
> Gesendet: Montag, 29. September 2014 um 20:03 Uhr
> Von: "Yann Droneaud"
> An: "Heinrich Schuchardt"
> Cc: "Greg Kroah-Hartman" , "Colin Cross"
> , "John Stultz" , "Daniel Vetter"
> , "Sumit Semwal" , "Masanari Iida"
> , "Daeseok Youn" , "Maarten
> Lankhorst" , de...@driverdev.osuosl.org,
On Mon, Sep 29, 2014 at 01:08:21PM -0500, Larry Finger wrote:
> On 09/29/2014 12:05 PM, Greg KH wrote:
> >On Sun, Sep 28, 2014 at 08:39:51PM -0500, Larry Finger wrote:
> >>A new version of this driver has been merged into the wireless-testing tree
> >>as commit 21e4b0726dc671c423e2dc9a85364716219c4
On Mon, Sep 29, 2014 at 08:03:34PM +0200, Philipp Zabel wrote:
> Decrementing the reference count of the previous endpoint node allows to
> use the of_graph_get_next_endpoint function in a for_each_... style macro.
> All current users of this function that pass a non-NULL prev parameter
> (that is,
> >I'll be looking to see that no object
> code has changed (./scripts/objdiff) across your patch series.
Hmm... I'm thinking of digging into it, but I'm not sure the #if's can
be gotten rid of sans object code changes, since its picking codeblocks
in the precompiler stage, right?
___
Eric,
On Mon, Sep 29, 2014 at 07:40:11PM -0500, Eric Rost wrote:
> > >I'll be looking to see that no object
> > code has changed (./scripts/objdiff) across your patch series.
>
> Hmm... I'm thinking of digging into it, but I'm not sure the #if's can
> be gotten rid of sans object code changes, si
From: "K. Y. Srinivasan"
Date: Sun, 28 Sep 2014 22:16:43 -0700
> After the packet is successfully sent, we should not touch the skb
> as it may have been freed. This patch is based on the work done by
> Long Li .
>
> In this version of the patch I have fixed issues pointed out by David.
> Davi
This patchset reorganizes skein_block.c to move macro definitions out of
functions, fixes whitspace issues, and removes the need for the #if'd
for loops.
Eric Rost (4):
drivers: staging: skein: Whitespace cleanup
drivers: staging: skein: Additional Whitespace Issues
drivers: staging: skein:
Pretties up multiline #defines and many other whitespace issues
Signed-off-by: Eric Rost
---
drivers/staging/skein/skein_block.c | 585 +++
1 file changed, 315 insertions(+), 270 deletions(-)
diff --git a/drivers/staging/skein/skein_block.c
b/drivers/staging/ske
Fixes leading and trailing whitespace issues.
Signed-off-by: Eric Rost
---
drivers/staging/skein/skein_block.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/skein/skein_block.c
b/drivers/staging/skein/skein_block.c
index d497
In progress commit
Signed-off-by: Eric Rost
---
drivers/staging/skein/skein_block.c | 132 +++
1 file changed, 70 insertions(+), 62 deletions(-)
diff --git a/drivers/staging/skein/skein_block.c
b/drivers/staging/skein/skein_block.c
index 71c14f5..b8e4bd8 100644
Reorganizes file to remove #defines from middle of functions. Also
removes #if'd loop declarations and adds ternary if driven loops.
Signed-off-by: Eric Rost
---
drivers/staging/skein/skein_block.c | 568 ++-
1 file changed, 291 insertions(+), 277 deletions(-)
d
On Tue, 2014-09-30 at 01:10 -0500, Eric Rost wrote:
> Fixes leading and trailing whitespace issues.
[]
> diff --git a/drivers/staging/skein/skein_block.c
> b/drivers/staging/skein/skein_block.c
[]
> @@ -36,7 +36,7 @@
> #define debug_save_tweak(ctx) \
> { \
Fixes the follwoing checkpatch.pl warnings:
WARNING: suspect code indent for conditional statements (16, 16)
+ for (r = 1; r < 2 * RCNT; r += 2 * SKEIN_UNROLL_512)
[...]
+ {
WARNING: suspect code indent for conditional statements (16, 16)
+ for (r = 1; r <
42 matches
Mail list logo