Using the for_each_... macro should make the code bit shorter and
easier to read. Since we can break out of the loop, we keep the
call to of_node_put after the loop.

Signed-off-by: Philipp Zabel <p.za...@pengutronix.de>
---
Changes since v3:
 - Kept of_node_put after the loop, as in the earlier soc_camera patch.
   This reduces the line count and is safe to do since of_node_put(NULL)
   is a no-op.
---
 drivers/staging/imx-drm/imx-drm-core.c | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

diff --git a/drivers/staging/imx-drm/imx-drm-core.c 
b/drivers/staging/imx-drm/imx-drm-core.c
index 69e7194..43285dc 100644
--- a/drivers/staging/imx-drm/imx-drm-core.c
+++ b/drivers/staging/imx-drm/imx-drm-core.c
@@ -439,17 +439,13 @@ int imx_drm_encoder_parse_of(struct drm_device *drm,
        struct drm_encoder *encoder, struct device_node *np)
 {
        struct imx_drm_device *imxdrm = drm->dev_private;
-       struct device_node *ep = NULL;
+       struct device_node *ep;
        uint32_t crtc_mask = 0;
-       int i;
+       int i = 0;
 
-       for (i = 0; ; i++) {
+       for_each_endpoint_of_node(np, ep) {
                u32 mask;
 
-               ep = of_graph_get_next_endpoint(np, ep);
-               if (!ep)
-                       break;
-
                mask = imx_drm_find_crtc_mask(imxdrm, ep);
 
                /*
@@ -462,6 +458,7 @@ int imx_drm_encoder_parse_of(struct drm_device *drm,
                        return -EPROBE_DEFER;
 
                crtc_mask |= mask;
+               i++;
        }
 
        of_node_put(ep);
-- 
2.1.0

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to