[PATCH 0/3] mfd: rtsx: Decrease driver size and add new device

2013-11-15 Thread micky_ching
From: Micky Ching With the recent added support request of yet another device, the burden of duplicated code was becoming a little messy. To rectify is, we init rtl8411-like chips to 8411 param first, then modify the different values according each chip. Lee Jones (2): mfd: rtsx: reduce code d

[PATCH 1/3] mfd: rtsx: reduce code duplication in rtl8411

2013-11-15 Thread micky_ching
From: Lee Jones in order to remove duplicated code in rtl8411, we make 8411 as the base init params, and other like-8411 chips will just change the different value with 8411, this can save some source code. Signed-off-by: Lee Jones Signed-off-by: Micky Ching --- drivers/mfd/rtl8411.c | 76

[PATCH 3/3] mfd: rtsx: Prevent 'used uninitialised' warnings

2013-11-15 Thread micky_ching
From: Lee Jones drivers/mfd/rtl8411.c: In function -F¡rtl8411_fetch_vendor_settings¢:-A drivers/mfd/rtl8411.c:58:7: warning: -F¡reg1¢ is used uninitialized in this function [-Wuninitialized]-A drivers/mfd/rtl8411.c: In function -F¡rtl8411b_fetch_vendor_settings¢:-A drivers/mfd/rtl8411.c:79

[PATCH 2/3] mfd: rtsx: add card reader rtl8402

2013-11-15 Thread micky_ching
From: Micky Ching Add card reader rtl8042, rtl8402 is much like rtl8411, so just add it to rtl8411.c Signed-off-by: Micky Ching --- drivers/mfd/rtl8411.c | 29 + drivers/mfd/rtsx_pcr.c |2 ++ 2 files changed, 31 insertions(+) diff --git a/drivers/mfd/rtl8411

[PATCH] staging: dwc2: do not clear pending interrupts twice

2013-11-15 Thread Julien DELACOU
Pending interrupts clearing is done in dwc2_enable_common_interrupts so we don't need to do it twice. Signed-off-by: Julien Delacou --- drivers/staging/dwc2/core.c |3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/dwc2/core.c b/drivers/staging/dwc2/core.c index c8ff668..83

Re: [PATCH] staging: dwc2: do not clear pending interrupts twice

2013-11-15 Thread Dan Carpenter
On Fri, Nov 15, 2013 at 11:39:38AM +0100, Julien DELACOU wrote: > Pending interrupts clearing is done in dwc2_enable_common_interrupts > so we don't need to do it twice. > Are there any user visible effects to this bug? How did you spot it? regards, dan carpenter _

[PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Geert Uytterhoeven
drivers/staging/btmtk_usb/btmtk_usb.c: In function ‘btmtk_usb_probe’: drivers/staging/btmtk_usb/btmtk_usb.c:1610: warning: assignment from incompatible pointer type Add the new hdev parameter, cfr. commit 7bd8f09f69f8a190f9b8334a07bb0a9237612314 ("Bluetooth: Add hdev parameter to hdev->send drive

Re: [PATCH] staging: dwc2: do not clear pending interrupts twice

2013-11-15 Thread Julien DELACOU
On 11/15/2013 11:55 AM, Dan Carpenter wrote: > On Fri, Nov 15, 2013 at 11:39:38AM +0100, Julien DELACOU wrote: >> Pending interrupts clearing is done in dwc2_enable_common_interrupts >> so we don't need to do it twice. >> > Are there any user visible effects to this bug? How did you spot it? > > r

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Marcel Holtmann
Hi Geert, > drivers/staging/btmtk_usb/btmtk_usb.c: In function ‘btmtk_usb_probe’: > drivers/staging/btmtk_usb/btmtk_usb.c:1610: warning: assignment from > incompatible pointer type > > Add the new hdev parameter, cfr. commit > 7bd8f09f69f8a190f9b8334a07bb0a9237612314 ("Bluetooth: Add hdev parame

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Dan Carpenter
On Fri, Nov 15, 2013 at 09:30:04PM +0900, Marcel Holtmann wrote: > > while this is patch is correct, I do not really care about staging drivers > that actually bluntly violate my copyright. > That's very cryptic. What is going on here? I googled it and I wasn't able to find what you are talki

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Marcel Holtmann
Hi Dan, >> while this is patch is correct, I do not really care about staging drivers >> that actually bluntly violate my copyright. >> > > That's very cryptic. > > What is going on here? I googled it and I wasn't able to find what you > are talking about. Care to give us a hint and what you

Re: [PATCH 1/3] mfd: rtsx: reduce code duplication in rtl8411

2013-11-15 Thread Lee Jones
> From: Lee Jones > > in order to remove duplicated code in rtl8411, we make 8411 as the base > init params, and other like-8411 chips will just change the different > value with 8411, this can save some source code. > > Signed-off-by: Lee Jones > Signed-off-by: Micky Ching It's not good etiq

Re: [PATCH 3/3] mfd: rtsx: Prevent 'used uninitialised' warnings

2013-11-15 Thread Lee Jones
On Fri, 15 Nov 2013, micky_ch...@realsil.com.cn wrote: > From: Lee Jones > > drivers/mfd/rtl8411.c: In function -F¡rtl8411_fetch_vendor_settings¢:-A > drivers/mfd/rtl8411.c:58:7: warning: -F¡reg1¢ is used uninitialized in this > function [-Wuninitialized]-A > drivers/mfd/rtl8411.c: In funct

Re: [PATCH 2/3] mfd: rtsx: add card reader rtl8402

2013-11-15 Thread Lee Jones
On Fri, 15 Nov 2013, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > Add card reader rtl8042, rtl8402 is much like rtl8411, so just add it to > rtl8411.c > > Signed-off-by: Micky Ching > --- > drivers/mfd/rtl8411.c | 29 + > drivers/mfd/rtsx_pcr.c |

Re: [PATCH 16/51] DMA-API: ppc: vio.c: replace dma_set_mask()+dma_set_coherent_mask() with new helper

2013-11-15 Thread Cedric Le Goater
Hi, On 09/19/2013 11:41 PM, Russell King wrote: > Replace the following sequence: > > dma_set_mask(dev, mask); > dma_set_coherent_mask(dev, mask); > > with a call to the new helper dma_set_mask_and_coherent(). > > Signed-off-by: Russell King > --- > arch/powerpc/kernel/vio.c |

RE: [PATCH] staging: dwc2: do not clear pending interrupts twice

2013-11-15 Thread Paul Zimmerman
> From: Julien DELACOU [mailto:julien.dela...@st.com] > Sent: Friday, November 15, 2013 2:40 AM > > Pending interrupts clearing is done in dwc2_enable_common_interrupts > so we don't need to do it twice. > > Signed-off-by: Julien Delacou > --- > drivers/staging/dwc2/core.c |3 --- > 1 file

[PATCH] staging: gdm724x: fix leak at failure path in gdm_usb_probe()

2013-11-15 Thread Alexey Khoroshilov
Error handling code in gdm_usb_probe() deallocates all resources, but calls usb_get_dev(usbdev) and returns error code after that. The patch fixes it and, by the way, several other issues: - no need to use GFP_ATOMIC in probe(); - return -ENODEV instead of -1; - kmalloc+memset -> kzalloc Found by

[PATCH 00/31] ARM: tegra: use common reset and DMA bindings

2013-11-15 Thread Stephen Warren
From: Stephen Warren This series implements a common reset framework driver for Tegra, and updates all relevant Tegra drivers to use it. It also removes the custom DMA bindings and replaced them with the standard DMA DT bindings. Historically, the Tegra clock driver has exported a custom API for

[PATCH 21/31] staging: nvec: use reset framework

2013-11-15 Thread Stephen Warren
From: Stephen Warren Tegra's clock driver now provides an implementation of the common reset API (include/linux/reset.h). Use this instead of the old Tegra- specific API; that will soon be removed. Cc: tred...@nvidia.com Cc: pdeschrij...@nvidia.com Cc: linux-te...@vger.kernel.org Cc: linux-arm-k

Re: [PATCH v2] Move DWC2 driver out of staging

2013-11-15 Thread Dan Carpenter
On Fri, Nov 15, 2013 at 07:48:30PM +, Paul Zimmerman wrote: > > From: Greg KH [mailto:gre...@linuxfoundation.org] > > Sent: Thursday, November 14, 2013 8:33 PM > > > > On Thu, Nov 14, 2013 at 02:50:24PM -0800, Paul Zimmerman wrote: > > > DWC2 driver should be in good enough shape to move out o

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Greg Kroah-Hartman
On Fri, Nov 15, 2013 at 10:26:41PM +0900, Marcel Holtmann wrote: > Hi Dan, > > >> while this is patch is correct, I do not really care about staging drivers > >> that actually bluntly violate my copyright. > >> > > > > That's very cryptic. > > > > What is going on here? I googled it and I was

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Marcel Holtmann
Hi Greg, while this is patch is correct, I do not really care about staging drivers that actually bluntly violate my copyright. >>> >>> That's very cryptic. >>> >>> What is going on here? I googled it and I wasn't able to find what you >>> are talking about. Care to give us a

[PATCH] staging: slicoss: fix possible missing iounmap

2013-11-15 Thread Laurent Navet
if slic_card_locate failed, memmapped_ioaddr is not unmapped. Signed-off-by: Laurent Navet --- drivers/staging/slicoss/slicoss.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/slicoss/slicoss.c b/drivers/staging/slicoss/slicoss.c index 652272b..ab7206d 10064

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Marcel Holtmann
Hi Greg, > while this is patch is correct, I do not really care about staging > drivers that actually bluntly violate my copyright. > That's very cryptic. What is going on here? I googled it and I wasn't able to find what you are talking about. Care to gi

Re: [PATCH] Staging: btmtk_usb: Add hdev parameter to hdev->send driver callback

2013-11-15 Thread Greg Kroah-Hartman
On Sat, Nov 16, 2013 at 07:36:31AM +0900, Marcel Holtmann wrote: > Hi Greg, > > > while this is patch is correct, I do not really care about staging > > drivers that actually bluntly violate my copyright. > > > > That's very cryptic. > > What is going on here?