On 09.07.20 11:32, Martin Kepplinger wrote:
> hi linux-media people,
>
> TL-DR: when exactly is "sd->entity.function == MEDIA_ENT_F_VID_MUX"?
>
>
> I try to use the camera on our librem5-devkit (imx8mq): I try to use
> only mainline drivers except for "mx
hi linux-media people,
TL-DR: when exactly is "sd->entity.function == MEDIA_ENT_F_VID_MUX"?
I try to use the camera on our librem5-devkit (imx8mq): I try to use
only mainline drivers except for "mxc-mipi-csi2_yav" taken from
linux-imx (which we can prepare to submit if a PoC works. This is the
t
realloc() returns NULL in case it fails. Since we don't save the
pointer in question elsewhere, we leak memory by assigning NULL
to the original memory in the heap.
realloc() doesn't free memory in case of failure, so let's do
it manually.
Signed-off-by: Martin Kepplinger
This fixes typos in vboxvideo's help text. Most notably, "to builtin
this module" becomes "to build this driver built-in to the kernel".
Signed-off-by: Martin Kepplinger
---
revision history
v3: Avoid a repetition of "this driver".
v2: Say &q
This fixes typos in vboxvideo's help text. Most notably, "to builtin
this module" becomes "to build this driver built-in to the kernel".
Signed-off-by: Martin Kepplinger
---
Thanks Dan. I actually also had the feeling that even though it's better,
it's not as
This fixes typos in vboxvideo's help text.
Signed-off-by: Martin Kepplinger
---
drivers/staging/vboxvideo/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/vboxvideo/Kconfig
b/drivers/staging/vboxvideo/Kconfig
index a52746f9a670..2b058d5
From: Martin Kepplinger
The MMA8653FC is a low-power, three-axis, capacitive micromachined
accelerometer with 10 bits of resolution with flexible user-programmable
options.
Embedded interrupt functions enable overall power savings, by relieving the
host processor from continuously polling data
FP_KERNEL);
> if (!buffer)
> - goto out;
> + goto free_fw;
>
> for (ii = 0; ii < fw->size; ii += FIRMWARE_CHUNK_SIZE) {
> length = min_t(int, fw->size - ii, FIRMWARE_CHUNK_SIZE);
>
looks good to me, although somebody else
remove a typedef that is not even really used.
Signed-off-by: Martin Kepplinger
---
builds in next-20140905.
drivers/staging/rtl8192u/r8192U_core.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u
at it.
Signed-off-by: Martin Kepplinger
---
Yes, there were changes in the meantime. This applies to -next20140808
and builds. thanks.
drivers/staging/rtl8192u/r8192U_core.c | 757 +---
1 file changed, 408 insertions(+), 349 deletions(-)
diff --git a/drivers/staging/rtl
remove dprintk() and replace it with dev_dbg() or pr_debug()
in order to use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
Thanks for looking at it. So this doesn't add anything and actually does
what it says. If I haven't understood what you meant, or if I sho
remove dprintk() and replace it with dev_dbg() in order to
use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
Thanks Dan. And since it continues to succeed if (dev == NULL),
differntiate if (dev) or not.
drivers/staging/media/as102/as102_drv.c | 15 +++---
drivers
This fixes sparse errors where 0 is used for non-integers.
Signed-off-by: Martin Kepplinger
---
applies to -next20140802
drivers/staging/lustre/lnet/lnet/api-ni.c |4 +-
drivers/staging/lustre/lustre/fld/fld_request.c|2 +-
drivers/staging/lustre/lustre/llite/llite_lib.c
ff-by: Martin Kepplinger
---
This changes only a part of rtl8192u's comments. When this is desired,
one can go about and change the rest of the driver.
build-tested. applies to -next20140801
drivers/staging/rtl8192u/r8180_93cx6.c | 12 +-
drivers/staging/rtl8192u/r8192U_cor
remove dprintk() and replace it with dev_dbg() in order to
use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
I don't have the device but this builds.
I think this is ok when it gets reviewed.
applies to -next20140801
drivers/staging/media/as102/as102_drv.c |
Fix the sparse error: cast removes address space of expression and
add __user annotation to the driver's ethtool_ioctl().
Signed-off-by: Martin Kepplinger
---
I think I forgot to change the declaration on top.
drivers/staging/vt6655/device_main.c |6 +++---
1 file changed, 3 inser
Fix the sparse error: cast removes address space of expression and
add __user annotation to the driver's ethtool_ioctl().
Signed-off-by: Martin Kepplinger
---
Beyond that, how would you include socket.c's ethtool_ioctl() here?
thanks for looking at these tiny changes.
drivers/stag
Remove a totally unnecessary typedef and rename it to lowercase.
This is more readable now.
Signed-off-by: Martin Kepplinger
---
so in that way, one could change the more heavily used typedefs as well.
thanks for your review.
drivers/staging/vt6655/card.c |2 +-
drivers/staging/vt6655
Remove a totally unnecessary typedef. This is more readable now.
Signed-off-by: Martin Kepplinger
---
applies to next-20140611
drivers/staging/vt6655/card.c |2 +-
drivers/staging/vt6655/device.h |6 +++---
drivers/staging/vt6655/wmgr.c |2 +-
3 files changed, 5 insertions
Fix the sparse error: cast removes address space of expression.
---
Is that even correct? I haven't signed-off on it yet.
ethtool_ioctl() takes a (void *) as user data, dereferenced and assigend to u32.
applies to next-20140611
drivers/staging/vt6655/device_main.c |2 +-
1 file changed, 1 ins
For obvious error messages, use dev_err() in order to provide userspace
with more useful information and use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
i just waited a week or so. this applies to next-20140516.
greetings from Linuxdays Vienna, Austria
drivers/staging
Am 2014-05-17 19:21, schrieb Antti Palosaari:
> On 05/17/2014 07:05 PM, Martin Kepplinger wrote:
>> don't reinvent dev_dbg(). remove dprintk() in as102_drv.c.
>> use the common kernel coding style.
>>
>> Signed-off-by: Martin Kepplinger
>
> Reviewed-by: Antt
don't reinvent dev_dbg(). remove dprintk() in as102_drv.c.
use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
this applies to next-20140516. any more suggestions?
more cleanup can be done when dprintk() is completely gone.
drivers/staging/media/as102/as102_drv.c |
don't reinvent dev_dbg(). use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
this applies to next-20140516.
drivers/staging/media/as102/as102_drv.c | 11 +++
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/media/as102/as102_drv
For obvious error messages, use dev_err() in order to provide userspace
with more useful information and use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
this applies to v3.15-rc4
greetings from Linuxdays Vienna, Austria
drivers/staging/winbond/wb35tx.c |6
Am 2014-05-06 15:33, schrieb Dan Carpenter:
> On Tue, May 06, 2014 at 02:41:37PM +0200, Martin Kepplinger wrote:
>> fix following warning by dynamically allocating memory:
>> dgnc_tty.c:583:1: warning: the frame size of 1060 bytes is larger than 1024
>> bytes [-Wframe-large
fix following warning by dynamically allocating memory:
dgnc_tty.c:583:1: warning: the frame size of 1060 bytes is larger than 1024
bytes [-Wframe-larger-than=]
Signed-off-by: Martin Kepplinger
---
This is more of a question. Is this a desired solution to fixing such a
frame size warning
Don't list elements to initialize. Remaining elements of a partly
initialized array are set to zero. Sparse complained here.
Signed-off-by: Martin Kepplinger
---
drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dr
Don't require FIRMWAREbDownload() to, first off, unlock a held lock.
Thus do all locking in main_usb.c and hold it for a insignificantly
shorter period of time. This makes the affected area significantly more
readable though.
Signed-off-by: Martin Kepplinger
---
I resend https://lkml.org
Am 2014-05-05 14:36, schrieb Dan Carpenter:
> On Mon, May 05, 2014 at 01:59:25PM +0200, Martin Kepplinger wrote:
>> Am 2014-05-05 13:35, schrieb Dan Carpenter:
>>> On Mon, May 05, 2014 at 12:29:39PM +0200, Martin Kepplinger wrote:
>>>> Use dev_err() instead of printk
Am 2014-05-05 13:35, schrieb Dan Carpenter:
> On Mon, May 05, 2014 at 12:29:39PM +0200, Martin Kepplinger wrote:
>> Use dev_err() instead of printk() and remove "dgnc:" from the message.
>> This should provide userspace with more useful information and use
>>
Use dev_err() instead of printk() and remove "dgnc:" from the message.
This should provide userspace with more useful information and use
the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
drivers/staging/dgnc/dgnc_sysfs.c |2 +-
1 file changed, 1 insertion(+),
Shared addresses can be marked as such.
Signed-off-by: Martin Kepplinger
---
I guess that's what you meant. Thanks for your feedback!
drivers/staging/rtl8821ae/wifi.h |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8821ae/wifi.h b/drivers/st
pci_iounmap is used that way in drivers/net/wireless/rtlwifi and this
fixes sparse warnings.
Signed-off-by: Martin Kepplinger
---
drivers/staging/rtl8821ae/pci.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8821ae/pci.c b/drivers/staging
Use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
noise from the eudyptula challenge. applies to next-20140408 as well as
linus' current tree.
drivers/staging/rtl8187se/ieee80211/ieee80211_tx.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --
35 matches
Mail list logo