On Fri, May 21, 2021 at 12:30:41AM +0530, Deepak R Varma wrote:
> This patch set overall improves the code organisation and readability of
> the files of atomisp drivers. There are several complaints reported by
> checkpatch including ERROR and WARNING types on the files under at
On Fri, May 21, 2021 at 01:52:22PM +0300, Dan Carpenter wrote:
> On Sat, May 01, 2021 at 12:16:07PM +0530, Deepak R Varma wrote:
> > @@ -1562,8 +1544,10 @@ ia_css_isp_3a_statistics_map_allocate(
> > base_ptr = me->data_ptr;
> >
> > me->size = isp_stat
On Fri, Apr 30, 2021 at 10:48:12PM +0530, Deepak R Varma wrote:
> On Fri, Apr 30, 2021 at 08:12:41PM +0300, Sakari Ailus wrote:
> > Hi Deepak,
> >
> > On Fri, Apr 30, 2021 at 10:34:37PM +0530, Deepak R Varma wrote:
> > > On Fri, Apr 30, 2021 at 07:33:27PM +0300,
Trivial code reformatting changes done according to the coding
style guidelines. These code changes overall improve code readability
and also address chackpatch complaints.
Signed-off-by: Deepak R Varma
---
drivers/staging/media/atomisp/pci/sh_css_version.c | 4 ++--
1 file changed, 2
Several trivial code reformatting changes done according to the coding
style guidelines. These code changes overall improve code organisation
and readability and also address many chackpatch error, warning and
check complaints.
Signed-off-by: Deepak R Varma
---
drivers/staging/media/atomisp/pci
Several trivial code reformatting changes done according to the coding
style guidelines. These code changes overall improve code organisation
and readability and also address many chackpatch error, warning and
check complaints.
Signed-off-by: Deepak R Varma
---
.../staging/media/atomisp/pci
Several trivial code reformatting changes done according to the coding
style guidelines. These code changes overall improve code organisation
and readability and also address many chackpatch error, warning and
check complaints.
Signed-off-by: Deepak R Varma
---
.../staging/media/atomisp/pci
Several trivial code reformatting changes done according to the coding
style guidelines. These changes improves code organisation and readability
and also 4 address many chackpatch error, warning and check complaints.
Signed-off-by: Deepak R Varma
---
.../staging/media/atomisp/pci/atomisp_csi2
issues to be addressed in each individual file. The patches are built
on the media_tree/for-v5.14-out1 tree/branch.
Deepak R Varma (5):
staging: media: atomisp: code formatting changes atomisp_csi2.c
staging: media: atomisp: code formatting changes sh_css_mipi.c
staging: media: atomisp: code
On Fri, Apr 30, 2021 at 08:12:41PM +0300, Sakari Ailus wrote:
> Hi Deepak,
>
> On Fri, Apr 30, 2021 at 10:34:37PM +0530, Deepak R Varma wrote:
> > On Fri, Apr 30, 2021 at 07:33:27PM +0300, Sakari Ailus wrote:
> > > Hi Deepak,
> > >
> > > If you'r
30, 2021 at 09:10:12PM +0530, Deepak R Varma wrote:
> > Misplaced braces makes it difficult to follow the code easily. This also
> > goes against the code style guidelines. This resolved following checkpatch
> > complaints:
> >
> > ERROR: open brace '{' fol
ne
Signed-off-by: Deepak R Varma
---
Please Note: There are several other checkpatch triggered warnings and
errors that should be addressed in separate patches.
.../staging/media/atomisp/pci/atomisp_csi2.c | 3 +-
.../staging/media/atomisp/pci/sh_css_mipi.c | 69 +++
.../staging/med
On Mon, Oct 26, 2020 at 06:57:17AM +0100, Greg Kroah-Hartman wrote:
> On Mon, Oct 26, 2020 at 09:34:53AM +0530, Deepak R Varma wrote:
> > On Wed, Oct 21, 2020 at 01:01:07PM +0530, Deepak R Varma wrote:
> >
> > Hello,
> > Requesting a review / ack of this patch.
>
&g
Rename show_engine_regs show function to engine_regs_show as per the
convention followed. The show function macro DEVICE_ATTR also replaced
by DEVICE_ATTR_RO. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v2:
- None for this patch.
Changes since v1
Reformat lines that exceed 100 column in length. Issue reported by
checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v2:
- Avoid too much line breaks for a single instruction.
- change suggested by Matthew Wilcox.
Changes since v1:
- No change in this patch.
- Patch
On Mon, Oct 26, 2020 at 04:16:52AM +, Matthew Wilcox wrote:
> On Mon, Oct 26, 2020 at 09:34:53AM +0530, Deepak R Varma wrote:
> > > - dev_dbg(&eng->pldev->dev, "Handling completed descriptor %p
> > > (acd = %p)\n", cur, cur->acd);
> &g
On Wed, Oct 21, 2020 at 01:05:25PM +0530, Deepak R Varma wrote:
Hello,
Requesting a review / ack for this patch.
Thank you,
Deepak.
> Rename show_engine_regs show function to engine_regs_show as per the
> convention followed. The show function macro DEVICE_ATTR is replaced
> by DEVIC
On Wed, Oct 21, 2020 at 01:01:07PM +0530, Deepak R Varma wrote:
Hello,
Requesting a review / ack of this patch.
Thank you,
Deepak.
> Reformat lines that exceed 100 column in length. Issue reported by
> checkpatch script.
>
> Signed-off-by: Deepak R Varma
> ---
> Changes s
On Thu, Oct 22, 2020 at 07:29:31AM +0200, Greg KH wrote:
> On Thu, Oct 22, 2020 at 09:07:01AM +0530, Deepak R Varma wrote:
> > Hello,
> > I am reviewing the file: drivers/staging/greybus/audio_manager_module.c
> > and have found that there are several gb_audio_module_*_sh
On Thu, Oct 22, 2020 at 07:29:31AM +0200, Greg KH wrote:
> On Thu, Oct 22, 2020 at 09:07:01AM +0530, Deepak R Varma wrote:
> > Hello,
> > I am reviewing the file: drivers/staging/greybus/audio_manager_module.c
> > and have found that there are several gb_audio_module_*_sh
Correct code indentation and realignment as per the coding style
guidelines. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
drivers/staging/greybus/audio_codec.c | 109 +++---
.../staging/greybus/audio_manager_module.c| 3 +-
2 files changed, 40
Hello,
I am reviewing the file: drivers/staging/greybus/audio_manager_module.c
and have found that there are several gb_audio_module_*_show functions
that accept "struct gb_audio_manager_module_attribute * " as a function
parameter. However, this parameter is not used and should not be
necessary. W
Re-indent code as per the coding style guidelines. The changes improve
code readability. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v2:
- None.
Changes since v1:
- Separate specific checkpatch issues into individual patches.
- Updated patch
Reformat lines that exceed 100 column in length. Issue reported by
checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v1:
- Separate specific checkpatch issues into individual patches.
- Updated patch subject and description to be specific to the issue
being fixed
Replace bit masking by the BIT macro. This resolves the checkpatch issue
"CHECK: Prefer using the BIT macro"
Signed-off-by: Deepak R Varma
---
Changes since v2:
- Update patch description as suggested by Julia L.
Changes since v1:
- Separate specific checkpatch issues into
Reformat lines that exceed 100 column in length. Issue reported by
checkpatch script.
Signed-off-by: Deepak R Varma
---
drivers/staging/kpc2000/kpc2000/cell_probe.c | 71 +++-
1 file changed, 55 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/kpc2000/kpc2000
Rename show_engine_regs show function to engine_regs_show as per the
convention followed. The show function macro DEVICE_ATTR is replaced
by DEVICE_ATTR_RO. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v1:
- Replace DEVICE_ATTR by DEVICE_ATTR_RO as
Replace bit masking by BIT macro. This resolves checkpatch issue
"CHECK: Prefer using the BIT macro"
Signed-off-by: Deepak R Varma
---
Changes since v1:
- Separate specific checkpatch issues into individual patches.
- Introduced patch 3/3.
- Suggested by Vaishali T.
drive
Reformat lines that exceed 100 column in length. Issue reported by
checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v1:
- No change in this patch.
- Patch 2/2 has a change.
drivers/staging/kpc2000/kpc_dma/dma.c | 27 +---
drivers/staging/kpc2000/kpc_dma
Re-indent code as per the coding style guidelines. The changes improve
code readability. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
Changes since v1:
- Separate specific checkpatch issues into individual patches.
- Update patch subject and description to specific
On Wed, Oct 21, 2020 at 07:50:31AM +0200, Greg Kroah-Hartman wrote:
> On Wed, Oct 21, 2020 at 10:40:21AM +0530, Deepak R Varma wrote:
> > Rename show_engine_regs to engine_regs_show as per the convention
> > followed. Issue reported by checkpatch script.
> >
> > Si
On Wed, Oct 21, 2020 at 10:11:52AM +0530, Vaishali Thakkar wrote:
> On Wed, Oct 21, 2020 at 8:33 AM Deepak R Varma wrote:
> >
> > Multiple issues reported by checkpatch script around lines exceeding 100
> > columns, indentation of function parameters, extra blank lines. Thes
Rename show_engine_regs to engine_regs_show as per the convention
followed. Issue reported by checkpatch script.
Signed-off-by: Deepak R Varma
---
drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/kpc2000
Reformat lines that exceed 100 column in length. Issue reported by
checkpatch script.
Signed-off-by: Deepak R Varma
---
drivers/staging/kpc2000/kpc_dma/dma.c | 27 +---
drivers/staging/kpc2000/kpc_dma/fileops.c | 44 +++
.../staging/kpc2000/kpc_dma
Replace bit masking by BIT macro. This resolves checkpatch issue
"CHECK: Prefer using the BIT macro"
Signed-off-by: Deepak R Varma
---
drivers/staging/kpc2000/kpc2000/dma_common_defs.h | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/stagi
Multiple issues reported by checkpatch script around lines exceeding 100
columns, indentation of function parameters, extra blank lines. These
code formatting changes improves the code readability.
Signed-off-by: Deepak R Varma
---
drivers/staging/kpc2000/kpc2000/cell_probe.c | 71
Boolean comparison of the condition inside unittest function is
unnecessary and can be simplified by directly using the condition
outcome for evaluation. Issue reported by :
scripts/coccinelle/misc/boolinit.cocci
Signed-off-by: Deepak R Varma
---
Changes since v2:
- Update patch subject to
Boolean comparison of the condition inside unittest function is
unnecessary and can be simplified by directly using the condition
outcome for evaluation. Issue reported by :
scripts/coccinelle/misc/boolinit.cocci
Signed-off-by: Deepak R Varma
---
Changes since v1:
- Corrected wrongly
On Mon, Oct 19, 2020 at 12:34:15PM +0100, Ian Abbott wrote:
> On 19/10/2020 11:57, Deepak R Varma wrote:
> > On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote:
> > >
> > >
> > > On Mon, 19 Oct 2020, Ian Abbott wrote:
> > >
>
On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote:
>
>
> On Mon, 19 Oct 2020, Ian Abbott wrote:
>
> > On 18/10/2020 20:49, Deepak R Varma wrote:
> > > Instructions split on multiple lines can be combined on a single line
> > > for improved readabi
On Mon, Oct 19, 2020 at 11:17:38AM +0100, Ian Abbott wrote:
> On 18/10/2020 20:48, Deepak R Varma wrote:
> > Boolean comparison of the condition inside unittest function is
> > unnecessary and can be simplified by directly using the condition
> > outcome for evaluati
Instructions split on multiple lines can be combined on a single line
for improved readability of the code.
Signed-off-by: Deepak R Varma
---
.../staging/comedi/drivers/tests/ni_routes_test.c| 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging
Boolean comparison of the condition inside unittest function is
unnecessary and can be simplified by directly using the condition
outcome for evaluation. Issue reported by :
scripts/coccinelle/misc/boolinit.cocci
Signed-off-by: Deepak R Varma
---
drivers/staging/comedi/drivers/tests
43 matches
Mail list logo