Hi Greg,
On Wed, 28 Mar 2018 13:31:01 +0200
Greg KH wrote:
> On Tue, Mar 27, 2018 at 12:52:13PM +0530, Ajay Singh wrote:
> >
> > Please let me know, in case I have to rework and resubmit this
> > patch series to make them into staging branch.
>
> You already sent a v2 series for this, right?
Hello,
syzbot hit the following crash on upstream commit
f2d285669aae656dfeafa0bf25e86bbbc5d22329 (Tue Apr 3 17:45:39 2018 +)
Merge tag 'pm-4.17-rc1' of
git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm
syzbot dashboard link:
https://syzkaller.appspot.com/bug?extid=0cf1f1aa154
Fix 'line over 80 characters' issue found by checkpatch.pl script in
mtk_set_link_ksettings().
Signed-off-by: Jefferson Capovilla
---
drivers/staging/mt7621-eth/ethtool.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-eth/ethtool.c
b/drivers/stagi
From: Michael Kelley
Add comments describing intricacies of Hyper-V ring buffer
signaling code. This information is not in Hyper-V public
documents, so include here to capture the knowledge for
future coders.
There are no code changes in this commit.
Signed-off-by: Michael Kelley
---
drivers
On Sat, Mar 31, 2018 at 10:09:40PM +0200, Stefan Wahren wrote:
> The kernel would like to have all stack VLA usage removed[1]. The array
> here is fixed (declared with a const variable) but it appears like a VLA
> to the compiler. Also, currently we are putting 768 bytes on the
> stack. So save sta
On Tue, 2018-04-03 at 21:33 +0800, Xidong Wang wrote:
> From: Xidong Wang <2711406...@qq.com>
>
> In function fbtft_framebuffer_alloc(), the memory allocated by
> framebuffer_alloc() is not released on the error path that txbuflen > 0
> and txbuf, which holds the return value of devm_kzalloc(), is
From: Michael Kelley
Add standard interrupt handler annotations to
hyperv_vector_handler().
Signed-off-by: Michael Kelley
---
Changes in v2:
* Fixed From: line
---
arch/x86/kernel/cpu/mshyperv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/kernel/cpu/mshyperv.c
On Tue, Apr 03, 2018 at 12:57:35PM -0700, Michael Kelley wrote:
> Add standard interrupt handler annotations to
> hyperv_vector_handler().
>
> Signed-off-by: Michael Kelley
Does not match the From: line :(
___
devel mailing list
de...@linuxdriverprojec
Add standard interrupt handler annotations to
hyperv_vector_handler().
Signed-off-by: Michael Kelley
---
arch/x86/kernel/cpu/mshyperv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/kernel/cpu/mshyperv.c b/arch/x86/kernel/cpu/mshyperv.c
index 4488cf0..20f6849 10064
On Tue, Apr 03, 2018 at 05:58:31PM +1000, NeilBrown wrote:
> Thanks for these.
> When I addressed the various problems that I've mentioned separately
> the code compiles and boots and can access the sd card!
Thanks for your and Dan's quick reviews! Dan, I have tried your
script, it makes the proce
On Tue, Apr 3, 2018 at 5:18 PM, Robert Jarzmik wrote:
> Arnd Bergmann writes:
>
>>> + { "smc911x.0", "rx", PDMA_FILTER_PARAM(LOWEST, -1) },
>>> + { "smc911x.0", "tx", PDMA_FILTER_PARAM(LOWEST, -1) },
>>> + { "smc91x.0", "data", PDMA_FILTER_PARAM(LOWEST, -1) },
>>
>> This one is
Arnd Bergmann writes:
>> + { "smc911x.0", "rx", PDMA_FILTER_PARAM(LOWEST, -1) },
>> + { "smc911x.0", "tx", PDMA_FILTER_PARAM(LOWEST, -1) },
>> + { "smc91x.0", "data", PDMA_FILTER_PARAM(LOWEST, -1) },
>
> This one is interesting, as you are dealing with an off-chip device,
> and
This commit checks missing error code check when checking
if the firmware is running reading General Communication
Register A (GCR_A).
It also set ret to EBUSY if firmware is running before
copying it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 3 +++
1 file ch
This commit extracts firmware copy process into a new function
ks7010_copy_firmware. Because rom_buf is only needed for this
process, memory request for it has been also moved to this new
function so the error handling label release_host_and_free has
been renamed to release_host into ks7010_upload_
This commit just fixes some checkpatch reported issues about
lines longer than 80 characters.
A new blank line has been added also to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
dif
This commit extract initial enqueue process into a new
ks7010_sme_enqueue_events function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 33 +++--
1 file changed, 19 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/ks7010/ks7
This commit fixs the label to jump to when in case
an error occurs disabling interrupts. At this point
of the code sdio_enable_func() function has been
successfully called.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 3 ++-
1 file changed, 2 insertions(+), 1 dele
This commit extract ks_wlan_private initialization process
into a new function ks7010_private_init to improve a bit
readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 50
1 file changed, 28 insertions(+), 22 deletions(-)
This commit extract sdio irq setup process into a new
function ks7010_sdio_setup_irqs to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 32 +---
1 file changed, 21 insertions(+), 11 deletions(-)
diff --git a/drivers/
This commit removes unnecessay out of memory message
fixing the following checkpach.pl warning:
WARNING: Possible unnecessary 'out of memory' message
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/
This commit extracts sdio irq enable process to a new function
ks7010_sdio_init_irqs to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 43 ++--
1 file changed, 27 insertions(+), 16 deletions(-)
diff --git a/drive
This patch series factors out some functions to improve
a bit readility in ks7010_sdio source file.
v2:
- PATCH 8: fix a memory leak in extracted factor out function
copy_firmware.
- PATCH 8: error label has been renamed from 'copy_error' to
'free_rom_buf'.
- some style issues in PATCH
On 2 April 2018 at 16:26, Robert Jarzmik wrote:
> Hi,
>
> This serie is aimed at removing the dmaengine slave compat use, and transfer
> knowledge of the DMA requestors into architecture code.
>
> This was discussed/advised by Arnd a couple of years back, it's almost time.
>
> The serie is divided
There is a typo in the subject. It should be "Staging" instead of
"taging:".
On Tue, Apr 03, 2018 at 09:14:28PM +0800, Xidong Wang wrote:
> From: Xidong Wang <2711406...@qq.com>
>
> In function fbtft_framebuffer_alloc(), the memory allocated by
> framebuffer_alloc() is not released on the error
From: Xidong Wang <2711406...@qq.com>
In function fbtft_framebuffer_alloc(), the memory allocated by
framebuffer_alloc() is not released on the error path that txbuflen > 0
and txbuf, which holds the return value of devm_kzalloc(), is NULL.
This will result in a memory leak bug.
Signed-off-by: Xi
From: Xidong Wang <2711406...@qq.com>
In function fbtft_framebuffer_alloc(), the memory allocated by
framebuffer_alloc() is not released on the error path that txbuflen > 0
and txbuf, which holds the return value of devm_kzalloc(), is NULL.
This will result in a memory leak bug.
Signed-off-by: Xi
On Tue, Apr 03, 2018 at 09:14:28PM +0800, Xidong Wang wrote:
> From: Xidong Wang <2711406...@qq.com>
>
> In function fbtft_framebuffer_alloc(), the memory allocated by
> framebuffer_alloc() is not released on the error path that txbuflen > 0
> and txbuf, which holds the return value of devm_kzallo
This will crash. Please see my comments that I just posted to v3.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Fri, Mar 30, 2018 at 02:51:55PM +0900, Ji-Hun Kim wrote:
> There was no code for handling memory leaks of device_init_rings() and
> request_irq(). It needs to free allocated memory in the device_init_rings()
> , when request_irq() is failed. Add freeing sequences of irq and device
> init rings.
On Tue, Apr 03, 2018 at 12:40:24PM +0200, Sergio Paracuellos wrote:
> +static int ks7010_upload_firmware(struct ks_sdio_card *card)
> +{
> + struct ks_wlan_private *priv = card->priv;
> + unsigned int n;
> + int ret;
> + const struct firmware *fw_entry = NULL;
> +
> + sdio_claim
Same complaint as last time...
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Tue, Apr 03, 2018 at 12:06:59PM +0200, Sergio Paracuellos wrote:
> On Tue, Apr 3, 2018 at 11:23 AM, Dan Carpenter
> wrote:
> > On Fri, Mar 30, 2018 at 05:13:20PM +0200, Sergio Paracuellos wrote:
> >> @@ -655,9 +663,7 @@ static int ks7010_upload_firmware(struct ks_sdio_card
> >> *card)
> >>
>
On Fri, Mar 30, 2018 at 11:44:04AM +0900, Ji-Hun Kim wrote:
> @@ -528,18 +528,22 @@ static void device_free_rings(struct vnt_private *priv)
> priv->tx0_bufs, priv->tx_bufs_dma0);
> }
>
> -static void device_init_rd0_ring(struct vnt_private *priv)
> +static int dev
This commit removes unnecessay out of memory message
fixing the following checkpach.pl warning:
WARNING: Possible unnecessary 'out of memory' message
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/
This commit fixs the label to jump to when in case
an error occurs disabling interrupts. At this point
of the code sdio_enable_func() function has been
successfully called.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 3 ++-
1 file changed, 2 insertions(+), 1 dele
This commit extract initial enqueue process into a new
ks7010_sme_enqueue_events function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 33 +++--
1 file changed, 19 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/ks7010/ks7
This commit just fixes some checkpatch reported issues about
lines longer than 80 characters.
A new blank line has been added also to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
dif
This commit extracts sdio irq enable process to a new function
ks7010_sdio_init_irqs to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 43 ++--
1 file changed, 27 insertions(+), 16 deletions(-)
diff --git a/drive
This commit extract ks_wlan_private initialization process
into a new function ks7010_private_init to improve a bit
readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 50
1 file changed, 28 insertions(+), 22 deletions(-)
This commit extract sdio irq setup process into a new
function ks7010_sdio_setup_irqs to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 32 +---
1 file changed, 21 insertions(+), 11 deletions(-)
diff --git a/drivers/
This commit extracts firmware copy process into a new function
ks7010_copy_firmware. Because rom_buf is only needed for this
process, memory request for it has been also moved to this new
function so the error handling label release_host_and_free has
been renamed to release_host into ks7010_upload_
This commit extracts process to check if firmware is running
into a new inline function called ks7010_is_firmware_running.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/drive
This patch series factors out some functions to improve
a bit readility in ks7010_sdio source file.
v2:
- PATCH 8: fix a memory leak in extracted factor out function
copy_firmware.
- PATCH 8: error label has been renamed from 'copy_error' to
'free_rom_buf'.
- some style issues in PATCH
On Tue, Apr 3, 2018 at 11:52 AM, Dan Carpenter wrote:
> On Fri, Mar 30, 2018 at 05:13:21PM +0200, Sergio Paracuellos wrote:
>> @@ -686,32 +673,61 @@ static int ks7010_upload_firmware(struct ks_sdio_card
>> *card)
>> }
>> if (size == 0)
>> break;
>
On Tue, Apr 3, 2018 at 11:23 AM, Dan Carpenter wrote:
> On Fri, Mar 30, 2018 at 05:13:20PM +0200, Sergio Paracuellos wrote:
>> This commit extracts process to check if firmware is running
>> into a new inline function called ks7010_is_firmware_running.
>>
>> Signed-off-by: Sergio Paracuellos
>> -
On Fri, Mar 30, 2018 at 05:13:21PM +0200, Sergio Paracuellos wrote:
> @@ -686,32 +673,61 @@ static int ks7010_upload_firmware(struct ks_sdio_card
> *card)
> }
> if (size == 0)
> break;
> +
There are a few unrelated white space changes. This one i
On Fri, Mar 30, 2018 at 05:13:20PM +0200, Sergio Paracuellos wrote:
> This commit extracts process to check if firmware is running
> into a new inline function called ks7010_is_firmware_running.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/ks7010/ks7010_sdio.c | 22 +++--
On 28.03.2018 18:06, Li Jun wrote:
> Add bingdings supported by current typec driver, so user can pass
> all those properties via dt.
>
> Signed-off-by: Li Jun
> ---
> .../bindings/connector/usb-connector.txt | 39
> ++
> 1 file changed, 39 insertions(+)
>
> diff --
On Tue, Apr 03, 2018 at 10:52:12AM +0300, Dan Carpenter wrote:
> I'm really concerned that you need a way to compile test your patches.
Never mind. Neil is compiling these for you. That's fine if he's Ok
with it.
regards,
dan carpenter
___
devel mail
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> This patch series does the first cleanups in this driver. At some
> points I already tried to get the code of this driver as near as
> possible to the mk-sd driver in mainline.
>
> Christian Lütke-Stetzkamp (34):
> staging: mt7621-mmc: Remo
I use my rename_rev.pl to review these sorts of patches. Attached. For
some reason, I hadn't seen that Neil had already reviewed it. Anyway,
what I did here was:
rename_rev.pl -ea 's/enum//' -ea 's/struct//' -e 's/_t//'
That strips out ever time "enum" or "struct" is used, then it removes
"_t"
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> Fixes checkpatch warning: NEW_TYPEDEFS
>
> Signed-off-by: Christian Lütke-Stetzkamp
> ---
> drivers/staging/mt7621-mmc/dbg.c | 2 +-
> drivers/staging/mt7621-mmc/dbg.h | 11 +-
> drivers/staging/mt7621-mmc/mt6575_sd.h | 305
I'm really concerned that you need a way to compile test your patches.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> Current code calls release_mem_regin on driver remove without
> requesting it explicit first. The region is only requested via
> devm_ioremap_resource and that releases it automatically. Removing the
> release_mem_region calls fixes this.
>
>
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> In case of dma_alloc_coherent failing the current code just called
> BUG_ON. By adding error handling for that case this can be avoided.
> This also fixes a memory leek in case of a fail later on in the probe
> function.
>
> Signed-off-by: Ch
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> Fixes checkpatch warning: NEW_TYPEDEFS
>
> Signed-off-by: Christian Lütke-Stetzkamp
> ---
> diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt7621-mmc/sd.c
> index b5bd31e220d6..ec28925093cd 100644
> --- a/drivers/staging
On Mon, Apr 02 2018, Christian Lütke-Stetzkamp wrote:
> The request of the irq line is not correctly handled by the current
> code, platform_get_irq may fail and if the irq is requested via
> devm_request_irq, its release is automatically done.
>
> Signed-off-by: Christian Lütke-Stetzkamp
> ---
>
On Fri, Mar 30, 2018 at 11:08:54PM -0700, Quytelda Kahja wrote:
> ether_addr_equal() is the function for comparing HW addresses,
> so remove the manual memcmp operation and replace it with
> ether_addr_equals().
>
> Signed-off-by: Quytelda Kahja
> ---
> drivers/staging/ks7010/ks_hostif.c | 4 ++-
When I look at them now in a more relaxed mood, they're basically all
fine except for patch 74 which is buggy.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-
On Mon, Apr 2, 2018 at 4:26 PM, Robert Jarzmik wrote:
> Hi,
>
> This serie is aimed at removing the dmaengine slave compat use, and transfer
> knowledge of the DMA requestors into architecture code.
>
> This was discussed/advised by Arnd a couple of years back, it's almost time.
>
> The serie is d
On Mon, Apr 2, 2018 at 6:35 PM, kbuild test robot wrote:
>
>drivers/mtd/nand/marvell_nand.c:2621:17: sparse: undefined identifier
> 'pxad_filter_fn'
>>> drivers/mtd/nand/marvell_nand.c:2621:17: sparse: call with no type!
>In file included from drivers/mtd/nand/marvell_nand.c:21:0:
>d
On Mon, Apr 2, 2018 at 4:26 PM, Robert Jarzmik wrote:
>
> +static struct pxa_ssp_info pxa_ssp_infos[] = {
> + { .dma_chan_rx_name = "ssp1_rx", .dma_chan_tx_name = "ssp1_tx", },
> + { .dma_chan_rx_name = "ssp1_rx", .dma_chan_tx_name = "ssp1_tx", },
> + { .dma_chan_rx_name = "ssp2
62 matches
Mail list logo