On Thu, 19 Oct 2017 16:06:32 -0400
Brian Masney wrote:
> This patch adds a return_max label for the two cases that need to set
> the lux to TSL2X7X_LUX_CALC_OVER_FLOW and return.
>
> Signed-off-by: Brian Masney
Sorry - don't like this last one. I think it hurts readability. Leave
this as it w
On Thu, 19 Oct 2017 16:06:31 -0400
Brian Masney wrote:
> The functions tsl2x7x_invoke_change() and tsl2x7x_prox_calculate() are
> short enough that the return value and static declaration can be moved
> onto the same line with the function name. This patch makes that change
> to increase code rea
On Thu, 19 Oct 2017 16:06:30 -0400
Brian Masney wrote:
> Correct the alignment of the break statements to match the alignment of
> the rest of the code within the case statements.
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/tsl2x7x.c | 4 ++--
> 1 file changed, 2
On Thu, 19 Oct 2017 16:06:29 -0400
Brian Masney wrote:
> The LED power defines are named like TSL2X7X_mAXXX. Rename these values
> to TSL2X7X_XXX_mA to improve code readability.
>
> Signed-off-by: Brian Masney
Applied
> ---
> drivers/staging/iio/light/tsl2x7x.c | 10 +-
> 1 file change
On Thu, 19 Oct 2017 16:06:28 -0400
Brian Masney wrote:
> Correct error from checkpatch.pl to improve code readibility: Alignment
> should match open parenthesis. An unnecessary cast to 'struct
> tsl2x7x_lux *' was removed and the return value of static definition of
> in_illuminance0_calibscale_a
On Thu, 19 Oct 2017 16:06:27 -0400
Brian Masney wrote:
> Correct error from checkpatch.pl to improve code readibility: Alignment
> should match open parenthesis. This involved shortening the name of
> tsl2x7x_als_gainadj and tsl2x7x_prx_gainadj to tsl2x7x_als_gain and
> tsl2x7x_prx_gain respectiv
On Thu, 19 Oct 2017 16:06:26 -0400
Brian Masney wrote:
> This patch fixes the error 'Unnecessary parentheses around 'XXX' from
> checkpatch.pl. It also fixes several other places with unnecessary
> parentheses that checkpatch.pl did not detect.
>
> Signed-off-by: Brian Masney
Some of these are
On Thu, 19 Oct 2017 16:06:25 -0400
Brian Masney wrote:
> The sysfs attribute in_proximity0_calibscale_available is currently
> created by using DEVICE_ATTR_RO(). Convert this over to use
> IIO_CONST_ATTR().
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/tsl2x7x.c |
On Thu, 19 Oct 2017 16:06:24 -0400
Brian Masney wrote:
> Some of the existing #defines have tabs between the name, and the value,
> while others have spaces. The alignment of the values mostly has a
> consistent layout, but there are some that don't. Change all of the
> defines so that the name a
On Thu, 19 Oct 2017 16:06:23 -0400
Brian Masney wrote:
> tsl2x7x.h has a blank definition for 'struct iio_dev' that is not
> needed. This patch removes that definition.
>
> Signed-off-by: Brian Masney
Applied
Thanks,
Jonathan
> ---
> drivers/staging/iio/light/tsl2x7x.h | 2 --
> 1 file chang
On Thu, 19 Oct 2017 16:06:22 -0400
Brian Masney wrote:
> Sort the #include statements for increased code readability.
>
> Signed-off-by: Brian Masney
Applied.
Thanks,
Jonathan
> ---
> drivers/staging/iio/light/tsl2x7x.c | 10 +-
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
>
On Thu, 19 Oct 2017 16:06:21 -0400
Brian Masney wrote:
> The structure tsl2x7x_parse_result is not used so this patch removes its
> definition.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as testing
for the autobuilders to play with it.
Thanks,
Jonat
On Thu, 19 Oct 2017 16:06:20 -0400
Brian Masney wrote:
> The sysfs attributes in_intensity0_thresh_period and
> in_proximity0_thresh_period are currently directly created by the driver.
> This patch migrates the creation of these sysfs attributes from the driver
> to using the IIO core via iio_ev
Hello,
On Thu, Oct 19, 2017 at 08:35:10AM -0700, Christoph Hellwig wrote:
> On Tue, Oct 17, 2017 at 01:35:21PM -0400, Cathy Avery wrote:
> > + /*
> > +* Set the error handler work queue.
> > +*/
> > + snprintf(host_dev->work_q_name, sizeof(host_dev->work_q_name),
> > +"stor
On Fri, Oct 20, 2017 at 08:58:58PM -0400, Sherry Yang wrote:
> Use binder_alloc struct's mm_struct rather than getting
> a reference to the mm struct through get_task_mm to
> avoid a potential deadlock between lru lock, task lock and
> dentry lock, since a thread can be holding the task lock
> and
On Fri, 20 Oct 2017, Bjorn Helgaas wrote:
> On Tue, Oct 17, 2017 at 09:54:56AM +0200, Thomas Gleixner wrote:
> > Dexuan reported that the recent rework of the vector allocation mode in x86
> > broke HyperV PCI passtrough because the rework missed to add the
> > MSI_FLAG_MUST_REACTIVATE flag to the
16 matches
Mail list logo