From: K. Y. Srinivasan
Fcopy may use a char device to support the communication between
the user level daemon and the driver. When the Fcopy channel is rescinded
we need to make sure that the char device is fully cleaned up before
we can process a new Fcopy offer from the host. Implement this log
From: K. Y. Srinivasan
VSS may use a char device to support the communication between
the user level daemon and the driver. When the VSS channel is rescinded
we need to make sure that the char device is fully cleaned up before
we can process a new VSS offer from the host. Implement this logic.
S
From: K. Y. Srinivasan
KVP may use a char device to support the communication between
the user level daemon and the driver. When the KVP channel is rescinded
we need to make sure that the char device is fully cleaned up before
we can process a new KVP offer from the host. Implement this logic.
S
From: K. Y. Srinivasan
The host can rescind a channel that has been offered to the
guest and once the channel is rescinded, the host does not
respond to any requests on that channel. Deal with the case where
the guest may be blocked waiting for a response from the host.
Signed-off-by: K. Y. Srin
From: K. Y. Srinivasan
Fix some rescind handling issues.
K. Y. Srinivasan (4):
Drivers: hv: vmbus: Fix a rescind handling bug
Drivers: hv: util: kvp: Fix a rescind processing issue
Drivers: hv: util: Fcopy: Fix a rescind processing issue
Drivers: hv: util: Backup: Fix a rescind processin
Some lines with more than 80 characters has been corrected.
Also, some printk() functions has been changed with their proper
print functions suggested by checkpatch.pl script as well as some
open braces has been aligned properly.
Finally, two strings has been merged into unique string.
Signed-of
On Thu, Dec 22, 2016 at 04:26:31PM +, Francis Laniel wrote:
> Le 2016-12-20 12:24, Dan Carpenter a écrit :
> >This patch doesn't apply. Read Documentation/process/email-clients.rst
> >
> >On Tue, Dec 20, 2016 at 11:49:41AM +0100, Francis Laniel wrote:
> >>Hello.
> >>
> >>
> >>As asked in the T
Fixed checkpatch.pl warnings in rtl8188eu/core directory.
Signed-off-by: Yamanappagouda Patil
---
drivers/staging/rtl8188eu/core/rtw_efuse.c | 4
drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 5 -
drivers/staging/rtl8188eu/core/rtw_led.c | 1 +
drivers/staging/rtl8188eu/
Le 2016-12-20 12:24, Dan Carpenter a écrit :
This patch doesn't apply. Read Documentation/process/email-clients.rst
On Tue, Dec 20, 2016 at 11:49:41AM +0100, Francis Laniel wrote:
Hello.
As asked in the TODO file for this driver I added some goto statements
to
handle errors.
I used Linus
I follow Dan Carpenter's advices and I update my patch.
I just add goto statements for error handling.
Good bye.
Signed-off-by: Francis Laniel
---
drivers/staging/dgnc/dgnc_mgmt.c | 12 +++-
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_mgmt.
Fixed checkpatch.pl 'Missing a blank line after declarations' in
rtl8188eu module.
Signed-off-by: Yamanappagouda Patil
---
drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 7 ++-
drivers/staging/rtl8188eu/os_dep/osdep_service.c | 2 +-
drivers/staging/rtl8188eu/os_dep/rtw_android.c | 1 +
From: Erik Arfvidson
This patch removes unused pound defines in controlvmchannel.h.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/controlvmchannel.h | 22 +---
1 file changed, 22 deletions(-)
diff --git
From: Bryan Thompson
Remove the MAX_BUF define and associated comments.
Signed-off-by: Bryan Thompson
Reviewed-by: Tim Sell
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorhba/visorhba_main.c | 4
1 file changed, 4 deletions(-)
diff --git a/driv
Add the proper error handling to my_device_destroy so it can be send
back up the stack for further error reporting.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorchipset.c | 17 +
1 file changed,
From: David Binder
Since a procfs or sysfs entry is allocated 1 page of memory (4096 bytes)
by default, there is no need to enforce this limit in the driver. This
patch corrects visorbus/visorbus_main.c.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Binder
Signed-off-by: David Kershner
From: David Binder
Removes references to visorchipset in the /proc filesystem, and replaces
them with references to the /sys filesystem. Also removes reference to the
visorchipset driver, and replaces it with a reference to plain
visorchipset (since it is no longer a standalone driver).
Signed-o
Add proper error handling to the function my_device_create and
propagate the error message up the stack.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorchipset.c | 44 ++-
1 file changed, 24 inser
From: David Binder
The 'retry' variable created in handle_command() is statically allocated,
and its address is never set to NULL. Therefore conditionals to verify
the validity of the retry variable's address are unnecessary.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Binder
Signed-o
This patch series addresses the following updates:
- Shortens CONTROLVM error response codes.
- Converted an if block to a more readable switch statement.
- Removes extraneous PAGE_SIZE checks.
- Removed some defines that weren't needed.
- Additional error ha
The function my_device_changestate was not returning errors up the stack.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorchipset.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --
The function save_crash_message returns an error, don't ignore it,
respond appropriately and send it up.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/visorchipset.c | 7 +--
1 file changed, 5 insertions(+), 2 de
From: Sameer Wadgaonkar
This patch shortens a few error message defines by removing ERROR
from the define.
Reported-by: Greg Kroah-Hartman
Signed-off-by: Sameer Wadgaonkar
Signed-off-by: David Kershner
Reviewed-by: David Binder
---
drivers/staging/unisys/visorbus/controlvmchannel.h | 65 +++
From: David Binder
Control flow is now directed using a switch statement, triggered by the
enum crash_obj_type function parameter, instead of a set of conditional
statements.
Reported-by: Greg Kroah-Hartman
Signed-off-by: David Binder
Signed-off-by: David Kershner
---
drivers/staging/unisys/
From: David Binder
Since a procfs or sysfs entry is allocated 1 page of memory (4096 bytes)
by default, there is no need to enforce this limit in the driver. This
patch corrects visorbus/visorchipset.c.
Signed-off-by: David Binder
Signed-off-by: David Kershner
Reported-by: Greg Kroah-Hartman
Fix coding style issue caught by checkpatch.pl related to the following
warning:
- "WARNING: Prefer [subsystem eg: netdev]_err([subsystem]dev, ... then
dev_err(dev, ... then pr_err(... to printk(KERN_ERR ."
Signed-off-by: Emmanuil Chatzipetru
---
v2: Add svc_watchdog to the subject line
Fix coding style issue caught by checkpatch.pl related to the following
warning:
- "CHECK: spaces preferred around that '*' (ctx:VxV) "
Signed-off-by: Emmanuil Chatzipetru
---
v2: Add svc_watchdog to the subject line
drivers/staging/greybus/svc_watchdog.c | 2 +-
1 file changed, 1 inser
Hello,
> On Wed, Dec 21, 2016 at 04:38:26PM +0100, Emmanuil Chatzipetru wrote:
> > Fix coding style issue caught by checkpatch.pl related to the following
> > warning:
> > - "WARNING: char * array declaration might be better as static const"
> >
> > Signed-off-by: Emmanuil Chatzipetru
> > --
This is a patch to the skein_base.c file that fixes up a
comment aligning warning found by the checkpatch.pl tool at line 2
Signed-off-by: Tobias Heineken
Signed-off-by: Florian Schleicher
CC: linux-ker...@i4.cs.fau.de
---
drivers/staging/skein/skein_base.c | 16
1 file changed
On 21/12/2016 14:23, Roman Kagan wrote:
> On Wed, Dec 21, 2016 at 01:00:44PM +0100, Olaf Hering wrote:
>> On Tue, Dec 20, Roman Kagan wrote:
>>
>> Reverting commit 22356585712d ("staging: hv: use sync_bitops when
>> interacting with the hypervisor") is save because ...
>>
>>> - sync
On Wed, Dec 21, 2016 at 04:38:26PM +0100, Emmanuil Chatzipetru wrote:
> Fix coding style issue caught by checkpatch.pl related to the following
> warning:
> - "WARNING: char * array declaration might be better as static const"
>
> Signed-off-by: Emmanuil Chatzipetru
> ---
> drivers/staging
On Wed, 2016-12-21 at 19:02 -0600, Scott Matheina wrote:
> On 12/20/2016 09:23 PM, Joe Perches wrote:
> > On Tue, 2016-12-20 at 20:58 -0600, Scott Matheina wrote:
> > > Fixed indention and space issues to align the code with the linux style
> > > guide.
> > []
> > > diff --git a/drivers/staging/ii
31 matches
Mail list logo