This patch series addresses the following updates:
        - Shortens CONTROLVM error response codes.
        - Converted an if block to a more readable switch statement.
        - Removes extraneous PAGE_SIZE checks.
        - Removed some defines that weren't needed.
        - Additional error handling cleanup.
        - Cleans up some patch comments.

Bryan Thompson (1):
  staging: unisys: visorhba: Remove unused MAX_BUF define

David Binder (5):
  staging: unisys: visorbus: Use switch statement instead of conditionals
  staging: unisys: visorbus: Remove unneeded checks for valid variable addr
  staging: unisys: visorbus: Convert references to /proc to /sys
  staging: unisys: visorbus: visorchipset.c: Don't check for more than 
PAGE_SIZE length
  staging: unisys: visorbus: Don't check for more than PAGE_SIZE length in 
visorbus

David Kershner (4):
  staging: unisys: visorbus: my_device_create add error handling
  staging: unisys: visorbus: Add err handling for function save_crash_message
  staging: unisys: visorbus: my_device_changestate add error handling
  staging: unisys: visorbus: my_device_destroy add error handling

Erik Arfvidson (1):
  staging: unisys: visorbus: controlvmchannel.h remove unused pound defines

Sameer Wadgaonkar (1):
  staging: unisys: visorbus: shorten error message defines

 drivers/staging/unisys/visorbus/controlvmchannel.h |  87 ++-----
 drivers/staging/unisys/visorbus/visorbus_main.c    |  32 +--
 drivers/staging/unisys/visorbus/visorchipset.c     | 164 +++++++-------
 drivers/staging/unisys/visorhba/visorhba_main.c    |   4 +-
 4 files changed, 135 insertions(+), 152 deletions(-)

base-commit: cdb98c2698b4af287925abcba4d77d92af82a0c3
-- 
git-series 0.9.1
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to