From: Vitaly Kuznetsov
Hyper-V VMs can be replicated to another hosts and there is a feature to
set different IP for replicas, it is called 'Failover TCP/IP'. When
such guest starts Hyper-V host sends it KVP_OP_SET_IP_INFO message as soon
as we finish negotiation procedure. The problem is that it
From: Vitaly Kuznetsov
When we iterate through all HA regions in handle_pg_range() we have an
assumption that all these regions are sorted in the list and the
'start_pfn >= has->end_pfn' check is enough to find the proper region.
Unfortunately it's not the case with WS2016 where host can hot-add
From: Vitaly Kuznetsov
lsvmbus keeps its own copy of all VMBus UUIDs, add PCIe pass-through
device there to not report 'Unknown' for such devices.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
tools/hv/lsvmbus |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
d
From: Vitaly Kuznetsov
Kdump keeps biting. Turns out CHANNELMSG_UNLOAD_RESPONSE is always
delivered to the CPU which was used for initial contact or to CPU0
depending on host version. vmbus_wait_for_unload() doesn't account for
the fact that in case we're crashing on some other CPU we won't get t
From: Vitaly Kuznetsov
We set host_specified_ha_region = true on certain request but this is a
global state which stays 'true' forever. We need to reset it when we
receive a request where ha_region is not specified. I did not see any
real issues, the bug was found by code inspection.
Signed-off-
Some miscellaneous fixes. All these patches are being resent.
Vitaly Kuznetsov (5):
Drivers: hv: kvp: fix IP Failover
Drivers: hv: vmbus: handle various crash scenarios
Drivers: hv: balloon: don't crash when memory is added in non-sorted
order
Drivers: hv: balloon: reset host_specified
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Saturday, April 30, 2016 2:54 PM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com
> Subje
On Sat, Apr 30, 2016 at 09:43:09PM +, KY Srinivasan wrote:
>
>
> > -Original Message-
> > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > Sent: Saturday, April 30, 2016 2:05 PM
> > To: KY Srinivasan
> > Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> > o...@ae
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Saturday, April 30, 2016 2:05 PM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com
> Subje
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Saturday, April 30, 2016 2:03 PM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com
> Subje
checkpatch complains about an extra blank line after an opening brace.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/i4l/act2000/act2000_isa.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/i4l/act2000/act2000_isa.c
b/drivers/staging/i4l/act2000/act2000_isa.c
index 0485
It is not the kernel coding style to assign values to some variable in
if statement. Split them up into different statements.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/i4l/act2000/act2000_isa.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/
It is not kernel coding style to give an extra space after a cast.
We get warned about it by checkpatch.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/i4l/act2000/act2000_isa.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/i4l/act2000/act20
checkpatch warns that return is not a function and as such the brace
after it is not required.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/i4l/act2000/act2000_isa.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/i4l/act2000/act2000_isa.c
b/drivers/sta
On Tue, Apr 05, 2016 at 04:57:40PM -0700, K. Y. Srinivasan wrote:
> From: Vitaly Kuznetsov
>
> Hyper-V VMs can be replicated to another hosts and there is a feature to
> set different IP for replicas, it is called 'Failover TCP/IP'. When
> such guest starts Hyper-V host sends it KVP_OP_SET_IP_INF
On Fri, Apr 29, 2016 at 11:45:17AM -0700, K. Y. Srinivasan wrote:
> From: Vitaly Kuznetsov
>
> When we iterate through all HA regions in handle_pg_range() we have an
> assumption that all these regions are sorted in the list and the
> 'start_pfn >= has->end_pfn' check is enough to find the proper
Spaces after casts are removed
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_api.c | 2 +-
drivers/staging/skein/skein_base.c | 12 ++--
drivers/staging/skein/skein_base.h | 12 ++--
drivers/staging/skein/skein_block.c | 12 ++--
4 files changed, 19 inser
Align wrapped lines to parentheses (if applicable).
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_base.c| 24
drivers/staging/skein/skein_generic.c | 6 +++---
2 files changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/skein/skein_b
added operator white space and parentheses for readability
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_base.c| 66 +--
drivers/staging/skein/skein_base.h| 28 +++
drivers/staging/skein/skein_block.c | 44 ---
Added lines between functions in skein_block.c and removed unneeded
lines in skein_block.c
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_api.c | 1 -
drivers/staging/skein/skein_block.c | 4 +++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/skein/s
On Sat, Apr 30, 2016 at 09:15:03AM -0700, Greg KH wrote:
As Dan pointed out, always use scripts/checkpatch.pl on your patches to
ensure you got them correct before sending them out with obvious errors
like this.
Sorry about that, re-sending with Signed-off-by.
--
Manu
_
On Sat, Apr 30, 2016 at 04:30:12PM +0800, Jacky Boen wrote:
> Fixed parentheses, braces, comments, constants on the left side
> comparisons, extra newlines and indentations, NULL comparisons,
> and a typo.
That's a lot of different things all in one patch. Please break it up
into "one patch per l
On Fri, Apr 29, 2016 at 11:59:01PM -0700, Manu Kumar wrote:
> Added lines between functions in skein_block.c and removed unneeded
> lines in skein_block.c
> ---
> drivers/staging/skein/skein_api.c | 1 -
> drivers/staging/skein/skein_block.c | 4 +++-
> 2 files changed, 3 insertions(+), 2 deleti
On Sat, Apr 30, 2016 at 10:23:37AM +0300, Dan Carpenter wrote:
> On Sat, Apr 30, 2016 at 01:53:03AM +0100, Salah Triki wrote:
> > The call of eprom_read may fail, therefore its return value must be
> > checked
> >
> > Signed-off-by: Salah Triki
> > ---
> > drivers/staging/rtl8192u/r8192U_core.c
On Fri, Apr 29, 2016 at 04:41:02PM -0500, Aaron Sierra wrote:
> There appear to be no in-kernel callers of vme_lm_attach (or
> vme_lme_request for that matter), so this change only affects the VME
> subsystem and bridge drivers.
Are we planning to add in-kernel users soon?
regards,
dan carpenter
Fixed parentheses, braces, comments, constants on the left side
comparisons, extra newlines and indentations, NULL comparisons,
and a typo.
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 73 ++---
1 file changed, 34 insertions(+), 39 deletions
On Fri, Apr 29, 2016 at 11:59:01PM -0700, Manu Kumar wrote:
> Added lines between functions in skein_block.c and removed unneeded
> lines in skein_block.c
No Signed-off-by.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http
On Sat, Apr 30, 2016 at 01:53:03AM +0100, Salah Triki wrote:
> The call of eprom_read may fail, therefore its return value must be
> checked
>
> Signed-off-by: Salah Triki
> ---
> drivers/staging/rtl8192u/r8192U_core.c | 145
> +++--
> 1 file changed, 103 insertions(
Align wrapped lines to parentheses (if applicable).
---
drivers/staging/skein/skein_base.c| 24
drivers/staging/skein/skein_generic.c | 6 +++---
2 files changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/skein/skein_base.c
b/drivers/staging/ske
Spaces after casts are removed
---
drivers/staging/skein/skein_api.c | 2 +-
drivers/staging/skein/skein_base.c | 12 ++--
drivers/staging/skein/skein_base.h | 12 ++--
drivers/staging/skein/skein_block.c | 12 ++--
4 files changed, 19 insertions(+), 19 deletions(-)
d
30 matches
Mail list logo