Fixes checkpatch.pl checks:
CHECK: Comparison to NULL could be written ...
Signed-off-by: Ryan Van Quinlan
---
drivers/staging/lustre/lustre/lclient/glimpse.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/lustre/lustre/lclient/glimpse.c
b/drivers/stag
Hi Punit,
[auto build test WARNING on v4.3-rc4 -- if it's inappropriate base, please
ignore]
reproduce:
# apt-get install sparse
make ARCH=x86_64 allmodconfig
make C=1 CF=-D__CHECK_ENDIAN__
sparse warnings: (new ones prefixed by >>)
drivers/staging/rtl8712/rtl871x_i
This introduces a new dma device that provides a single ioctl call that
provides DMA read and write functionality to the user space.
Signed-off-by: Dmitry Kalinkin
Cc: Igor Alekseev
---
Hi Punit,
[auto build test ERROR on v4.3-rc4 -- if it's inappropriate base, please ignore]
config: x86_64-randconfig-x005-201541 (attached as .config)
reproduce:
# save the attached .config to linux build tree
make ARCH=x86_64
All error/warnings (new ones prefixed by >>):
In
Hi Dmitry,
[auto build test WARNING on driver-core/driver-core-next -- if it's
inappropriate base, please ignore]
config: x86_64-randconfig-x010-201541 (attached as .config)
reproduce:
# save the attached .config to linux build tree
make ARCH=x86_64
Note: it may well be a FALSE
This introduces a new dma device that provides a single ioctl call that
provides DMA read and write functionality to the user space.
Signed-off-by: Dmitry Kalinkin
Cc: Igor Alekseev
---
In the last reply Martyn suggested a rework of this to make it use existing
bus/vme/ctl instead of creating a
Fixes an off by one array size.
Signed-off-by: Dmitry Kalinkin
---
drivers/vme/vme_bridge.h | 4 +++-
include/linux/vme.h | 3 +++
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/vme/vme_bridge.h b/drivers/vme/vme_bridge.h
index 397578a..b59cbee 100644
--- a/drivers/vm
Hi Martyn,
Sorry, your comment is too late. This patch is already in staging-next.
Dmitri
> On 2015/10/10, at 17:35, Martyn Welch wrote:
>
> On 5 October 2015 at 04:59, Dmitry Kalinkin wrote:
>> The warning is a false positive.
>>
>
> That seems very likely.
>
> Please could you role this
On 5 October 2015 at 04:59, Dmitry Kalinkin wrote:
> The warning is a false positive.
>
That seems very likely.
Please could you role this into the original patch (vme: change bus
error handling scheme)?
Martyn
> drivers/vme/bridges/vme_tsi148.c: In function 'tsi148_master_write':
> drivers/vm
Jacob Kiefer writes:
> From: Jacob Kiefer
>
> Changed rssi_cmd interface to accept le32 param instead of
> unnecessary u8 * conversion. Updated existing calls to rssi_cmd.
> This patch pushes responsibility to caller to convert to
> le32. This cleans up the code quite a bit.
> Also removed magic
On Sun, Oct 11, 2015 at 1:52 AM, punit vara wrote:
> On Sun, Oct 11, 2015 at 1:20 AM, Julia Lawall wrote:
>>
>>
>> On Sun, 11 Oct 2015, punit vara wrote:
>>
>>> On Sat, Oct 10, 2015 at 11:04 PM, Larry Finger
>>> wrote:
>>> > On 10/10/2015 11:58 AM, Punit Vara wrote:
>>> >>
>>> >> This patch is t
On Sun, Oct 11, 2015 at 1:20 AM, Julia Lawall wrote:
>
>
> On Sun, 11 Oct 2015, punit vara wrote:
>
>> On Sat, Oct 10, 2015 at 11:04 PM, Larry Finger
>> wrote:
>> > On 10/10/2015 11:58 AM, Punit Vara wrote:
>> >>
>> >> This patch is to the rtl871x_ioctl_linux.c file that fixes up following
>> >>
This patch fixes a potential buffer overflow detected by smatch.
pda16 has length 512, while processing an element with index < 512 we
are checking for an end marker in the next element. This poses a
potential buffer overflow if no end marker is present.
Signed-off-by: Tillmann Heidsieck
---
v2:
On Sat, Oct 10, 2015 at 10:37 PM, Julia Lawall wrote:
>
>
> On Sat, 10 Oct 2015, Punit Vara wrote:
>
>> This patch is to the rtl871x_ioctl_linux.c file that fixes up following
>
> The entire above line doesn't give any information (except the file name,
> but that can easily be seen from what come
On Sun, 11 Oct 2015, punit vara wrote:
> On Sat, Oct 10, 2015 at 11:04 PM, Larry Finger
> wrote:
> > On 10/10/2015 11:58 AM, Punit Vara wrote:
> >>
> >> This patch is to the rtl871x_ioctl_linux.c file that fixes up following
> >> warning reported by checkpatch.pl :
> >>
> >> -Prefer ether_addr_
On Sat, Oct 10, 2015 at 11:04 PM, Larry Finger
wrote:
> On 10/10/2015 11:58 AM, Punit Vara wrote:
>>
>> This patch is to the rtl871x_ioctl_linux.c file that fixes up following
>> warning reported by checkpatch.pl :
>>
>> -Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()
>>
>
From: Jacob Kiefer
Changed raid_cmd interface to accept le32 mask instead of
u32 and converting internally. Updated existing calls to raid_cmd.
This patch pushes responsibility to the caller to convert
the mask to le32 and opts for a temp local struct instead of
memset/memcpy. This cleans up the
From: Jacob Kiefer
Changed rssi_cmd interface to accept le32 param instead of
unnecessary u8 * conversion. Updated existing calls to rssi_cmd.
This patch pushes responsibility to caller to convert to
le32. This cleans up the code quite a bit.
Also removed magic numbers.
This patch fixes the foll
On Sat, Oct 10, 2015 at 02:50:44PM -0400, Jacob Kiefer wrote:
> Hello
>
> This patch set fixes the same sparse errors as v2, taking Al's
> advice into consideration and changing the interfaces to little-endian.
Please resend these in a format that I can apply them in (i.e. one patch
per email in
Hello
This patch set fixes the same sparse errors as v2, taking Al's
advice into consideration and changing the interfaces to little-endian.
Jake
>From 8c66f23a08417c59400a60c2dcf5a519795e401f Mon Sep 17 00:00:00 2001
From: Jacob Kiefer
Date: Sat, 10 Oct 2015 14:33:02 -0400
Subject: [PATCH 1/2 v
On 10/10/2015 11:58 AM, Punit Vara wrote:
This patch is to the rtl871x_ioctl_linux.c file that fixes up following
warning reported by checkpatch.pl :
-Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()
bssid has datatype u8 and pnetwork->network.MacAddress has data type
u
On Sat, 10 Oct 2015, Punit Vara wrote:
> This patch is to the rtl871x_ioctl_linux.c file that fixes up following
The entire above line doesn't give any information (except the file name,
but that can easily be seen from what comes just below). A commit message
that would get to the point (what
This patch is to the rtl871x_ioctl_linux.c that fixes up following
warning by checkpatch.pl:
-Prefer eth_broadcast_addr() over memset()
Signed-off-by: Punit Vara
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/stagi
This set of patch fixes following warnings reported by checkpatch.pl:
-Prefer eth_broadcast_addr() over memset()
-Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()
-Block comments use * on subsequent lines
-Block comments use a trailing */ on a separate line
-Comparisons shou
This patch is to the rtl871x_ioctl_linux.c file that fixes up following
warnings reported by checkpatch.pl :
-Block comments use * on subsequent lines
-Block comments use a trailing */ on a separate line
Signed-off-by: Punit Vara
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 26 ++
This patch is to the rtl871x_ioctl_linux.c file that fixes up following
warnings reported by checkpatch.pl:
-Comparisons should place the constant on the right side of the test
Signed-off-by: Punit Vara
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 16
1 file changed, 8 i
This patch is to the rtl871x_ioctl_linux.c file that fixes up following
warning reported by checkpatch.pl :
-Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()
bssid has datatype u8 and pnetwork->network.MacAddress has data type
unsigned char.
Signed-off-by: Punit Vara
---
The following changes since commit 9ffecb10283508260936b96022d4ee43a7798b4c:
Linux 4.3-rc3 (2015-09-27 07:50:08 -0400)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/
tags/staging-4.3-rc5
for you to fetch changes up to b1d562acc78f0
Den 07.10.2015 22:15, skrev Dennis Menschel:
This patch adds support for the Sitronix ST7789V display controller.
The controller is intended for small color displays with a resolution
of up to 320x240 pixels.
Signed-off-by: Dennis Menschel
---
The future of fbtft is uncertain after fbdev mai
Braces in single statement blocks are not needed.
Found by checkpatch.pl
Signed-off-by: Ksenija Stanojevic
---
drivers/staging/olpc_dcon/olpc_dcon.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/olpc_dcon/olpc_dcon.c
b/drivers/staging/olpc_dcon/olpc_dcon.
On Sat, Oct 10, 2015 at 01:37:47AM +0300, Alexey Khoroshilov wrote:
> _enter_critical_mutex() is a simple call to mutex_lock_interruptible(),
> but there is no error handling code for it.
>
> The patch removes wrapper _enter_critical_mutex() and
> adds error handling for mutex_lock_interruptible()
On Sat, Oct 10, 2015 at 02:48:22PM +0800, Chen Feng wrote:
> +static int hi6220_ion_probe(struct platform_device *pdev)
> +{
> + int i;
> + int err = 0;
> + static struct ion_platform_heap *p_heap;
> +
> + idev = ion_device_create(NULL);
> + hi6220_set_platform_data(pdev);
> +
The config option in the subject may be removed, because,
indeed, it only serves as the 'n' value for
CONFIG_WILC1000_PREALLOCATE_AT_LOADING_DRIVER
Signed-off-by: Stanislav Kholmanskikh
---
drivers/staging/wilc1000/Kconfig | 15 ++-
drivers/staging/wilc1000/Makefile | 3 ---
2 file
This patch inserts spaces preferred around that '+' found by checkpatch.
Signed-off-by: Ivan Safonov
---
Changes in v2:
- inserted description to this patch,
- added Signed-off record.
Changes in v3:
- Signed-off before cut-off.
Changes in v4: no changes.
drivers/staging/rtl8188eu/hal/bb_
This patch inserts ARRAY_SIZE instead of sizeof(type array[])/sizeof(type),
made arraylen variable constant
and removes unnecessary default value in variable definition.
Signed-off-by: Ivan Safonov
---
Changes in v2:
- inserted description to this patch.
Changes in v3:
- signed-off before cut
This patch removes unused macro read_nexp_pair.
Signed-off-by: Ivan Safonov
---
Changes in v2:
- added description to this patch.
Changes in v3:
- Signed-off before cut-off.
Changes in v4: no changes.
drivers/staging/rtl8188eu/hal/bb_cfg.c | 8
1 file changed, 8 deletions(-)
diff
This patchset:
- removes unused macro read_nexp_pair,
- inserts ARRAY_SIZE instead of sizeof(type array[])/sizeof(type),
- inserts spaces preferred around that '+' found by checkpatch.
- performs small accompanying changes:
a. const keyword inserted,
b. unnecessary default value
On 09/10/15 21:07, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/adv_pci1724.c | 15 ---
1 file changed, 8 insertio
On 09/10/15 21:02, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/adv_pci1723.c | 33 +++-
1 file change
On 09/10/15 20:57, H Hartley Sweeten wrote:
Rename thie CamelCase member of the private data.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/adv_pci1710.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/
On 09/10/15 19:53, H Hartley Sweeten wrote:
Fix the checkpatch.pl issues in this driver.
H Hartley Sweeten (3):
staging: comedi: adq12b: tidy up multi-line comments
staging: comedi: adq12b: prefer using the BIT macro
staging: comedi: adq12b: usleep_range is preferred over udelay
driv
On 09/10/15 19:34, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/adl_pci9111.c | 41 ++--
1 file change
On 09/10/15 19:09, H Hartley Sweeten wrote:
Fix the checkpatch.pl issues in this driver.
H Hartley Sweeten (2):
staging: comedi: adl_pci9118: prefer using the BIT macro
staging: comedi: adl_pci9118: rename Compute_and_setup_dma()
drivers/staging/comedi/drivers/adl_pci9118.c | 64 +++
On 09/10/15 19:01, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/adl_pci6208.c | 2 +-
1 file changed, 1 insertion(+), 1 deleti
On 09/10/15 18:58, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/addi_apci_3xxx.c | 6 +++---
1 file changed, 3 insertions(+),
On 09/10/15 18:56, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/addi_apci_3120.c | 54 +
1 file change
On 09/10/15 18:47, H Hartley Sweeten wrote:
Minor cleanup to address the checkpatch.pl issues.
H Hartley Sweeten (2):
staging: comedi: addi_apci_2032: prefer using the BIT macro
staging: comedi: addi_apci_2032: document the spinlock_t definition
drivers/staging/comedi/drivers/addi_apci_
On 09/10/15 18:32, H Hartley Sweeten wrote:
As suggested by checkpatch.pl, use the BIT macro to define the
register bits.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/addi_apci_1032.c | 7 ---
1 file changed, 4 insertions(+),
On Sat, Oct 10, 2015 at 04:31:21PM +0700, Ivan Safonov wrote:
> On 10/10/2015 03:35 PM, Sudip Mukherjee wrote:
> >On Thu, Oct 08, 2015 at 10:21:07PM +0700, Ivan Safonov wrote:
> >>This patch inserts ARRAY_SIZE instead of sizeof(type array[])/sizeof(type).
> >>---
> >>Changes in v2:
> >> - inserte
On 10/10/2015 03:35 PM, Sudip Mukherjee wrote:
On Thu, Oct 08, 2015 at 10:21:07PM +0700, Ivan Safonov wrote:
This patch inserts ARRAY_SIZE instead of sizeof(type array[])/sizeof(type).
---
Changes in v2:
- inserted description to this patch
Signed-off-by: Ivan Safonov
---
drivers/staging/
On Fri, Oct 09, 2015 at 12:11:33PM +0100, Colin King wrote:
> From: Colin Ian King
>
> Static analysis with cppcheck found the following memory leak:
>
> [drivers/staging/wilc1000/linux_mon.c:255]: (error) Memory leak: mgmt_tx
>
> Free mgmt_tx on the error return path when mgmt_tx->buff fails t
On Thu, Oct 08, 2015 at 08:53:18PM +0100, paulmcq...@gmail.com wrote:
> From: Paul McQuade
This line is not required. You can configure your .gitconfig so that
your name will be mentioned correctly in the From: header of the patch.
regards
sudip
___
de
On Thu, Oct 08, 2015 at 10:23:35PM +0700, Ivan Safonov wrote:
> This patch inserts spaces preferred around that '+' found by checkpatch.
> ---
You missed the Signed-off-by:
regards
sudip
___
devel mailing list
de...@linuxdriverproject.org
http://driverd
On Thu, Oct 08, 2015 at 10:21:07PM +0700, Ivan Safonov wrote:
> This patch inserts ARRAY_SIZE instead of sizeof(type array[])/sizeof(type).
> ---
> Changes in v2:
> - inserted description to this patch
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/hal/bb_cfg.c | 8
54 matches
Mail list logo