On Wed, May 06, 2015 at 05:13:41PM -0500, Jaime Arrocha wrote:
> Errors found by checkpatch.pl.
> ERROR: code indent should use tabs where possible
> /drivers/staging/comedi/drivers/das16m1.c:49
> /drivers/staging/comedi/drivers/das16m1.c:50
>
> Signed-off-by: Jaime Arrocha
> ---
you are sending
On 2015/05/06, 6:02 AM, "Mike Shuey" wrote:
>Clean up spacing in some variable declarations, to be more consistent.
>
>It's small, but I need to start somewhere. Please let me know if I'm not
>adhering to proper procedure for trivial cleanups.
It's actually Lustre coding style to align the vari
On 27/04/15 07:12, Dan Carpenter wrote:
> Can't we just export the tkip.c function?
>
> regards,
> dan carpenter
>
Hi Dan,
(sorry for the delayed response)
The inputs of the two implementations of tkip_mixing_phase2() differ in
one parameter:
- ieee80211_crypt_tkip.c expects 'const u16 *TTAK'
In addition to fixing an issue in the vmbus_open failure path,
this patch-set improves the distribution of channels/sub-channels
across the available CPUs in the guest.
Vitaly Kuznetsov (7):
Drivers: hv: vmbus: do cleanup on all vmbus_open() failure paths
Drivers: hv: vmbus: kill tasklets on m
From: Vitaly Kuznetsov
Remove some code duplication, no functional change intended.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/channel_mgmt.c | 51 +++-
1 files changed, 18 insertions(+), 33 deletions(-)
diff --git
From: Vitaly Kuznetsov
We need to call init_vp_index() after we added the channel to the appropriate
list (global or subchannel) to be able to use this information when assigning
the channel to the particular vcpu. To do so we need to move a couple of
functions around. The only real change is the
From: Vitaly Kuznetsov
In case there was an error reported in the response to the
CHANNELMSG_OPENCHANNEL
call we need to do the cleanup as a vmbus_open() user won't be doing it after
receiving an error. The cleanup should be done on all failure paths. We also
need
to avoid returning open_info->
From: Vitaly Kuznetsov
It is unlikely that that host will ask us to close only one subchannel for a
device but let's be consistent. Do both num_sc++ and num_sc-- with
channel->lock to be on the safe side.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/channel_m
From: Vitaly Kuznetsov
Explicitly kill tasklets we create on module unload.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/vmbus_drv.c |5 -
1 files changed, 4 insertions(+), 1 deletions(-)
diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
i
From: Vitaly Kuznetsov
Primary channels are distributed evenly across all vcpus we have. When the host
asks us to create subchannels it usually makes us num_cpus-1 offers and we are
supposed to distribute the work evenly among the channel itself and all its
subchannels. Make sure they are all ass
From: Vitaly Kuznetsov <[mailto:vkuzn...@redhat.com]>
next_oc and num_sc fields of struct vmbus_channel deserve a description. Move
them closer to sc_list as these fields are related to it.
Signed-off-by: Vitaly Kuznetsov
Signed-off-by: K. Y. Srinivasan
---
include/linux/hyperv.h | 12 ++
Christian Lamparter writes:
> On Tue, May 5, 2015 at 7:23 PM, Jes Sorensen wrote:
>> Xose Vazquez Perez writes:
>>> On 06/20/2014 10:52 PM, Christian Lamparter wrote:
>>>
rtl8192su development is chugging along. It just doesn't take place on
driverdev list. The driver reached "feature
Errors found by checkpatch.pl.
ERROR: code indent should use tabs where possible
/drivers/staging/comedi/drivers/das16m1.c:49
/drivers/staging/comedi/drivers/das16m1.c:50
Signed-off-by: Jaime Arrocha
---
drivers/staging/comedi/drivers/das16m1.c |4 ++--
1 file changed, 2 insertions(+), 2 del
This is to officially inform you that you been accredited with an ATM CARD
worth $2.8Million Dollars on the ongoing Global international ATM Card Award
held on 2nd of May 2015. Email address for this award was selected from
databases of major shopping mails, electricity companies,railways statio
If the lpi-parent property is not present in the fsl,qoriq-mc node
of the device tree, the MC bus driver will assume that the GIC is not
supported.
This change is made in order to be able to use the MC bus driver in a
KVM VM, without having GIC-ITS support in guests. Added function
fsl_mc_interrup
Add a locking mechanism to serialize mc_send_command() calls that use
the same fsl_mc_io object (same MC portal). When the fsl_mc_io object is
created the owner needs to know in which type of context the fsl_mc_io
object is going to be used. A flag passed-in to fsl_create_mc_io()
will indicate whet
- Migrated MC bus driver to use DPRC API 0.6.
- Changed IRQ setup infrastructure to be able to program MSIs
for MC objects in an object-independent way.
Signed-off-by: J. German Rivera
---
Changes in v2:
- Addressed comments from Dan Carpenter:
* Added #ifdef GIC_ITS_MC_SUPPORT's that had bee
When a child DPRC is bound to the vfio_fsl_mc driver via driver_override,
its own children should not be bound to corresponding host kernel
drivers, but instead should be bound to the vfio_fsl_mc driver as
well.
Currently, when a child container is scanned by the vfio_fsl_mc driver,
child devices
All the IRQs for DPAA2 objects in the same DPRC must use
the ICID of that DPRC, as their device Id in the GIC-ITS.
Thus, all these IRQs must share the same ITT table in GIC. As
a result, a pool of IRQs with the same device Id must be
preallocated per DPRC (fsl-mc bus instance). So, the fsl-mc
bus o
- Refactored fsl_mc_io object to have a DPMCP object attached to it
- Created DPMCP object for DPRC's built-in portal, so that waiting
on MC command completions for MC commands sent on the DPRC's built-in
portal can be done using a DPMCP interrupt and a Linux completion
variable. For most ca
From: Bharat Bhushan
This patch is required for vfio-fsl-mc meta driver to successfully bind
layerscape container devices for device passthrough. This patch adds
a mechanism to allow a layerscape device to specify a driver rather than
a layerscape driver provide a device match.
This patch is bas
This patch series includes new functionality for the Freescale fsl-mc
bus driver.
Patch 1: MC bus IRQ support
Patch 2: add device binding path 'driver_override'
Patch 3: Propagate driver_override for a child DPRC's children
Patch 4: Upgraded MC bus driver to match MC fw 7.0.0
Patch 5: Allow the MC
Based on the information given to this driver (via the xmit_more skb flag),
we can defer signaling the host if more packets are on the way. This will help
make the host more efficient since it can potentially process a larger batch of
packets. Implement this optimization.
Signed-off-by: K. Y. Srin
Errors found by checkpatch.pl.
ERROR: code indent should use tabs where possible
/drivers/staging/comedi/drivers/das16m1.c:49
/drivers/staging/comedi/drivers/das16m1.c:50
Signed-off-by: Jaime Arrocha
---
drivers/staging/comedi/drivers/das16m1.c |4 ++--
1 file changed, 2 insertions(+), 2 del
On 2015-05-06 03:09 PM, Greg KH wrote:
> On Wed, May 06, 2015 at 10:05:55AM -0400, nick wrote:
>> On 2015-05-06 05:10 AM, Ian Abbott wrote:
>>> On 06/05/15 01:22, nick wrote:
Greetings All,
I am wondering if in the function,ni_stc_dma_channel_select_bitfield the
line:
return
> -Original Message-
> From: Eric Dumazet [mailto:eric.duma...@gmail.com]
> Sent: Wednesday, May 6, 2015 12:18 PM
> To: KY Srinivasan
> Cc: da...@davemloft.net; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jas
On Wed, 2015-05-06 at 18:28 +, KY Srinivasan wrote:
> Ah! I too was wondering how we could get into this situation. The condition
> you mention
> is already handled in the lower level - if the attempt to put the last packet
> on vmbus were to
> fail because the ring is full, we will notify t
On Wed, May 06, 2015 at 10:05:55AM -0400, nick wrote:
> On 2015-05-06 05:10 AM, Ian Abbott wrote:
> > On 06/05/15 01:22, nick wrote:
> >> Greetings All,
> >> I am wondering if in the function,ni_stc_dma_channel_select_bitfield the
> >> line:
> >> return 1 << channel;
> >> is guaranteed to be below
> -Original Message-
> From: Eric Dumazet [mailto:eric.duma...@gmail.com]
> Sent: Wednesday, May 6, 2015 11:09 AM
> To: KY Srinivasan
> Cc: da...@davemloft.net; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jas
On Wed, 2015-05-06 at 11:20 -0700, K. Y. Srinivasan wrote:
> Based on the information given to this driver (via the xmit_more skb flag),
> we can defer signaling the host if more packets are on the way. This will help
> make the host more efficient since it can potentially process a larger batch
>
On Wed, May 06, 2015 at 12:25:43PM -0400, Ben Romer wrote:
> On 05/06/2015 08:15 AM, Dan Carpenter wrote:
> >Also there were some unrelated changes. Benjamin, you should have
> >complained about those when the patch was first sent. That's like the
> >most obvious thing to check when you're review
Based on the information given to this driver (via the xmit_more skb flag),
we can defer signaling the host if more packets are on the way. This will help
make the host more efficient since it can potentially process a larger batch of
packets. Implement this optimization.
Signed-off-by: K. Y. Srin
On 05/06/2015 08:15 AM, Dan Carpenter wrote:
Also there were some unrelated changes. Benjamin, you should have
complained about those when the patch was first sent. That's like the
most obvious thing to check when you're reviewing patches.
I'm sorry, I don't understand what part of this is un
On Wednesday, May 06, 2015 7:06 AM, nick wrote:
> On 2015-05-06 05:10 AM, Ian Abbott wrote:
>> On 06/05/15 01:22, nick wrote:
>>> Greetings All,
>>> I am wondering if in the function,ni_stc_dma_channel_select_bitfield the
>>> line:
>>> return 1 << channel;
>>> is guaranteed to be below the thresho
Drop variables made unnecessary by conversion of obd free functions
to kfree.
Signed-off-by: Julia Lawall
---
drivers/staging/lustre/lustre/llite/file.c |2 --
drivers/staging/lustre/lustre/llite/llite_lib.c |1 -
2 files changed, 3 deletions(-)
diff --git a/drivers/staging/lustre
On Wed, May 06, 2015 at 10:47:56AM -0400, Michael Shuey wrote:
> Sudip, Dan, thanks for your feedback. I'll see what I can do to clean up
> the trimmings in my next iteration (and add more files' worth of cleanup as
> well).
>
> While editing these 4 files, I found two more (non-white space) clea
Dan Carpenter writes:
> On Tue, May 05, 2015 at 06:36:56PM -0400, Benjamin Romer wrote:
>> From: Jes Sorensen
>>
>> Signed-off-by: Jes Sorensen
>> Signed-off-by: Benjamin Romer
>> ---
>> drivers/staging/unisys/visorbus/visorchannel.c | 9 ++---
>> 1 file changed, 6 insertions(+), 3 deleti
Changing it later is fine.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On 2015-05-06 05:10 AM, Ian Abbott wrote:
> On 06/05/15 01:22, nick wrote:
>> Greetings All,
>> I am wondering if in the function,ni_stc_dma_channel_select_bitfield the
>> line:
>> return 1 << channel;
>> is guaranteed to be below the threshold that guarantees us to not overflow on
>> a unsigned
On Wed, May 06, 2015 at 08:02:55AM -0400, Mike Shuey wrote:
> Clean up spacing in some variable declarations, to be more consistent.
>
> It's small, but I need to start somewhere. Please let me know if I'm not
> adhering to proper procedure for trivial cleanups.
Don't put these "aside" comments
On Tue, May 05, 2015 at 06:36:56PM -0400, Benjamin Romer wrote:
> From: Jes Sorensen
>
> Signed-off-by: Jes Sorensen
> Signed-off-by: Benjamin Romer
> ---
> drivers/staging/unisys/visorbus/visorchannel.c | 9 ++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers
On Tue, May 05, 2015 at 06:36:18PM -0400, Benjamin Romer wrote:
> From: Prarit Bhargava
>
> Just some cleanups for visorchannel.c, and removal of
> safe_sig_queue_validate() which is dead code.
>
> Signed-off-by: Prarit Bhargava
> Signed-off-by: Benjamin Romer
> ---
> drivers/staging/unisys/v
there variables were not used anywhere and was showing as build warning.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/lustre/lustre/llite/file.c | 2 --
drivers/staging/lustre/lustre/llite/llite_lib.c | 2 --
2 files changed, 4 deletions(-)
diff --git a/drivers/staging/lustre/lustre/
On Wed, May 06, 2015 at 08:02:55AM -0400, Mike Shuey wrote:
> Clean up spacing in some variable declarations, to be more consistent.
>
> It's small, but I need to start somewhere. Please let me know if I'm not
> adhering to proper procedure for trivial cleanups.
these comments should not come he
On Tue, May 5, 2015 at 7:23 PM, Jes Sorensen wrote:
> Xose Vazquez Perez writes:
>> On 06/20/2014 10:52 PM, Christian Lamparter wrote:
>>
>>> rtl8192su development is chugging along. It just doesn't take place on
>>> driverdev list. The driver reached "feature parity" with rtl8192cu for
>>> some
On Tue, May 05, 2015 at 06:36:17PM -0400, Benjamin Romer wrote:
> From: Prarit Bhargava
> diff --git a/drivers/staging/unisys/visorbus/visorchannel.c
> b/drivers/staging/unisys/visorbus/visorchannel.c
> index 33a4360..ff14a0d 100644
> --- a/drivers/staging/unisys/visorbus/visorchannel.c
> +++ b/d
Clean up spacing in some variable declarations, to be more consistent.
It's small, but I need to start somewhere. Please let me know if I'm not
adhering to proper procedure for trivial cleanups.
Signed-off-by: Mike Shuey
---
drivers/staging/lustre/lnet/lnet/acceptor.c | 32 ++--
drivers/stag
Oh. Don didn't introduce this bug, he was just moving files around.
It's better to not modify things when you move them so Don's patch is
correct.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverpr
On Tue, May 05, 2015 at 06:36:01PM -0400, Benjamin Romer wrote:
> From: Don Zickus
> + rc = p;
> +cleanup:
> +
> + if (!rc) {
> + if (!p) {
> + visorchannel_destroy(p);
> + p = NULL;
> + }
> + }
> + return rc;
> +}
Ho
On Tue, May 05, 2015 at 06:36:00PM -0400, Benjamin Romer wrote:
> +int
> +devmajorminor_create_file(struct visor_device *dev, const char *name,
> + int major, int minor)
> +{
> + int maxdevnodes = ARRAY_SIZE(dev->devnodes) / sizeof(dev->devnodes[0]);
On 06/05/15 01:22, nick wrote:
Greetings All,
I am wondering if in the function,ni_stc_dma_channel_select_bitfield the line:
return 1 << channel;
is guaranteed to be below the threshold that guarantees us to not overflow on
a unsigned 32 integer due to bit wise shifting to the left.
Thanks Nick
On Wed, May 06, 2015 at 10:06:21AM +0300, Dan Carpenter wrote:
> Looks good.
but its applying to linux-next and not applying to staging-testing.
There are a few patches which Greg applied to staging-testing before the
merge-window but they were not applied to staging-next. I guess he has
been busy
Looks good.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
53 matches
Mail list logo