On Thu, Nov 27, 2014 at 08:13:03PM +0530, Anjana Sasindran wrote:
> This patch fixes the five checkpatch.pl warnings:
>
> WARNING:Missing a blank line after declaration
>
> Signed-off-by: Anjana Sasindran
> ---
> drivers/staging/rtl8188eu/hal/usb_halinit.c | 6 ++
> 1 file changed,
On Thu, Nov 27, 2014 at 9:09 PM, Dexuan Cui wrote:
In the case the user-space daemon crashes, hangs or is killed, we
need to down the semaphore, otherwise, after the daemon starts next
time, the obsolete data in fcopy_transaction.message or
fcopy_transaction.fcopy_msg will be used immediately.
From: Micky Ching
Add support for sdio card by SD interface. The main change is data
transfer mode, When read data, host wait data transfer while command
start. When write data, host will start data transfer after command get
response. The transfer mode modify can be applied both for SD/MMC card
From: Micky Ching
v2:
rtsx_pci.h:
- remove unused rtsx_pci_write_le32
- add SD_CMD_START
rtsx_pci_sdmmc.c:
- dump_reg_range
- alloc data on stack
- remove forward declaration
- use SD_CMD_START replace magic number 0x40
- move initialize assignment to error handl
From: Micky Ching
Add helper function to write u32 to registers, if we want to put u32
value to 4 continuous register, this can help us reduce tedious work.
Signed-off-by: Micky Ching
---
include/linux/mfd/rtsx_pci.h | 9 +
1 file changed, 9 insertions(+)
diff --git a/include/linux/mf
On 11/27/2014 11:23 PM, Dan Carpenter wrote:
>> +static inline void rtsx_pci_write_be32(struct rtsx_pcr *pcr, u16 reg, u32
>> val)
>> >+{
>> >+ rtsx_pci_add_cmd(pcr, WRITE_REG_CMD, reg, 0xFF, val >> 24);
>> >+ rtsx_pci_add_cmd(pcr, WRITE_REG_CMD, reg + 1, 0xFF, val >> 16);
>> >+ rtsx_pc
On 11/27/2014 11:43 PM, Dan Carpenter wrote:
>> +int stat_idx = sd_status_index(rsp_type);
> I have always hated this terrible pointer math. 5 is relative to
> pcr->host_cmds_ptr + 1. It's a mess...
5 mean CRC7 offset of Response R1, see SD spec V3.01 Page 82.
4.9.1 R1 (normal response comma
Avoid magic number and use a comparison with a defined value instead
that checks whether module param has been set by the user to some
value at loading time.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 86 +--
Start decoupling module params from the actual device state,
both for lcd and keypad, by keeping the params read-only
and moving the device state to related structs.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 35 +--
Make keypad_type and lcd_type module params read-only.
This step also starts making it more clear what is
the precedence of device params coming from different
sources (device profile, runtime module param values etc).
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/pa
Move more or less all LCD-related state into struct lcd
in order to get better cohesion; use bool instead of int
where it makes sense.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 255 ++
1 file changed, 134 in
Rework lcd_init method to make it a little bit more clear about
the precedence of the params, move LCD geometry and pins layout
to the LCD struct and thus make the LCD-related module params
effectively read-only.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/pa
Set default parport module param value to DEFAULT_PARPORT so that
a if-block can be avoided.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/st
Get rid of magic numbers indicating that the value of a module param
is not set. Use a defined value instead.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 22 --
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a/driv
Use a defined value instead of magic number comparison
for checking whether a module param value has been set.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drive
This set of patches focuses on making current initialization
process easier to understand - especially it tries to emphasize
what are the priorities of the params coming from different
sources (Kconfig values, device profiles and module param values
set on loading). I paid attention not to change t
Remove useless function and let the kernel call the actual
init function directly.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/pa
On Thu, Nov 27, 2014 at 7:05 PM, Willy Tarreau wrote:
> Mariusz, for people who have to parse hundreds to thousands of e-mails
> a day, dealing with non-trivial operation modes like this is never easy.
>
> I think (I'll let Greg suggest what he prefers) that the most reliable
> thing to do *right
On Thu, Nov 27, 2014 at 08:50:55PM +0100, Mariusz Gorski wrote:
> > And the reason I got confused was because you didn't label your second
> > set of patches "v2", which it was, I saw two separate series, one with a
> > few patches, and then 2 sets of 9, the second set labeled "v2" so I
> > thought
On Thu, Nov 27, 2014 at 07:57:06AM -0800, Greg Kroah-Hartman wrote:
> On Thu, Nov 27, 2014 at 07:24:17AM -0800, Greg Kroah-Hartman wrote:
> > On Thu, Nov 27, 2014 at 02:26:59PM +0100, Mariusz Gorski wrote:
> > > On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wrote:
> > > > On Wed, Nov
Hello Greg,
After some investigation, I think that removing these wrappers is not going to
improve the code readability:
On Wed, Nov 26, 2014 at 12:54:43PM -0800, Greg KH wrote:
> On Wed, Nov 26, 2014 at 05:15:48PM +0100, Loic Pefferkorn wrote:
> > Add __acquires() and __releases() function anno
On Thu, Nov 27, 2014 at 08:34:00AM -0800, Joe Perches wrote:
> On Thu, 2014-11-27 at 17:18 +0100, Luis de Bethencourt wrote:
> > Fixing 80 character limit warnings in octeon/ethernet-rx.c
>
> Hello again Luis.
>
> Another thing you might consider is to align
> multiple line statements to the app
On 11/27/2014 10:28 AM, Greg KH wrote:
On Thu, Nov 27, 2014 at 10:10:21AM -0600, Larry Finger wrote:
The DLink GO-USB-N150 with revision B1 uses this driver.
Signed-off-by: Larry Finger
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drive
On Thu, 2014-11-27 at 17:18 +0100, Luis de Bethencourt wrote:
> Fixing 80 character limit warnings in octeon/ethernet-rx.c
Hello again Luis.
Another thing you might consider is to align
multiple line statements to the appropriate
open parenthesis.
> diff --git a/drivers/staging/octeon/ethernet-
On Thu, Nov 27, 2014 at 10:10:21AM -0600, Larry Finger wrote:
> The DLink GO-USB-N150 with revision B1 uses this driver.
>
> Signed-off-by: Larry Finger
> ---
> drivers/staging/rtl8188eu/os_dep/usb_intf.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/staging/rtl8188eu/os_dep/
On Thu, Nov 27, 2014 at 05:14:06PM +0100, Willy Tarreau wrote:
> On Thu, Nov 27, 2014 at 07:57:06AM -0800, Greg Kroah-Hartman wrote:
> > And the reason I got confused was because you didn't label your second
> > set of patches "v2", which it was, I saw two separate series, one with a
> > few patche
Fixing 80 character limit warnings in octeon/ethernet-rx.c
Signed-off-by: Luis de Bethencourt
---
drivers/staging/octeon/ethernet-rx.c | 51 +---
1 file changed, 35 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/octeon/ethernet-rx.c
b/drivers/stagin
On Thu, Nov 27, 2014 at 07:57:06AM -0800, Greg Kroah-Hartman wrote:
> And the reason I got confused was because you didn't label your second
> set of patches "v2", which it was, I saw two separate series, one with a
> few patches, and then 2 sets of 9, the second set labeled "v2" so I
> thought the
The DLink GO-USB-N150 with revision B1 uses this driver.
Signed-off-by: Larry Finger
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
b/drivers/staging/rtl8188eu/os_dep/usb_intf.c
index 65a257f..d3cbc
On Thu, Nov 27, 2014 at 07:24:17AM -0800, Greg Kroah-Hartman wrote:
> On Thu, Nov 27, 2014 at 02:26:59PM +0100, Mariusz Gorski wrote:
> > On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wrote:
> > > On Wed, Nov 19, 2014 at 09:38:46PM +0100, Mariusz Gorski wrote:
> > > > Avoid magic num
On Thu, Nov 27, 2014 at 09:00:03PM +0530, Anjana Sasindran wrote:
> This patch fixes the two checkpatch.pl warnings:
>
> WARNING:Missing a blank line after declaration
>
> Signed-off-by: Anjana Sasindran
> ---
> drivers/staging/rtl8712/drv_types.h | 4 +++-
> 1 file changed, 3 i
> #ifdef DEBUG
> -static void sd_print_debug_regs(struct realtek_pci_sdmmc *host)
> +static void dump_reg_range(struct realtek_pci_sdmmc *host, u16 start, u16
> end)
> {
> - struct rtsx_pcr *pcr = host->pcr;
> - u16 i;
> - u8 *ptr;
> + u16 len = end - start + 1;
> + int i;
>
This patch fixes the two checkpatch.pl warnings:
WARNING:Missing a blank line after declaration
Signed-off-by: Anjana Sasindran
---
drivers/staging/rtl8712/drv_types.h | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/drv_types.h
b/d
On Thu, Nov 27, 2014 at 02:26:59PM +0100, Mariusz Gorski wrote:
> On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wrote:
> > On Wed, Nov 19, 2014 at 09:38:46PM +0100, Mariusz Gorski wrote:
> > > Avoid magic number and use a comparison with a defined value instead
> > > that checks whet
On Thu, Nov 27, 2014 at 10:53:58AM +0800, micky_ch...@realsil.com.cn wrote:
> +static inline void rtsx_pci_write_be32(struct rtsx_pcr *pcr, u16 reg, u32
> val)
> +{
> + rtsx_pci_add_cmd(pcr, WRITE_REG_CMD, reg, 0xFF, val >> 24);
> + rtsx_pci_add_cmd(pcr, WRITE_REG_CMD, reg + 1, 0xFF, v
Am 27.11.2014 15:25, schrieb SF Markus Elfring:
>>> diff --git a/drivers/staging/android/ion/ion.c
>>> b/drivers/staging/android/ion/ion.c
>>> index df12cc3..7a26b85 100644
>>> --- a/drivers/staging/android/ion/ion.c
>>> +++ b/drivers/staging/android/ion/ion.c
>>> @@ -226,7 +226,7 @@ static stru
On Wed, Nov 26, 2014 at 06:34:10PM -0800, Greg KH wrote:
> On Thu, Nov 27, 2014 at 12:35:23AM +, Luis de Bethencourt wrote:
> > On Wed, Nov 26, 2014 at 01:45:23PM -0800, Greg KH wrote:
> > > On Tue, Nov 25, 2014 at 01:26:14PM +, Luis de Bethencourt wrote:
> > > > This patch fixes the checkp
This patch fixes the five checkpatch.pl warnings:
WARNING:Missing a blank line after declaration
Signed-off-by: Anjana Sasindran
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drive
>> diff --git a/drivers/staging/android/ion/ion.c
>> b/drivers/staging/android/ion/ion.c
>> index df12cc3..7a26b85 100644
>> --- a/drivers/staging/android/ion/ion.c
>> +++ b/drivers/staging/android/ion/ion.c
>> @@ -226,7 +226,7 @@ static struct ion_buffer *ion_buffer_create(struct
>> ion_heap *he
On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wrote:
> On Wed, Nov 19, 2014 at 09:38:46PM +0100, Mariusz Gorski wrote:
> > Avoid magic number and use a comparison with a defined value instead
> > that checks whether module param has been set by the user to some
> > value at loading t
C V is my initals . Can I just go with the name Athira Lekshmi ?
Thanking You
Athira Lekshmi C V
On Thu, Nov 27, 2014 at 3:14 AM, Greg KH wrote:
> On Wed, Nov 26, 2014 at 05:58:37PM +0530, Athira Lekshmi C V wrote:
>> Fixed the checkpatch warning:
>> WARNING: Missing a blank line after declarati
In the case the user-space daemon crashes, hangs or is killed, we
need to down the semaphore, otherwise, after the daemon starts next
time, the obsolete data in fcopy_transaction.message or
fcopy_transaction.fcopy_msg will be used immediately.
Cc: Jason Wang
Cc: Vitaly Kuznetsov
Cc: K. Y. Sriniv
> -Original Message-
> From: Jason Wang [mailto:jasow...@redhat.com]
> Sent: Thursday, November 27, 2014 17:01 PM
> To: Dexuan Cui
> Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; KY
> Srinivasan;
Eliminate the `next_dma_buf` variable in `interrupt_pci9118_ai_dma()`.
It holds the next value of `devpriv->dma_actbuf` when double buffering
is used, but we can just set that to the next value directly at the
point where the buffers are switched as the old value is not used
anywhere else.
Signed-
The DMA operations used by the driver may have been set up to acquire
data from unwanted channels in addition to the wanted channels.
Currently, `interrupt_pci9118_ai_dma()` calls `defragment_dma_buffer()`
to move all the wanted data to the start of the DMA buffer and then
calls `comedi_buf_write_s
For streaming acquisition on the analog input subdevice, this driver
normally uses DMA double buffering into two internal DMA buffers, so it
can switch buffers early after a DMA transfer has completed, while it
processes the completed DMA buffer.
PATCH 1 is just a bit of tidy up.
PATCH 2 avoids s
`interrupt_pci9118_ai_dma()` is called on interrupt to transfer data
from DMA buffers into the comedi async data buffer. Currently it always
restarts DMA. If double buffering, it restarts DMA on the next DMA
buffer before processing the current DMA buffer, otherwise it restarts
DMA on the same DM
Dexuan Cui writes:
>> -Original Message-
>> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
>> Behalf Of Greg Kroah-Hartman
>> Sent: Thursday, November 27, 2014 11:03 AM
>> To: Vitaly Kuznetsov
>> Cc: de...@linuxdriverproject.org; Haiyang Zhang; linux-
>> ker...@vge
On Thu, Nov 27, 2014 at 4:50 PM, Dexuan Cui wrote:
-Original Message-
From: Jason Wang [mailto:jasow...@redhat.com]
Sent: Thursday, November 27, 2014 15:15 PM
To: Dexuan Cui
Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
driverdev-
de...@linuxdriverproject.org; o
> -Original Message-
> From: Jason Wang [mailto:jasow...@redhat.com]
> Sent: Thursday, November 27, 2014 15:15 PM
> To: Dexuan Cui
> Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; KY
> Srinivasan;
50 matches
Mail list logo